Оглавление

Иллюстрированный самоучитель по виртуальному звуку

  • Введение
  • Глава 1. SAWStudio — виртуальная студия нового поколения
  • Глава 2. Nuendo — виртуальная лаборатория звука
  • Глава 3. Маршрутизация в Samplitude Producer


Глава 1. SAWStudio — виртуальная студия нового поколения

  • SAWStudio — виртуальная студия нового поколения
  • Настройка программы
    • Советы по оптимизации Windows 2000 для работы с SAWStudio
      • Общие рекомендации
      • Оптимизация Windows 2000 с помощью утилиты Xteq Systems X-Setup
    • Настройка программы SAWStudio в конкретной конфигурации PC
      • Настройка аудиооборудования
      • Сохранение настроек
      • Режим Region Memory Caching
      • Режим Region PeakData Memory Caching
      • Выбор модели аудиодрайвера
      • Auto Zero Cross — установка автоматического поиска нулевого отсчета
      • Auto Monitor Switching Protocol — выбор протокола мониторинга
      • Настройка максимального количества уровней отмены
      • Default File Path Setup (настройка путей к файлам по умолчанию)
      • Настройка рабочих экранов
      • Режим Force Single CPU
    • Форматы файлов SAWStudio
  • Мультитрек SAWStudio
    • Описание интерфейса
      • Окно MultiTrack
      • Окно Regions
      • Окно SoundFile
    • Виртуальный микшер
      • Приемы работы с окнами виртуальной консоли
      • Маршрутизация аудиопотоков в SAWStudio
      • Структура Input-канала
      • Параллельное управление каналами (группирование)
      • Несколько полезных приемов управления консолью
    • Работа с plug-ins в SAWStudio
      • Слот FX Pre Fader
      • Окно настроек plug-in
      • Создание групп plug-ins
      • Особенность обработки звука plug-ins в окне FX F-Res Patches
    • Запись и редактирование в SAWStudio
      • Повышение качества записи 16-битной звуковой карты
      • Запись в окне MultiTrack
      • Недеструктивное редактирование
      • Свойства виртуального объекта
      • Многослойный мультитрек
      • Запись в окне SoundFile
      • Импорт звуковых файлов в SAWStudio
  • Сведение в SAWStudio
    • Автоматизация
      • Режим Automation Entry
      • Запись автоматизации
      • Редактирование автоматизированных данных
    • Сведение в файл
      • Практические приемы сведения в SAWStudio
      • Промежуточное сведение
      • Финальное сведение
    Surround в SAWStudio
    • Регулятор XY Surround Pan
  • Аудиомонтаж в SAWStudio
    • Библиотеки сэмплов
  • MS-мастеринг в SAWStudio


SAWStudio — виртуальная студия нового поколения

Итак, мы начнем рассмотрение программы SAWStudio (версия 2.4), разработанной фирмой Innovative Quality Software (www.sawstudio.com). Этот продукт является продолжением линейки продуктов SAW (Software Audio Workshop). В книге ""Живая'' музыка на PC" мы представили читателям программу SAWPro с точки зрения ее удобства для записи "живого" исполнителя, операций сведения и мастеринга.
Программа SAWStudio — не очередной релиз серии SAW, она существенно отличается от предыдущих продуктов данной серии в лучшую сторону. В ней полностью и на новом уровне реализована концепция виртуальной студии, совмещены программно реализованные аналоги двух дорогостоящих аппаратных устройств: виртуального микшера (консоли) и мультитрекового (многодорожечного) цифрового магнитофона.
Помимо этих достижений, в программе SAWStudio получила дальнейшее развитие идея автоматизации, благодаря которой пользователи смогут записывать изменения параметров настройки виртуальной консоли и параметров виртуальных процессоров обработки звука (studio plug-ins). SAWStudio поддерживает plug-ins трех стандартов: DirectX, VST и Studio Native (внутренний стандарт). На сегодняшний день она выпускается в двух версиях: SAWStudio и SAWStudio Lite.

Рассмотрим технические параметры SAWStudio:

  • качество записи 24 бит/96 кГц;
  • количество треков — 72 (моно/стерео) (SAWStudio Lite — 36 треков) или
    144 канала;
  • количество выходных треков (output tracks) — 24 (SAWStudio Lite — 12) или 48 каналов;
  • шесть дополнительных AUX-шин (стерео) с возможностями панорамирования и подключения DirectX, VST и Studio plug-ins;
  • поддержка целочисленных форматов звуковых файлов 24 bit packed int и 24 bit unpacked int;
  • восьми канальное Surround-панорамирование (8 point XY Surround Pan) с раздельными центральным и сабвуферным каналами.

Помимо перечисленных достоинств программы SAWStudio существует и много других, на которых мы остановимся позже.
Главное отличие этой программы от ей подобных заключается в том, что она представляет собой сплав новых достижений: во-первых, виртуальную технологию микширования, разработанную фирмой IQS, и во-вторых, высокоскоростной 24-битный "движок" (hard disk engine), обеспечивающий беспрецедентное быстродействие при работе с жестким диском. Такое новое и сильное технологическое решение позволяет превратить ваш PC в настоящую цифровую рабочую станцию (Digital Audio Workstation — DAW), предназначенную для цифровой многоканальной звукозаписи. Помимо этого, SAWStudio специально спроектирована для работы под управлением операционной системы (ОС) Windows 2000 (NT) и поддерживает двухпроцессорные конфигурации компьютеров, что также повышает ее эффективность.
Основной операционной системой (ОС) для построения DAW на PC следует считать Windows 2000, а также дальнейшие релизы операционных систем Microsoft, базирующиеся на ядре NT (например, Windows XP). Для такого вывода существуют объективные причины, отличающие эти системы от других ОС:

  • поддержка мультипроцессорности;
  • высокая надежность и производительность;
  • совместимость с аудиооборудованием большинства производителей;
  • технология DirectX.

Но, к сожалению, рабочая станция DAW, использующая виртуальные технологии, тоже имеет свои недостатки. Ее проблемной зоной является производительность системы. Но этот недостаток можно исправить: использование двухпроцессорных конфигураций позволяет распределить задачи между процессорами и тем самым увеличить производительность — например, в том случае, если ресурсы одного из процессоров отдать под цифровую обработку звука.
Для того чтобы правильно оценить преимущества двухпроцессорной конфигурации, рассмотрим пример из мира мультимедиа.
Итак, чип EMUlOkl обладает высокой производительностью — сравнимой с процессором Pentium 100.
Производительность процессора Audigy (звуковой карты Creative Sound Blaster) больше в четыре раза. Это позволяет говорить уже о 24-битном звуке с частотой 96 кГц, включающее внутреннее 32-битное представление данных, совершенные алгоритмы микширования и т. д.
Исходя из этих данных, нетрудно представить, какой превосходный результат можно получить при использовании процессоров Intel или AMD с тактовой частотой, превышающей 1000 МГц (если они, конечно, не будут вынуждены отвлекаться на другие задачи, а будут только обрабатывать звук по оптимизированным алгоритмам).
В информации, размещенной на сайте www.sawstudio.com, звукорежиссеры дают высокую оценку SAWStudio. Некоторые сравнивают этот программный продукт с профессиональными системами стоимостью в 30 000 $.
Существует и такое мнение: отставить в сторону аппаратный цифровой микшерный пульт и перейти на программу SAWStudio.
Оценочные суждения пользователей сводятся к следующему:

  • программа создает полное ощущение работы с аппаратными устройствами;
  • в связи с тем, что в SAWStudio обспечивается высокая производительность без использования аппаратных процессоров DSP, пользователи сравнивают эту программу с гоночным автомобилем;
  • при полной переустановке системы (с удалением папок Winnt и Program Files) программа SAWStudio останется работоспособной с сохранением рабочей конфигурации и, что крайне важно, не потребует переинсталляции (как, например, Norton Commander для DOS). Это объясняется тем, что при инсталляции программа не создает никаких лишних записей в системном реестре Windows, т. е. все файлы конфигурации находятся в папке SAWStudio;
  • пользователями дается высокая оценка удобства интерфейса программы SAWStudio. Некоторые даже утверждают, что Бобу Лентини (создателю программ серии SAW) удалось спроектировать цифровую рабочую станцию нового поколения: "Bob really has replaced an entire studio full of very high-end gear with one incredible program" ("Боб действительно заменил полную студию с аппаратными устройствами класса Hi-End одной невероятной программой") (www.sawstudio.com, Tony Perisich, Musician/ recording engineer, Mourning wood studio, Chicago, IL).

Программа SAWStudio написана в ассемблере, что подчеркивает ее уникальность и обеспечивает беспрецедентное быстродействие.
Нельзя не отметить еще одну отличительную черту этой программы — создание качественного алгоритма микширования. Именно различием в подходах к решению этой крайне сложной задачи объясняется тот факт, что каждая мультитрековая программа, использующая виртуальное микширование, звучит по-разному.
Звучание SAWStudio значительно отличается от других программ в лучшую сторону — оно приближено к аналоговому, можно сказать "ламповому", эталону. Поэтому фонограмма, сделанная в SAWStudio, звучит значительно "живее", "теплее", чем в других программах.
И, подводя итоги сказанному, заметим, что программа SAWStudio не только являет собой успех программистов, но и своим существованием опровергает два распространенных мифа, один из которых убеждал пользователей в превосходстве аппаратных устройств DSP, а другой — в недостаточности быстродействия PC для профессиональной обработки звука в реальном времени.
Для работы в SAWStudio определены следующие минимальные системные требования:

  • процессор Pentium II-450;
  • память RAM 384 Мбайт (для SAWStudio Lite — 256 Мбайт);
  • операционная система Windows 2000 или Windows NT 4.0;
  • видеокарта и монитор, поддерживающие разрешение 1024x768 при 65 000 цветов;
  • любое Windows-совместимое звуковое оборудование: от 16-битной звуковой карты до многоканальных интерфейсов.


Общие рекомендации

Уважаемые читатели, советы, которые мы даем в этой главе по настройке Windows 2000, не являются обязательными. Но если вы хотите максимально повысить производительность компьютера, советуем уделить немного времени и все же отрегулировать систему, что означает отказаться от настроек операционной системы Windows 2000, предлагаемых пользователю по умолчанию.
Если же кто-то чувствует себя недостаточно уверенно в системных вопросах, то ему лучше оставить этот раздел без внимания. Отметим, что для практического применения описанных ниже рекомендаций необходимо войти в систему с правами Администратора.
С нашей точки зрения лучше использовать не Windows 2000 Professional, a Windows 2000 Server, причем при инсталляции системы следует придерживаться следующих рекомендаций.

  • При установке выбирать файловую систему FAT 32, т. к. FAT 32 с точки зрения задач цифрового аудио эффективнее NTFS и требует меньше оперативной памяти. Это вызвано тем, что в память не загружаются дополнительные драйверы и сервисы, необходимые для NTFS. Кроме того, многие преимущества NTFS относятся к офисной работе компьютера в сети, и в нашем случае в них нет необходимости.

Совет
Лучше всего для звуковых файлов вообще выделить отдельный жесткий диск или, в крайнем случае, раздел на диске с файловой системой FAT 32. Причем этот диск (раздел) нужно отформатировать с размером кластера 32 Кбайт. Для этого можно воспользоваться недокументированным ключом для команды FORMAT в DOS 7.0 (Windows 95 OSR2 и выше).
Командой FORMAT <drive> /z:64, отформатировать диск (раздел) или изменить размер кластера диска (раздела) с уже записанными данными можно с помощью утилиты PartitionMagic фирмы PowerQuest (www.powerquest.com). Кроме этого, для форматирования дисков (разделов) с заданным размером кластера можно воспользоваться внутренними средствами Windows 2000 — удобной оснасткой Управление дисками.
Преимущество больших кластеров для аудиоданных состоит в меньшем количестве операций чтения/записи, а эффективность использования дискового пространства будет высокой, т. к. на этом диске (разделе) будут размещаться файлы очень большого размера.

  • При появлении окна со списком компонентов Windows следует установить флажок только у компонента Стандартные и служебные программы (рис. 1.1).

Рис. 1.1. Выбор компонентов Windows 2000 Server при установке

Все остальные флажки должны быть сняты. При этом не будут устанавливаться необязательные для использования PC как цифровой звуковой рабочей станции компоненты.

После окончания установки Windows 2000 Server нужно отказаться от настройки сервера в окне, которое появляется при первом запуске, и щелкнуть правой кнопкой мыши на значке Мой компьютер. В контекстном меню выбрать пункт Свойства. В открывшемся окне Свойства системы нужно выбрать вкладку Дополнительно (рис. 1.2).

  • Рис. 1.2. Настройка параметров быстродействия

На вкладке Дополнительно нужно щелкнуть по кнопке Параметры быстродействия. При этом откроется одноименное окно, где следует установить зависимый переключатель Оптимизировать быстродействие в позицию приложений (рис 1.3).
Таким образом, максимальный приоритет получит приложение переднего плана, что нам и требуется для SAWStudio. За этот параметр отвечает ключ системного реестра:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\PriorityControl] "Win32PrioritySeparation"=dword:00000024

Рис. 1.3. Оптимизация быстродействия системы для приложений

Примечание
В некоторых двухпроцессорных конфигурациях можно получить большую эффективность, если оптимизировать быстродействие для служб, работающих в фоновом режиме. В связи с огромным ассортиментом комплектующих для PC учесть все возможные варианты и дать универсальную рекомендацию невозможно.

Далее можно подкорректировать настройку параметров управления памятью. Для этого существует отдельная ветвь системного реестра Windows 2000:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Man-agerXMemory Management

На рис. 1.4 показаны ключи, которые отвечают за наиболее важные для быстродействия параметры:

  • LargeSystemCache — (большой системный кэш). Этот параметр, если установлена ОС Windows 2000 Server, имеет по умолчанию значение 1. Так как мы собираемся использовать PC как рабочую станцию, то имеет смысл установить значение 0;
  • loPageLockLimit — (размер памяти в Кбайт, резервируемый для операций ввода/вывода). Значение по умолчанию — 512 Кбайт. Так как для SAWStudio необходимы большие объемы оперативной памяти RAM (при объеме памяти меньше 256 Мбайт программа не стартует), то появляется возможность увеличить значение loPageLockLimit. Рекомендуемые значения — 32 768 (в скобках указаны десятичные значения) и выше. Для размера RAM, превышающего 256 Мбайт, значение параметра должно быть равно 65 536. Увеличение размера памяти loPageLockLimit может существенно увеличить быстродействие системы.

Рис. 1.4. Настройка реестра Windows2000

  • DisablePagingExecutive — (запрет сброса данных ядра Windows 2000 в файл виртуальной памяти Pagefile.sys). Значение по умолчанию — 0. Имеет смысл запретить сброс данных ядра в виртуальную память, т. е. установить значение 1. Дело в том, что процесс сброса данных начинается тогда, когда одновременно открыто много приложений. При этом работа системы сильно замедляется. В нашем случае будет применяться одно приложение — SAWStudio, использующее конфигурацию компьютера с большим объемом RAM, поэтому предложенный нами выбор однозначен.
  • SecondLevelDataCache — (размер микропроцессорного кэша второго уровня). Значение по умолчанию — 0, что соответствует размеру кэша в 256 Кбайт. Если используется процессор с кэшем в 512 Кбайт, то нужно ввести десятичное значение 512.

Внимание
Изменять параметр SecondLevelDataCache следует только в случае использования процессоров ранних выпусков, имеющих внешний кэш второго уровня. Для процессоров с интегрированным кэшем второго уровня нужно оставить значение по умолчанию.

  • Если компьютер не предполагается использовать в локальной сети и на нем не будет использоваться удаленный доступ, то можно попробовать остановить некоторые лишние службы (Services).
    Для этого нужно щелкнуть правой кнопкой на значке     Мой компьютер и выбрать в контекстном меню пункт Управление (Manage).При этом откроется окно оснастки Управление компьютером (Computer management). В правом списке следует выбрать узел Службы и приложения Services and Applications) (рис. 1.5).

  • Рис. 1.5. Выбор узла Службы и приложения

    Выбранный узел является контейнером, содержащим другие оснастки. На следующем уровне нужно выбрать оснастку Службы (Services) (рис. 1.6). При этом откроется окно оснастки Службы.
    Для доступа к свойствам службы нужно дважды щелкнуть на ее названии в списке. После этого откроется окно Свойства (рис. 1.7).

Рис. 1.6. Окно оснастки Службы

Рис. 1.7. Окно Свойства

Для остановки службы достаточно нажать кнопку Стоп, а чтобы служба не запускалась автоматически при загрузке системы, нужно изменить тип запуска в одноименном выпадающем списке с Авто на Вручную.

Ниже перечислен минимальный список служб, которые должны быть запущены:

    • Plug and Play;
    • диспетчер логических дисков;
    • диспетчер учетных записей безопасности;
    • журнал событий;
    • инструментарий управления Windows;
    • клиент отслеживания изменившихся связей;
    • координатор распределенных транзакций;
    • рабочая станция;
    • расширения драйвера оснастки управления Windows;
    • система событий СОМ+;
    • служба RunAs;
    • телефония;
    • уведомление о системных событиях;
    • удаленный вызов процедур (RPC).

Примечание
Напоминаем, что приведенные рекомендации не являются обязательными для исполнения. Поэтому можно к ним не прислушиваться — например, уменьшить данный список. Но, предостерегая читателей, заметим, что при этом Windows может не загрузиться или начать работать с проблемами.
Тип запуска службы Сетевые подключения должен быть установлен в положение Отключено.

Если после остановки служб при загрузке системы появляются сообщения об ошибках, то следует создать приведенный ниже запрещающий ключ реестра:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Windows] "NoPopupsOnBoot"=dword:00000001


Оптимизация Windows 2000 с помощью утилиты Xteq Systems X-Setup

Для управления скрытыми функциями системы создаются специализированные программы-твикеры, которые заменяют ручное редактирование реестра.
Одной из таких наиболее удачных программ является утилита Xteq Systems X-Setup (версия 6) (http://www.xteq.com).
Утилита имеет предельно ясный интерфейс с исчерпывающими комментариями для каждого из параметров настройки.
Помимо этого, в ней имеется режим Record Mode, который позволяет записывать все произведенные в реестре изменения в текстовый файл.
На рис. 1.8 изображен пример редактирования параметра loPageLockLimit.

Рис. 1.8. Рабочее окно утилиты Xteq Systems X-Setup

В случае возникновения проблемы с CD-рекордером следует вернуться к установке по умолчанию (Default). Об этом говорится в комментарии окна Description (Описание) (рис. 1.8).
Обращаем ваше внимание на то, что для того, чтобы изменения достигли системного реестра, необходимо щелкнуть на кнопке Apply Changes (F9) (Сохранить изменения).
На рис. 1.9 показан пример еще одной важной установки — режима UDMA 66, который особенно актуален при работе с цифровым звуком с точки зрения быстродействия жесткого диска (или дисков).
Заключительным этапом оптимизации может стать отключение всевозможных спецэффектов, таких как анимация, отображение содержимого окна при перетаскивании и т.д. На рис. 1.10 представлен пример настройки с отключением FX-параметров.

Рис. 1.9. Включение режима UDMA 66

Рис. 1.10. Отключение спецэффектов Windows FX

Сформулируем еще одно "золотое" правило: "На компьютер, предназначенный для использования в качестве DAW, нужно устанавливать только необходимое для работы программное обеспечение (например, SAWStudio и plug-ins)".


Настройка аудиооборудования

Все основные настройки программы осуществляются в меню Options. В программах серии SAW базовая настройка традиционно начинается с настройки аудиооборудования.
Для этого в меню Options нужно выбрать пункт меню Audio Device Setup (Установка аудиоустройства).

Рис. 1.11. Настройка в окне Audio Device Setup

Окно Audio Device Setup (рис. 1.11) отображает только часть списка выходов конфигурируемых аудиоустройств — а именно, первую его половину: с Wave Device Out 01 по Wave Device Out 12. Для доступа ко второй половине (с Wave Device Out 13 по Wave Device Out 24) нужно щелкнуть по кнопке, расположенной вверху слева — с изображением двух стрелок.
Напомним, что SAWStudio поддерживает 24 стереоустройства, что соответствует 48 каналам.
Переход между списками входов (Wave Device In) и выходов (Wave Device Out) осуществляется нажатием кнопки Out/In в верхнем левом углу окна. По умолчанию все раскрывающиеся списки содержат надпись Not Assigned (Не назначенный). Для того чтобы назначить вход или выход доступного устройства, достаточно щелкнуть по кнопке, отмеченной стрелкой на рис. 1.11, а затем выбрать устройство в раскрывающемся списке.
Количество доступных в списке драйверов устройств определяется конфигурацией оборудования. На рис. 1.11 рассмотрен пример самой простой конфигурации с мультимедийной звуковой картой Sound Blaster Audigy, поэтому в раскрывающемся списке находится всего один пункт SB Audigy Audio [C400].
К большому сожалению, мультимедийные драйверы этой звуковой карты (в отличие от драйверов ASIO) позволяют использовать только два канала в программе SAWStudio — ограничивая, таким образом, выход двумя каналами. Для примера, приведенного в книге, лучше назначить SB Audigy на Wave Device Out 01.
В случае многоканального оборудования или нескольких звуковых карт конфигурация может быть произвольной, хотя удобнее всего назначать устройства по порядку (рис. 1.12).

Рис. 1.12. Пример сложной конфигурации оборудования

Например, если оборудование имеет один вход и четыре выхода, то выходы нужно поставить в соответствие с четырьмя Wave Device Out (с 01 по 04), а вход назначить только на Wave Device 01. Для Wave Device 02—04 назначать входы не нужно. Если оборудование имеет несколько входов и выходов, следует придерживаться соответствия: пара вход/выход — Wave Device XX.
Нужно отметить, что входы и выходы устройств в принципе могут назначаться независимо друг от друга. Например, вход может назначаться на Wave Device In 01, а выход на Wave Device Out 04. В случае использования единственной двухканальной звуковой карты целесообразно для ее пары вход/выход определить Wave Device 01 (рис. 1.13).
В окне Audio Device Setup выставляются еще два важных параметра:

  • In (Out) Preload Buffers — количество буферов данных предварительной загрузки (от 1 до 10) входа (выхода);
  • In (Out) Buffer Size — размер входного (выходного) буфера (от 64 до 8192 выборок (samples).
Комбинация этих двух параметров определяет фактическое время реакции виртуальной студии на любые изменения параметров в реальном времени (виртуальное микширование, нажатие на кнопки в реальном времени и т. д.). Настройка параметров сводится к выбору конкретного значения из раскрывающегося списка (рис. 1.14).

Рис. 1.13.Назначение входов звукового оборудования

Рис. 1.14. Настройка размера выходного буфера

Уменьшение размера буфера или количества буферов уменьшает время реакции виртуальной консоли, что позволяет более реально имитировать аппаратные устройства. Но это может привести к сбоям (искажениям звука) при воспроизведении или записи из-за недостаточного быстродействия компьютера. Поэтому хорошим решением оказывается, как всегда, золотая середина. В начале процесса настройки для режима воспроизведения (Out Buffer Size и Out Preload Buffers) можно использовать такое соотношение: 6 буферов при размере буфера в 1024 выборки.

Совет
При одинаковом времени отклика такая установка предпочтительнее с точки зрения стабильности воспроизведения/записи: 4 буфера по 1024 выборки, а не 2 буфера по 2048 выборок. Поэтому в случае возникновения сбоев лучше сначала увеличивать количество буферов, а уже затем — если результат не улучшается — увеличивать размер буфера.

Подход к настройке параметров для буферов входа — In Buffer Size и In Preload Buffers — имеет отличия. Как известно, главный фактор для режима записи — отсутствие сбоев (искажений). Это особенно актуально, если используется режим одновременной записи и воспроизведения SRP (Simultaneous Record and Play) и процессор сильно нагружен виртуальной обработкой звука.
Вследствие этого размер буфера входа и количество буферов должны быть обязательно увеличены по сравнению с параметрами буфера выхода. Начинать можно с комбинации 8 буферов с размером 1024 выборки.

Совет
Следует обратить внимание еще и на то, что при переходе на более высокую частоту дискретизации мультитрека увеличивается поток данных. А это потребует обязательного увеличения размера и количества буферов входа и выхода. Поэтому для удобства достаточно произвести настройку буферов входа один раз, но с некоторым запасом, или создать различные конфигурации для каждой частоты дискретизации и сохранить их в файлах настройки (об этом ниже).


Сохранение настроек

Выполнить те настройки, что были описаны выше, достаточно единожды. Это, конечно же, не касается случаев замены оборудования. Сохраняются эти настройки в файл с расширением prf (так же, как и в программе SAWPro). Но при внешнем сходстве этих двух программ SAWStudio имеет существенное отличие — здесь эта функция расширена. Точнее говоря, одни и те же установки можно сохранить в двух вариантах: как пользовательские или как установки по умолчанию.
Пользовательские установки могут понадобиться, например, в случае применения различных конфигураций оборудования под разные типы проектов. Установки по умолчанию загружаются в SAWStudio автоматически при каждом запуске программы.

Примечание
К настройкам, сохраняемым в файлах prf, относится глобальная конфигурация программы. Исключение составляют: установки по умолчанию конфигурации рабочих экранов (для них предусмотрен отдельный конфигурационный тип файла — F-Key File) и шаблоны по умолчанию виртуального микшера — Mix Template File (об этом ниже).

Для сохранения пользовательской настройки необходимо:
  1. 1. Открыть меню File | Preferences File и выбрать пункт меню Save.
  2. 2. В диалоговом окне Save Preferences File (рис. 1.15) озаглавить файл с расширением prf.

Рис. 1.15. Cохранение пользовательской настройки

Примечание
Если программа SAWStudio устанавливалась на диск С:, то файлы пользовательских настроек (prf) сохраняются в папке C:\SAWStudio\Configuration.

Загрузить пользовательскую настройку можно командой Open в меню File | Preferences File. При этом программа SAWStudio переинициализируется с новыми параметрами.
Для сохранения установок по умолчанию нужно выполнить команду Save Default в меню File | Preferences File.
Файл, содержащий настройки по умолчанию — SAWStudio.prf — располагается в папке SAWStudio.
Возвратить настройки в первоначальное состояние (соответствующее первому запуску программы) можно командой Clear Default в меню File | Preferences File.

Внимание
Команда Clear Default очищает файл SAWStudio.prf без переинициализации программы. Поэтому для возврата к первоначальным установкам программу необходимо перезапустить.


Режим Region Memory Caching

Недеструктивное редактирование — способ, при котором исходный материал не разрушается. Он основан на понятиях Entry (запись) — объект, расположенный на мультитреке, и Region (регион) — образно говоря, ссылка на область звукового файла, или его "фотография".
Метод недеструктивного редактирования позволяет производить операции не с самими физическими файлами, а со ссылками на них — Regions, Например, разрезание, копирование, перемещение и т. д. При этом существенно экономится место на жестком диске компьютера, т. к. один регион может размещаться на мультитреке многократно. Забегая вперед, отметим, что регионы проекта хранятся в своеобразной "базе данных" программы SAWStudio — специальном списке Regions, который отображается в одноименном окне.
В верхней строчке окна Regions (рис. 1.16) отображены параметры кэширования в процентном отношении:
  • первый параметр (Р-100%) — отражает количество кэшированных Peak-данных регионов, выложенных на мультитрек и содержащих графическое отображение формы волны (подробнее об этом ниже);
  • второй параметр (N-100%) — показывает количество кэшированных регионов, выложенных на мультитрек (то есть wave-данных).
Существует режим, позволяющий загружать непосредственно в оперативную память все физические звуковые данные, соответствующие тем регионам, которые используются на мультитреке. Для активизации этого режима достаточно отметить опцию Use Region Memory Caching в меню Options.

Рис. 1.16. Индикация режимов кэширования в окне Regions

Примечание
Здесь прослеживается аналогия с проектом RAM Wave программы Samplitude 2496, который также полностью загружается в оперативную память.
Подобный метод полного кэширования звуковых данных проекта позволяет существенно увеличить быстродействие. Это объясняется тем, что данные считываются не с жесткого диска, а непосредственно из оперативной памяти. Такая возможность особенно важна для работы со звуковыми данными, имеющими разрядность 24 бита и частоту дискретизации 96 кГц. Однако применять этот режим следует на компьютерах с объемом RAM не менее 768 Мбайт.

Примечание
Отметим, что на сегодняшний день увеличение объема RAM обходится дешевле, чем приобретение дорогостоящих HDD SCSI RAID-систем. Поэтому режим кэширования регионов можно отнести к серьезным преимуществам SAWStudio.

Если объема RAM будет недостаточно, то операционная система Windows начнет сбрасывать звуковые данные на жесткий диск в файл виртуальной памяти. Это приведет к большему снижению производительности, чем при отключенном режиме кэширования регионов. Однако в тех случаях, когда проект состоит из значительного количества небольших регионов (например, циклических фрагментов Loops), режим кэширования регионов можно включать и при меньшем объеме RAM.
Для контроля за состоянием памяти нужно запустить диспетчер задач (Task manager) Windows 2000 (NT). Он вызывается одним из трех способов:

  • в контекстном меню панели задач выбирается пункт Диспетчер задач (Task manager);
  • в окне Запуск программы (Пуск | Выполнить) в списке Открыть вводится имя программы taskmgr;
  • после нажатия комбинации клавиш <Ctrl>+<Alt>+<Del> в появившемся окне нажимается кнопка Диспетчер задач.
На вкладке Быстродействие в окне Диспетчер задач Windows (рис. 1.17) можно наглядно определить в процентах использование физической памяти. Если оно превышает 50—75%, то режим кэширования регионов следует отключить.

Рис. 1.17. Контроль за использованием физической памяти

Установка режима кэширования регионов может быть сохранена как настройка по умолчанию.


Режим Region PeakData Memory Caching

Этот режим включен программой по умолчанию и отключать его не следует, т. к. это может снизить быстродействие графического вывода картинки формы волны региона.
В процессе редактирования проекта пользователю приходится многократно менять масштаб отображения формы волны на мультитреке. В решении этой задачи программе SAWStudio нет равных — она обладает поистине беспрецедентным быстродействием графического вывода и оставляет далеко позади другие известные мультитрековые программы (например, Cakewalk Pro Audio или Cool Edit Pro). Это особенно заметно при редактировании сложных проектов, содержащих большое количество аудиообъектов.
Файлы, содержащие графическую информацию, имеют расширение wpd (сокращение от wave peak data) и имя, совпадающее с названием исходного звукового wave-файла.
Режим Region PeakData Memory Caching включен, если отмечена опция Use Region PeakData Memory Caching в меню Options. Данная установка может быть также сохранена как настройка по умолчанию.


Выбор модели аудиодрайвера

Модели аудиодрайвера выбираются в меню Options, подменю Audio Driver Model.
  • Модель Standard MultiMedia подходит для большинства мультимедийных звуковых карт.
  • Модель Hi Performance MultiMedia устраняет избыточные обращения к функции драйвера в течение записи и воспроизведения (за счет этого повышается быстродействие), однако не все звуковые карты способны работать в таком режиме.
  • Модель DWave Protocol предложена фирмой IQS для самой короткой связи между звуковой картой и программой SAWStudio.

Примечание
Эта модель обеспечивает самое высокое быстродействие, но, к сожалению, до сих пор — на момент написания данной книги — она не получила широкого распространения. Протокол DWave минимизирует задержку (extremely low latency) при взаимодействии драйвера аудиоустройства с программой SAWStudio. Можно сказать, что DWave Protocol — это своеобразный аналог программного интерфейса ASIO, который поддерживается такими программами, как Nuendo и Cubase VST. Разработчики фирмы IQS утверждают, что в настоящее время они добиваются поддержки данного протокола у производителей звуковых карт. Когда это произойдет, вероятно, DWave станет таким же распространенным стандартом, как ASIO (разговор об ASIO мы возобновим в следующей главе).

Эта установка также может быть сохранена как настройка по умолчанию.


Auto Zero Cross — установка автоматического поиска нулевого отсчета

В режиме Auto Zero Cross операции редактирования — разрезания и выделения — осуществляются вблизи отсчета с нулевым уровнем. Это позволяет избежать щелчков на стыках при соединении фрагментов.
Включается данный режим одноименной опцией Auto Zero Cross в меню Options и, при необходимости, может сохраняться как установка по умолчанию.


Auto Monitor Switching Protocol — выбор протокола мониторинга

Подменю Auto Monitor Switching Protocol меню Options содержит два пункта:
  • off — выключено. Эта опция должна быть установлена для всех звуковых карт, за исключением аудиоинтерфейсов RME;
  • RME ZLM Protocol — протокол мониторинга профессиональных аудиоинтерфейсов RME (http://www.rme-audio.com). Если включена эта опция, то входной сигнал контролируется с нулевой задержкой.

Выбор протокола мониторинга также может быть сохранен в качестве установки по умолчанию.


Настройка максимального количества уровней отмены

Одно из главных преимуществ программы SAWStudio — это максимальная надежность и сохранность данных. Она достигается благодаря тому, что в программе — после каждой операции недеструктивного редактирования на мультитреке — автоматически создается новый дублирующий файл проекта.
Это происходит потому, что в меню Options по умолчанию отмечена опция Auto EDL Undo. Мы рекомендуем ее не отключать, чтобы не лишать себя такой замечательной страховки. Нужно помнить, что сессионный EDL-файл — несмотря на то, что в нем нет никаких звуковых данных — содержит важную служебную информацию (по аналогии с проектом программы SAWPro). В нем находятся следующие сведения: конфигурации мультитрека со всеми настройками (включая расположение на дорожках аудиообъектов (Entry)), пресеты эффектов, автоматизация, конфигурация виртуальной консоли и пути к звуковым файлам на жестком диске, — все это хранится в файле с расширением edl (сокращение от EDL — Edit Decision List, список решений редактирования).

Внимание
Потеря ЕDL-файла приводит к исчезновению виртуального проекта (сессии). Восстановить его вручную можно, но на практике это оказывается трудоемким процессом.

Термин Entry
Термин Entry, введенный разработчиками IQS, переводится на русский язык как запись, элемент, вход. Фактически это аудиообъект (или просто объект), помещенный на мультитрек. Именно так он и будет называться в книге. Для удобства восприятия материала мы взяли на себя смелость вольного перевода этого термина, т. к., с нашей точки зрения, слова объект, аудиообъект лучше передают суть данного термина.

Нумерация EDL-файлов происходит одинаково в обеих программах — SAWStudio и SAWPro. Решение реализовано так: все операции редактирования сохраняются как копия EDL-файла с расширением, состоящим из буквы "u" и двухзначного числа (uХХ): например, u12, где 12 — порядковый номер уровня отмены. При этом номера возрастают по мере их удаления во времени, т. е. последнее исправление — ближайший уровень отмены — всегда будет отмечено самым маленьким номером — uОО.
Пользователь сам определяет "запас прочности", задавая необходимое количество уровней отмены командой Set EDL Undo Levels в меню Edit. Для этого в окне Set EDL Undo Level Count (рис. 1.18) вводится выбранное число: от 1 до 99.

Рис. 1.18. Ввод количества уровней отмены

EDL-файлы отмены с лихвой окупают затраченное на них дисковое пространство: они предохраняют проект от сбоев в оборудовании, потери напряжения электросети и т. п. В связи с тем, что их размеры невелики в сравнении с аудиоданными, емкость современных жестких дисков вполне безболезненно позволяет хранить до 99 файлов отмены каждого проекта. Поэтому экономить на надежности, по всей видимости, нет смысла.
Однажды установленное количество уровней отмены можно не повторять в дальнейшем, а сохранить как настройку по умолчанию.

Примечание
Когда "черновые варианты" — файлы уровней отмены — становятся не нужны, их можно удалить командой Clear EDL Undo Hystory (Очистить историю отмены) в меню Edit.

Нужно отметить, что уровень сервиса в SAWStudio повысился со времен достаточно "аскетичной" программы SAWPro. Теперь, например, значительно удобнее стало передвигаться по истории отмен. Для этого создано специальное окно EDL Undo History (рис. 1.19), которое вызывается командой Display EDL Undo History в меню Edit.

Рис. 1.19. Окно истории отмен EDL Undo History

Слово Before (прежде) в строке списка означает, что если на ней выполнить двойной щелчок, то мультитрек окажется в состоянии до выполнения выделенной в списке операции. Операция с номером 01 является последней в истории команд.

Примечание
Для того чтобы окно EDL Undo History стало доступным, нужно сохранить проект командами Save Session As или Update Session в меню File или открыть историю отмен командой Display EDL Undo History в меню Edit. При этом будет предложено загрузить файл последней отмены с расширением uОО.


Default File Path Setup (настройка путей к файлам по умолчанию)

Все файлы проекта (сессии) являются взаимосвязанными и по умолчанию хранятся в папке программы SAWStudio. Но бывают ситуации, когда пользователю удобнее расположить эти файлы по-другому, например, на наиболее свободном диске (логическом, физическом). Для выполнения подобной операции предусмотрена команда File Path Setup в меню Options, после которой в открывшемся окне Default File Path Setup (рис. 1.20) можно задать новые пути к сессионным файлам.
Рассмотрим настройку в этом окне подробнее.
  • Session EDL Path — строка, в которой задается путь к файлам сессии с расширением edl. Для его изменения нужно:
    • либо щелкнуть в начале текстового поля и ввести новые данные с клавиатуры;
    • либо после щелчка на текстовом поле нажать кнопку Browse (Обзор) и в окне Browse For Folder (рис. 1.21) определить или создать новую папку.

      Рис. 1.20. Окно Default File Path Setup

      Рис. 1.21. Окно Browse For Folder

      • SoundFile Playback Path — путь к звуковым файлам, загружаемым в SAWStudio.
      • SoundFile Record Path — путь к папке, где будут автоматически сохраняться записанные звуковые файлы. (Эта установка может быть изменена в окне МТ Record Setup в процессе записи — см. разд. "Окно Record Remote Transport Window").
      • Mix Template Path — путь к папке, куда будут сохранены шаблоны виртуального микшера Mix Template.
      • Alternate PeakData Path — путь к дополнительной папке. В ней графические Peak-файлы формы волны сохраняются тогда, когда они по каким-то причинам не могут быть помещены в одно и то же место со звуковым файлом-источником. Например, в том случае, если звуковые файлы расположены на CD-ROM.
      • EDL Undo Path — путь к папке, где будут сохраняться файлы отмены (uХХ).

      Совет
      Если это текстовое поле не заполнять, то файлы отмены будут иметь тот же путь, что и файлы текущей сессии. Но лучше так не делать, а зарезервировать для файлов отмены отдельную папку.

      • SoundFile Undo Path — путь к той папке, в которой будут храниться файлы отмены редактирования звуковых файлов. Если это текстовое поле оставить незаполненным, то файлы отмены будут размещены вместе с файлами текущей сессии.
      • Кнопка Current Patch изменяет значение в выбранном текстовом поле — устанавливает в нем тот путь, который используется в настоящее время. Для проведения этой операции нужно:
        • предварительно щелкнуть на текстовом поле того пути, который нужно изменить;
        • затем нажать кнопку Current Patch.
      • Кнопка Reset сбрасывает все установки, сделанные пользователем, и возвращает их в состояние по умолчанию.

      Совет
      Для того чтобы в дальнейшем использовать сделанные вами установки в окне Default File Path Setup, их нужно сохранить как настройки по умолчанию командой File | Preferences File | Save Default.


Настройка рабочих экранов

Размещение полномасштабной цифровой студии на экране монитора — задача не из легких. Для ее решения создатели SAWStudio разработали уникальный интерфейс с большим количеством окон, предназначенный для того, чтобы пользователь имел возможность оперировать с необходимым количеством графических объектов в жестко ограниченном пространстве, не выходящем за рамки экрана монитора.
"Расставлять мебель" в виртуальной студии — организовывать свое "рабочее место" — пользователь должен самостоятельно, исходя из своих предпочтений. Действительно, кто может справиться с этой задачей лучше?

Примечание
Отметим, что Боб Лентини при создании этой программы сумел обойти (насколько это вообще возможно) операционную систему Windows. Результат от "обмана" Windows достаточно интересен: при работе SAWStudio операционная система "считает", что открыто только одно окно. Иными словами, все внутренние окна этой программы являются "невидимыми" для Windows. А весь графический интерфейс достаточно мал — он занимает всего 10,2 Мбайт— и компактно расположен — в одной библиотеке SAWStudioGraphics.dll.

В программе предлагаются базовые конфигурации рабочих экранов, предназначенные для разных разрешений монитора (файлы SAWStudioJ024x768.fky — SAWStudio_ 1600x1200.fky). Они находятся в папке Configuration, вложенной в папку SAWStudio и, честно говоря, являются больше ознакомительными, т. к. зачастую пользователь при эксплуатации программы самостоятельно определяет эти настройки.
Отрадно отметить, что общий уровень сервиса в SAWStudio значительно повышен по сравнению с SAWPro. Более того, он улучшен соразмерно возросшей сложности программы:

  • появилась возможность создания 24 рабочих экранов;
  • конфигурации рабочих экранов сохраняются независимо от остальных установок программы в файлы с расширением fky.

Закрепление настройки рабочего экрана за функциональной клавишей

Для настройки одного рабочего экрана и закрепления его за определенной функциональной клавишей нужно выполнить описанную ниже последовательность действий.

  1. 1. Нажать любую из функциональных клавиш с <F1> пo <F12>.
  2. 2. Свернуть все ненужные окна. Для этого достаточно щелкнуть по кнопке в правом верхнем углу сворачиваемого окна. На рис. 1.22 показана кнопка свертывания окна MultiTrack.
    Вызвать окна, необходимые для данного экрана, из меню View.
  3. 3. Расположить их на экране (изменив при необходимости их размеры).

Примечание
Обращаем внимание, что "запоминается" не только расположение окон и их размеры, но и выбор активного окна. Поэтому перед закреплением конфигурации за функциональной клавишей следует выделить активное окно — для этого нужно щелкнуть мышью в его поле. При этом название активного окна "подсветится" желтым цветом.

Совет
В окне MultiTrack можно задать масштаб по вертикали клавишами <Раgе Up>, <Раgе Down>.

  1. 4. Закрепить экран за функциональной клавишей. Для этого нужно сначала нажать клавишу <Shift>, а затем, не отпуская ее, — любую из функциональных клавиш <F1>—<F12>.

Рис. 1.22. Кнопка свертывания окна MultiTrack

Таким способом можно зафиксировать 12 рабочих экранов и сохранить созданную конфигурацию в файл my_configuration.fky командой File | F-Key File | Save. Для загрузки ранее сохраненной конфигурации следует воспользоваться командой File | F-Key File | Open.
Программа SAWStudio позволяет сохранять 12 дополнительных экранов — в дополнение к такому же количеству основных. Они закрепляются аналогичным образом, но с одним отличием: дополнительной клавишей <Alt>.
Таким образом, алгоритм создания дополнительного рабочего экрана выглядит так: комбинация <Alt>+<Shift>+<Fn> при закреплении и <Alt>+<Fn> при вызове, где n — номер функциональной клавиши.
По аналогии с основными экранами, конфигурация дополнительных рабочих экранов может быть сохранена в отдельный файл командой File | F-Key File | Save Alternate. Загрузка дополнительных экранов осуществляется командой File | F-Key File | Open Alternate.
Если полученная конфигурация из 24 экранов оказалась универсальной, то имеет смысл сохранить ее в качестве настройки по умолчанию. Делается это с помощью команды File | F-Key File | Save Default. Сбросить настройки экранов в состояние по умолчанию, которое было при первом запуске программы, можно командой File | F-Key File | Clear Default.

Примечание
На прилагаемом к книге компакт диско предлагается авторский вариант конфигурации рабочих экранов, файлы FKey.fky и FKey_alt.fky, расположенные в папке SAWStudicAConfiguration.


Режим Force Single CPU

Для двухпроцессорных конфигураций предусмотрен режим Force Single CPU, который включается одноименной командой в меню Options.

Примечание
Команда Force Single CPU недоступна в однопроцессорных системах.

Рис. 1.23. Загрузка процессоров в дуальном режиме

Двухпроцессорный режим — это одно из главных достижений SAWStudio. Он является основным, и переходить в режим Force Single CPU следует в двух случаях: для тестирования системы или для освобождения ресурсов второго процессора для других приложений.
В режиме Force Single CPU производительность SAWStudio всегда падает по сравнению с двухпроцессорным режимом. На рис. 1.23 показана загрузка процессоров, отображаемая на графике Хронология загрузки ЦП диспетчера задач Windows в дуальном режиме.

Примечание
Для тестирования использовался проект, "нагруженный" виртуальными plug-ins.

На графике отчетливо видно, что загрузка у второго процессора значительно выше, чем у первого. Если исследовать загрузку процессоров в режиме старта воспроизведения проекта, "тяжелого" с точки зрения количества подключенных plug-ins, то мы увидим картину, изображенную на рис. 1.24.

Рис. 1.24. Перераспределение нагрузки в момент рестарта воспроизведения

В момент рестарта нагрузка перераспределилась в сторону первого процессора, а затем система вернулась к прежнему состоянию. Распределение нагрузки в режиме Force Single CPU показано на рис. 1.25.

Рис. 1.25. Перераспределение нагрузки в режиме Force Single CPU

Может сложиться впечатление, что процессоры поменялись ролями. Однако это не так — просто теперь программой SAWStudio "занимается" только первый процессор.
На рис. 1.26 хорошо видно, что у второго процессора отсутствует характерный пик нагрузки в момент рестарта воспроизведения.
Двухпроцессорный режим имеет большое значение с точки зрения повышения производительности PC DAW. Увеличивается максимальное количество подключаемых plug-ins, обеспечивается более высокая стабильность при "тяжелой" загрузке. Поэтому можно еще раз подчеркнуть, что для построения высокопроизводительных виртуальных DAW с профессиональным качеством обработки звука нужно использовать мультипроцессорные конфигурации PC.

Рис. 1.26.Рестарт воспроизведения проекта режиме Force Single CPU


Форматы файлов SAWStudio

Программа SAWStudio является достаточно сложной системой, поэтому помимо основных файлов сессий EDL и звуковых wav-файлов в ней используются дополнительные форматы. Рассмотрим все форматы файлов SAWStudio подробнее и для удобства сведем их в табл. 1.1.

Таблица 1.1. Форматы файлов SAWStudio

Название файла | Расширение файла | Назначение файла
Сессия, EDL (Edit Decision List) | edl | Содержит всю информацию о виртуальном проекте, включая настройки виртуального микшера и plug-ins, список регионов, расположение объектов (Entry) на мультитреке, списки регионов библиотек Library, а также информацию о расположении звуковых файлов
Звуковой файл (sound file) | wav | Содержит цифровые аудиоданные
Файл отмены | uXX | Физическая копия EDL-файла, содержащая состояние проекта на данном уровне отмены
Файл конфигурации рабочих экранов F-Key File | fky | Содержит запрограммированное соответствие 12 рабочих экранов 12-ти функциональным клавишам
Файл шаблона микшера Mix Template File. Может загружаться в любую сессию | mxt | Содержит конфигурацию виртуального микшера с подключенными plug-ins, названия дорожек мультитрека, выбор текстуры объектов, а также текущие активные установки шаблона записи
Файл шаблона записи Record Template File | mrt | Содержит информацию о соответствии входов и дорожек мультитрека при записи
Файл настройки Preferense File | prf | Содержит информацию о глобальных установках SAWStudio
Файл шаблона управления по MIDI (MIDI-Control Template File) | mct | Содержит настройку для организации взаимодействия по MIDI программы SAWStudio с микшер-контроллерами
Файл-пресет для DirectX plug-ins (DirectX Preset File) | dxp | Содержит настройку конкретного DirectX plug-in
Файл-пресет для VST plug-ins (VST Preset File) | vsp | Содержит настройку конкретного VST plug-in
Файл графического интерфейса Shades File | shd | Содержит настройку внешнего вида дизайна программы (аналог Skin)
Файл-пресет автоматизации Automation Preset File | aut | Содержит кривую автоматизации параметра (например, Fade In или Fade Out)

Файлы, содержащие настройки, которые загружаются при старте программы, называются SAWStudio и имеют расширения, соответствующие назначению сохраненных предустановок:

  • SAWStudio.fky — настройка по умолчанию 12-ти рабочих экранов (клавиши <F1>-<F12>);
  • SAWStudioAlt.fky — настройка по умолчанию 12-ти дополнительных рабочих экранов (клавиши <Alt>+<Fl>—<Alt>+<F12>);
  • SAWStudio.prf — глобальная настройка по умолчанию;
  • SAWStudio.mxt — настройка по умолчанию шаблона виртуального микшера.
Все эти файлы хранятся в папке SAWStudio.


Окно MultiTrack

Базовые понятия

В этой главе мы введем базовые понятия, облегчающие восприятие дальнейшего материала.
Интерфейс SAWStudio во многом напоминает интерфейс SAWPro, хотя имеет и существенные отличия, вызванные большими возможностями SAWStudio. Рассмотрим основное окно программы SAWStudio, которое называется MultiTrack (рис. 1.27).
Так как SAWStudio представляет собой не только виртуальную консоль, но и программно реализованный мультитрековый Hard Disk Recorder, то окно MultiTrack состоит из большого количества дорожек.
В отличие от других рассматриваемых в этой книге программ количество дорожек в SAWStudio строго фиксировано.

Окно MultiTrack можно условно разделить на две части:
  • меньшая часть (слева), где располагается управление треками — зона
    треков;
  • большая часть (справа), где располагаются аудиообъекты — зона объектов.
Вертикальная граница проходит чуть правее кнопок с надписью REC.

Дорожки в SAWStudio подразделяются на пять различных классов:
  • 72 дорожки класса Input (входные дорожки);
  • 6 дорожек класса Return (дорожки возврата);
  • 24 дорожки класса Output (выходные дорожки);
  • 1 дорожка класса Video (дорожка видео);
  • 1 дорожка класса Control (управляющая дорожка).
Нужно отметить некоторое сходство в реализации концепции виртуальных каналов в двух программах: в SAWStudio и Cubase VST фирмы Steinberg.

Рис. 1.27.Окно MultiTrack

Примечание
В Cubase VST разные аудиодорожки могут использовать общий аудиоканал.

В отличие от программы SAWPro, в SAWStudio понятия дорожки и виртуального канала не тождественны: в SAWPro любая дорожка одновременно является каналом виртуального микшера, в SAWStudio каналы виртуального микшера могут использоваться отдельно от дорожек и подключаться (в зависимости от их класса) к любому входу или выходу аудиоустройств.
Дорожки разных классов занимают соответствующие вертикальные секции в окне MultiTrack. Самую большую секцию составляют 72 дорожки класса Input, содержащие аудиоданные в виде объектов и данные автоматизации.
Для быстрого перемещения между секциями на интерфейсе предусмотрены три кнопки I (Input), R (Return), О (Output), расположенные в левом нижнем углу окна MultiTrack.

Примечание
Каждая кнопка переносит "горячий" трек на первую дорожку секции. Смысл понятия "горячий" трек будет подробно раскрыт в дальнейшем.

На рис. 1.28 изображены вертикальные секции дорожек Return и Output. Если сравнить номера дорожек, то можно увидеть, что номер дорожки Input Track не имеет никаких дополнительных символов кроме цифр. Напротив, номер дорожки Return Track содержит символ возврата <. Например, номер 2< означает, что данная дорожка — это вторая дорожка возврата.

Рис. 1.28. Секции дорожек Return и Output

Номер выходной дорожки содержит символ >. Например, номер 9> обозначает девятую выходную дорожку.
Скажем несколько слов об общепринятой терминологии. Термин возврат пришел в программу SAWStudio из мира аппаратных микшерных пультов.
Каждый современный микшерный пульт помимо основных каналов содержит еще и вспомогательные — auxiliary (AUX-шины), имеющие многофункциональное назначение.
Сигнал с каждого канала микшера может посылаться на AUX-шину и затем возвращаться, смешиваясь с основным сигналом. Например, он может быть послан через AUX-шину на аппаратный процессор эффектов, а затем — с его выхода — возвращен обратно в микшер.
Виртуальный микшер SAWStudio создан по образу и подобию аппаратного, поэтому в нем предусмотрены шесть вспомогательных AUX-шин. Соответственно и дорожек возврата Return Track тоже шесть.
Таким образом, сигнал каждой дорожки класса Input может посылаться через виртуальную AUX-шину на виртуальную (или аппаратную) обработку и возвращаться на дорожку класса Return (как это делается, мы рассмотрим ниже).

Примечание
По умолчанию выход AUX-канала назначен на вход Return-канала через виртуальную шину.

Может возникнуть вопрос: "А зачем вообще внутренние шины виртуальной консоли нужно было выносить на мультитрек в виде дорожек?" Ответ содержится в принципах построения интерфейса SAWStudio. На дорожках мультитрека располагаются не только аудиоданные в виде объектов, но и данные автоматизации, которые мы в дальнейшем подробно рассмотрим. Так как интерфейс SAWStudio не предусматривает отдельных дорожек автоматизации, как, например, интерфейс программы Nuendo, то для разработчиков оказалось проще и логичнее запретить расположение аудиообъектов на дорожках Return Track. Таким образом, дорожки Return предназначены только для данных автоматизации.
Теперь остановимся на дорожках класса Output. Дорожки этого класса тоже предназначены для данных автоматизации. Но из-за сложностей маршрутизации сигналов в SAWStudio они выполняют двойные функции:

  • мастер-каналов, если их выходы назначены на аудиоустройства (фейдеры (Fader) громкости и панорамы мастер-канала маркируются ярким темно-красным цветом);

Примечание
В случае использования обычной двухканальной Windows-мультимедиазвуковй карты функцию мастер-дорожки может выполнять всего один Output Track.

  • групп (sub-group), если их выходы назначены на мастер-каналы (фейдеры громкости и панорамы группового канала маркируются светло-красным цветом).

Примечание
Аналогичное устройство, состоящее из каналов и групп, имеет виртуальный микшер программы Cubase VST, поэтому те пользователи, которые хорошо знакомы со структурой виртуальной студии VST, не столкнутся с трудностями в освоении SAWStudio.

Группы — это Submix-каналы, куда могут сводиться сигналы Input Tracks и Return Tracks. В свою очередь группы сводятся в мастер-каналы.
В SAWStudio можно создавать любые виртуальные схемы маршрутизации разной степени сложности, зависящей от конкретной задачи.
Рассмотрим подробнее мастер-каналы. Организация мастер-каналов и групп подчиняется простым правилам:

  • Если Out Track N назначается на Wave Device Out N (где N — номер устройства), то он становится мастер-каналом. Иными словами, номер устройства и выходного канала должны совпадать.

Примечание
Номер мастер-канала должен совпадать с реальным номером аудиоустройства, назначенного в окне Audio Device Setup (см. рис. 1.11). В противном случае при старте воспроизведения появится предупреждающее сообщение. Это говорит о том, что если устройство Wave Device Out 2 не определено, то, соответственно, не может быть и мастер-канала Out Track 2.

  • Если Out Track N назначен на устройство Wave Device Out M (где N — номер выходного канала, а М — номер устройства), то он становится группой или групповым каналом. В этом случае номер устройства и выходного канала не совпадают.

Примечание
Недопустимо назначение групп друг на друга.

Если, например, Wave Device Out 03 назначен на выход звуковой карты, то только Out Track 03 может быть мастер-каналом для этого выхода. Все остальные выходные каналы, назначенные на устройство Wave Device Out 03, могут выполнять только функции групп, т. е. их сигналы пройдут на выход звуковой карты через мастер-канал Out Track 03.
Введем еще одно фундаментальное понятие интерфейса SAWStudio — "горячий" трек (Hot Track). На рис. 1.28 "горячей" является дорожка Return Track 1<.
Hot Track обозначается двумя белыми параллельными линиями на границах дорожки.
Для того чтобы сделать дорожку "горячей", достаточно щелкнуть на ней мышью в зоне объектов.

Примечание
Дальше при описании команд, выполняемых с помощью мыши, в случае, если название кнопки не указывается, имеется в виду левая кнопка мыши.

С точки зрения программы "горячий" трек — это та дорожка, которую в данный момент редактирует пользователь, поэтому все остальные окнапрограммы жестко привязаны к "горячему" треку и отображают только его параметры.
С точки зрения удобства пользователя интерфейс, использующий "горячий" трек, трудно переоценить.
В обычных мультитрековых программах виртуальный микшер представляет собой отдельное окно, которое нужно постоянно прокручивать в поисках нужного канала. Это занятие чрезвычайно утомляет и отнимает дополнительное время. В SAWStudio благодаря "горячему" треку нет необходимости постоянно прокручивать микшер, достаточно сделать дорожку "горячей", и все сопутствующие окна, включая микшер, виртуальные эффекты, автоматически примут номер выделенного трека.

Манипуляции с дорожками мультитрека

Рассмотрим основные манипуляции, которые можно производить с дорожками в окне MultiTrack.

  • Перемещение дорожки можно производить, ухватившись мышью за кнопку с номером трека (Track Number Zone) при нажатой клавише <Shift> (рис. 1.29).

Рис. 1.29. Перемещение дорожек

Очень часто порядок расположения дорожек приходится изменять, например, при совместном редактировании треков.
Для того чтобы восстановить стандартный порядок расположения треков, нужно щелкнуть на любой кнопке с номером трека при нажатой клавише <Ctrl>.
  • Дать название треку можно после щелчка на поле Track Label, расположенном между кнопкой с номером трека и кнопкой REC. Для этого нужно ввести заголовок в текстовое поле в диалоговом окне Enter Input Track Label (рис. 1.30) и нажать клавишу <Enter>.

Рис. 1.30. Ввод названия трека

Маленькая цифра 1, расположенная в левом нижнем углу поля Track Label, означает, что на мультитреке используется первый слой.
Уникальность интерфейса SAWStudio заключается в том, что ее мультитрек не ограничен двумя измерениями — он имеет несколько слоев. Многослойностъ проявляется в том, что пользователь имеет возможность независимо использовать на каждой из дорожек до восьми слоев (подробнее о слоях, см. разд. "Многослойный мультитрек" далее в этой главе).

  • Изменить вертикальный масштаб дорожек можно с помощью "горячих" клавиш:
    • <Page Up> — увеличение масштаба по вертикали;
    • <Page Down> — уменьшение масштаба по вертикали (рис. 1.31);

Совет
Рекомендуем закрепить часто используемые значения масштаба по вертикали за функциональными клавишами (подробнее об этом см. разд. "Настройка рабочих экранов" ранее в этой главе). В этом случае в области отображения всегда будет расположен "горячий" трек и границы окна MultiTrack изменяться не будут.

    • сочетания <Ctrl>+<Page Up> и <Ctrl>+<Page Down> устанавливают, соответственно, максимальный и минимальный масштаб по вертикали.

Рис. 1.31. Изменение масштаба по вертикали

  • Позиционировать курсор мультитрека можно щелчком мыши в выбранной позиции в зоне объектов (рис. 1.31). Курсор мультитрека можно также перетаскивать мышью.
  • Изменить горизонтальный масштаб отображения формы волны объектов можно с помощью кнопок Zoom (+Zm; —Zm) или горячих клавиш (<+> и <->) на дополнительной клавиатуре:
    • кнопка +Zm или клавиша <+> — увеличивает горизонтальный масштаб;
    • кнопка —Zm или клавиша <-> — уменьшает масштаб;
    • комбинации <Ctrl>+<+> и <Ctrl>+<-> на дополнительной клавиатуре, соответственно, устанавливают максимальный и минимальный масштаб по горизонтали.

Кнопки +Zm и -Zm имеют контекстные меню, позволяющие быстро устанавливать необходимый масштаб по горизонтали (рис. 1.32). Для вызова контекстного меню нужно щелкнуть правой кнопкой мыши на кнопке +Zm или —Zm.

Рис. 1.32. Контекстное меню Zoom

Наибольший масштаб достигается при такой установке Zoom, когда один отсчет равен одному пикселу (1 Samples/Pixel), а наименьший — при максимальном количестве отсчетов на пиксел (Zoom равен 2 097 152 Samples/ Pixel).

Область Top-Client Area в окне MultiTrack

В левом верхнем углу окна MultiTrack располагается транспортная панель, совмещенная с индикатором позиции курсора мультитрека (рис. 1.33).
Интересно разрешена в программе извечная дилемма с удобством расположения транспортной панели (или деки). Проблема заключалась в том, что, с одной стороны, панель постоянно нужна в работе, а с другой — из-за ее больших размеров — загораживается значительная часть экрана. Для того чтобы транспортная панель не путалась под ногами и ее не приходилось постоянно сворачивать и разворачивать, в SAWStudio транспортная панель просто встроена в окно MultiTrack. Теперь она всегда на виду и не мешает работе.

Рис. 1.33. ОбластьТор-Client Area

Кроме этого, дека совмещена с дисплеем позиции курсора (Time Display)
мультитрека ("счетчиком ленты"), что, несомненно, является еще одним удобством программы.
Резюмируя сказанное, отметим, что общие принципы построения интерфейса SAWStudio базируются на идее максимального комфорта пользователя. Очевидно, в связи с этим все основные элементы управления сосредоточены в верхней части окна MultiTrack, которая называется Top-Client Area.

Перечислим функции кнопок транспортной панели.

  • Stop — остановка воспроизведения или записи, дублируется щелчком правой кнопки мыши в зоне объектов или в окне микшера.
  • Play — старт воспроизведения, дублируется щелчком правой кнопки мыши в зоне объектов или в окне микшера. Иначе говоря, каждый щелчок правой кнопки мыши запускает или останавливает воспроизведение. (Старт и остановка воспроизведения также дублируются клавишей <Пробел>).

Примечание
Операцию старт воспроизведения — с предварительной загрузкой буферов мультитрека — можно выполнить клавишей <Enter> (вместо кнопки Play). При этом появится диалоговое окно с сообщением PreLoad Complete... Click OK To Begin Playback!. Воспроизведение начнется после щелчка на кнопке ОК.

  • Play Mark — однократное воспроизведение выделенного участка. Воспроизведение начнется со стартовой границы выделенной области и автоматически закончится на финальной границе.
  • Play Loop — циклическое воспроизведение выделенной области. Если эта кнопка нажата, то выделенный участок будет проигрываться неограниченное количество раз — до остановки этого процесса пользователем. Режим Play Loop является очень удобным в тех ситуациях, когда идет поиск нужного звучания в реальном времени или отрабатывается сложный в техническом отношении фрагмент музыкального произведения.
  • Auto Rewind — автоперемотка. При остановке воспроизведения он автоматически возвращает курсор мультитрека в последнюю стартовую позицию. Режим Auto Rewind позволяет зафиксировать точку старта, что крайне удобно, например, при записи дублей или "живом" сведении с записью автоматизации.

Формат отображения времени дисплеем позиции курсора ("счетчиком ленты") определяется выбранным пунктом меню TimeLine.

  • Time Mode — стандартный режим отображения.
  • Smpte/Mtc — режим отображения SMPTE/MTC (стандарт синхронизации видео и аудио). Причем под дисплеем позиции курсора (Time Display) размещена дополнительная панель индикации формата отображения (рис. 1.34). Формат SMPTE/MTC определяется пунктами субменю Smpte/Mtc Format в меню Smpte/Midi.

На рис. 1.34 показан формат SMPTE 30 Non-Drop.

Рис. 1.34. Индикация формата отображения

  • Tempo Mode — режим MIDI-секвенсоров Такт:Доля:Тик.
  • Sample Mode — режим отображения в отсчетах (сэмплах).

Формат отображения времени определяется той задачей, для выполнения которой используется SAWStudio. Если, например, на мультитреке расставляются циклические фрагменты loops, то лучше установить режим Tempo Mode.
При этом на дополнительной панели (рис. 1.35) отображается темп и музыкальный размер, которые можно задать с помощью субменю Tempo Settings в меню TimeLine.

Рис. 1.35. Индикация режима Tempo Mode

Изменение формата отображения времени затрагивает не только счетчик Time Display, но и специальную дорожку TimeLine, расположенную в самом низу окна MultiTrack (рис. 1.36).

Рис. 1.36. Дорожка TimeLine

На рис. 1.36 показан пример режима Tempo Mode, когда дорожка TimeLine поделена на музыкальные такты.
Продолжим рассмотрение области Top-Client Area.
Следующей областью интерфейса, которую можно функционально выделить, является Locate Point Controls (управление локальными точками — маркерами) (рис. 1.37).

Рис. 1.37. Область Locate Point Controls

Примечание
Locate Point в программе SAWStudio— это ни что иное, как закладка, маркер. В связи с тем, что, на наш взгляд, этот аналог из других программ более понятен в смысловом отношении, мы будем в дальнейшем употреблять именно этот термин.

Маркеры (или закладки) нужны для быстрого перемещения внутри мультитрека по оси времени в определенные участки проекта. Применение маркеров существенно ускоряет работу при редактировании материала.
Взаимодействие с закладками в SAWStudio организовано следующим образом:

  • курсор мультитрека позиционируется щелчком мыши в заданном месте;
  • комбинацией <Shift> + щелчок мышью на любой из кнопок L1—L4 программируется маркер;
  • щелчок на любой из кнопок L1—L4 устанавливает курсор мультитрека в запрограммированную ранее позицию.

Перепрограммирование маркера осуществляется повторением первых двух пунктов в этой последовательности действий.
Кнопки L1—L4 предназначены для наиболее часто употребляемых закладок, к которым нужно оперативно получать доступ.
Помимо четырех "временных" маркеров SAWStudio позволяет запрограммировать еще 26 постоянных. Для доступа к ним предназначена кнопка L>, открывающая общий список закладок (рис. 1.38).
Маркеры Locate 01—Locate 04 имеют статус Temp (временные). Значок < > показывает, что маркер запрограммирован.
Закладки Locate 05—Locate 30 имеют статус постоянных маркеров. Для того чтобы запрограммировать постоянный маркер, нужно выполнить следующее:

  1. 1. Позиционировать курсор мультитрека.
  2. 2. Вызвать общее меню маркеров щелчком на кнопке L>.
  3. 3. Запрограммировать маркер комбинацией <Shift> + щелчок мыши на любом элементе списка закладок.

Для позиционирования курсора в запрограммированную ранее точку достаточно щелкнуть на избранном элементе списка закладок.
Постоянным маркерам можно присваивать имена. Для этого предусмотрено отдельное подменю Rename в общем списке закладок (рис. 1.39).
Для присвоения имени маркеру нужно щелкнуть на соответствующем элементе списка Rename и ввести название закладки в диалоговом окне Rename Locate.
Область Locate Point Controls помимо элементов управления закладками содержит еще и дополнительный дисплей для индикации выделенной области и относительного смещения курсора.

Рис. 1.38. Общий список маркеров

Рис. 1.39. Подменю Rename

На рис. 1.40 показан пример смещения курсора вправо по оси времени. Для смещения курсора достаточно протащить его мышью вправо или влево. При этом на дополнительном дисплее будет отображаться смещение Relative Time со знаком:

  • + — если смещение производится вправо;
  • - — если смещение производится влево.

Примечание
Клавиши < [image] > и < [image] > позволяют перемещать курсор мультитрека соответственно влево или вправо точно на один пиксел. То есть в зависимости от выбранного масштаба по горизонтали (см. контекстное меню кнопок +Zm, -Zm), курсор будет сдвигаться на фиксированное количество отсчетов.

Рис. 1.40. Индикация относительного смещения курсора

Такая точная индикация может понадобиться, например, для смещения отдельных циклических фрагментов loops относительно друг друга с целью получения необычного ритмического рисунка.
Выделить область на мультитреке можно двумя способами:

  • протащить курсор мультитрека вправо по дорожке TimeLine;
  • комбинацией: щелчок в позиции начала области + <В> (begin), затем щелчок в позиции окончания области + <Е> (end).

При этом дисплей отобразит расстояние между стартовой и финальной границами выделенной области (рис. 1.41).

Рис. 1.41. Индикация выделенной области Marked Time

Снять выделение можно также двумя способами:

  • клавишей <С>;
  • щелчком правой кнопки мыши на дорожке TimeLine.

На рис. 1.42 изображена область управления режимами работы SAWStudio.

Рис. 1.42. Область управления режимами SAWStudio

Область управления состоит из четырех кнопок и четырех индикаторов. Рассмотрим функции кнопок.

  • Sel (Selection Mode) — включение режима выделения объектов. В этом режиме курсор мыши изменяет свою форму на [image].
    Режим Selection Mode предназначен для недеструктивного перемещения и копирования объектов. Перейти в него можно также, нажав клавишу <S>. Повторное нажатие отменяет режим Selection Mode, и мультитрек возвращается в основной режим Normal Mode.
  • Wv (Wave Mode) — включение режима отображения формы волны объектов. "Горячая" клавиша — <W>. Повторное нажатие отменяет режим отображения формы волны. (Комбинации <Shift>+<Page Up> и <Shift>+<Page Down> увеличивают и уменьшают масштаб формы волны "горячего" трека).
  • Aut (Automation Mode) — включение режима автоматизации. В этом режиме почти все манипуляции, производимые на виртуальной консоли, записываются на "горячий" трек в виде последовательности точек автоматизации. Кроме того, полностью автоматизируются органы управления Studio plug-ins. "Горячая" клавиша — <А>.

Дорожка мультитрека в режиме автоматизации изменяет свой вид, как показано на рис. 1.43.

Рис. 1.43. Вид трека в режиме автоматизации

  • Ofst (Offset Mode) — включение режима смещения. Режим Offset Mode позволяет добавить смещение к кривой автоматизации параметра канала виртуального микшера (подробно эти моменты будут обсуждаться е разд. "Автоматизация" далее в этой главе).
  • Solo Mode — многофункциональная кнопка режима Solo, которая выполняет две функции:
    • включает режим Hot Track Solo Mode, при этом кнопка должна постоянно "гореть" красным светом. В режиме Hot Track Solo Mode только "горячий" трек получает режим Solo. Остальные кнопки Solo заблокированы. Иными словами, делая какую-либо дорожку класса Input Track "горячей", мы автоматически устанавливаем на ней режим Solo. (Удобство этой функции трудно переоценить, т. к. она сильно экономит время, избавляя от бесконечного "кликания" по кнопкам Solo, характерного для конкурирующих мультитрековых программ);
    • работает индикатором режима Solo. Если установить режим Solo с помощью виртуального микшера на одной или нескольких дорожках, то кнопка Solo Mode начнет мигать. Щелчок на мигающей кнопке Solo Mode сбрасывает режим Solo для всех дорожек.
  • Кнопка Sync предназначена для управления мультитреком в режиме синхронизации.

Индикаторы загрузки мультитрека (рис. 1.44) позволяют определить степень загруженности центрального процессора и дисковой подсистемы в процентах.

Рис. 1.44. Индикаторы загрузки мультитрека

Индикатор МТ Load отражает загрузку CPU. Если показание индикатора равно 100% — воспроизведение невозможно.
Индикатор Src Load отражает процент данных, считываемых с жесткого диска или RAM (если включен режим кэширования регионов). Показания индикатора должны находиться вблизи 0%, иначе процесс воспроизведения остановится.

Панель навигации Track Locator Zone + Mixer Link Controls

В левом верхнем углу окна MultiTrack расположена вертикальная панель с кнопками, предназначенная для быстрой навигации по графическим объектам мультитрека (рис. 1.45).
Дизайн панели выполнен таким образом, что каждая кнопка представляет собой просто графический символ.

Рис. 1.45. Панель быстрой навигации

Панель быстрой навигации условно делится на две панели: панель Track Locator Zone, предназначенную для быстрого перемещения между треками, и панель Mixer Link Controls, необходимую для быстрой навигации по секциям виртуальной консоли. Рассмотрим эти панели подробнее.
Панель Track Locator Zone состоит из одной кнопки [image], нажатие на которую открывает контекстное меню, содержащее список всех треков (рис. 1.46).
Галочкой в списке отмечен "горячий" трек, а для перехода на любую дорожку достаточно щелкнуть на элементе списка. Выбранный в списке трек становится "горячим".
Такой сервис в SAWStudio организован не случайно. Далеко не во всех проектах будут использоваться абсолютно все дорожки мультитрека. Однако удаление "лишних" треков не запланировано разработчиками программы в силу ее архитектурных особенностей. Поэтому пользователю приходится либо каждый раз устанавливать комфортный порядок расположения треков с учетом особенностей каждого проекта, либо, чтобы постоянно не прокручивать мультитрек, пользоваться панелью навигации со списком треков.
Панель Mixer Link Controls состоит из восьми кнопок, щелчок по любой из которых позволяет быстро переместиться в нужную секцию виртуального микшера. Несколько забегая вперед отметим, что виртуальная консоль в SAWStudio представлена в четырех видах:

  • Zoom View Mixer (Z Mixer) — масштабированный вид;
  • Wide View Mixer (W Mixer) — широкий вид;
  • Full View Mixer (F Mixer) — полный вид;
  • Exploded View Mixer (E Mixer) — вырезанный вид.

Рис. 1.46. Список треков

Сделано это для того, чтобы максимально снизить временные издержки пользователя на управление графическими объектами интерфейса. Еще раз напомним, что центральная идея интерфейса SAWStudio — это привязка всех окон виртуальной консоли к "горячему" треку. Это избавляет пользователя от нудного прокручивания виртуального микшера при поиске элементов управления нужного трека и позволяет полностью сосредоточиться на творчестве. Действительно, процесс бесконечного путешествия по окнам и пунктам меню некоторых музыкальных программ может вообще лишить музыканта желания использовать компьютер в своем творчестве.
Уникальность интерфейса SAWStudio состоит как раз в том, что он предельно лаконичен и содержит инструменты, максимально облегчающие творческий процесс пользователя.
Рассмотрим подробнее связь кнопок панели Mixer Link Controls со структурой виртуальной консоли.

— секция Input/Attenuator (Вход/Аттенюатор), где осуществляется переключение виртуального канала с дорожки на вход аудиоустройства;

— Eq — секция канального параметрического эквалайзера;

— секция канального динамического процессора Dynamics;

— секция FX Patch для подключения plug-ins в разрыв до и после фейдера (рге- и post-fader);

— секция вспомогательных AUX-шин Aux Assigns (Aux Sends);

— секция Out Assigns, где назначается выход канала на группы или мастер-каналы;

— секция Labels, где открывается доступ к XY-регулятору surround-панорамы и названию (ярлыку) канала на микшере;

— секция Faders, где расположены регуляторы громкости и панорамы, а также кнопки Solo и Mute.

Мы подробно ознакомимся с виртуальной консолью в разд. "Виртуальный микшер" далее в этой главе, а здесь лишь отметим, что кнопки панели Mixer Link Controls расположены в той же последовательности, что и секции канальной ячейки виртуального микшера. Одиночный щелчок на любой кнопке панели Mixer Link Controls сдвигает окно Z Mixer на соответствующую секцию. Двойной щелчок — вызывает окно Е Mixer, содержащее выбранную секцию.

Выделение треков

В программе SAWStudio есть еще одна важная функция — выделение треков. Благодаря ей пользователь имеет возможность оперативно контролировать распределение вычислительных ресурсов компьютера.
Дело в том, что при работе в мультитрековой программе часто возникают ситуации, когда пользователю необходимо вмешаться в распределение ресурсов. Поясним на примере. В ситуации, когда идет редактирование проекта с большим количеством подключенных plug-ins, быстродействия PC часто становится недостаточно — и компьютерному музыканту приходится принимать срочные меры (контролировать загрузку центрального процессора). Например, обходить эффекты, активно использовать кнопки Mute и Solo, традиционно расположенные на дорожках мультитрека или виртуального микшера и т. п. Все эти лишние операции, безусловно, отнимают время и отвлекают от творческого процесса.
Положение усугубляется тем, что некоторые мультитрековые программы "не обращают внимание" на отключение дорожек кнопками Solo или Mute — и продолжают считывать с жесткого диска все данные (даже те, которые соответствуют приглушенным дорожкам). В результате чего режимы Solo и Mute ничуть не уменьшают нагрузку на жесткий диск.
В программе SAWStudio эта задача успешно решена, в результате чего пользователю предоставляется возможность просто и оперативно контролировать распределение ресурсов. И реализована эта возможность в виде простой функции выделения треков.
Правило здесь несложное: ресурсы потребляют только выделенные дорожки; все остальные полностью обходятся (bypass) и вычислительных ресурсов не требуют.
В результате чего отпадает необходимость в дополнительных операциях: манипулировать кнопками Solo и Mute в окне виртуального микшера, обходить или отключать виртуальные эффекты plug-ins и т. п. В программе SAWStudio пользователь всегда может выделить треки, которые в данный момент находятся в работе (при этом мультитрек виртуально уменьшается).

Внимание
Функция выделения треков не работает в "горячем" режиме и требует рестарта воспроизведения для того, чтобы изменения вошли в силу. Исключение составляет режим циклического воспроизведения, в котором рестарт осуществляется автоматически. Эффекты, подключенные к дорожкам класса Return Track, не обходятся.

Выделение треков производится следующим образом:

    1. Щелчок на кнопке с номером дорожки выделяет ее. Повторный щелчок снимает выделение (рис. 1.47).
  1. 2. Для выделения группы треков достаточно щелкнуть на каждой дорожке, входящей в группу.

Рис. 1.47. Выделение трека

Другой способ выделения группы из соседних треков выполняется так:

  1. 1. Нужно выделить первый трек.
  2. 2. Затем щелкнуть на последнем треке с нажатой клавишей <Alt>.

С помощью клавиши <Alt> можно установить/снять выделение группы между последним выделенным треком и текущим. В примере на рис. 1.48 сначала была выделена группа с 13-го по 7-ой трек, а затем снято выделение с 8-го по 10-й повторным щелчком на десятой дорожке при нажатой клавише <Alt>.

Рис. 1.48. Выделение группы треков

Для простого выделения группы треков можно протащить курсор мыши по их номерам.
Снять выделение с группы можно щелчком правой кнопки мыши на любом номере трека.


Окно Regions

В программе SAWStudio редактирование является недеструктивным. (Элементы деструктивного редактирования возможны только на уровне одного отсчета в окне SoundFile.)

Недеструктивное редактирование
Напомним, что недеструктивное (не разрушающее оригинал) редактирование основано не на физическом изменении самих звуковых файлов, а на манипулировании ссылками на определенные области (регионы, сегменты) в исходных звуковых данных.
Образно говоря, при недеструктивном редактировании идет работа не с самим звуковым файлом, а с его "фотографией" — снимком области реального оцифрованного звука.
При недеструктивном редактировании программа SAWStudio запоминает, как расположить эти "снимки": какую область, где и сколько раз нужно воспроизвести.

Иформация о регионах содержится в сессионных EDL-файлах. Непосредственный доступ к регионам осуществляется через окно Regions (рис. 1.49).

Рис. 1.49. Окно Regions

Прослушивание региона

Интерфейс окна Regions предельно прост. Регионы в нем представлены в виде списка. Щелчок левой кнопкой мыши выделяет регион в списке. Щелчок правой кнопкой в окне Regions включает режим однократного прослушивания выделенного региона. При этом вызывается окно SoundFile с соответствующей выделенной областью (рис. 1.50).
Двойной щелчок на имени региона в списке вызывает только окно SoundFile с выделенной областью без прослушивания.

Создание объектов на мультитреке

Выложить регион в виде объекта на мультитрек можно так (рис. 1.51):

  1. 1. Нажать и удерживать клавишу <Alt>.
  2. 2. Выделить регион в списке, отпустить левую кнопку мыши и перетащить его на мультитрек в окно MultiTrack.
    При этом курсор мыши изменит свой вид на [image].
  3. 3. Зафиксировать регион щелчком левой кнопки мыши в выбранной позиции (на любом треке класса Input Track). При этом регион становится полноправным объектом.

Рис. 1.50. Прослушивание региона

Рис. 1.51. Добавление региона на мультитрек

Предупреждение
Этим способом нельзя накладывать объекты друг на друга с пересечением границ. Если это происходит, то выдается предупреждающее сообщение. В случае игнорирования предупреждающего сообщения объекты, расположенные правее курсора, будут сдвинуты. Исключением из этого правила является случай, когда накладываемый объект располагается правее соседнего и рядом имеется свободное пространство.

Проиллюстрируем различия между регионом и объектом на примере рис. 1.51. Дорожка № 9 содержит два объекта (с именем Loop1), созданных из одного и того же региона. То есть, регион Loop1 воспроизводится дважды (в разных временных позициях и даже с разной звуковой обработкой — в зависимости от настройки виртуальной консоли). Такое "тиражирование без дополнительных затрат" становится возможным только при недеструктивном редактировании.
В противном случае (при деструктивном редактировании) для решения подобной задачи понадобилось бы создавать физическую копию региона и затем применять к ней деструктивную звуковую обработку. Подчеркиваем, что в SAWStudio все звуковые процессы происходят в реальном времени и все параметры аудио-обработки сохраняются предельно компактно: в виде последовательности команд недеструктивного редактирования.
Выложить регион на мультитрек можно и другим способом — с помощью кнопки Insert To MT (Вставить на мультитрек), расположенной в левом верхнем углу окна Regions. При этом выполняется следующая последовательность действий:

  1. 1. Выделяется регион в списке.
  2. 2. Нажимается кнопка Insert То МТ или клавиша <Insert>.
  3. При этом стартовая граница нового объекта на "горячем" треке будет совпадать с текущей позицией курсора мультитрека.

Примечание
Каждый щелчок по кнопке Insert То МТ (или нажатие на клавишу <lnsert>) будет добавлять объект на "горячую" дорожку мультитрека, причем объекты будут пристыковываться друг к другу вплотную также, как в примере на рис. 1.53.

Создание групп объектов

Для того чтобы выложить группу регионов на мультитрек, нужно предварительно выделить ее в списке в окне Regions.
Выделяется группа щелчками по каждому выбранному региону при нажатой клавише <Ctrl>, либо щелчками по первому и последнему региону группы при нажатой клавише <Shift>.
Затем следует нажать кнопку Insert To MT.
При выполнении такой последовательности действий стартовые границы объектов группы совпадут с текущей позицией курсора мультирека. Причем сами объекты расположатся друг под другом в той же последовательности, как и в списке регионов. А первый регион в списке разместится на "горячем" треке (рис. 1.52).

Рис. 1.52. Добавление группы регионов на мультитрек

Если требуется зациклить (размножить) регион или группу регионов, то для этого можно выполнить следующую последовательность действий:

  1. 1. Подготовить на мультитреке область для размещения регионов. Для этого нужно протащить курсор мультитрека вправо по дорожке TimeLine.
  2. 2. Выделить в списке регионов группу или отдельный регион.
  3. 3. Вставить регионы на мультитрек, щелкнув по кнопке Insert To MT с нажатой клавишей <Ctrl>.

Предупреждение
Выделенная область не должна быть меньше длины региона.

В результате будет создана последовательность объектов на дорожке (дорожках, если выделена группа) по всей длине выделенной области (рис. 1.53).

Рис. 1.53. Создание зацикленной группы

Совет
Точно перемещать курсор мультитрека по границам объектов на "горячей" дорожке можно с помощью клавиш: клавиша <ТаЬ> — вправо, комбинация <Shift>+<Tab> — влево.
Точно выделять область, равную длине объекта на "горячей" дорожке, можно комбинациями <ТаЬ>+<В> и <ТаЬ>+<Е>. Можно также протащить курсор по дорожке Time Line с нажатой клавишей <Ctrl>. В этом случае, если курсор мультитрека даже немного "заедет" внутрь объекта "горячей" дорожки, то объект сразу выделяется целиком.

Сортировка регионов по группам

Дополнительным сервисом SAWStudio является возможность сортировки регионов по группам. Это очень удобная функция, т. к. она позволяет создавать до 30 групп. Кнопка Group открывает доступ к списку групп (рис. 1.54).
Пункт All Regiuns (Все регионы) обеспечивает отображение всех регионов в окне Regions. Выбор любого доступного пункта из списка фильтрует список регионов в окне Regions в соответствии с содержимым конкретной группы (например, [Group 08]-Loops (см. рис. 1.54)).

Рис. 1.54. Пример списка групп регионов

Такая возможность избавляет пользователя от необходимости постоянно пролистывать список регионов в окне Regions, который может быть достаточно большим (например, содержать множество дублей "живой" записи или различных сэмплов для "конструирования" композиции).
Порядок сортировки регионов по группам может быть любым, главное — придерживаться системы. Например, можно рассортировать записи дублей по датам или по музыкальным инструментам (см. рис. 1.54).
Для операций с группами предусмотрены четыре подменю:

  • Add Selected To (Добавить выделенное в) — присоединяет выделенные регионы к группе. Это подменю содержит список всех групп, поэтому для присоединения выделенных регионов нужно просто выбрать из списка нужную группу.

Примечание
Выбор группы в списке Add Selected To одновременно делает ее доступной и в основном списке групп (см. рис. 1.54).

  • Remove Selected From (Удалить выделенное из) — удаляет выделенные регионы из группы. Сначала регионы, которые планируется удалить из группы, выделяются в окне Regions, а затем в подменю Remove Selected From выбирается конкретная группа, содержащая эти регионы.
  • Clear All From (Удалить все из) — удаляет все регионы из группы. Пункт All Groups этого подменю полностью очищает все группы.
  • Rename (Переименовать) — позволяет присвоить или изменить имя любой из тридцати групп. Для этого нужно сначала в подменю Rename выбрать необходимую группу, а затем ввести для нее название в диалоговом окне Re-Name Region Group.

Переименование и удаление регионов

Если регион никак не назван, то имя ему присвоит программа. Оно будет соответствовать названию звукового файла и иметь расширение wav.
Для переименования регионов предусмотрена команда Regions | Re-Name Region(s). Ее применение вызывает одноименное диалоговое окно, в которое нужно ввести новое название региона или регионов (если была выделена группа). После переименования группы программа автоматически присваивает всем входящим в нее регионам порядковые номера (рис. 1.55).

Предупреждение
После переименования региона все объекты, с ним связанные, переименовываются автоматически.

Удаление выделенных регионов производится клавишей <Delete>.

Рис. 1.55. Переименование группы регионов

Экспорт региона в звуковой файл

При необходимости регион или группу можно экспортировать в отдельный звуковой файл (файлы). Для этого служит команда Export Region(s) To Sound File(s). Данная функция может быть полезна, например, для создания готовых циклических фрагментов loops в виде отдельных звуковых файлов.

Помеченные регионы

В предыдущих примерах мы рассматривали регионы импортированных звуковых файлов. Несколько забегая вперед, отметим, что существует еще один особый тип регионов. Они создаются в результате записи на мультитреке. Такие регионы помечаются символом @ и сохраняют этот знак даже после переименования. Особенность регионов с такой отметкой состоит в том, что они содержат не только информацию об области физического звукового файла, но и оригинальную стартовую позицию на мультитреке, полученную при записи. Это их свойство позволяет крайне эффективно работать с дублями. Ведь для того, чтобы из региона со знаком @ восстановить объект на "горячей" дорожке в оригинальной стартовой позиции, достаточно нажать комбинацию клавиш <Shift>+<Insert> или щелкнуть по кнопке Insert To МТ при нажатой клавише <Shift>.
На рис. 1.56 показан пример того, как на разные дорожки в оригинальной стартовой позиции выложены дубли вокальной партии, в результате чего последующий монтаж (разрезание и склеивание из нескольких дублей "идеального") становится очень удобен.

Совет
Регионы дублей, помеченные символом @, можно выкладывать и на разные слои одного трека (см. разд. "Многослойный мультитрек" далее в этой главе).

Рис. 1.56. Создание объектов в оригинальной стартовой позиции

В программе SAWStudio вся работа по "живой" записи надежно защищена. Это связано с тем, что SAWStudio автоматически помечает все записи, сделанные на мультитреке. Поэтому если вы случайно удалили объект с дорожки мультитрека, его можно легко восстановить, отыскав соответствующий ему регион в окне Regions.

Cовет
Если выделить группу помеченных регионов в окне Regions, то комбинация клавиш <Shift>+<lnsert> создаст на мультитреке группу объектов в оригинальных стартовых позициях. При этом первый помеченный регион в списке будет соответствовать объекту на "горячем" треке.


Окно SoundFile

Основное назначение окна SoundFile — создание регионов и возможность деструктивного редактирования на уровне одного отсчета. На рис. 1.57 показано, как отображается в этом окне звуковой файл с выделенным регионом.

Рис. 1.57. Окно SoundFile

Интерфейсы окон SoundFile и MultiTrack во многом схожи: например, внизу также расположена дорожка TimeLine.

Создание региона в окне SoundFile

Первым шагом при создании региона является выделение области звукового файла. Приемы выделения в окне SoundFile такие же, как и в окне MultiTrack: нужно протащить курсор вправо вдоль дорожки TimeLine или воспользоваться клавишами <В> (Begin) и <Е> (End).
Но помимо этих способов в окне SoundFile существуют дополнительные возможности проведения этой операции. В верхней части этого окна находится ряд кнопок — Top-Client Area. В нем расположены две кнопки выделения:

  • Mrk Beg (Mark Begin) — позиция курсора является началом области выделения;
  • Mrk End (Mark End) — следующая позиция курсора (правее предыдущей) будет означать окончание области выделения.
Снимается выделение щелчком правой кнопки мыши на дорожке TimeLine или клавишей <С>.
Создать из выделенной области регион можно следующими способами:
  • нажать на клавиатуре клавишу <N>, затем в диалоговом окне Create New Region ввести новое имя региона (или согласиться с именем, предложенным программой) и завершить процесс нажатием клавиши <Enter>;
  • выбрать пункт меню Regions | Create New Region (SoundFile View), а затем ввести имя региона в диалоговом окне.
В обоих случаях в окне Regions будет создан новый элемент списка с именем, введенным в диалоговом окне.
Регион можно выкладывать на мультитрек прямо из окна SoundFile.
Делается это так:
  1. 1. В окне SoundFile выделяется регион.
  2. 2. С нажатой клавишей <Alt> выполняется щелчок (с отпусканием левой кнопки мыши) в выделенной области. При этом курсор мыши изменит свой вид на [image].
  3. 3. После того как регион будет перенесен в выбранную позицию на мультитрек в окне MultiTrack, его положение нужно зафиксировать щелчком левой кнопки мыши на любом треке класса Input Track (рис. 1.58). При этом программа SAWStudio автоматически присвоит название региону.

Рис. 1.58. Перенос региона на мультитрек из окна SoundFile

Изменение границ региона

Для изменения границ региона в меню Regions предусмотрена специальная команда Update Region (SoundFile View) (клавиша <U>). Для того чтобы ей воспользоваться, необходимо открыть регион в окне SoundFile. Это можно сделать так:
  • двойным щелчком на объекте в окне MultiTrack;
  • двойным щелчком на имени региона в списке в окне Regions.
Затем границы региона можно менять — например, привязать их к нулевым
отсчетам (информацию об этом можно найти в разд. "Создание циклических фрагментов") — после чего нажать клавишу <U>.
В результате этих действий в диалоговом окне Update Current Region появится имя изменяемого региона. Завершается изменение границ нажатием клавиши <Enter>.

Примечание
Если в окне Update Current Region ввести имя другого (ранее созданного региона), то в названии появится символ @. Например, Region1 @, если в проекте уже присутствовал регион с именем Region 1.

Создание циклических фрагментов

SAWStudio не отличается от предыдущих продуктов SAW в подходах к оформлению программы из-за "графического аскетизма" — многие возможности скрыты от неискушенного пользователя в комбинациях "горячих" клавиш и прочих "неочевидных" возможностях.
В связи с этими особенностями мы будем акцентировать внимание именно на практических приемах работы с программой.
Рассмотрим технику создания циклического фрагмента (loop). В SAWStudio эта процедура упрощена до предела.
  1. 1. Сначала следует приближенно выделить искомый регион, где предполагается создание цикла.

    Совет
    Для выделения звукового файла в окне SoundFile полностью необходимо при нажатой клавише <Ctrl> протащить курсор по дорожке TimeLine.

  2. 2. Затем нужно включить режим циклического воспроизведения в окне SoundFile.
    Для этого следует щелкнуть в окне правой кнопкой мыши с нажатой клавишей <Ctrl>.

    3. Предупреждение
    Транспортная панель окна MultiTrack не действует в окне SoundFile. Для управления процессом воспроизведения следует пользоваться правой кнопкой мыши.

  3. 3. Теперь, не прерывая процесс воспроизведения, можно, щелкая левой кнопкой мыши в окне SoundFile, корректировать границы фрагмента (рис. 1.59).

Рис. 1.59. Создание циклического фрагмента loop в реальном времени

В завершение процесса следует создать циклическую последовательность объектов на мультитреке (см. рис. 1.53). Циклическая последовательность (многократное повторение одного и того же региона) создается таким способом: сначала нужно "зарегистрировать" новый регион (нажатием клавиши <N>), затем перейти в окно MultiTrack, выделить необходимую область на "горячей" дорожке, после чего комбинацией <Ctrl>+<Insert> "размножить" объект одного региона.
Если требуется выделить регион, границы которого находятся в местах нулевых отсчетов (это может понадобиться для "гладкой" (бесшовной) стыковки объектов), то следует выполнить следующую последовательность действий:

  1. 1. С предельной точностью установить курсор в точку начала региона и нажать последовательно клавиши <Z> и <В>.
  2. 2. Затем так же точно позиционировать курсор в конечной точке региона и набрать последовательно <Z> и <Е>.

В результате этих манипуляций будет выделен регион с границами в местах нулевых отсчетов.
Если выделение региона происходило в режиме циклического воспроизведения, то можно подкорректировать фаницы фрагмента до нулевых отсчетов следующим образом:

  1. 1. Комбинацией клавиш <Ctrl>+< [image] > позиционировать курсор точно на левой фанице выделенной области.
  2. 2. Последовательно набрать на клавиатуре <Z> и <В>.
  3. 3. Затем комбинацией клавиш <Ctrl>+< [image] > позиционировать курсор точно на правой границе выделенной области.
  4. 4. Последовательно набрать на клавиатуре <Z> и <Е>.

Используя приведенный метод, можно быстро создать качественный loop, лишенный при циклическом повторении каких-либо щелчков или нестыковок.

Элементы управления в окне SoundFile

Рассмотрим более детально элементы управления в окне SoundFile и для удобства сведем их в табл. 1.2.

Таблица 1.2. Элементы управления в окне SoundFile

Название элемента | Функция элемента
+Zoom Full | Максимальный масштаб отображения по горизонтали (комбинация клавиш <Ctrl>+<Доп.+>)
Zoom In, Zoom Out | Увеличение и уменьшение масштаба по горизонтали (клавиши <Доп.+> и <Доп.->) Щелчок правой кнопкой мыши на любой из этих кнопок открывает контекстное меню масштаба
-Zoom Full | Минимальный масштаб отображения по горизонтали (комбинация клавиш <Ctrl>+<Доп.->)
Lock | Блокировка текущего масштаба отображения по горизонтали и по вертикали. Все последующие вызовы окна SoundFile будут содержать заблокированный масштаб
Up, 0db. Down | Увеличение и уменьшение масштаба по вертикали. Кнопка 0db устанавливает масштаб, при котором максимальный отображаемый уровень равен 0 дБ
Mark Begin, Mark End | Кнопки выделения региона
Out Devices | Выбор выходного аудиоустройства. В окне SoundFile можно воспроизводить звуковой файл через любое доступное аудиоустройство
SoundFile Record | Кнопка включения режима записи в окне SoundFile

Предупреждение
SAWStudio позволяет воспроизводить на мультитреке звуковые файлы с различной частотой дискретизации (samplerate) и разрядностью кодирования (resolution). При этом разрядность мультитрека должна соответствовать максимальной разрядности звуковой карты. Например, файлы с 24-битным разрешением будут воспроизводиться с разрядностью 16 бит, если установлены соответствующие параметры в меню MultiTrack | Resolution. Однако в окне SoundFile файлы воспроизводятся с реальным разрешением, поэтому воспроизвести 20-битный или 24-битный звук на 16-битной звуковой карте уже не получится.

Редактирование звукового файла на уровне отсчетов

Пожалуй, единственное, что осталось от деструктивного редактирования в SAWStudio, — это редактирование звукового файла на уровне одного отсчета. Напомним, что цифровой звук представляет собой последовательность выборок (отсчетов, моментальных снимков) непрерывного аналогового сигнала, взятых через равные промежутки времени.
Необходимость в редактировании на уровне одного отсчета возникает достаточно редко, поэтому доступ к этому уровню в SAWStudio ограничен. Например, кнопка +Zm Full "лукавит" и отображает не самый максимальный масштаб по горизонтали. Для перехода в масштаб редактирования отсчетов (Sample Edit Zoom) нужно после кнопки +Zm Full еще раз нажать кнопку +Zm. Тогда форма отображения волны в окне SoundFile примет вид, приведенный на рис. 1.60.
Каждая точка представляет собой выборку цифрового сигнала. Для редактирования достаточно протащить в окне курсор мыши с нажатой клавишей <Shift>.

Примечание
В стереофонических звуковых файлах редактирование левого и правого каналов выполняется независимо друг от друга.

Рис. 1.60. Масштаб редактирования отсчетов

При этом фактически осуществляется рисование новой формы волны. Для изменения амплитуды одного отсчета нужно протащить курсор только по вертикали (рис. 1.61).

Рис. 1.61. Редактирование отсчета

Предупреждение
Операция редактирования отсчетов полностью деструктивна и не имеет отмены. Поэтому перед редактированием рекомендуется сделать резервные копии звуковых файлов.

В каких случаях может помочь деструктивное редактирование отсчетов?
Например, для ручной реставрации удачного с музыкальной точки зрения дубля, но содержащего посторонние щелчки, нежелательные шумы и т. д. Даже если сигнал был усечен (клиппирован) вследствие превышения порога в 0 дБ при записи, ручное редактирование отсчетов может помочь — выправить сигнал в области отсечения.
Дополнительное удобство при поиске клиппированных отсчетов создает окно SF Sample Info (рис. 1.62). Оно вызывается одиночным щелчком на индикаторе уровня SoundFile View Meter, расположенном на левой границе окна SoundFile.

Предупреждение
Для того чтобы индикатор уровня отображался в окне SoundFile, высота окна должна превышать высоту индикатора.

Рис. 1.62. Использование окна SF Sample Info

В окне SF Sample Info текущая позиция курсора для каждого канала отображается в четырех форматах: dec (десятичном), hex (шестнадцатеричном), в децибелах и процентах. На рис. 1.62 показан пример клиппирования сигнала в левом канале, при котором количество отрицательных уровней 16-битного сигнала уже исчерпано — 100% или "-32 768 dec".

Приемы редактирования в окне SoundFile

Рассмотрим некоторые приемы, облегчающие редактирование в окне SoundFile.

  • Каждый щелчок у границы окна SoundFile автоматически прокручивает окно на один шаг. Если подвинуть и удерживать курсор у границы окна при нажатой левой кнопке мыши, то прокручивание окна будет непрерывным.
  • Клавиши < [image] > или < [image] > устанавливают курсор в середине окна и сдвигают его точно на один пиксел. Количество отсчетов на пиксел определяется масштабом, установленным в контекстных меню кнопок -Zm и +Zm.
  • Клавиши < [image] > или < [image] > смещают, соответственно, вверх или вниз центр формы волны (это может понадобиться для точного редактирования клиппированных фрагментов). Для возврата центра в нулевую позицию нужно нажать комбинацию клавиш <Ctrl>+< [image] > или <Ctrl>+< [image] >.
  • Клавиши <Ноmе> и <End> перемещают курсор, соответственно, в начало и конец звукового файла.
  • Пункт SoundFile Fixed Position Scroll Mode в меню Options включает автоматическое прокручивание окна SoundFile в режиме воспроизведения (рис. 1.63).

Рис. 1.63. Режим автоматического прокручивания окна SoundFile при воспроизведении


Виртуальный микшер

Так как SAWStudio является виртуальным аналогом цифровой студии, то и виртуальный микшер соответствует по структуре, сложности и функциональным возможностям аппаратному цифровому пульту. Еще раз отметим, что в SAWStudio виртуальные каналы могут эксплуатироваться отдельно от дорожек мультитрека. Благодаря этому повышается гибкость и функциональность виртуальной студии.
Структура виртуального микшера, приведенная в документации к программе, отображена на рис. 1.64.

Рис. 1.64. Структурная схема виртуального микшера

По ходу изложения мы постепенно расшифруем все блоки, входящие в эту схему.
Напомним, что виртуальная консоль в SAWStudio представлена в четырех видах.

  • Zoom View Mixer (Z Mixer) — масштабированный вид;
  • Wide View Mixer (W Mixer) — широкий вид;
  • Full View Mixer (F Mixer) — полный вид;
  • Exploded View Mixer (E Mixer) — вырезанный вид.

Это связано с тем, что отобразить на экране монитора все элементы управления такой сложной структуры одновременно и при этом обеспечить комфортную работу пользователя невозможно. С другой стороны, управление микшером является основной задачей при работе в SAWStudio, поэтому путь к его элементам управления должен быть максимально коротким. Создателям программы пришлось разработать четыре разные формы графического отображения виртуальной консоли и привязать их к "горячему" треку. Таким оригинальным способом решена задача управления большим количеством объектов.

Примечание
Это решение вызвано еще и тем фактом, что в SAWStudio реализована концепция мультитрека с фиксированным количеством дорожек. В других программах, рассматриваемых в данной книге, — Nuendo и Samplitude Producer — количество треков определяется пользователем, следовательно, и число канальных ячеек виртуального микшера в большинстве случаев может оказаться значительно меньшим.


Приемы работы с окнами виртуальной консоли

Так как все секции и канальные ячейки виртуальной консоли одновременно на экране не умещаются, то для быстрого перемещения между ними предусмотрены различные приемы.

Прокручивание окна по вертикали

Делается это так. Например, в окне F Mixer нажимается и удерживается правая кнопка мыши. При этом курсор мыши принимает вид [image].
Если подвинуть мышь по вертикали, то курсор изменит свой вид на [image] и начнется прокрутка окна (рис. 1.65).
Это правило действительно для всех окон виртуального микшера, кроме окна W Mixer.

Примечание
Прокручивать таким способом по вертикали и по горизонтали можно и окно MultiTrack.

Рис. 1.65. Прокручивание окна F Mixer

Быстрый переход между каналами микшера

Это выполняется почти так же, как и прокручивание, за исключением того, что мышь подвигается в горизонтальном направлении.

Рис. 1.66. Быстрый переход через список каналов

При этом появляется список каналов (рис, 1.66), где и выполняется переход на другой канал простым выбором элемента списка.

Примечание
Отметим, что операция перехода сводится к простому переносу статуса Hot Track на новый трек. "Горячий" трек жестко связан с "горячим" каналом, который выделяется на микшере красной рамкой.

Совет
Пользоваться списком треков намного удобнее, если присвоить дорожкам имена.

Это правило действительно для всех окон виртуального микшера, кроме окна Е Mixer.

Использование окна W Mixer

Действительно, окно W Mixer отображает все элементы управления канала.

Рис. 1.67. Окно W Mixer

Поэтому имеет смысл зарезервировать для него отдельный рабочий экран и закрепить его за любой удобной функциональной клавишей, например, за клавишей <F2>. Вид элементов управления канала в окне W Mixer отображен на рис. 1.67.

Совет
Может оказаться удобной следующая конфигурация рабочих экранов: за клавишей <F1> закрепить только окно MultiTrack, а за клавишей <F2>— окно W Mixer. Тогда доступ ко всем элементам управления микшера и ко всему мультитреку осуществляется простым переключением двух соседних клавиш.

Совместное использование окон F Mixer и Е Mixer

При сведении может возникнуть желание контролировать одновременно несколько дорожек. Для этого лучше всего подходит окно F Mixer, отображающее максимум каналов.

Рис. 1.68. Окна F Mixer и Е Mixer

Однако секции в этом окне показаны символически, в виде кнопок. В связи с этим реально доступны для управления только фейдеры, регуляторы панорамы и кнопки Solo, Mute. Для управления "скрытыми" секциями микшера предназначено окно Е Mixer. Двойной щелчок на любой секции, расположенной выше кнопки Solo, вызывает окно Е Mixer (рис. 1.68).
При этом в окне Е Mixer отображается та секция, на уровне которой был выполнен двойной щелчок в окне F Mixer.

Растягивание окна Z Mixer по горизонтали

Подобное решение (рис. 1.69) можно рекомендовать для больших мониторов или в случае использования двух мониторов, когда можно одновременно контролировать и пульт, и мультитрек. Растянутое окно Z Mixer следует закрепить за функциональной клавишей.

Рис. 1.69. Окно Z Mixer, растянутое на 10 каналов


Маршрутизация аудиопотоков в SAWStudio

Напомним, что в SAWStudio помимо 72 обычных каналов Input существует 6 AUX-каналов Return (Rtn) и 24 канала Output (Out).Каждый канал класса Output может являться или мастер-каналом или группой (submix) в зависимости от конфигурации оборудования и воли пользователя.
В связи с тем, что основная идея книги посвящена "полезности виртуального", мы не станем акцентировать внимание на особенностях дорогостоящих аппаратных конфигураций. По нашему мнению, виртуализация студий — это прогрессивный путь развития (в отличие от увеличения количества "ящиков" и "коробочек" в домашней студии современного компьютерного музыканта).

Примечание
Скорее всего, эволюция звукотехники идет по следующему пути: аналоговая — цифровая — виртуальная.

Мы намерены показать, какие преимущества дает SAWStudio тому современному среднестатистическому любителю музыки, у которого в компьютере установлена стандартная мультимедийная звуковая карта. Ведь сложности этой программы, в конечном счете, направлены на получение пользователем качественного результата. Именно для этого в ней создана непростая система виртуальной маршрутизации, имитируется аппаратный микшер с AUX-шинами и т. д.
В результате этого SAWStudio позволяет компьютерному музыканту любого уровня получить полноценную виртуальную студию на PC без применения дорогостоящих аппаратных решений.
В книге рассматривается самое массовое, с нашей точки зрения, применение SAWStudio — в конфигурации со стандартной мультимедийной звуковой картой. Главным достоинством программы является то, что она может превратить в Digital Audio Workstation любой PC, удовлетворяющий ее системным требованиям.
Основное отличие этой новой программы от предыдущих продуктов SAW и конкурирующих мультитрековых программ предшествующего поколения, например, Cool Edit Pro или Samplitude 2496 версии 5.9 и ниже, состоит именно в развитой виртуальной маршрутизации.
Что же такое маршрутизация аудиопотоков? Выразим ее смысл обобщающим тезисом: "Подключив один общий эффект для нескольких треков, вы не только сокращаете время управления им, не только получаете новые возможности, но и значительно экономите ресурсы компьютера". Действительно, в предыдущей программе — SAWPro — программные эффекты plug-ins можно было подключать только в разрыв канала.

Примечание
Для того чтобы сделать эффект общим для нескольких треков, требовался специальный plug-in AUX Send/Return стандарта SAW Native (крайне неудачно реализованный, с нашей точки зрения).

В результате приходилось включать один и тoт же plug-in в разрыв пять раз, если планировалось использовать его для пяти треков.
Такая неоправданная избыточность не только приносила неудобства управления, но и понапрасну тратила вычислительные ресурсы компьютера.
Отметим достоинства виртуальной маршрутизации.

  • AUX-канал программы SAWStudio позволяет перейти на новый уровень управления — настраивать глубину эффекта для каждого Input-канала регуляторами громкости и панорамы AUX-send.
  • В SAWStudio каждый Input-канал имеет шесть регуляторов уровня и панорамы в секции AUX Assigns.
  • Кроме того, пользователь может использовать групповые каналы. Так, например, в конфигурации с одним мастер-каналом все остальные 23 Output-канала можно использовать как группы (submix).
  • Каждый Input-канал может одновременно подключаться к 24 Output-каналам в секции Out Assigns. Иначе говоря, аудиопоток может разветвляться на 24 Output-канала и на 6 AUX-каналов.
  • Более того, с выходов AUX-каналов аудиопоток тоже может распределяться по группам.

Примечание
Вся виртуальная маршрутизация в SAWStudio выполняется в стереорежиме.

Забегая вперед, отметим, что существует методика сведения, при которой сначала каналы группируются по определенному признаку, а затем достигается баланс в группах. После этого уже группы балансируются между собой. Считается, что благодаря такой последовательности обеспечивается наибольшая ясность фонограммы.

Примечание
Заметим, что в других программах (например, SAWPro или Cool Edit Pro) применение этого метода почти нереально. Во-первых, для этого необходимо промежуточное сведение в файл. Во-вторых, для оперативной корректировки баланса инструментов в группе требуется множество лишних операций.
Кстати, из-за таких объективных ограничений программ прошлого поколения и появилась точка зрения, что "PC не подходит для серьезной работы со звуком".

В SAWStudio офаничений для сведения виртуальных групп в реальном времени нет. Вы можете делать это с такой скоростью, с какой это позволит быстродействие вашего PC. Рассмотрим маршрутизацию в SAWStudio подробнее.

Секция Out Assigns

Секция Out Assigns представляет собой панель с 24-мя кнопками (рис. 1.70) и является неотъемлемым атрибутом любого канала.

Рис. 1.70. Секция Out Assign

Нажатая кнопка соответствует назначению канала на определенный выход.

Предупреждение
В SAWStudio запрещено "горячее" переопределение выходов. Для этого потребуется остановить процесс воспроизведения.

Назначать выходы можно не только с помощью кнопок, но и выбором соответствующих пунктов в списке устройств (рис. 1.71).
Для вызова списка достаточно щелкнуть в любом свободном месте в пределах секции Out Assigns. Группы обозначаются символом пунктира "----".
Мастер-каналом в данном примере является Output-канал № 1, т. к. он назначен на физическое устройство.

Рис. 1.71. Назначение выхода в списке устройств

Совет
Сведение — процесс творческий. Поэтому структура маршрутов в процессе может изменяться неоднократно.
Для быстрого перехода между секциями Out Assigns различных каналов лучше пользоваться списком каналов (см. разд. "Быстрый переход между каналами микшера" ранее в этой главе) (рис. 1.72).
Старт и остановку воспроизведения удобно осуществлять клавишей <Пробел> или щелкая правой кнопкой мыши непосредственно в секции Out Assigns, не сворачивая окно микшера.

Предупреждение
Напомним, что группы нельзя назначать друг на друга: сигнал каждой группы должен быть направлен на мастер-канал.

Рис. 1.72. Быстрый переход на другой канал с помощью списка

Секция AUX Sends (AUXAssigns)

Секция AUX Sends (AUX Assigns) имеется только у Input-каналов и содержит шесть модулей по числу AUX-каналов. На рис. 1.73 секция AUX Sends изображена в том виде, в каком она отображается в окне W Mixer.
Модуль содержит два типа взаимосвязанных регуляторов уровня Send (посыл): ползунковый и цифровой.
Манипулировать ползунковым регулятором (фейдером) можно по-разному:
  • сдвигать, ухватившись за него мышью (при этом курсор примет вид [image]);
  • перемещать в пошаговом режиме (для этого нужно щелкнуть в области, отмеченной вертикальной линией на рис. 1.74, рядом с фейдером). Каждый щелчок выше/ниже символа [image] повышает уровень на один шаг в 0,25 дБ.

Рис. 1.73. Секция AUX Sends

С цифровым регулятором тоже можно работать в пошаговом режиме. Для этого нужно щелкать по верхней или нижней стрелочке символа [image] в поле цифрового регулятора. Кроме того, он поддерживает режим непрерывного регулирования. Для его осуществления нужно щелкнуть на символе и [image] левой кнопкой и удерживать ее до появления курсора [image]. Затем слегка протащить курсор вверх или вниз. Скорость регулирования зависит от того, насколько смещен курсор относительно центра символа [image] (рис. 1.75).

Рис. 1.74. Пошаговое регулирование

Рис. 1.75. Непрерывное регулирование

Совет
Непрерывным регулированием можно пользоваться при "живом" сведении, когда требуется записывать автоматизацию. В некоторых случаях это более удобно, чем плавно уводить/выводить уровень, ухватившись мышью за фейдер.

Управление регулятором панорамы модуля AUX Sends выполняется аналогично:

  • перемещением ползунка (быстро, но не всегда точно);
  • щелчками на стрелках [image] (максимально точно).

Совет
Сбросить регулятор в положение по умолчанию можно, щелкнув по нему одновременно двумя кнопками мыши.

Остановимся на функциях кнопок In, Fdr (Pst) и FX (Pst).

  • Кнопка In включает посыл сигнала на AUX-канал.
  • Кнопка Fdr (Pst) переключает вход AUX-канала на выход Input-канала, после регулятора громкости и панорамы.

Примечание
В этом режиме сигнал ответвляется на AUX-канал после обработки в Input-канале, исключая эффекты секции FX Patch (Pst Fader).

  • Нажатие кнопки FX (Pst) активизирует два режима обработки сигнала AUX-send эффектами секции FX Patch, которые зависят от состояния кнопки Fdr (Pst):
    • если кнопка Fdr (Pst) отключена, то сигнал AUX-канала будет обработан эффектами до регулятора громкости и панорамы;

      Примечание
      В этом случае кнопка FX(Pst) подключает вход AUX-канала к выходу секции FX Patch (Pre Fader) Input-канала и сигнал, посылаемый на дополнительную шину, будет обработан эффектами секции FX Patch (Pre Fader) — до регулятора громкости и панорамы Input-канала.

    • если кнопка Fdr (Pst) включена, то сигнал AUX-канала будет обработан эффектами секции FX Patch (Pst Fader) после регулятора громкости и панорамы Input-канала.

Примечание
Сигнал ответвляется на AUX-канал уже после секции FX Patch (Pst Fader), т. е. он отправляется в AUX-канал после прохождения полной обработки в Input-канале.

Примечание
Управление кнопками и регуляторами в секции AUX Sends автоматизируется.

Использование AUX-каналов для мониторинга

Использование AUX-каналов при мониторинге может существенно облегчить совместную работу звукорежиссера и исполнителя.

Примечание
Отметим, что выходы AUX-каналов можно назначать на физические устройства. Это позволит эффективно использовать AUX-канал для мониторинга при "живой" записи.

Часто исполнителю в процессе последовательной многоканальной записи мешают несведенные "посторонние партии" аранжировки. Рассмотрим на примере, как в этом случае звукорежиссер может ему помочь.
Сформируем маршрут, при котором через AUX-канал № 1 пройдет сигнал только тех каналов, которые нужны исполнителю. В этом случае звукорежиссер будет контролировать мастер-сигнал (все партии), а исполнителю будет слышна только нужная ему часть — собственный отрегулированный сигнал.

Примечание
Для того чтобы воспользоваться этой возможностью, необходима многоканальная звуковая карта (в крайнем случае две мультимедийные звуковые карты, установленные на один компьютер).

Опишем последовательность действий для приведенного примера.

  1. 1. Вызвать окно W Mixer для выбранной дорожки Return-трек.
  2. 2. Щелкнуть по полю Out Asgn [image] в секции Aux Master, при этом откроется список устройств (рис. 1.76).

    Примечание
    Все поля, содержащие треугольник в левом верхнем углу (указан стрелкой на пиктограмме поля Out Asgn), раскрываются в виде списка параметров настройки.

  3. 3. Выбрать в списке свободное физическое устройство.

В результате проделанных операций AUX-канал № 1 в данном примере будет выводиться на внешнее физическое устройство.

Примечание
Входы Return-каналов и выходы AUX-каналов можно назначать на физические устройства. Это дает возможность подключения к мультитреку SAWStudio внешних аппаратных устройств обработки звука.
В связи с тем, что данная тема выходит за рамки концепции книги "весь звук внутри компьютера", мы адресуем читателей, интересующихся этой темой, к официальной документации SAWStudio.
Для использования AUX- и Return-каналов исключительно в виртуальной студии в поле Out Asgn секции Aux Master (и в поле Input Source секции Return) должна быть надпись — Virtual (установка по умолчанию).

Рис. 1.76. Назначение физического выхода Aux Master

Предупреждение
Если маршрут AUX-канала сформирован не полностью, то прохождения сигнала не будет. В секции Out Asgn Return-канала (не путать с полем Out Asgn секции Aux Master) обязательно должен быть назначен хотя бы один из двадцати четырех Output-каналов.


Структура Input-канала

Рассмотрим внутреннее устройство Input-канала подробнее. О его структуре уже говорилось в разд. "Панель навигации Track Locator Zone + Mixer Link Controls".
Секции канальной ячейки можно обозревать как полностью в окне W Mixer, так и по частям, прокручивая их в окнах микшеров: Z Mixer, F Mixer или Е Mixer.
Сигнал в канале проходит последовательно — сверху вниз (так же, как отображается консоль в вертикальных окнах микшера — например, Z Mixer). В этой последовательности мы и рассмотрим структуру канала.

Секция Input Source

Секция Input Source определяет источник сигнала для канала. Источником может быть сам мультитрек (рис. 1.77) или любой физический вход.

Рис. 1.77. Секция Input Source

Рассмотрим типичную для интерфейса SAWStudio работу с элементами управления. И сделаем это на примере выбора входа.

  • Для непрерывного прокручивания списка нужно удерживать левую кнопку мыши нажатой у правой границы поля — [image] (вид курсора при этом изменяется).
  • Выбор входов в списке осуществляется после щелчка по треугольнику в верхнем левом углу поля — [image].
  • Пошаговое прокручивание списка делается щелчками по стрелке — [image].

Примечание
После того как физический вход выбран, можно производить запись через Input-канал с обработкой виртуальными эффектами (подробнее об этом в разд. "Запись в окне MultiTrack").

Секция Attenuator

Секция Attenuator (рис. 1.78) предназначена для того, чтобы ослабить уровень входного сигнала.
Чаще всего она применяется для записи с физического входа, причем тогда, когда входной сигнал имеет слишком большой уровень. Поэтому в большинстве случаев уровень этой секции можно оставить равным 0 дБ.

Примечание
Все функции секции Attenuator могут автоматизироваться. (Подробную информацию об этом можно найти в разд. "Автоматизация".)

Рис. 1.78. Секция Attenuator

Помимо регулятора уровня, секция Attenuator содержит три кнопки: Phs Rvs, Swap L/R и Mono. Они позволяют оперативно решать некоторые проблемы, возникающие при записи или сведении:

  • кнопка Phs Rvs — инвертирует фазу. Ее следует применять, если каналы конфликтуют по фазе (то есть происходит вычитание сигналов или частотных компонентов);
  • кнопка Swap L/R — меняет местами левый и правый каналы;
  • кнопка Mono — суммирует левый и правый каналы с подстройкой общего уровня на 6 дБ.

Секция Input EQ

В секции Input EQ находится встроенный канальный параметрический эквалайзер, содержащий дополнительные фильтры верхних и нижних частот. (На рис. 1.79 секция Input EQ изображена в окне W Mixer).

Рис. 1.79. Секция Input EQ

Условно секцию Input EQ можно разделить на два модуля:

  • модуль фильтров Hi Cut и Lo Cut (слева на рис. 1.79);
  • параметрический эквалайзер (справа).

Основное преимущество этого устройства состоит в том, что оно требует минимальное количество вычислительных ресурсов и позволяет полностью автоматизировать параметры настройки. Причем автоматизация позволяет использовать эквалайзер полнее, например, "крутить ручку фильтра" для создания спецэффектов в электронной музыке.
Рассмотрим элементы управления секции Input EQ.

  • Для включения секции в канал необходимо нажать кнопку In (в противном случае сигнал обойдет секцию).
  • Для активизации фильтров Lo Cut (ФВЧ) или Hi Cut (ФНЧ) нужно нажать соответствующую кнопку.
  • Через поле Frq (frequency — частота) осуществляется управление частотой среза фильтра.
    Выбор значения в списке происходит одинаково для всех полей управления (так же, как и для списка входов секции Input Source).

    Примечание
    В интерфейсе SAWStudio все поля управления параметрами (цифровые регуляторы) стандартны и представляют собой списки значений.

    Диапазон частот среза для фильтра Lo Cut — от 40 до 2000 Гц, для фильтра Hi Cut — от 2 до 15 кГц. Крутизна фильтров — 18 дБ/окт.

Параметрический эквалайзер секции Input EQ находится справа. В этой большей по размеру части расположены пять полосовых фильтров, предназначенных для регулирования центральной частоты и добротности. Управление эквалайзером происходит с помощью:

  • панели интерфейса SAWStudio (с полями управления);
  • графической панели (над кнопкой Reset Flat).

Примечание
Графическая панель, в сущности, является простым пятиполосным эквалайзером, предназначенным для оперативного изменения уровня в частотной полосе. Регуляторы графической панели совмещены с полями управления Gn (Gain-уровень, усиление).

Для точной настройки требуется использовать все пятнадцать цифровых регуляторов (по три на каждый фильтр). Каждый фильтр представляет собой блок с названием Band (полоса) и номером фильтра. Каждый блок содержит три элемента управления:

  • Q — добротность фильтра. Добротность измеряется как ширина полосы частот в октавах (Oct), поэтому максимальной добротности (узкой полосе) будет соответствовать величина 0,1 (рис. 1.80).

Совет
Для создания спецэффектов хороший эффект дает сочетание высоких значений добротности и автоматизации.

Рис. 1.80. Установка добротности фильтра

  • Frq (Frequency) — центральная частота фильтра. Диапазон регулирования каждого из пяти фильтров: от 40 Гц до 15 кГц.
  • Gn (Gain)— уровень (усиление). Диапазон значений: от -15 дБ до + 15 дБ.

Совет
Считаем, что начинать настройку эквалайзера лучше всего со значений добротности "-1.0" для всех полос. Затем производить более точную подстройку под задачу. Так как значения по умолчанию в списках выделены, вернуться к ним не составляет труда на любом этапе работы.

Сбросить эквалайзер "в линию" можно кнопкой Reset Flat. При этом параметр Gn (gain) принимает нулевое значение.

Секция Dynamics

Секция Dynamics содержит такие традиционные эффекты, как Compressor (Компрессор) и Gate (Гейт).
Внешний вид секции Dynamics в окне W Mixer изображен на рис. 1.81.

Рис. 1.81. Секция Dynamics

Помимо модулей с одноименными названиями Gate и Compressor в секции содержатся дополнительные модули Key и Gain, назначение которых мы рассмотрим по ходу изложения.
Начнем наше исследование с модуля Gate (Гейт). Гейт традиционно является пороговым шумоподавителем сигнала, основным предназначением которого всегда было подавление шумов в паузах. Однако творческое применение Gate не ограничено никакими правилами. Гейт относительно прост в работе, поэтому он содержит небольшое число элементов управления. Перечислим их.

  • Thr (Threshold) — порог срабатывания (в децибелах). Он дублируется ползунковым регулятором.
    Если уровень входного сигнала ниже этого порога, то уровень сигнала на выходе модуля Gate становится равным значению параметра Fir (Floor, Noise Floor — уровень шума). Гейт закрывается.
  • Fir (Floor) — уровень сигнала в дБ на выходе модуля Gate при его закрывании.
    Если установлено значение -inf, то гейт полностью отсекает низкоуровневые сигналы.

Примечание
Если, например, установить уровень Floor в -10 дБ, то при установке порога в 0 дБ индикатор Gain Reduction (Уровень подавления) (см. рис. 1.81) покажет значение-10 дБ.

  • Att (Attack) — время открывания гейта или время атаки в секундах, за которое сигнал на выходе принимает свой номинальный уровень при превышении порога на входе. Этот параметр всегда настраивается экспериментально и его значение зависит от конкретного материала и задачи. Например, в случае решения задачи шумоподавления сигналов с плавной атакой лучше установить время срабатывания в диапазоне от 20 мс и больше для более "мягкого" открывания гейта. В случае обработки гейтом звуков ударных инструментов время атаки наоборот следует уменьшать для избежания неестественного звучания.
  • Rel (Release) — время закрывания (восстановления) гейта, за которое сигнал на выходе получит уровень Floor при снижении уровня сигнала на входе ниже порога. В случае решения задачи шумопонижения параметр Release должен находиться в некотором оптимальном диапазоне. Недостаточное время восстановления приводит к паразитному дрожанию сигнала на уровне порога. Чрезмерно большое время восстановления приведет к появлению "шумовых хвостов", т. е. гейт будет не успевать закрываться и отсекать шум.

Совет
Настройку параметра Release следует производить совместно с параметром Floor. Хорошие, с точки зрения сохранения естественности звучания, результаты могут быть получены при достаточно высоких значениях уровня Floor. Тогда гейт будет только лишь приглушать шум до некоторого допустимого уровня, который будет хорошо маскироваться сигналами других каналов.

  • Кнопка On — активизирует модуль Gate.
  • Кнопка Rvrs (Reverse) — переключает гейт в инверсный режим, при котором уровень Floor устанавливается при превышении сигналом порога срабатывания.

Совет
Инверсный режим Gate открывает много новых возможностей. Если, например, уровень Floor и порог установить на уровне -5 дБ, то, при превышении сигналом порога в -5 дБ его уровень ограничивается этим же значением.
Если установить время атаки и восстановления, равные Att — 0 сек и Rel — 500 мс, то эффект будет напоминать лимитер, но с необычным звучанием.
Кроме того, можно понизить уровень Floor, например, до -20 дБ, увеличить время атаки и уменьшить время восстановления. Тогда гейт станет пропускать сигналы с резкими фронтами (верхушки атак), а средний уровень поддерживать внизу со значением 20 дБ. Эту технику можно применить для получения специальных эффектов, например, при обработке drum loops, особенно, если ограничивать частотный диапазон в модуле Key в сочетании с малым временем восстановления и автоматизацией переключения прямого и инверсного режимов гейта. (О модуле Key см. ниже.)

Подстройку параметров Threshold и Floor можно выполнять визуально, с контролем в окнах Multitrack или SoundFile.

Рис. 1.82. Визуальный контроль настройки порога

Пары горизонтальных линий (указаны стрелками на рис. 1.82) позволяют соотносить величину настраиваемого параметра с фактической формой волны. Функционально модуль Gate зависит от настроек модуля Key, поэтому с ним тоже стоит познакомиться подробно. Модуль Key содержит четыре элемента управления (рис. 1.83).

Рис. 1.83. Модуль Key

  • Key (Ключ) — выбор канала управления эффектами Gate и Compressor. Значение Self указывает на то, что обрабатываемый сигнал является управляющим (то есть управляет эффектами собственный сигнал Input-канала). Это типичная настройка. При ней модули Gate и Compressor ведут себя традиционно.
    Выбор другого канала из списка приводит к тому, что срабатыванием гейта может управлять "чужой" сигнал.

    Совет
    Такая конфигурация с использованием инверсного гейта образует ducking processor или ducker. Работу этого устройства можно рассмотреть на примере сведения речи и фоновой музыки. Канал с речью должен управлять инверсным гейтом музыкального канала с пониженным уровнем Floor. Тогда при соответствующих настройках атаки и восстановления гейта появление речи будет автоматически снижать уровень музыки до значения Floor.

  • Элементы Eq Hi и Eq Lo служат для ограничения частотной полосы управляющего сигнала.
  • Кнопка Key Listen (прослушивание, контроль) дает возможность оценить правильность настроек на слух.

Модуль Compressor устроен достаточно традиционно и предназначен для сжатия динамического диапазона сигнала. Он управляется следующими элементами:
  • кнопка On — включает эффект;
  • Att (Attack) и Rel (Release) — установка времени атаки и восстановления
    компрессора;
  • Rat (Ratio) — коэффициент сжатия динамического диапазона. Значение —inf превращает компрессор в лимитер, ограничивающий сигнал на уровне порога;
  • Thr (Threshold) — уровень порога, выше которого и происходит сжатие. Дублируется ползунковым регулятором.

Как и всякий традиционный компрессор, данный модуль ослабляет сигнал выше порога (к сожалению, в нем не предусмотрена функция автокомпенсации уровня). Для ручной компенсации предусмотрен модуль Gain, где в поле управления Gn можно скомпенсировать снижение в диапазоне до 20 дБ. Ослабление уровня компрессором можно контролировать с помощью индикатора Gain Reduction.
На этом возможности модуля Compressor не исчерпываются. Можно поэкспериментировать с ограничением частотного диапазона управляющего сигнала (в режиме Sel) в модуле Key (если выделить диапазон высоких частот, то можно получить простой de-esser (подавитель звуков "с")). Кроме этого, можно переключить управление компрессором на другой канал, а также использовать компрессор совместно с гейтом.

Примечание
При совместном использовании модулей Gate и Compressor следует учитывать, что по управляющему сигналу оба эффекта подключены к модулю Key параллельно. Настройку порога компрессора можно визуально контролировать в окнах MultiTrack и SoundFile, так же, как в модуле Gate.

Конечно, рассмотренным выше модулям секции Dynamics не хватает тех преимуществ, которые есть у DirectX- и VST-plug-ins, но этот недостаток всецело компенсируется высоким быстродействием и полной автоматизацией всех параметров за исключением кнопки Key Listen и выбора управляющего канала.

Секция Fader

Мы сознательно пропустили секции подключения plug-ins и секцию Surround-панорамирования — о них речь пойдет в следующих разделах. Здесь мы остановимся на секции регуляторов громкости и панорамы Fader (рис. 1.84).
Секция Fader представляет собой ячейку виртуальной консоли, предназначенную для изменения громкости и панорамы канала, а также для управления режимами Mute и Solo.
Регуляторы громкости и панорамы реализованы в двух видах — в виде ползунковых регуляторов и в цифровом виде: .
Управление ими организовано идентично управлению уровнем и панорамой в AUX-секции (см. разд. "Секция AUXSends (AUXAssigns)").

Рис. 1.84. Секция Fader

Шаг изменения панорамы — 0,1 дБ. Шаг изменения громкости — 0,25 дБ. Под регулятором панорамы расположен ярлык, в котором можно задать название канала. Для этого нужно сначала щелкнуть на ярлыке с нажатой клавишей <Shift>, затем ввести название в диалоговом окне Enter Input Chan Label, после чего нажать клавишу <Enter>.

Совет
Для того чтобы быстро присвоить названия группе каналов, нужно щелкнуть на ярлыке с нажатой клавишей <Ctrl>. Тогда при каждом завершении ввода названия будет появляться новое диалоговое окно — следующего канала.

Кнопки Solo и Mute управляют, соответственно, режимами Solo и Mute (приглушение) канала.

Предупреждение
Для высвобождения вычислительных ресурсов нужно выделять треки, т. к. приглушение каналов не отменяет обработку канальными эффектами и считывание данных с жесткого диска. (О выделении треков см. разд. "Выделение треков".)

Рассмотрим режим Solo подробнее.
Определить, включен или выключен режим Solo, можно по кнопке-индикатору Solo, которая находится в области управления режимами (окно MultiTrack) (см. рис. 1.42).

Примечание
Информацию о функциях кнопки Solo Mode см. в разд. "Top-Client Area в окне MultiTrack".

Режим Solo имеет свои разновидности. Это зависит от того, какой канал используется.
Режим Solo для каналов класса Input может быть двух видов.

  • Обычный режим. Включается кнопкой Solo.
    В обычном режиме приглушаются все остальные каналы — работает только один маршрут: от Input-канала до мастер-канала.
  • Режим Solo с Return-каналами. Включается кнопкой Solo с нажатой клавишей <Shift>.
    В этом режиме вместе с Input-каналом прослушиваются все маршрутизируемые Return-каналы.

Совет
Часто при сведении требуется прослушивать только один канал совместно с эффектами, включенными в разрыв Return-каналов. Таким AUX-эффектом может быть, например, ревербератор. В этом случае оперативное переключение между двумя видами режимов Solo на Input-канале позволит наиболее точно отстроить уровень и панораму сигнала AUX-send (посыл).

Режим Solo Return-канала приглушает все маршруты, кроме аудиопотока от Return-канала до мастер-канала, что позволяет оперативно контролировать настройки plug-ins Return-канала.
Режим Solo для Output-канала, используемого в качестве группы, выделяет маршрут от всех ассоциированных с группой Input-каналов до мастер-канала с приглушением всех остальных маршрутов.
Для того чтобы снять режим Solo одновременно-на всех каналах, достаточно щелкнуть по кнопке Solo (см. рис. 1.42) в окне MultiTrack или "отжать" любую кнопку Solo виртуальной консоли с нажатой клавишей <Ctrl>.

Внимание
Режим Solo не автоматизируется.

Режим Mute используется для приглушения канала.
Кнопка Mute прерывает аудиопоток, однако все маршрутизируемые данные до нее продолжают обрабатываться. Если, например, на Input-канале используется AUX-маршрутизация (посыл) с отжатой кнопкой Fdr (см. разд. "Секция AUX Sends (AUX Assigns)"), то режим Mute отключит только прямой сигнал. Точно так же будет продолжаться вся обработка звука канальными виртуальными эффектами.
Режим Mute автоматизируется. В меню Automation существует специальный пункт Set Default Mute Slope, где можно установить скорость приглушения.

Примечание
В SAWStudio предусмотрен специальный параметр Slope (Наклон), который задает скорость изменения параметра в точке регулирования. (Информацию о Slope можно найти в разд. "Автоматизация".)

Если выставить параметр Slope в пределах двух секунд, то режим приглушения превратится в плавное изменение уровня Fade In, Fade Out.
Продолжим описание секции Fader.
Рядом с регулятором громкости расположен комбинированный индикатор уровня канала. Индикатор относится к разряду измерителей пикового уровня сигнала Peak Meter. Индикация пикового уровня особенно важна для цифровых систем с ограничением в 0 дБ, поэтому в SAWStudio используются комбинированные измерители, совмещающие Peak Meter и "светодиодный" индикатор перегрузки (рис. 1.85).

Рис. 1.85. Измеритель уровня

Индикатор перегрузки запоминает кратковременное превышение сигналом порога в 0 дБ. Поэтому для осуществления непрерывного контроля его необходимо сбрасывать.

Примечание
Все измерители автоматически сбрасываются при рестарте воспроизведения. В данном случае имеется в виду сброс без остановки воспроизведения.
Индикаторы отображают уровень сигнала после обработки plug-ins, подключенных в слот Pst Fader (post fader) (см. рис. 1.64).

Делается это через контекстное меню, которое вызывается щелчком мыши непосредственно на "столбиках" индикатора (рис. 1.86).

Рис. 1.86. Сброс индикатора перегрузки

Контекстное меню предлагает две альтернативы:

  • Clear Current Meter Peaks — сброс индикатора "горячего" канала;
  • Clear All Meter Peaks — сброс индикаторов всех каналов.

Настройка режимов измерителя производится в меню Mixer. За нее "отвечают" пункты подменю Meter Active, Meter Peak Hold, Meter Response.
Изучим эти настройки более детально.
  • Подменю Meter Active содержит пункты Full Mixer View и Zoom Mixer View.
    Если эти пункты отмечены, то индикаторы работают в обоих представлениях виртуальной консоли.
    В документации к программе рекомендуется отключать индикацию для освобождения ресурсов. Но по нашим наблюдениям измерители потребляют всего около 1% ресурсов на десять треков. Экономия здесь несущественна.

Примечание
Стоит отметить преимущество SAWStudio перед конкурирующими продуктами, индикаторы которых начинают заметно "тормозить" при сильной загрузке процессора. В программе SAWStudio индикаторы продолжают работать быстро даже при максимальной загрузке процессора — на уровне 90%.

  • Подменю Meter Peak Hold (Удержание пикового уровня) состоит из пунктов:
    • Off — удержание последнего пикового значения отключено;
    • Infinite — бесконечное удержание последнего пикового значения;
    • Slow — медленный сброс пикового значения;
    • Fast — быстрый сброс пикового значения.
  • Подменю Meter Response (Отклик индикатора) содержит пункты:
    • Slow — медленный, в котором удобнее оценивать средний уровень сигнала из-за сглаживания переходных процессов;
    • Med — средний режим;
    • Fast — быстрый, для отслеживания динамики сигнала.

Вернемся к регулятору громкости. Для настройки кривой регулирования, т. е. зависимости приращения громкости от величины смещения фейдера, предназначено подменю Chan Fader Taper (Плавность регулирования канального фейдера) в меню Mixer.
Рассмотрим пункты этого подменю более детально:

  • Standard Log — стандартная логарифмическая зависимость, имитирующая фейдеры физической консоли;
  • Expanded Log — расширенная зависимость, при которой в области около О дБ приращения громкости становятся минимальными, что придает большую свободу в перемещении фейдера. Наиболее комфортный режим для микширования громких сигналов;
  • Condensed Log — сжатая зависимость, при которой область около 0 дБ уплотняется до линейной зависимости, но при этом растягивается низкоуровневая область. Комфортный режим для микширования тихих сигналов;
  • Linear — линейный закон изменения громкости от смещения фейдера;
  • Custom — пользовательская настройка кривой регулирования. Это особый режим, позволяющий построить собственный закон изменения громкости.

Режим Custom требует, на наш взгляд, более детального рассмотрения. При его активизации появляется окно Е Mixer с тремя узлами (рис. 1.87).

Рис. 1 .87. Окно Е Mixer в режиме Custom

Узел, расположенный выше уровня 0 дБ, управляет двумя зонами. Узлы, находящиеся ниже 0 дБ, управляют оставшимися тремя. Перемещая узлы, можно манипулировать пятью зонами и создавать так называемые "sweet spot" — области комфортного регулирования.
Как это делается. По умолчанию узлы находятся в точках +6 дБ, -12 дБ и -36 дБ.
Перемещая узел, мы одну область растягиваем, а другую, соответственно, сжимаем.
Сжатая зона означает большую крутизну кривой регулирования: небольшие смещения фейдера вызывают существенные изменения громкости.
Зона "sweet spot" соответствует растянутой области: большие смещения фейдера изменяют громкость менее значительно. Поэтому регулирование в зоне "sweet spot" более комфортно.
Пользовательская настройка фиксируется после закрытия окна Е Mixer.

Совет
После того как окно Е Mixer вызвано, начинать настройку можно с выбора стандартных предустановок: Standard Log, Expanded Log и т. д. При этом окно Е Mixer не нужно закрывать до окончания настройки. Удачно созданную кривую регулирования можно сохранить как настройку по умолчанию или в отдельный prf-файл.

Подводя промежуточные итоги, отметим, что мультитрековые программы других производителей не создают такой живой иллюзии аппаратного микширования, как SAWStudio.
Этот факт еще раз подтверждает, что при совершенной программе совсем не обязательно дополнять компьютер дорогостоящим цифровым микшерным пультом.
Появление столь уникального программного продукта, как SAWStudio заставляет пересматривать многие устоявшиеся стереотипы и признать, что талантливые программисты способны сломать сложившиеся у музыкантов стереотипы о "невозможности делать звук на PC".


Параллельное управление каналами (группирование)

Еще одна сервисная возможность, предусмотренная в программе SAWStudio, позволяет объединять элементы управления канала.
Это может использоваться, например, как для установки однотипных параметров, так и для синхронного их изменения.
Объединение каналов происходит просто — щелчком мыши в специальном поле, изображенном на рис. 1.88.

Рис. 1.88. Пример объединения каналов в окне F Mixer

В примере на рис. 1.88 в группу объединены каналы I-03, I-05, I-07, т. к. их номера выделены черным цветом. Повторный щелчок снимает выделение и, соответственно, удаляет канал из группы.

Совет
Для быстрого выделения группы близлежащих каналов достаточно просто протащить курсор мыши по их номерам. С помощью клавиши <Alt> можно установить/снять выделение группы между последним выделенным каналом и текущим (см. разд. "Выделение треков" выше в этой главе).

На рис. 1.89 изображен другой пример выделения канала в окне Z Mixer.

Рис. 1.89. Пример включения канала в группу в окне Z Mixer

В группу объединяются все элементы управления канала, кроме элементов управления секции Input Source и plug-ins, подключенных в секции FX Patch.
Управление каким-либо параметром любого канала, входящего в группу, автоматически и синхронно изменяет те же параметры в других каналах группы.

Примечание
Конфигурирование групп можно выполнять в "горячем" режиме (в отличие от выделения треков).

Внимание
Несмотря на схожесть интерфейса, выделение каналов и выделение треков — это две разные по сути операции.


Несколько полезных приемов управления консолью

Так как создатель программы SAWStudio Боб Лентини — замечательный программист и специалист в области профессиональных аудиосистем, он смог применить при разработке интерфейса своей программы богатый личный опыт в эксплуатации подобных систем.
Как известно, бичом подавляющего большинства мультитрековых программ является информативная избыточность интерфейса. Она постоянно отвлекает пользователя, заставляя его делать лишние движения мышью, читать ненужные сообщения и бесконечные контекстные меню, прокручивать окна и т. д.
С нашей точки зрения, такая избыточность оправдывает себя только на первых этапах работы с программой. Но впоследствии лаконичный интерфейс несоизмеримо более продуктивен.
Для сравнения можно привести любую область деятельности. Новичку подсказки нужны, а мастеру они мешают. Представьте ситуацию: опытному водителю "подсказывает" встроенный "инструктор вождения". Помочь такое устройство не сможет — только отвлечет. Ведь с опытом знания переходят на уровень автоматизма.
Конечно, для поверхностного знакомства с программой подсказки удобны, но для освоения любой программы (даже с избыточным интерфейсом) требуется время.
Первая встреча с программой всегда проходит быстро. За ней наступает этап эксплуатации, в котором ценятся быстрота и надежность, а не "понятность с первого взгляда".
Может быть поэтому программу SAWStudio пользователи сравнивают с хорошим, надежным автомобилем, который небросок на первый взгляд, но зато никогда не подводит на виражах.
Перейдем к практическим примерам.
Одна из часто встречающихся операций — изменение параметров одинаковых секций соседних каналов.
Предположим, что в окне Z Mixer завершена настройка эквалайзера для одного канала. После этого нужно будет перейти на соседний канал и выполнить соответствующую настройку эквалайзера уже для соседнего канала. Сделать эту операцию можно разными способами.
Самый быстрый — щелкнуть у левого или правого края окна Z Mixer (рис. 1.90). Каждый щелчок подвинет "горячий" канал на соседний трек:

  • щелчок у левого края — переместит вверх (в окне MultiTrack);
  • щелчок у правого края — переместит вниз.

Таким способом можно быстро пролистывать каналы, значительно сэкономив время.
Если окна Z Mixer и F Mixer используются совместно, то может потребоваться быстро прокрутить микшер в окне F Mixer.

Рис. 1.90. Пошаговое изменение номера "горячего" канала

Допустим, "горячий" канал (с номером I-21) расположен у правого края окна F Mixer. Тогда щелчок правой кнопкой мыши в окне Z Mixer при нажатой клавише <Ctrl> прокрутит окно F Mixer таким образом, что "горячий" канал I-21 расположится первым с левого края (рис. 1.91).
По вертикали прокручивать окно F Mixer удобнее, чем окно Z Mixer.
Еще один способ получить быстрый доступ к элементам управления секций.
Для того чтобы привести в соответствие секции разных окон (F Mixer и Z Mixer), нужно щелкнуть правой кнопкой мыши на выбранной секции одного из окон (F Mixer) при нажатой клавише <Ctrl>. Тогда другое окно (Z Mixer) автоматически прокрутится до соответствующей секции (рис. 1.92).

Примечание
Если на рабочем экране присутствует только окно F Mixer, то вышеописанная комбинация вызовет окно Z Mixer.

Рис. 1.91. Быстрое прокручивание окна F Mixer

Рис. 1.92. Быстрое прокручивание окна Z Mixer

Двойной щелчок на выбранной секции окна F Mixer вызывает окно Е Mixer, содержащее выбранную секцию. Щелчок правой кнопкой мыши в окне Е Mixer закрывает это окно. Это позволяет контролировать виртуальный микшер в полном масштабе в окне F Mixer и оперативно управлять большим количеством параметров в окне Е Mixer.
Для одновременного доступа ко всем элементам управления канала самым удобным является окно W Mixer. Для его вызова можно использовать специальный рабочий экран, закрепленный за функциональной клавишей, например, <F2>. Помимо этого, существует другой способ быстрого вызова окна W Mixer: щелчок правой кнопкой в окне Z Mixer (или F Mixer) с нажатой клавишей <Shift>. Такой вызов окна W Mixer из окна F Mixer делается всего за одну операцию: выбор канала и вызов окна W Mixer происходит одновременно.


Работа с plug-ins в SAWStudio

Обратим внимание на тот факт, что встраиваемые программные модули обработки звука (plug-ins) экономически выгоднее своих "железных" аналогов, т. к. при виртуальных технологиях один и тот же код (алгоритм) может использоваться одновременно в разных участках виртуальной консоли с разными настройками (рис. 1.93).
Образно говоря, вам достаточно заплатить при покупке за один plug-in, чтобы потом виртуально "размножить" его в мультитрековой программе по мере необходимости.
Это очевидный факт. И по понятным причинам он намеренно замалчивается авторами заказных рекламных статей о "железных" устройствах.
Конечно, искусственный спор о качестве звучания при выборе между "железом" и "железом" (персональным компьютером и специализированным компьютером) может продолжаться бесконечно. Но преимущества виртуальных технологий, способных "увеличиваться количеством" по желанию пользователя, непреложны с точки зрения бюджета. Кроме этого, прогресс виртуальных технологий стремителен: качество алгоритмов plug-ins неуклонно растет, их ассортимент постоянно совершенствуется.
Единственным ограничивающим фактором для виртуальных устройств традиционно являлась производительность PC.
Но тот технологический скачок, который был совершен в производстве PC в последние годы, позволяет ожидать доминирования виртуальных звуковых технологий. Во всяком случае, в секторе малобюджетных домашних студий, где добиваться высокопрофессионального звучания, по меньшей мере, наивно.

Рис. 1.93. "Размножение" виртуального эффекта

Примечание
Кроме того, в компьютерной музыке возникла мода на Low End-технологии звучания с низкой разрядностью сэмплирования.

Нужно понимать, что отличие профессиональной записи состоит не только и не столько в дорогостоящем оборудовании, но также и в наличии специального помещения, специалистов-профессионалов и т. п.
Мы убеждены, что музыканту, занимающемуся домашним творчеством, удобнее управлять программными модулями. Ведь справиться с ними гораздо легче — здесь не нужна специальная инженерная квалификация. При их подключении не требуется решать "аппаратные ребусы" по стыковке оборудования различных фирм-производителей, тщетно пытаться разобраться с документацией. А если еще учесть, что абсолютное большинство людей на планете не отличают на слух среднее качество формата МРЗ от высокого качества AUDIO CD, то тема дискуссии отпадает сама собой.
Во всяком случае, нужно понять главное: само по себе дорогостоящее оборудование еще не гарантирует высокого качества фонограммы. Так же, как дорогие краски не сделают человека художником. Но созданная в спокойной творческой обстановке демо-запись поможет донести вам свое творчество до слушателей.
Преимущество программы SAWStudio состоит еще и в том, что она поддерживает не только свой внутренний стандарт — SAWStudio Native, — но и наиболее распростаненные DirectX и VST-plug-ins:

  • SAWStudio Native — внутренний стандарт;
  • VST— широкий класс эффектов, совместимых с Nuendo, Cubase, WaveLab;
  • DirectX— самый широкий класс plug-ins, совместимых со всеми программами обработки звука.

Все виртуальные модули подключаются абсолютно одинаково — без VST- и DirectX-Linker (как это было в программе предыдущего поколения — SAWPro).

Примечание
Еще один шаг вперед программы SAWStudio: впервые в программных продуктах SAW введена автоматизация элементов управления plug-ins (но только для стандарта SAWStudio Native).

Для подключения виртуальных модулей предназначена отдельная секция виртуальной консоли FX Patch, состоящая из двух слотов с кнопками [image] (FX):

  • Рге Fader — подключение plug-ins до регуляторов громкости и панорамы;
  • Post Fader — подключение plug-ins после регуляторов громкости и панорамы.

Рассмотрим интерфейс подключения plug-ins подробнее.


Слот FX Pre Fader

Для подключения plug-ins до регуляторов громкости и панорамы служит слот Pre Fader. Щелчок в области, расположенной правее кнопки FX (рис. 1.94), вызывает окно FX Pre Patches.
В примере на рис. 1.94 список plug-ins пуст, .поэтому присутствует только надпись [End Of List]. Поле Input Trk N (где N — номер трека) информирует о том, на какой трек назначаются эффекты.

Рис. 1.94. Вызов окна FX Pre Patches

Все управление процессом подключения plug-ins сосредоточено в четырех кнопках.

  • FX — доступ к окну FX Choices (рис. 1.95), в котором содержится список установленных plug-ins.

Рис. 1.95. Окно FX Choices

  • Add (Добавить) — подключение программного модуля, выделенного в списке FX Choices (рис. 1.96). При этом автоматически вызывается окно с элементами управления plug-ins.

Примечание
Такое подключение plug-ins называется "в разрыв", т. к. канал как бы разрыва ется и в точку разрыва подключается эффект (эффекты). Сигнал последовательно проходит через цепочку подключенных модулей.

Рис. 1.96. Подключение plug-ins

Совет
Если щелкнуть по кнопке Add с нажатой клавишей <Shift>, то окно настроек эффекта не появляется. Этим способом удобно пользоваться в том случае, если открыто одновременно несколько окон plug-ins, т. к. окна plug-ins находятся всегда на переднем плане и могут закрыть окно FX Pre Patches.

  • Rem (Remove) — удаление выделенного модуля из списка в окне FX Рге Patches.
  • Clr (Clear) — полная очистка списка подключенных plug-ins. Комбинация <Ctrl>+ щелчок на кнопке Clr очищает от plug-ins все каналы, ассоциированные с окном FX Pre Patches.

Совет
Комбинация <Ctrl>+Clr действует во всех окнах подключения plug-ins. Поэтому для очистки всех каналов, например, от plug-ins, подключенных в слот Pst Fader, необходимо применить эту комбинацию в окне FX Post Patches любого канала.

Манипуляции с plug-ins в окне FX Pre Patches

Последовательность plug-ins в списке имеет значение для обработки звука. Первый (верхний) модуль в списке обрабатывает звук первым и т. д. вниз по цепочке. Последним эффектом является модуль над строкой [End Of List].
К сожалению, интерфейс SAWStudio не позволяет изменять порядок plug-ins в списке путем простого перетаскивания. Поэтому для создания определенной цепочки виртуальных модулей необходимо пользоваться описанными ниже приемами подключения.

  • Подключение эффекта в конце цепочки выполняется после предварительного выделения строки [End Of List]. Если модули подключаются последовательно друг за другом, то строка [End Of List] выделяется автоматически.
  • Для вставки модуля в цепочку между двумя другими необходимо предварительно выделить нижний в списке модуль. Модуль всегда подключается перед выделенным эффектом в списке (рис. 1.97).

Рис. 1.97. Вставка plug-in

  • Для добавления эффекта в начало цепочки достаточно выделить первый элемент списка.


Окно настроек plug-in

Двойной щелчок на названии эффекта в списке вызывает окно с его элементами управления (рис. 1.98).

Рис. 1.98. Окно настроек plug-in

Все элементы управления, расположенные внутри окна, принадлежат конкретному эффекту. От SAWStudio добавлена только общая часть — верхняя панель, содержащая три основные кнопки:

  • (Close window) — кнопка закрытия окна (правый верхний угол);
  • (IQS Logo) — кнопка сохранения пресетов (предустановок);
  • (FX Bypass) — кнопка обхода эффекта. В режиме bypass кнопка меняет вид на [image] (bypass).
Кнопка IQS Logo предназначена для сохранения индивидуальных настроек эффекта.

Рис. 1.99. Контекстное меню пресетов

Команда Save Presets сохраняет текущие настройки в файл с расширением dxp (DirectX preset) или vsp (VST preset). При этом для каждого эффекта автоматически создается папка с одноименным названием (рис. 1.100).

Рис. 1.100. Структура каталога пресетов

Пресеты DirectX и VST-plug-ins рассортированы по разным каталогами:

  • пресеты DirectX размещены в папке DirectX_Presets;
  • пресеты VST — в папке VST_Presets.

Команда Load Presets возвращает ранее сохраненные настройки.

Примечание
Инсталляция VST-plug-ins производится непосредственно в папку VST_Pluglns, расположенную в каталоге SAWStudio.

Особенности применения кнопки FXBypass

Функция обхода эффекта с помощью кнопки FX Bypass автоматизируется. Это дает возможность в реальном времени изменять конфигурацию цепочки plug-ins, например, для оперативного изменения порядка расположения эффектов в цепочке или переключения пресетов. Делается это следующим образом.
Рассмотрим пример подключения последовательно трех DirectX plug-ins (рис. 1.101). На разных участках трека обработка должна выполняться одним и тем же эффектом, но с тремя разными настройками.

Рис. 1.101. Коммутируемая цепочка plug-ins

Для этого создается цепочка из трех одинаковых plug-ins, два из которых всегда находятся в режиме обхода. Далее с помощью автоматизации кнопки FX Bypass в определенных местах включается только один из plug-ins с заданными параметрами. По этому методу можно на одном треке коммутировать целые цепочки plug-ins. Например, цепочки, в которых изменяется порядок расположения эффектов.

Примечание
Надписи "Bypass" и "Working" на рис. 1.101 не являются принадлежностью интерфейса, и добавлены авторами для наглядности. Хотя, с нашей точки зрения, подобная индикация не была бы лишней. Забегая вперед, отметим, что для записи коммутации эффектов нужно включить режим автоматизации кнопкой Aut в окне MultiTrack.

Повышение КПД виртуальной студии

Алгоритмы подключаемых модулей достаточно ресурсоемки. Поэтому несложно перегрузить центральный процессор виртуальными эффектами. Но на самом деле ресурсы центрального процессора при этом будут израсходованы неэффективно.
Ведь далеко не в каждой точке мультитрека требуется вся обработка. Например, в местах пауз (между аудиообъектами одной группы треков) вполне можно разгрузить процессор и направить высвобожденные ресурсы на другую группу, где идет интенсивная обработка.
Решить эту задачу просто. Нужно применить автоматизированный обход тех plug-ins, которые временно не выполняют полезной работы. Можно сказать, что основное правило для PC звучит так: "Отключать все, что не используется в данный момент".
Обходить можно как отдельные plug-ins, так и целые слоты. Для этого предусмотрена отдельная кнопка FX (рис. 1.102).

Рис. 1.102. Обход всех эффектов слота Pre Fader

Кнопка FX отображает три состояния слота:

  • — отсутствие plug-ins;
  • — активное состояние. Загружены plug-ins;
  • — режим bypass. Загружены plug-ins.

Автоматизируя общий обход, можно существенно повысить общую производительность. Хотя, конечно, многое зависит от структуры самого проекта.


Создание групп plug-ins

По сравнению с предшествующими программными продуктами линейки SAW интерфейс SAWStudio значительно модернизирован. Особенно удобно он реализован для работы с подключаемыми приложениями — plug-ins. Образно говоря, plug-ins — это "наборы красок музыканта", из которых он создает свою звуковую палитру.
Постоянно расширяющийся ассортимент plug-ins побуждает музыкантов к новым экспериментам. В виртуальной студии plug-ins используются особенно активно благодаря возможности многократного подключения, доступности в ценовом плане и т. д.
Если в системе установлено большое количество plug-ins, то музыкант вынужден постоянно выискивать в длинном списке наиболее подходящий для звучания в каждом конкретном случае. Но утомительный поиск порой губителен для творчества.
Для помощи пользователям в этом вопросе в SAWStudio предусмотрена возможность группирования plug-ins по любому признаку.
Например, можно рассортировать plug-ins по стандартам DirectX, VST и Studio Native. Или создать группы по названиям фирм — производителей plug-ins. Ничто не мешает создать группу "My favorite plug-ins" с наиболее часто используемыми эффектами. Или сгруппировать их по функциональному признаку, например, создать группу: "Ревербераторы", "Компрессоры" и т. д. В конечном итоге выбор за вами. Тем более, что одни и те же plug-ins могут состоять одновременно в разных группах.
Познакомимся с этим сервисом SAWStudio подробнее.
Группы plug-ins создаются по такому же принципу, как и группы регионов в окне Regions.
Для вызова контекстного меню необходимо щелкнуть по кнопке Group в окне FX Choices (рис. 1.103).

Рис. 1.103. Контекстное меню групп plug-ins

Контекстное меню разделено на две части:

  • нижняя часть, в которой располагаются сами группы;
  • верхняя часть, предназначенная для управления этими группами.

Максимальное число групп — 30. Кратко перечислим основные операции, которые можно выполнять с группами.

  • Add Selected To — добавление выделенных в списке plug-ins в группу.

Примечание
Выделять группу plug-ins в списке можно быстро с клавишей <Shift> или последовательно (выборочно) с клавишей <Ctrl>.

  • Remove Selected From — удаление выделенных plug-ins из группы.
  • Clear All From — очистка группы или всех групп (если выбрана команда All Groups).
  • Rename — переименование группы. В примере на рис. 1.103 группы созданы и переименованы по трем принципам классификации.

Совет
Операцию создания групп plug-ins достаточно выполнить один раз — структура групп сохраняется в файле SAWStudioFx.grp в папке SAWStudio. В случае полной переустановки операционной системы (с форматированием жесткого диска) или переноса программы на другой компьютер можно сохранить или перенести структуру групп на обычной дискете. При этом, естественно, количество и типы установленных plug-ins должны совпадать. Группы, содержащие не установленные plug-ins, будут пустыми.


Особенность обработки звука plug-ins в окне FX F-Res Patches

Давайте заглянем в программу несколько глубже, чем это предлагается обычному пользователю. И сделаем это не из праздного любопытства, а для того, чтобы лучше понимать процессы, происходящие "на поверхности".
Несмотря на то что алгоритмы программы почти всегда являются "секретом фирмы", некоторое общее исследование провести можно.
В качестве "инструмента исследования" возьмем программный битоскоп AnalogX BitPolice (www.analogx.com), который подключается как DirectX plug-in.
В программе SAWStudio кнопки FX слотов всех Input-каналов и Return-каналов имеют желтый цвет. А у Output-канала имеется еще и красная FX-кнопка, рядом с которой написано Final Res (Финальное разрешение).
Сделано это не случайно:

  • обработка звука plug-ins, подключенными в "желтые" слоты, производится с 24-битным разрешением;
  • plug-ins, подключенные в "красные" слоты, обрабатывают звук с финальным разрешением.

Поясним отличия, обозначенные разным цветом.
Финальное разрешение — это разрешение (или разрядность) мультитрека, установленное в меню MultiTrack | Resolution.

Примечание
Этот параметр должен соответствовать возможностям аудиооборудования. Как правило, мультимедийные звуковые карты позволяют воспроизводить только 16-битный звук. Поэтому после установки разрешения, превышающего возможности оборудования, будет выдано предупреждающее сообщение в момент старта воспроизведения.

Необходимо помнить о важности сохранения промежуточных результатов обработки в файлах с высокой разрядностью. (Об этом мы подробно писали в книге "'Живая' музыка на PC", БХВ-Петербург, 2001.)
В SAWStudio эта возможность реализуется благодаря тому, что внутри программы исходные звуковые файлы преобразуются к более высокой разрядности. Поэтому разрядность виртуальной обработки выше исходной разрядности АЦП 16-битной звуковой карты.
При виртуальном сведении 16-битная звуковая карта может влиять на качество только с точки зрения мониторинга.
В SAWStudio могут одновременно сводиться 16, 20 и 24-битные файлы, а финальное разрешение целиком зависит от возможностей применяемого оборудования и задачи.

Примечание
В дальнейшем мы подробно рассмотрим процесс сведения в финальный файл с 24-битным разрешением, команды BuiltMix To... и т. д.

Из всего этого следует простой вывод: при 16-битном оборудовании не следует подключать plug-ins в слот Final Res (окно FX F-Res Patches). В архитектуре SAWStudio обработка в слоте Final Res будет производиться после подпрограммы дизеринга и подпрограммы "мягкого" клиппирования (Dithering — сглаживание полутонов, Soft-Clipping — клиппирование).

Команды меню MultiTrack
Команда MultiTrack Soft-Clipping вызывается через меню MultiTrack и обеспечивает алгоритм "мягкого" клиппирования. Это означает, что если выходной сигнал мультитрека превышает уровень 0 дБ, то ограничение происходит мягкое (едва заметное на слух). Последующая обработка в слоте Final Res в 16 битах может вызвать дополнительное ограничение сигнала.
В документации к SAWStudio рекомендуется отключать режим "мягкого" клиппирования. Во-первых, это высвобождает ресурсы центрального процессора. А во-вторых, если перегрузку выше уровня 0 дБ не маскировать с его помощью, то можно вовремя предупредить ошибки сведения.
Подменю Dither меню MultiTrack содержит четыре пункта, из которых один соответствует выключенному состоянию, а три остальных разным алгоритмам дизеринга. В выборе алгоритма дизеринга не существует четких правил. Мы рекомендуем его вообще отключить и сводить в файл с 24-битным разрешением. И дизеринг применять только однократно — на заключительной стадии мастеринга Audio CD (к этому мы вернемся позже, в разд. "MS-мастеринг в SAWStudio").

Проведем небольшое исследование. Подключим битоскоп в разрыв Input-канала после регулятора громкости и панорамы.

Рис. 1.104. Обработка в Input-канале

На рис. 1.104 видно, когда разряды с номерами не изменяются — с 1 по 8 (число 100), и когда они активно работают — с 9 по 32 (числа в диапазоне от 1 до 68).

Примечание
Число 50 означает, что разряд принимает значения 0 и 1 с одинаковой частотой, т. е. идет обработка.

Теперь увеличим регулятором громкости уровень канала на 20 дБ.
На рис. 1.105 видны изменения: заработали оставшиеся восемь разрядов. Они обеспечивают запас по перегрузке (Headroom) виртуального канала на 48 дБ.
Поэтому можно смело повышать уровень Input-канала на 20 дБ, а затем скомпенсировать это превышение на Output-канале (понизить там уровень на 20 дБ) без искажений сигнала.

Рис. 1.105. Обработка в Input-канале с уровнем выше 0 дБ

Рис. 1.106. Обработка в слоте Final Res

Для того чтобы картина была полной, подключим битоскоп в слот Final Res мастер-канала.
Для наглядности на рис. 1.106 показан случай мастер-канала с 16-битной звуковой картой. Это сделано для того, чтобы продемонстрировать распространенные проблемы 16-битной обработки: отсутствие запаса по перегрузке, отсечение низкоуровневых сигналов.
В заключение акцентируем внимание на некоторых важных моментах.
Если не стоит задача сжатия материала в МРЗ, то вообще не рекомендуется использовать слот Final Res (при 16-битном оборудовании).
В случае использования Output-канала как группы, аудиопоток обходит слот Final Res и движется в направлении мастер-канала. Поэтому единственное место, где может произойти снижение качества звука — это слот Final Res мастер-канала.


Запись и редактирование в SAWStudio

Приступим к рассмотрению способов записи в SAWStudio.
Программа позволяет осуществлять три способа многоканальной записи:
  1. 1. Последовательный — когда все партии записываются последовательно "под фонограмму". Музыкант прослушивает ранее созданные треки и под них исполняет новую партию.
  2. 2. Параллельный — когда все треки записываются одновременно. Этот способ применяется при необходимости синхронной записи исполнителей. Например, на концертах или в студии — при записи джазовой музыки, когда при исполнении музыканты нуждаются в "исполнительском диалоге".
  3. 3. Комбинированный способ, представляющий собой сочетание первых двух.

Параллельная многоканальная запись — это в большинстве случаев кратчайший путь к получению фонограммы наиболее музыкальной, вовлекающей в прослушивание. При этом способе не нарушается "музыкальное время", не разрывается тонкая исполнительско-музыкальная ткань. При последовательном способе записи творческий взаимообмен в реальном времени между музыкантами невозможен. Живое дыхание игры исчезает. Многие музыканты, понимая это, стараются всеми способами сохранить музыкальность исполнения и не подменить его "звуковым консервантом", состоящим исключительно из стерильного звука и безукоризненного исполнения.
Конечно, в условиях домашней студии организовать полноценную акустическую параллельную запись невозможно. Но преимущества этого способа можно использовать, например, при параллельной записи электрогитары, синтезатора, вокала собственной демо-фонограммы, т. к. он позволяет сохранить на аудионосителе музыкальность исполнения. Ведь если демо-запись не вовлекает в прослушивание, то она теряет свою основную функцию. Параллельная многоканальная запись на компьютере может быть выполнена как в полном объеме, так и частично - комбинированным способом. В идеале она требует установки мультиканальной звуковой карты или аудиоинтерфейса. В этом случае разные каналы можно будет одновременно записывать на разные треки.
При малобюджетном варианте — с двухканальной мультимедийной звуковой картой — можно пользоваться комбинированным способом.

  • Один путь — это записывать одновременно двух музыкантов, подключенных к левому и правому каналу звуковой карты, на две отдельные дорожки. И затем повторить "под фонограмму" параллельную двухканальную запись для других партий необходимое количество раз. Исполнительские диалоги способны существенно добавить музыкальности.

Примечание
В условиях домашней студии производить качественную параллельную запись с использованием микрофонов практически невозможно, поэтому мы рассматриваем здесь случай исполнения на электроакустических и электронных музыкальных инструментах.

  • Другой путь — это выполнять микширование на внешнем микшерном пульте и записывать группы инструментов. Этот способ требует предварительной звуковой обработки и с точки зрения концепции виртуальной студии менее предпочтителен.


Повышение качества записи 16-битной звуковой карты

Качественные преобразователи, как известно, достаточно дороги. Но качество оцифровки можно повысить и на недорогих 16-битных звуковых картах.
Кратко остановимся на технических приемах, позволяющих это сделать.
Динамический диапазон 16-битного цифрового сигнала — 96 дБ. Если уровень записи превышает -6 дБ, то мы эффективно используем все 16 разрядов. С каждым понижением уровня в два раза (на 6 дБ) теряется один бит. И на уровне -48 дБ работает только восемь бит.

Примечание
При этом реальная точность преобразователей звуковых карт, как правило, ниже их разрешающей способности (разрядности).

Таким образом, для того, чтобы использовать весь 16-битный динамический диапазон, уровень записи должен превышать -6дБ.
Разрядность преобразования оценивается шумом квантования. Чем меньшим количеством разрядов представлен сигнал, тем больше искажение квантования. Негативный эффект от него воспринимается на слух как потеря звукового пространства стереосигнала или обедненный звук ("тусклый", "грязный" и т. п.).
О шуме квантования следует помнить на всех стадиях звуковой обработки, начиная с оцифровки аналогового сигнала. Без преувеличения можно сказать, что низкий уровень шума — это один из главных критериев качества любой звукозаписывающей системы — как цифровой, так и аналоговой.
В аналоговой магнитной звукозаписи используются широко известные компандерные (компрессор/экспандер) системы шумопонижения. Их основной принцип действия сводится к тому, чтобы сжать динамический диапазон перед записью на магнитную ленту, а затем расширить его при воспроизведении.
Цифровая звукозапись — новая ступень на лестнице технического прогресса. Но платой за нее являются шумы квантования, которые проявляются как специфическая деградация качества звука. Правда, бороться с ними можно — как и при аналоговой магнитной звукозаписи — с помощью компандерной технологии.
Так, например, для того, чтобы уменьшить искажения квантования в цифровых радиовещательных процессорах, на входе АЦП динамический диапазон сигнала сжимается на 20—40 дБ.

Примечание
Перед оцифровкой сигнал можно обработать лимитером или компрессором, т. к. реальные звуковые сигналы обладают большим пик-фактором (отношением пикового уровня к среднеквадратическому уровню RMS — root mean square). Но грубое вмешательство в динамику сигнала — не всегда хорошее решение. Поэтому на практике самым безопасным является простое уменьшение уровня записи на 15—20 дБ для того, чтобы создать запас по перегрузке, предотвратить отсечение сверху. Однако при 16-битном аналого-цифровом преобразовании произойдет заметная деградация качества из-за шума квантования ("отсечение снизу"). Для того чтобы сохранить качество, нужно либо применить 20—24-битные преобразователи, либо низкоуровневую компрессию, не искажающую динамику сигналов высокого уровня, которая и будет рассмотрена ниже.

В этом разделе мы рассмотрим билинейную аддитивную компандерную систему (рис. 1.107).

Примечание
Билинейная — сжатие осуществляется только в фиксированном диапазоне уровней. Аддитивная — основной сигнал суммируется с обработанным сигналом.

Рис. 1.107. Аддитивная система сжатия

Возможности виртуальной студии позволяют легко реализовать эту систему. Выберем билинейный компрессор аппаратный, а экспандер виртуальный. Если для аналогового сигнала мы применим низкоуровневое сжатие, то сигналы с уровнем ниже -40 дБ, 50 дБ получат дополнительное усиление. И будут, соответственно, оцифрованы с большей точностью. Затем полученный 16-битный звуковой файл мы должны преобразовать в 24—32-битный и применить к нему обработку виртуальным экспандером (plug-in) с комплиментарной амплитудной характеристикой для восстановления динамики. Этот обобщенный алгоритм позволяет частично обойти недостатки дешевого 16-битного преобразователя звуковой карты и более качественно оцифровать низкоуровневые сигналы.
Статические амплитудные характеристики компандерной системы приведены на рис. 1.108.

Рис. 1.108. Статическая характеристика компандера

Один из способов реализации экспандера в мультитрековой программе — это подключение DirectX-plug-in фирмы Sonic Foundry (http://www.sonicfoundry.com) Graphic Dynamics, т. к. он позволяет построить любой график амплитудной характеристики.
Plug-in Graphic Dynamics должен быть первым в цепочке plug-ins, подключенной до фейдера (Pre Fader). Тогда все условия обобщенного алгоритма компандирования будут соблюдаться автоматически, т. к. внутри виртуального микшера SAWStudioтранкейт исключен.


Запись в окне MultiTrack

Управление процессом записи в SAWStudio организовано просто и логично. Щелчок по любой кнопке МТ Record вызывает окно Record Meter и окно Record Remote Transport Window (рис. 1.109), которое мы будем в дальнейшем для краткости называть декой.

Оба окна можно закрыть повторным щелчком на кнопке МТ Record или кнопкой Close (отмечена стрелкой на рис. 1.109).

Рис. 1.109. Вызов окон Record Remote Transport Window и Record Meter

Окно Record Meter

Окно Record Meter содержит индикатор уровня записи такой же конструкции, как и канальный индикатор уровня. Слева от индикатора располагается информационное поле с названием трека. Поле Track (Track Zone) несет двойную нагрузку:

  • отображает номер трека;
  • позволяет изменить номер трека через список (для этого необходимо щелкнуть по этому полю).

Поле Input (Input Zone) служит для выбора источника записываемого сигнала на данный трек (рис. 1.110).
Щелчок по полю Input вызывает контекстное меню, состоящее из трех субменю:

  • Stereo Device — список стереоустройств или стереовходов. Его следует выбирать для записи в режиме стерео;
  • Mono Device — список моноустройств или моновходов. Он предназначен для записи только одного канала: правого или левого;
  • Stereo Channels — список каналов виртуальной консоли. Позволяет осуществлять запись через виртуальный Input-канал (включая обработку plug-ins), назначенный на физический стереовход аудиоустройства (см. разд. "Структура Input-канала" выше в этой главе).

Рис. 1.110. Выбор устройства для записи

Таким образом, надписи на рис. 1.109 в поле Track — Т-01 и в поле Input — D-01S означают, что на первый трек будет записываться сигнал со стереовхода устройства № 1

Предупреждение
Назначенные входы и каналы становятся недоступными в списках.

Пример конфигурации для параллельной двухканальной записи изображен на рис. 1.111.
Такое распределение входов обычной мультимедийной двухканальной звуковой карты обеспечивает одновременную "живую" запись двух исполнителей на разные треки.
Для параллельной многоканальной записи нужно нажать одновременно несколько кнопок МТ Record и назначить входы в соответствии с задачей и возможностями оборудования.

Совет
Из конфигурации соответствия назначенных входов и треков можно создать пользовательский шаблон записи. Для этого нужно щелкнуть по кнопке Close с нажатой клавишей <Ctrl>. Тогда комбинация <С1г1>+щелчок на любой кнопке МТ Record восстановит эту конфигурацию из шаблона. Шаблон может быть сохранен для использования в других проектах — в файл шаблона записи Record Template File (см. разд. "Форматы файлов SAWStudio" выше в этой главе).

Рис. 1.111. Конфигурация для параллельной двухканальной записи

Окно Record Remote Transport Window

Окно Record Remote Transport Window или дека служит для управления процессом записи. Перед тем, как перейти к самой записи, нажмем кнопку Setup. При этом появится окно МТ Record Setup (рис. 1.112).

Рис. 1.112. Окно МТ Record Setup

Окно МТ Record Setup содержит следующие элементы управления:

  • поле Rate предназначено для установки частоты дискретизации записываемого звукового файла. При изменении этого параметра частота дискретизации мультитрека устанавливается равной новому значению Rate;
  • поле Res нужно для задания разрядности звукового файла. Установленная разрядность не должна превышать возможностей звуковой карты. При изменении этого параметра разрядность мультитрека устанавливается равной новому значению Res;
  • поле Base существует для присвоения базового имени группы звуковых файлов при параллельной многоканальной записи. В этом же поле задается путь к звуковым файлам. По умолчанию базовое имя — это имя сессионного файла edl;
  • поля Mtr 01—Mtr 48 содержат имена звуковых файлов, состоящие из базового имени и номера трека. Имена и пути к звуковым файлам также могут быть изменены. Количество одновременно записываемых звуковых файлов определяется числом одновременно нажатых кнопок МТ Record и возможностями оборудования. На рис. 1.112 изображен случай двухканальной параллельной записи.

Теперь рассмотрим функциональное назначение кнопок деки:

  • — остановка записи, а также сброс режима Rec Ready (паузы). Дублируется клавишей <Пробел>. Повторное нажатие <Пробел> активизирует режим SRP;
  • — режим паузы, предназначенный для предварительной установки уровня записи;
  • — включение режима записи без прослушивания дорожек мультитрека. В этом режиме можно записывать самый первый трек проекта или производить параллельную многоканальную запись. Дублируется клавишей <Enter>;
  • — режим одновременной записи и воспроизведения (Simultaneous Record and Play или SRP). В этом режиме можно записывать, прослушивая остальные дорожки мультитрека. Основной режим для последовательной и комбинированной многоканальной записи. Дублируется клавишей <Пробел>, повторное нажатие активизирует режим STOP.

Предупреждение
Процесс записи начнется сразу после нажатия кнопки REC. Поэтому режим одновременной записи и воспроизведения записи нужно включать последовательным нажатием кнопок SRP и REC. Кнопку SRP можно использовать отдельно от кнопки REC — например, когда нужно установить уровень записи при прослушивании остальных треков.

Установка уровня записи

Уровень записи необходимо регулировать либо собственным микшером звуковой карты, либо внешним микшером.
Подбирая уровень, следует помнить, что его понижение на 6 дБ — всегда потеря одного разряда. Если же уровень записи превышает -6 дБ, то сигнал оцифровывается с максимальным разрешением.
Кроме этого, следует учитывать, что не должно быть превышения порога в 0 дБ. Индикатор уровня записи содержит еще и пиковый "светодиодный" индикатор, поэтому кратковременное превышение порога в 0 дБ легко обнаружить и провести необходимую корректировку уровня.

Запись дублей

Создание дублей — неотъемлемая часть творческого процесса. Для работы с ними на деке расположена специальная отдельная кнопка — Re Take. Нажатие этой кнопки вызывает контекстное меню, содержащее три команды.

  • ReTake To Last Record Position — удаляет последний записанный регион
    и позиционирует курсор мультитрека в точку последнего старта.
  • ReTake To Current MT Cursor Position — удаляет часть записанного региона, расположенную справа от текущей позиции курсора. С помощью этой команды можно удалить фрагмент дубля, предварительно сдвинув курсор влево.
  • ReTake All — удаляет все регионы, связанные с записываемым звуковым файлом, и очищает сам звуковой файл. Поэтому после применения этой команды можно начинать запись сначала.

Примечание
Напомним, что SAWStudio автоматически помечает регионы, записанные на мультитреке, символом @. Такие регионы легко восстанавливаются на "горячем" треке в оригинальной стартовой позиции нажатием комбинации клавиш <Shift>+<Insert>. Поэтому новые дубли можно смело перезаписывать поверх предыдущих.

Режим записи Punch

Режим вставки (Punch) часто используется при записи.
В SAWStudio (как и в SAWPro) он тоже "зашифрован": не имеет кнопки или
опознавательных знаков вроде маркеров Punch In и Punch Out.

Режим Punch имеет несколько вариантов.

  • Режим Punch on the Fly (на лету) — включение/выключение записи без остановки воспроизведения. В SAWStudio выполняется простым нажатием на кнопку REC с предварительно нажатой кнопкой SRP. Повторное нажатие кнопки SRP останавливает запись, не прерывая воспроизведения. Проще использовать клавишу <Enter>, каждое нажатие которой включает/выключает запись.

Совет
Если щелкнуть по кнопке SRP с нажатой клавишей <Shift>, то произойдет одновременная активизация режима записи и режима SRP (<Shift>+<Пробел>).

  • Режим Auto Punch (автоматический) — автоматическое включение/ выключение записи на заданном участке. В SAWStudio выполняется на выделенной области мультитрека (рис. 1.113).

Рис. 1.113. Режим Auto Punch

На дорожке мультитрека предварительно выделяется область и нажимается кнопка МТ Record, а затем с некоторым отступом начинается воспроизведение в режиме SRP (о выделении области см. в разд. "Манипуляции с дорожками мультитрека" ранее в этой главе). При пересечении курсором левой границы выделенной области запись автоматически включится и также автоматически выключится при пересечении правой границы.
Режим Auto Punch незаменим в ситуациях, когда нужно "вмонтировать" в удачный дубль лишь небольшой фрагмент.
Для этого нужно сначала выделить область, равную длительности того фрагмента, который требуется заменить. Затем в режиме Auto Punch произвести запись. (Для того чтобы исполнитель успел подстроиться к партии, воспроизведение начинается несколько раньше записи.) Запись автоматически точно включается при пересечении курсором выделенного фрагмента и выключается на его второй границе. В результате выделенный фрагмент заменяется новым вариантом с предельной точностью.
Рассмотрим этот метод записи на примере.

  1. 1. Выделим на объекте фрагмент.
  2. 2. Затем скорректируем границы выделенной области к ближайшим нулевым отсчетам. Эта операция необходима для устранения возможных щелчков в местах стыков. Привязка к нулевым отсчетам выполняется так:
      • левая граница — комбинация клавиш <Ctrl>+< [image] >, затем клавиша <В>
      • правая граница — комбинация <Ctrl>+< [image] >, затем клавиша <Е>.

    Примечание
    Привязка к нулевым отсчетам с помощью этих комбинаций клавиш происходит только в том случае, если предварительно отмечена опция Auto Zero Cross в меню Options. Если она не отмечена, то перед клавишами <В> и <Е> следует нажимать <Z>.

  3. 3. Вызовем деку кнопкой МТ Record и активизируем режим SRP.
  4. 4. По окончании записи остановим процесс клавишей <Пробел>.

Результат изображен на рис. 1.114.

Рис. 1.114. Пример записи в режиме Auto Punch


Недеструктивное редактирование

Главное преимущество недеструктивного редактирования заключается в том, что при нем не создаются физические копии звуковых файлов и не разрушается оригинал. При недеструктивном редактировании идет работа не с самими звуковыми файлами, а только со ссылками на них (регионами). В результате чего, во-первых, значительно экономится место на жестком диске, а во-вторых, сохраняется целостность оригинального материала.
Все операции этого вида редактирования сохраняются в виде последовательности команд, которая может быть экономично упакована в файл небольшого размера. Этот файл называется сессией и имеет в SAWStudio расширение edl.
Рассмотрим подробнее операции недеструктивного редактирования в окне MultiTrack.

Удаление выделенных объектов

Многие операции в SAWStudio реализованы значительно удобнее, чем в SAWPro.
Например, удаление с "горячей" дорожки выделенной области объекта или самих выделенных объектов (о выделении области на мулыпитреке см. в разд. "Манипуляции с дорожками мультитрека " выше в этой главе).
Делается это следующим образом.

  1. 1. На "горячей" дорожке выделяется область. Один из способов точного выделения объекта такой: нужно протащить курсор по дорожке Time Line с нажатой клавишей <Ctrl>.
  2. 2. Нажимается клавиша <Delete> или комбинации клавиш <Shift>+ +<Delete>, <Ctrl>+<Delete>:
    • <Delete> — удаляет объект или выделенный фрагмент (который может захватывать несколько объектов);
    • <Shift>+<Delete> — удаляет со сдвигом влево. После удаления те объекты, которые были захвачены выделенной областью, будут сдвинуты влево — до стыковки границ;
    • <Ctrl>+<Delete> — удаляет со сдвигом влево. Причем после удаления сдвигаются влево на длительность выделенной области все объекты "горячей" дорожки, расположенные правее выделенного фрагмента.

На рис. 1.115 наглядно изображены отличия действий этих операций для одинаковой группы объектов. Для наглядности названия треков содержат названия примененных комбинаций "горячих" клавиш. На 9-й дорожке отдельно изображена только выделенная область, равная по размеру тем, с которыми производились операции на верхних дорожках.

Рис. 1.115. Варианты удаления выделенной области объекта

Для удаления объектов можно использовать режим Select Mode. Он включается/выключается кнопкой [image] или клавишей <S>. А его активность отображается видоизмененным курсором мыши — [image].
При выделенной группе объектов принцип удаления объектов сохраняется. (Группу можно выделить, последовательно щелкая на выбранных объектах.)

Совет
Если после выделения группы был выполнен переход в режим Normal Mode, то комбинация клавиш <Shift>+<S> переведет мультитрек обратно в режим Select Mode с восстановлением последней выделенной группы.

Клавиша <Alt> ускоряет выделение объектов. Так, например, если щелкнуть по первому и последнему объектам группы при нажатой клавише <Alt>, то автоматически выделятся все объекты, расположенные между ними. Таким способом можно отмечать большую группу объектов, причем расположенных, например, по диагонали или на одной дорожке.
Еще один простой способ для выделения объектов — протащить по ним курсор [image] при нажатой левой кнопке мыши.
Снимается выделение так: со всех объектов — щелчком правой кнопки мыши или клавишей <С>, с конкретного объекта — щелчком на нем правой кнопкой мыши при нажатой клавише <Shift>.
Перечислим удобные комбинации "горячих" клавиш:

  • <End> — выделение всех объектов "горячей" дорожки: от последнего выделенного объекта до конца дорожки;
  • <Shift>+<End> — тоже выделяет объекты до конца "горячего" трека, начиная с выделенного, но команда распространяется только на объекты, пристыкованные друг к другу;
  • <Ctrl>+<End> — такое же выделение (от последнего выделенного объекта до конца дорожки), но действует на все дорожки вниз от "горячего" трека;

Примечание
Если вместо клавиши <End> использовать в этих комбинациях клавишу <Ноте>, то выделение будет происходить по тем же принципам, но в обратном порядке — от выделенного объекта к началу трека.

  • <Ctrl>+<A> — выделение всех объектов мультитрека.

Возможность запоминания групп выделенных объектов является дополнительным сервисом SAWStudio. Максимальное число групп — 30. Для доступа к контекстному меню групп нужно щелкнуть правой кнопкой мыши на интерфейсной кнопке [image].
Алгоритм создания групп полностью совпадает с группированием регионов или plug-ins.

Разрезание (splitting) объектов

Напомним, что любую операцию недеструктивного редактирования можно отменить комбинацией клавиш <Ctrl>+<<> или воспользоваться историей команд EDL Undo Hystory (см. разд. "Настройка максимального количества уровней отмены " выше в этой главе).
Эта сервисная возможность программы SAWStudio надежно защищает проект от любых ошибок.
Многие команды недеструктивного редактирования реализованы в SAWStudio в виде комбинаций "горячих" клавиш, т. к. это значительно ускоряет взаимодействие с программой. Поэтому для эффективной работы в SAWStudio их нужно просто выучить наизусть:

  • <К> — разрезание объекта (split) "горячей" дорожки по линии курсора мультитрека;
  • <Ctrl>+<K> — то же, но для всех дорожек: разрезание объектов всех дорожек;
  • <М> — разрезание объекта (split) "горячей" дорожки по линии курсора мультитрека с выделением части, расположенной слева от курсора. Требует режима Select Mode или комбинации клавиш <Shift>+<S> после разрезания;
  • <Ctrl>+<M> — то же, но для нескольких дорожек: разрезание объектов всех дорожек с выделением частей, расположенных слева от курсора;
  • <R> — разрезание объекта "горячей" дорожки с удалением части, расположенной левее курсора;

Рис. 1.116. Варианты операции split

  • <Ctrl>+<R> — то же самое для всех дорожек: разрезание объектов всех дорожек с удалением частей, расположенных слева от курсора;
  • <D> — разрезание объекта "горячей" дорожки с удалением части, расположенной левее курсора и со сдвигом влево на длительность этой части всех пристыкованных объектов, расположенных справа от курсора;
  • <Ctrl>+<D> — то же самое для всех дорожек мультитрека.

На рис. 1.116 наглядно проиллюстрированы действия команд, причем название трека отражает примененную команду.

Изменение границ объекта

Вариант недеструктивного изменения границ объекта в SAWStudio реализован так же, как и в SAWPro, за исключением того, что нажимается и удерживается клавиша <Alt>. Делается это так:

  1. Нажимается и удерживается клавиша <Alt>.
  2. Курсор мультитрека протаскивается левой кнопкой мыши от границы объекта по горизонтали (рис. 1.117).

Рис. 1.117. Изменение границ объекта

При этом если объект имеет копии на мультитреке, то автоматически создается новый регион.

Перемещение и копирование объектов

Эти наиболее часто применяемые операции могут быть выполнены в SAWStudio несколькими способами. Нужно отметить еще один плюс SAWStudio: теперь для реализации перемещения или копирования не нужно специально переходить в режим Select Mode, как это было в SAWPro. Доступ к ним возможен в нормальном режиме (Normal Mode) при отжатой кнопке Sel.
Операция перемещения индивидуального объекта (Moving) выполняется следующим образом:

  • Для смещения по горизонтали нажимается и удерживается клавиша <Shift>. Затем объект перетаскивается мышью строго по горизонтали, т. к. вертикальный сдвиг заблокирован (рис. 1.118).

Рис. 1.118. Перемещение объекта по горизонтали

  • В процессе сдвига тремя вертикальными линиями отображаются границы объекта и позиция курсора со смещением относительно начала объекта.
  • Перемещение по вертикали выполняется аналогично, только с нажатой клавишей <Ctrl>. При этом синхронизация перемещаемого объекта с остальными сохраняется.

Совет
Для свободного перемещения объекта достаточно отпустить клавишу <Shift> или <Ctrl> во время перетаскивания.

Частным случаем операции Move является сдвиг циклической группы объектов (Sequence Entry). Выполняется он так: точно выделяется циклическая группа объектов (с использованием клавиш <В>, <ТаЬ> и <Е>) и затем перетаскивается с нажатой клавишей <Shift> (рис. 1.119).

Рис. 1.119. Сдвиг циклической группы объектов

При перемещении объектов возможны две ситуации, когда объекты накладываются друг на друга (например, объект А на объект В).

  • Наложение с пересечением только одной границы. При этом объект А автоматически пристыкуется к границе объекта В.
  • Наложение с пересечением обеих границ. При этом программа выдаст предупреждающее сообщение. После утвердительного ответа накладываемый объект А будет врезан во второй объект В.

Предупреждение
Если размеры налагаемого объекта (А) превышают размеры того объекта, на который происходит наложение, то последний (В) удаляется.

Для применения операции сдвига к группе объектов следует перейти в режим Select Mode и выделить группу.

Совет
В режиме Select Mode курсор мультитрека блокируется, и его нельзя перетаскивать мышью. Для временного снятия блокировки следует нажать комбинацию клавиш <Ctrl>+<Shift>.

Копирование объектов выполняется точно так же, как и перемещение, за исключением небольшого отличия.
Рассмотрим детально копирование индивидуального объекта:

  1. Нажимаются и удерживаются клавиши <Shift> или <Ctrl>.
  2. Затем объект перетаскивается мышью.
  3. Перед отпусканием левой кнопки мыши (в течение перемещения) выполняется щелчок правой.

Предупреждение
Данный алгоритм копирования неприменим к выделенной в нормальном режиме циклической группе объектов. Для копирования групп следует применять режим Select Mode, где точно так же функционируют вышеописанные способы копирования и перемещения.

Копирование выделенной области

В SAWStudio предусмотрено достаточно много способов копирования. Рассмотрим, как копируется выделенная область объекта.

  1. Внутри объекта выделяется область (например, клавишами <В>, <Е>).
  2. Затем с нажатой клавишей <Alt> выполняется щелчок на выделенной области.
  3. Далее образ нового объекта перетаскивается в выбранную позицию и повторным щелчком фиксируется на дорожке (рис. 1.120).

Рис. 1.120. Копирование выделенной области

Привязка к тактовой сетке

В SAWStudio отсутствует режим жесткой привязки к таковой сетке (Snap to Grid). Поэтому для выравнивания и синхронизации объектов между собой нужно использовать вспомогательные средства. Синхронизация с тактовой сеткой особенно актуальна при музыкальном конструировании работы с готовыми циклическими фрагментами (Loops).
В SAWStudio формат измерения времени задается в меню TimeLine. Для музыкального конструирования наиболее приемлемым является режим Tempo Mode.
В этом режиме время измеряется в тактах, долях и тиках — в соответствии с интерфейсом MIDI.
Субменю Tempo Settings содержит специальные опции для настройки тактовой сетки:

  • Set Tempo — команда ввода с клавиатуры темпа сессии. Диапазон от 20,000 до 350,000 долей в минуту с точностью до тысячных;
  • Set Tempo To Marked Measures — вычисление темпа сессии по выделенной области. При этом в диалоговом окне будет предложено ввести предполагаемое количество музыкальных тактов, которое должно содержаться в выделенном фрагменте. Эта команда применима, например, в случае вычисления темпа сессии по длительности импортированного циклического фрагмента для удобства Loop-конструирования;
  • Set Time Signature — ввод музыкального размера. Размер вводится для всего мультитрека;
  • Set Tick Resolution — ввод количества тиков (минимальных длительностей MIDI) на четвертную ноту. Параметр Tick Resolution сессии должен соответствовать этому же параметру MIDI-секвенсора, если таковой используется совместно с SAWStudio.

По умолчанию тактовая сетка на дорожке TimeLine отсчитывается от начала мультитрека.
Иногда бывает нужно привязать начало сетки к конкретной точке, например, началу какого-нибудь объекта. Так как в SAWStudio не поддерживается изменение музыкального размера и темпа по точкам, то эта задача решается "в обход". Нужно сместить начало тактовой сетки. Например, если стартовая граница объекта совпадает с изменением размера и/или темпа, то можно привязать нулевую точку сетки к границе этого объекта и временно модифицировать размер и темп в субменю Tempo Settings, скажем, для правильного и комфортного монтажа композиции на конкретном участке.
Привязка начала тактовой сетки выполняется командой меню TimeLine | Set Zero Locate Point или комбинацией клавиш <Shift>+<Home>.
Сброс нулевой точки TimeLine к началу мультитрека выполняется командой TimeLine | Clear Zero Locate Point или комбинацией клавиш <Ctrl>+<Home>.

Совет
Комбинацию клавиш <Shift>+<Home> можно также использовать для временного ограничения мультитрека по горизонтали, т. к. клавиша <Ноте> будет возвращать курсор в новую нулевую точку.

Рассмотрим способы недеструктивного редактирования, обеспечивающие косвенную привязку к тактовой сетке. Данные команды выполняются в режиме Select Mode.

  • Перемещение объекта или группы объектов к курсору мультитрека (Snap to cursor) выполняется с помощью клавиши <Backspace>, при этом выделенный объект своей левой границей "прилипает" к курсору мультитрека на "горячей" дорожке.

Примечание
Объекты "движутся" и за курсором и за "горячей" дорожкой. Поэтому сдвиг "горячего" трека вызовет смещение объектов по вертикали.

  • Комбинация <Shift>+<Backspace> отличается тем, что объект "прилипает" к курсору своей правой границей.
  • Комбинация <Ctrl>+<Backspace> вместо сдвига выполняет копирование выделенного объекта (или группы объектов) к позиции курсора.
  • Комбинация <Ctrl>+<Shift>+<Backspace> создает копию объекта (или группы), которая "фиксируется" в позиции курсора своей правой границей.

Предупреждение
При сдвиге и копировании группы объектов имеет значение последовательность выделения. Команда выполняется относительно последнего выделенного объекта (Key Entry) в группе.

В SAWStudio некоторые операции имеют схожие функции. Помимо команд, рассмотренных выше, существует дополнительный набор полезных функций:

  • Snap and nudge — привязка по левой границе и "подталкивание" выделенного объекта или группы (в группе привязка объекта Key Entry). Выполняется клавишами < [image] > и < [image] > в режиме Select Mode. Шаг смещения при подталкивании (nudge) определяется масштабом по горизонтали.

Предупреждение
Команда nudge выполняется на "горячем" треке, поэтому при его сдвиге вверх или вниз повторение команды nudge вызовет смещение выделенных объектов по вертикали.

  • Snap and nudge — привязка по правой границе и "подталкивание" выделенного объекта или группы; выполняется этими же клавишами с нажатой клавишей <Shift>.

С помощью этих функций, изменяя масштаб по горизонтали, можно с большой точностью позиционировать объекты на мультитреке по тактовой сетке.


Свойства виртуального объекта

Раньше — в программах SAW предыдущего поколения — уровень виртуализации был существенно ниже, чем в SAWStudio. На этом фоне конкурирующая программа Samplitude фирмы Sekd выглядела выигрышнее.
Теперь же у объектов мультитрека в SAWStudio появились дополнительные параметры, доступ к которым осуществляется через меню свойств (МТ Entries Property Menu) (рис. 1.121).
Меню свойств объекта вызывается двумя способами:

  • Щелчок на объекте левой кнопкой мыши с удержанием, затем производится щелчок правой.
  • Щелчок правой кнопкой при нажатой клавише <Alt>.

В меню свойств можно производить простое виртуальное редактирование объекта по аналогии с редактором объектов программы Samplitude (см. главу 3), но со значительно меньшим количеством настроек.

Рис. 1.121. Меню свойств объекта

Совет
В режиме Select Mode можно установить одинаковые настройки для группы выделенных объектов.

Рассмотрим свойства объекта более детально.

"Гладкие" границы объекта SoftEdge

В верхней части меню свойств расположены два субменю: Set SoftEdge и Clear SoftEdge. Субменю Set SoftEdge содержит команды для "сглаживания" границ объектов (Soft Edge — гладкий край).
Рассмотрим субменю Set SoftEdge более подробно.

  • Start — установка длительности левой границы объекта в миллисекундах.
    Ввод значения осуществляется с клавиатуры в диалоговом окне Set Start SoftEdge Milliseconds. При этом новая "гладкая" граница объекта будет отображаться наклонной линией (рис. 1.122). Крутизна линии определяется параметром Start.
  • End — длительность правой границы объекта.
  • Both — установка симметричных "гладких" границ.
  • Start Splice — создание кроссфейда (crossfade) на стартовой границе объекта, если к нему слева пристыкован другой объект.
  • End Splice — то же самое для правой границы объекта.

Рис. 1.122. "Гладкая" граница объекта

  • Both Splices — создание кроссфейда с пристыкованными объектами на обеих границах (рис. 1.123).

Рис. 1.123. Симметричный кроссфейд

Примечание
"Гладкие" границы нужно использовать для объектов, чьи регионы меньше размера исходного wav-файла. Например, для получения эффекта Fade, объект с регионом, равным по длине исходному звуковому файлу, необходимо подрезать.

  • То Marked Area — установка "гладкой" границы по длине выделенной области (клавиша <Х>). Если выделенная область охватывает границу одиночного объекта, то образуется одна "гладкая" граница. Если выделенная область охватывает границу стыка двух объектов, то автоматически образуется кроссфейд (рис. 1.124).

Рис. 1.124. Автоматический кроссфейд на выделенной области

Субменю Clear SoftEdge позволяет выборочно отменить установки, сделанные с помощью команд субменю Set SoftEdge.

Совет
Линии SoftEdge можно сделать невидимыми, если отменить опцию SoftEdge Display в меню MultiTrack.

Смещение относительно стартовой границы объекта (Offset)

В некоторых случаях удобно выполнять команду Snap to cursor (см. разд. "Привязка к тактовой сетке" выше в этой главе) со смещением относительно стартовой границы объекта. Для этого в свойствах объекта предусмотрена специальная команда Set Offset To MT Mark-Beg Position. Перед ее вызовом необходимо на объекте выделить область. Смещение начала выделенной области (Mark Begin) относительно стартовой границы и есть параметр Offset.
Команда Jump To Offset перемещает курсор в точку смещения, а команда Clear Offset удаляет смещение.
После установки смещения объект можно переместить к курсору мультит-река комбинацией <Alt>+<Backspace> в режиме Select Mode.

Совет
Если установить смещение на последнем выделенном объекте (Key Entry) группы, то комбинация <Alt>+<Backspace> сдвинет группу к позиции курсора со смещением.

Reverse Audio

В SAWStudio воспроизведение звука в обратную сторону (Reverse) выполняется полностью виртуально (недеструктивно). Достаточно отметить опцию Reverse Audio в меню свойств, и объект будет проигрываться наоборот. Удобство данного способа трудно переоценить, т. к. это позволяет легко получать различные звуковые спецэффекты, которыми насыщена современная электронная музыка.
Самый простой способ — это скопировать выделенную область объекта на соседнюю дорожку и применить виртуальный реверс, а затем смешать их с автоматизированной обработкой реверсированного звука канальным эквалайзером (например, со сдвигом частоты одной выделенной полосы) и панорамированием.

Vari-Speed

Скорость воспроизведения объекта на мультитреке также является его виртуальным свойством. Это означает, что у каждого объекта на мультитреке может быть своя скорость воспроизведения.
Редактирование свойства Vari-Speed выражается в изменении длины объекта и появлении особой метки в левом верхнем углу объекта.

Примечание
Изменение скорости происходит одновременно с изменением высоты тона.

Настройки Vari-Speed сосредоточены в нижней секции меню свойств. Рассмотрим их более детально.

  • Set Vari-Speed (в процентах) — установка скорости в диапазоне от 50% до 200% от оригинальной.
  • Sweep Vari-Speed To Destination Value — плавное изменение скорости на выделенном фрагменте объекта в том же диапазоне от 50% до 200%.
    Эта команда позволяет выполнить виртуальное замедление или ускорение темпа при воспроизведении объекта. Выделенная область дробится на некоторое количество маленьких объектов, каждый из которых представляет собой дискретный шаг однопроцентного изменения скорости (рис. 1.125).

Рис. 1.125. Плавное изменение темпа

  • Set Vari-Pitch — установка высоты тона по полутонам от —12 до +12.
  • Sweep Van- Pitch To Destination Value — плавное изменение высоты тона на выделенном фрагменте объекта в том же диапазоне. Выполняется аналогично команде Sweep Vari-Speed To Destination Value.
  • Set Vari-Speed/Pitch To MT Mark-End Position — вычисление Vari-Speed/Pitch-фактора относительно правой границы выделенной области. Данная команда растягивает или сжимает объект таким образом, чтобы его правая граница совпала с границей Mark-End выделенной области.
    Например, можно подогнать по темпу два циклических объекта Drumloop. Для этого они должны быть расположены так, чтобы совпали их стартовые границы. Затем нужно выделить область, равную по длине образцовому объекту, и применить команду Set Vari-Speed/Pitch To MT Mark-End Position для второго объекта, после чего переместить и/или скопировать скорректированный объект в предназначенную для него позицию.

Примечание
Свойства объекта при копировании сохраняются.

  • Clear Vari-Speed/Pitch — сброс виртуальных настроек Vari-Speed/Pitch.


Многослойный мультитрек

Как уже отмечалось, все технологические возможности программы SAWStudio упакованы в лаконичный интерфейс. Поэтому при первом знакомстве с окном MultiTrack трудно догадаться о трехмерности мультитрека. Единственное, что "намекает" на эти возможности — цифра 1 в левом нижнем углу поля Track Label каждого трека.
Она означает, что по умолчанию на треке отображается первый слой. Общее количество слоев — 8. Таким образом, мультитрек SAWStudio представляет собой "восьмиэтажный дом".

Примечание
SAWStudio Lite имеет четырехсложный мультитрек.

Это огромное преимущество SAWStudio с точки зрения "живой" записи, т. к. нет ничего проще, чем разместить дубли на разных "этажах". Переходы между слоями могут быть выполнены в "горячем" режиме, например, при циклическом воспроизведении. Благодаря этому максимально облегчается выбор наилучшего дубля. Кроме того, из дублей, размещенных на семи слоях, можно смонтировать "идеальный" на восьмом слое.
Многослойность можно использовать просто для хранения вариантов сведения каждой дорожки мультитрека, поскольку автоматизация, так же, как и цифровой звук, записывается послойно.
В итоге SAWStudio позволяет хранить в одном сессионном файле большое количество вариантов одного проекта.

Примечание
Слои дорожек Input-трек содержат и автоматизацию, и объекты. А слои дорожек Return-трек и Output-трек — только автоматизацию.

Остановимся на этой технологической возможности программы подробнее.
На рисунке 1.126 отображено меню Track Properties, содержащее команды управления слоями.
Меню Track Properties вызывается щелчком правой кнопки мыши на поле Track Label.
На рис. 1.126 меню Track Properties вызвано для первой дорожки. Первый слой Layer 1 является активным (он отмечен "галочкой"). В поле Track Label отображается номер слоя — 1+. Плюс рядом с номером слоя означает, что на других слоях находятся аудиоданные. (Данные автоматизации знаком "плюс" не отображаются.) В меню Track Properties слой, содержащий информацию, отмечается символом < > напротив пунктов Layer I—Layer 8 (на рис. 1.126 используются два слоя).

Рис. 1.126. Меню Track Properties

В иерархии SAWStudio первый слой Layer 1 является самым верхним, а восьмой слой — самым нижним. В воспроизведении или записи участвует только активный слой.
"Горячие" клавиши <1>, <2> ... <8> осуществляют быстрый доступ к соответствующему слою "горячего" трека.
Рассмотрим меню Track Properties подробнее.

  • Set MT-Entry Texture — субменю для выбора текстуры объектов. Программой предлагается двадцать вариантов расцветки объектов. Выбор текстуры закрепляется за конкретной дорожкой. При перемещении на другую дорожку объект автоматически сменит текстуру. Для закрепления текстуры нужно отметить конкретное название текстуры:
    • если просто отметить название текстуры, то она будет принята только для одного слоя;
    • если ее отметить при нажатой клавише <Shift>, то ее действие распространится на все слои "горячего" трека;
    • для того чтобы одной текстурой отметить все активные слои, нужно выбрать ее в списке при нажатой клавише <Ctrl>;

Примечание
Этот способ применим в том случае, когда нужно одним цветом выделить вариант проекта, составленный из разных слоев.

    • для всех слоев всех треков, если отметить с комбинацией <Ctrl>+ +<Shift>.
  • Copy Track (Or Marked Area) To — копирование всех объектов трека или данных в выделенной области на другой слой.
  • Copy Selected MT-Entries To — копирование выделенных (в режиме Select Mode) объектов на другой слой.

Примечание
Команда применима для монтажа "идеального" дубля на отдельном слое.

  • Copy Texture To — копирование текстуры на другой слой.
  • Copy Marked Automation To — копирование выделенных данных автоматизации на другой слой.

Примечание
Необходимая команда для сохранения варианта сведения на другой слой.

  • Clear All MT-Entries On Current Layer — удаление всех объектов на активном слое.
  • Clear All MT-Entries On All Layers — удаление всех объектов на всех слоях "горячей" дорожки.
  • Clear All (Or Marked) SoftEdges On Current Layer — удаление всех (или выделенных) "гладких" границ объектов активного слоя.
  • Clear All (Or Marked) SoftEdges On All Layers — удаление всех (или выделенных) "гладких" границ объектов всех слоев "горячей" дорожки.
  • Slip Track To Cursor On Current Layer (Marked Area) — сдвигает объекты слоя (которые охвачены выделенной областью) к текущей позиции курсора. При этом стартовая граница выделенной области перемещается в позицию куреора мультитрека.
  • Slip Track To Cursor On All Layers (Marked Area) — та же операция, но применительно одновременно ко всем слоям.

Примечание
В связи с тем, что следующая группа команд связана с настройками канального эффекта Gate, мы изменим порядок их рассмотрения.

  • Set Defaults From HotChan Gate — фиксирование текущих параметров настройки эффекта Gate "горячего" канала в качестве настройки по умолчанию.

Примечание
Эта команда должна выполняться после настройки эффекта Gate — например, в случае подавления шумов в паузах. Настройки по умолчанию, созданные таким образом, будут использованы при операциях вырезания или маркирования (об этом будет рассказано позже).

  • Remove Silence From Track (Or Marked) - Automatic — автоматически определяет и затем удаляет те регионы "горячего" трека, у которых уровень сигнала ниже порога Gate (рис. 1.127). Если выделена область, то процедура удаления регионов выполняется только в ее границах.
    Данная операция использует настройки по умолчанию (Defaults From HotChan Gate).

Рис. 1.127. Процедура Remove Silence - Automatic

  • Remove Silence From Track (Or Marked) - Split/Mark — автоматически определяет регионы с низким уровнем, разрезает их и маркирует (рис. 1.128) в соответствии с настройками по умолчанию. При этом мультитрек автоматически переходит в режим Select Mode.

Рис. 1.128. Процедура Remove Silence - Split/Mark

Предупреждение
Если не выделена область, то обе операции выполняются от текущей позиции курсора мультитрека.

Совет
Диапазон применения обеих процедур можно расширить, если использовать выделение треков (см. разд. "Выделение треков" выше в этой главе).
Процедуру Remove Silence - Split/Mark можно использовать творчески, для получения специальных эффектов. Например, маркировать "тихие" регионы, а затем переместить (скопировать) их на другую дорожку и обработать plug-ins в сочетании с выборочным виртуальным реверсом.

Многослойная запись "живого" исполнения

В этом разделе мы познакомимся с многослойной технологией записи и последующего монтажа "идеального дубля". Рассмотрим самый простой пример.
Допустим, что на одной дорожке располагаются Drumloops, а на соседнюю дорожку необходимо записать, например, партию гитары. Для многослойной записи необходимо выполнить следующую последовательность действий:

  1. 1. Выделить на дорожке участок, равный длине записываемого фрагмента или превышающий ее (рис. 1.129).

      2. Рис. 1.129. Подготовка к многослойной записи

  2. 2. Нажать кнопку [image] (Автоперемотка).
  3. 3. Вызвать кнопкой REC окна Record Meter и Record Remote Transport Window (см. разд. "Запись в окне MultiTrack" выше в этой главе) и установить курсор мультитрека левее начала выделенной области (в стартовую позицию).
  4. 4. В окне Record Remote Transport Window нажать кнопку REC RDY и настроить уровень записи. После настройки уровня отменить режим паузы клавишей <Пробел>.
  5. 5. Включить запись клавишей <Пробел> (режим Autopunch). Запись будет производиться только на выделенном участке. После того как курсор пересечет правую границу выделенной области, на дорожке автоматически появится созданный объект, запись отключится, а режим воспроизведения останется активным.
  6. 6. Остановить воспроизведение клавишей <Пробел>. При этом курсор мультитрека автоматически вновь займет стартовую позицию.
  7. 7. Перейти на следующий слой соответствующей клавишей из диапазона <2> ... <7> (в данном примере предыдущий дубль записывался на первый слой).
  8. 8. Включить запись клавишей <Пробел>.

      Примечание
      В управлении процессом записи участвуют только клавиша <Пробел> и клавиши-номера слоев <1>, <2> ... <7>.

    9. Повторять два предыдущих пункта до седьмого слоя. Восьмой слой разумнее зарезервировать — оставить его для монтажа "идеального" дубля.

Следующий этап — прослушивание дублей. В том случае, если ни один из них не подходит полностью, то потребуется собрать из них один — окончательный вариант — и смонтировать его на восьмом слое.
Для прослушивания дублей необходимо включить режим циклического воспроизведения на выделенном фрагменте и переходить между слоями, не прерывая воспроизведения.
Для монтажа можно воспользоваться стандартными командами недеструктивного редактирования (разрезание, удаление и т. д.), рассмотренными в разд. "Недеструктивное редактирование", а также опциями меню Track Properties.
Кроме этого, существует метод, позволяющий ускорить редактирование дублей:

  1. 1. Выбрать первый слой и настроить порог канального эффекта Gate таким образом, чтобы он захватывал верхушки атак сигнала (рис. 1.130).
  2. 2. Применить команду Set Defaults From HotChan Gate из меню Track Properties для того, чтобы настройки Gate были приняты как установки по умолчанию.
  3. 3. Выполнить команду Remove Silence From Track (Or Marked) - Split/Mark из меню Track Properties. При этом исходный объект будет разрезан в местах атаки сигнала (рис. 1.131), а мультитрек автоматически перейдет в режим Select Mode.

Рис. 1.130. Настройка порога Gate

Рис. 1.131. Разрезание объекта Split/Mark

  1. 4. Для повышения точности может понадобиться подстройка времени атаки и спада эффекта Gate с последующим сохранением установок командой Set Defaults From HotChan Gate.
  2. 5. Выделить те объекты, которые "достойны" копирования на восьмой слой, и применить команду Copy Selected MT-Entries To из меню Track Properties с выбором опции Layer 8.
  3. 6. Повторить алгоритм для каждого слоя, содержащего дубли, с подстройкой при необходимости параметров Gate.

Примечание
Команда Copy Selected MT-Entries To может применяться неоднократно для одинаковых временных позиций фрагментов, т. к. она просто заменяет фрагмент с одного слоя на фрагмент с другого слоя. Если границы объектов "конфликтуют", то копируемый объект врезается поверх предыдущего.

В результате на восьмом слое окажется смонтированный "идеальный" дубль (рис. 1.132).

Рис. 1.132. Результат монтажа на восьмом слое

Совет
Паузы между объектами на восьмом слое можно легко устранить с помощью изменения границ (см, разд. "Изменение границ объекта" выше в этой главе).


Запись в окне SoundFile

Запись в окне SoundFile может использоваться в том случае, когда не требуется синхронизация с мультитреком. Например, можно записать материал, который в дальнейшем будет интегрирован в проект в виде снятых с него регионов.

Примечание
Связь между окнами SoundFile, Regions и MgltiTrack подробно рассматривалась в разд. "Описание интерфейса".

Таким образом, запись в окне SoundFile можно рассматривать как процесс создания собственного "строительного материала" композиции. Причем этот метод универсален. Он позволяет записывать "живое" исполнение или переносить в проект озвученные фрагменты из внешнего MIDI-секвенсора без синхронизации.
Если эти фрагменты представляют собой партии ударных инструментов или шумовые спецэффекты, то можно легко подогнать темп с помощью Vari-Speed (см. разд. "Van-Speed" выше в этой главе).
Управление процессом записи в окне SoundFile имеет некоторые отличия по сравнению с окном MultiTrack:

  • вызов записывающей деки осуществляется нажатием на единственную кнопку REC (рис. 1.133);

Рис. 1.133. Вызов записывающей деки в окне SoundFile

  • запись может производиться только в один звуковой файл (то есть невозможна многоканальная запись);
  • кнопка SRP заблокирована, т. к. в окне SoundFile невозможна одновременная запись и воспроизведение.

Буквы SF (SoundFile) в поле Track означают, что запись производится в окне SoundFile. В поле Input окна Record Meter осуществляется выбор источника сигнала так же, как и при записи на мультитреке.
Окно SoundFile очень удобно для создания коллекции собственных звуков. Особенно, если производить запись через виртуальный канал с обработкой эффектами DirectX и VST-plug-ins.
Для этой операции нужно вход виртуального канала (например, Channel 01) переназначить с мультитрека на физическое устройство (секция Input Source), а в поле Input окна Record Meter выбрать в качестве источника сигнала Chan 01.
Тогда появится возможность сэкономить время, т. к. обработка звука будет происходить одновременно с процессом записи.

Совет
Прослушать сигнал, обрабатываемый эффектами канала, можно в любое время. Для этого нужно просто включить воспроизведение на мультитреке. Но для этого на одной из дорожек должны находиться объекты. Лучше всего многократно размножить на треке один объект, и затем эту "дорожку для воспроизведения" приглушить, чтобы она не мешала при записи.

Рис. 1.134. Запись коллекции звуков

Предупреждение
Воспроизведение на мультитреке автоматически останавливается на правой границе самого последнего объекта.

Последовательно включая и останавливая запись, можно сформировать коллекцию звуков в одном звуковом файле. Сразу после остановки записанная область остается выделенной для создания региона клавишей <N> (рис. 1.134).


Импорт звуковых файлов в SAWStudio

В проект SAWStudio можно импортировать "посторонние" звуковые файлы. Например, файлы, обработанные в звуковом редакторе Sound Forge или Wave Lab.
При этом следует учитывать, что в SAWStudio нельзя импортировать файлы в формате с плавающей точкой 32bit Float, т. к. этот формат не поддерживается.
SAWStudio поддерживает целочисленные упакованные (Packed) и неупакованные (Unpacked) форматы звуковых файлов с разрядностью 20 и 24 бита, а также звуковые файлы с разрядностью 16 битов.
Импорт звуковых файлов осуществляется следующими командами меню File:

  • Add SoundFile To MT — импорт звукового файла непосредственно на "горячий" трек в текущую позицию курсора. При этом создается регион в списке Regions;
  • Add SoundFile As Region — импорт звукового файла в список регионов. Причем регион создается по всей длине звукового файла;

Примечание
Эти команды не загружают звуковой файл в окно SoundFile.

  • Open SoundFile — импорт звукового файла непосредственно в окно SoundFile. При этом не создается регион;
  • Open SoundFile And Add To MT — универсальная команда, импортирующая звуковой файл сразу в три окна: в позицию курсора на "горячий" трек в окно MultiTrack, в список Regions и в окно SoundFile;
  • Open SoundFile And Create Region — импорт в окно SoundFile с созданием региона длиной в файл;
  • Open SoundFile And Refresh — импорт в окно SoundFile с обновлением графического Beak-файла. Эта команда необходима в том случае, если звуковой файл, входящий в проект, был отредактирован в другой программе, т. к. каждая звуковая программа создает свой собственный Peak-файл.

Совет
После применения команды Open SoundFile And Refresh необходимо перезагрузить проект.


Сведение в SAWStudio

Сведением называется процесс смешивания сигналов нескольких источников (каналов) в фонограмму, соответствующую современному стандарту. Возможности SAWStudio позволяют производить сведение 72-х Input-каналов в 24 Output-канала. Практическая цель этой операции — получить фонограмму такого качества и формата, чтобы ее можно было тиражировать на коммерческом носителе.
До последнего времени лидером аудионосителей был AUDIO CD с двухканальным стерео. Двадцать первый век привел к трону новых кумиров цифрового аудио: DVD-Audio и SACD (Super Audio CD).
И сегодня современная музыка требует расширения границ — она завоевывает новые многоканальные просторы.

Примечание
О работе SAWStudio с многоканальным звуком будет рассказано в разд. "Surround в SAWStudio".

Но заслуженный лидер — AUDIO CD — свои позиции еще не сдает. Вполне возможно, он станет таким же долгожителем, как и его "старшая подруга" — аудиокассета. Поэтому уделим ему достаточное внимание в этом разделе и расскажем о сведении самой распространенной в наши дни двухканальной фонограммы.


Автоматизация

В предыдущих разделах мультитрек рассматривался в двух режимах: Normal Mode и Select Mode.
Напомним, что в этих режимах те изменения в секциях виртуальной консоли (Fader, Pan, EQ и т. д.), которые были сделаны последними, автоматически действовали на весь трек — независимо от позиции курсора. Иначе говоря, они становились настройками по умолчанию.
Если где-то на мультитреке была сделана установка (например, регулятора громкости канала в позицию -12 дБ), то она действовала на весь трек. Это способ неавтоматизированной регулировки (non-automated).
Для того чтобы пояснить возможности автоматизации, проведем образную параллель. Представим, что дорожки — это музыкальные партии, а данные автоматизации на них — это приложение к партиям в виде указаний к исполнению.
При неавтоматизированной регулировке оттенки исполнения партии не будут меняться. И музыка будет исполнена в соответствии с первым (и единственным) указанием.
Запись автоматизации позволяет менять оттенки исполнения как угодно часто и в любой последовательности.
Таким образом, возвращаясь к сведению, можно классифицировать процесс микширования как статический и динамический.
Статическое микширование, с однократным созданием баланса между каналами, предполагает, что при сведении многоканальной фонограммы все необходимые параметры виртуальной консоли настраиваются за один раз, и после этого они никак не изменяются. Такой способ может применяться только при сведении "гипермонотонного" продукта, реанимировать который уже все равно не удастся.
Если в произведении есть музыка — присутствует картина композиции, которая разворачивается при исполнении, используются разнообразные оттенки фразировки для передачи музыкальных образов, то такое произведение заслуживает качественной звукорежиссуры.
Ведь сведение очень похоже на работу дирижера. И талант людей в этих важных областях творческой деятельности способен, во-первых, выявить те скрытые, на первый взгляд, нюансы, оттенки художественного образа, а во-вторых, ювелирно огранить сверкающий алмаз музыки, заключить его в дорогую оправу "звуковой трактовки".
Автоматизацию динамического микширования в работе компьютерного звукорежиссера трудно переоценить. Ведь она предполагает последовательное и многоразовое изменение параметров консоли, которое фиксируется программой во времени.
Как известно, при всей схожести виртуальных пультов с "железными", у них есть одно существенное отличие. Компьютерный музыкант может дотронуться до виртуальных элементов управления только одной "рукой" — курсором мыши.
Но ведь даже один Input-канал содержит много элементов управления, регулировать которые курсором мыши раздельно в режиме реального времени невозможно. Более того, даже в том случае, если подключить к SAWStudio микшер-контроллер, то и это не отменит необходимости автоматизации.
Главное преимущество автоматизации заключается в том, что с ее помощью можно выполнять динамическое микширование последовательно, в несколько проходов. При этом можно создавать сложнейшие варианты сведения, изменять их при необходимости, манипулируя ручками управления в любой последовательности, и при этом быть уверенным, что все звукорежиссерские указания будут надежно зафиксированы программой SAWStudio.


Automation Entry

Перевод мультитрека в режим Automation Mode выполняется нажатием кнопки Aut [image] или клавиши <А>.
В этом режиме текстура объектов темнеет для того, чтобы было удобнее редактировать данные автоматизации, отображаемые яркими цветами.

Примечание
В SAWStudio данные автоматизации обозначаются тем же термином Entry (запись), что и аудиообъект. В программе Nuendo аналогичное понятие обозначается как Event point. Поэтому в дальнейшем во избежание путаницы термин Automation Entry будет переводиться на русский язык как точка автоматизации.

Рассмотрим более детально понятие точка автоматизации. Для этого в режиме Automation Mode в реальном времени запишем автоматизацию регулятора громкости и увеличим горизонтальный масштаб (рис. 1.135).

Рис. 1.135. Данные автоматизации

На рис. 1.135 хорошо видно, что "живая" запись изменения громкости представляет собой последовательность наклонных отрезков. Нижняя точка каждого отрезка и есть точка автоматизации. Верхняя точка — фактическое значение регулируемого параметра. Линия, образованная верхними точками отрезков, представляет собой кривую автоматизации. Фактически кривая автоматизации состоит из сегментов. Сегмент образуется двумя соседними верхними точками отрезков. Внутри сегмента параметр не изменяется. Между сегментами параметр изменяется скачкообразно (дискретно).

Примечание
Напомним, что минимальный шаг изменения громкости — 0,25 дБ.

Перед разработчиками SAWStudio стояла задача обеспечения плавности дискретного регулирования, которая решена с помощью компромисса — в линейном сглаживании. Степень сглаживания определяется наклоном отрезка.
В режиме воспроизведения при пересечении курсором нижней точки отрезка (точки автоматизации) быстро отреагирует только элемент управления виртуальной консоли. Фактическое изменение параметра определяется наклоном отрезка и может быть сильно сглажено по линейному закону.

Примечание
Регулирование параметра завершается при достижении курсором мультитрека верхней точки отрезка.

Степень сглаживания определяется специальным параметром Slope (наклон).
Если задать значение Slope равным нулю (отсутствие наклона), то при регулировании громкости непрерывного сигнала (например, синусоидального) будут отчетливо прослушиваться щелчки.
Для настройки параметра Slope в меню Automation предусмотрены отдельные пункты:

  • Set Default Mute Slope — установка по умолчанию для режима приглушения Mute. Значение 0 мсек вызовет хорошо различимые на слух щелчки, поэтому для "мягкого" приглушения следует использовать большие величины;
  • Set Default Fader Slope — установка по умолчанию для регулятора громкости. Диапазон значений от 20 до 40 мсек вполне подойдет для большинства случаев, однако в SAWStudio заложен больший диапазон — от 0 до 2083 мсек;

Совет
При сведении партий, исполненных большими по длительности звуками (например, аккорды музыкального фона), можно увеличить параметр Slope до 100 мсек для уменьшения искажений.

  • Set Default Pan Slope — установка по умолчанию для регулятора панорамы;
  • Change Marked Automation Slope — изменение наклона отрезков автоматизации на выделенной области. Дублируется клавишей </> на дополнительной клавиатуре. Комбинация <Ctrl>+</> устанавливает новое значение для всех треков на выделенной области.

Команда Change Marked Automation Slope должна использоваться наиболее часто, т. к. установки по умолчанию не могут быть универсальными для всех случаев.


Запись автоматизации

Запись автоматизированных данных можно производить в двух режимах.

  • В режиме реального времени в процессе воспроизведения (так называемое "живое" сведение).
  • В пошаговом режиме (программирование виртуальной консоли по точкам).

Перед началом записи автоматизации нужно перевести мультитрек в режим Automation Mode (клавиша <А>). Как только это будет сделано, все регулировки (произведенные автоматизируемыми элементами управления виртуальной консоли) будут фиксироваться как данные автоматизации.

Примечание
Данные автоматизации всегда записываются на "горячий" трек.

Программный движок SAWStudio уникален. Он обеспечивает кратчайшее время реакции консоли — даже с драйверами звуковой карты стандарта Windows MultiMedia. Благодаря этому при записи автоматизации в реальном времени с виртуальной консолью можно работать точно так же, как и с аппаратным микшером.
Пошаговая запись выполняется в режиме STOP. Ее название выражает смысл такого способа — запись автоматизации происходит по шагам. Причем потенциальной точкой автоматизации может стать любая позиция курсора мультитрека. Более того, в ней можно один за другим скорректировать мышью несколько значений элементов управления консоли. Тогда при воспроизведении этого фрагмента настройки автоматизации начнут действовать. Это произойдет синхронно — при пересечении курсором точек автоматизации.
Пошаговая запись используется также и для редактирования точек автоматизации (об этом подробнее в разд. "Редактирование автоматизированных данных").

Предупреждение
При выходе из режима Automation Mode чтение данных автоматизации не пре кращается. Поэтому для остановки чтения данных автоматизации необходимо удалить точки автоматизации.


Редактирование автоматизированных данных

Микширование, сделанное в режиме реального времени, не всегда может сразу оказаться удачным. Для его корректировки в SAWStudio заложена возможность редактирования данных автоматизации.

Перемещение по точкам автоматизации

Для исправления автоматизации нужно встать на точку "горячего" трека, которая требует корректировки настроек. Точное перемещение по точкам автоматизации выполняется комбинациями клавиш:

  • <Ctrl>+<Tab> — движение вправо;
  • <Ctrl>+<Shift>+<Tab> — движение влево.

После того как точка найдена, достаточно просто изменить мышью требуемый параметр. Делается это с помощью соответствующего элемента управления виртуальной консоли.

Совет
Подобное точечное редактирование часто оказывается гораздо эффективнее, чем перезапись дублей автоматизации.

Удаление точек автоматизации

Удаление автоматизированных данных выполняется несколькими способами.

  • Команда Clear All Entries On Track(s) в меню Automation стирает все точки автоматизации на "горячем" треке или на всех выделенных треках.
    Вызов этой команды с нажатой клавишей <Ctrl> удаляет все данные автоматизации на мультитреке.

Примечание
Команда Clear All Entries On Track(s) выполняется через диалоговое окно Warning, поэтому случайное удаление автоматизации исключено. Если же произошло незапланированное удаление материала автоматизации, то всегда можно его вернуть, воспользовавшись историей отмен.

  • Клавиша <Delete> стирает все точки автоматизации в выделенной области "горячего" трека или всех выделенных треков.
    Комбинация <Ctrl>+<Delete> удаляет все автоматизированные данные в выделенной области со всех дорожек мультитрека (рис. 1.136).

Совет
В зависимости от положения курсора, точное выделение области с точками автоматизации можно выполнить двумя способами. Если курсор установлен до первой точки автоматизации, то комбинацией клавиш <Ctrl>+<Tab>, затем <В>. Если курсор установлен после последней точки автоматизации, то комбинацией <Ctrl>+<Shift>+<Tab>, затем <Е>. Опция Auto Zero Cross в меню Options должна быть отменена.

Рис. 1.136. Удаление автоматизированных данных в выделенной области

Фильтрация точек автоматизации

Фильтрация точек автоматизации необходима, т. к. на экране все типы точек представлены сразу — они накладываются друг на друга (рис. 1.136).
Раздельно их редактировать довольно сложно, даже несмотря на то, что они разного цвета (например, точки канального эквалайзера — красные, а динамического процессора — синие).
В SAWStudio для таких случаев существует фильтрация точек автоматизации по типам. Причем в традициях "скромной" программы эта функция не демонстрируется и поддерживается только "горячей" клавишей <V>.
Каждое нажатие на клавишу <V> включает/выключает фильтр. Фильтрация точек автоматизации подчиняется следующим правилам:

  • если курсор установлен точно в точку автоматизации, то на экране остается именно этот тип данных. (Перемещение по точкам — клавиши <Ctrl>+<Tab>, <Ctrl>+<Shift>+<Tab>);
  • если курсор не находится в точке автоматизации, то на экране остаются данные того типа автоматизации, точка которого была расположена перед позицией курсора (ближе всех к нему).

Предупреждение
При включенном фильтре операции редактирования распространяются только на отфильтрованные точки автоматизации (находящиеся в выделенной области).

Рис. 1.137. Фильтрация точек автоматизации

Нажатие на клавишу <V> сделает невидимыми наклонные отрезки (автоматизация громкости), изображенные на рис. 1.137, т. к. курсор установлен в позицию после вертикального отрезка (автоматизация панорамы).

Растяжение и сжатие автоматизированных данных

Предположим, что объект был недеструктивно растянут или сжат командой Set Vari-Speed. В этом случае возникает потребность вновь синхронизировать его аудиоданные с точками автоматизации. Проще говоря, привести в соответствие звучание и настройки.
Для этого, рассуждая логично, нужно соответствующим образом растянуть или сжать кривую точек автоматизации. Делается это просто.

  1. Выделяется область, охватывающая все необходимые данные автоматизации.
  2. Перемещается на новое место граница выделенной области (ее нужно протащить мышью с нажатой клавишей <Alt>) (рис. 1.138).

Рис. 1.138. Растяжение данных автоматизации

Перемещение и копирование автоматизированных данных

Операции с точками автоматизации, находящимися внутри выделенной области, точно такие же, как и с выделенными объектами: их перемещение и копирование ничем не отличаются.
Если с помощью фильтра (клавиша <V>) вычленить нужный тип данных, то производить эти операции становится очень удобно.
Для того чтобы переместить/скопировать данные автоматизации, существует несколько способов.

  • Перемещение:
    • перетащить выделенную область по горизонтали с нажатой клавишей <Shift>;
    • перетащить выделенную область по вертикали с нажатой клавишей <Ctrl>;
    • привязать стартовую границу выделенной области с данными автоматизации (Snap to cursor) к текущей позиции курсора мультитрека клавишей <Backspace>.
  • Копирование:
    • перетащить по горизонтали (по вертикали) с нажатой клавишей <Shift> (<Ctrl>), при этом во время перетаскивания, не отпуская левой кнопки мыши, произвести щелчок правой;
    • скопировать выделенную область с данными автоматизации на другой слой командой Copy Marked Automation To в меню Track Properties;
    • скопировать выделенную область данных автоматизации с привязкой стартовой границы (Snap to cursor) к текущей позиции курсора мультитрека комбинацией <Ctrl>+<Backspace> (рис. 1.139).

Рис. 1.139. Копирование с привязкой к курсору

  • "Подталкивание" (nudge) выделенной области производится клавишами < [image] > и < [image] >.

Функции постепенного изменения (Fade)

Распространенная задача звукорежиссера — плавное изменение параметров при сведении. Это может относиться к разным видам операций. Например:

  • постепенно увести один канал (Fade Out или Fade Down), выводя при этом другой (Fade In или Fade Up);
  • плавно изменить параметр между двумя точками автоматизации;
  • постепенно изменять частоту параметрического эквалайзера, панораму и т. д.

Качественное выполнение всех видов подобных операций требует не только определенного навыка, но и, как правило, времени для выполнения этой "ручной работы".
В SAWStudio благодаря тому, что график плавного изменения параметра может быть вычислен программно, рутинные операции сведения могут быть автоматизированы.
Программа сама строит кривую автоматизации плавного изменения параметра по исходным данным, заданным пользователем. Для его создания предназначены две команды меню Automation (их результат зависит от установок, описанных ниже):

  • Fade Dn/Up To Next Automation Change — постепенно изменяет (уменьшает или увеличивает) громкость к следующей точке автоматизации на "горячем" треке (клавиша <F>);
  • Fade Up To Next Automation Change — постепенно увеличивает громкость к следующей точке автоматизации на "горячем" треке (комбинация клавиш <Shift>+<F>).

Примечание
Обе команды используют значение Slope, установленное по умолчанию.

Результат выполнения этих команд зависит от того, какие им предшествуют исходные данные.
Если на треке вообще отсутствовали точки автоматизации громкости, то команда Fade Dn/Up To Next Automation Change будет выполнена между двумя крайними значениями: "0 дБ" (значение громкости по умолчанию) и "inf (тишина). Причем длительность процесса Fade в этом случае — 2 с (рис. 1.140), а первая точка автоматизации будет находиться в текущей позиции курсора.
Команда Fade Up To Next Automation Change (Fade In) действует в этом случае в обратной последовательности: от "inf" к "0 дБ".

Рис. 1.140. Fade Down (Out), Fade Up (In) по умолчанию

Если к моменту применения команд на дорожке были точки автоматизации, то команды Fade Dn/Up To Next Automation Change и Fade Up To Next Automation Change выполняются вправо от текущей позиции курсора — к ближайшей точке автоматизации. Рассмотрим рисунок 1.141.

Рис. 1.141. Различия между результатами выполнения команд Fade Dn/Up To Next Automation Change и Fade Up To Next Automation Change

Для наглядности на рис. 1.141 названия крайних дорожек соответствуют примененным командам: трек Fade Dn/Up — команде Fade Dn/Up To Next Automation Change, а трек Fade Up — команде Fade Up To Next Automation Change (трек Fade Up)). Средняя дорожка (A-n Entries сокращенно от Automation Entries) — содержит исходные точки автоматизации и номера примеров.

Пример 1. Результаты действия обеих команд (на верхней и нижней дорожках) совпали. Это произошло потому, что вторая точка автоматизации больше по величине.

Примечание
В качестве стартовой величины принято значение громкости первой точки автоматизации (последней относительно текущей позиции курсора).

Пример 2. Здесь результаты различны, т. к. громкость в первой точке больше. Поэтому одна команда выполнила плавное уменьшение, а вторая проигнорировала уровень громкости первой точки и в качестве стартового приняла уровень тишины — "inf.

Пример 3. Теперь текущая позиция курсора совпала с позицией первой точки автоматизации.

Если на треке есть выделенная область, то обе команды на всю ее длину рассчитывают кривую плавного изменения (рис. 1.142).

Рис. 1.142. Результаты выполнения команд Fade Dn/Up To Next Automation Change и Fade Up To Next Automation Change на выделенной области

Совет
Если использовать фильтр (клавиша <V>), то команду Fade Dn/Up To Next Automation Change можно с успехом применять и к другим типам автоматизированных данных.

Шаблоны автоматизации

К программе SAWStudio поставляется библиотека стандартных шаблонов автоматизации. Если успешно созданную кривую регулирования предполагается использовать в других проектах, ее тоже можно сохранить в виде шаблона — в отдельном файле с расширением aut.
Файлы стандартных шаблонов располагаются в папке Mix, которая находится в папке SAWStudio. Для доступа к ним в программе существует специальное окно Automation Gallery. Чтобы его увидеть, нужно выбрать одноименный пункт меню View.

Совет
Для удобства пользования окно Automation Gallery следует включить в состав хотя бы одного рабочего экрана, закрепленного за функциональной клавишей.

Окно Automation Gallery устроено просто (рис. 1.143). Оно состоит из двух секций. В левой расположен список шаблонов, в правой — графическое изображение кривой автоматизации выделенного в списке шаблона.
Кнопка Insert То МТ или клавиша <Insert> переносит выделенный в списке шаблон на "горячий" трек. При этом стартовая точка автоматизации устанавливается в текущую позицию курсора.

Предупреждение
Перед использованием "горячей" клавиши <lnsert> окно Automation Gallery следует сделать активным, щелкнув в нем мышью.

Рис. 1.143. Окно Automation Gallery

Если перед операцией переноса выделить на дорожке мультитрека область, то линия автоматизации изменится в соответствии с размерами этой области: будет растянута или сжата (см. рис. 1.143).

Совет
В одну и ту же выделенную область можно последовательно переносить несколько шаблонов автоматизации, например, громкости и панорамы.

Загрузка шаблонов выполняется следующим образом. Сначала в окне Automation Gallery нужно нажать кнопку File, затем в открывшемся меню выбрать пункт Open Directory Of Automation Files. После этого в диалоговом окне Select Automation Gallery Folder следует выбрать папку с файлами aut.
Для создания собственного шаблона необходимо точно выделить область, охватывающую точки автоматизации, нажать кнопку File и воспользоваться командой Save Automation File. Команда Clear Gallery Window полностью очищает список пресетов.

Режим Offset Mode

Несколько раньше мы отмечали, что микширование можно условно разделить на два вида: статическое и динамическое. На практике они комбинируются.
Так, например, после установки первоначального баланса уровней каналов и записи автоматизации динамического микширования может обнаружиться, что всю кривую регулирования нужно немного сместить по шкале регулируемого параметра. В этом случае ее проще подвинуть, чем записывать новый дубль.
Для такой операции здесь есть режим смещения — Offset Mode. Он вызывается кнопкой [image] (Ofst) в окне MultiTrack (или клавишей <О>).
Если этот режим включен, то любое изменение автоматизированного параметра воспринимается программой как смещение. Причем, если выделена область, то смещение затронет только выделенные точки автоматизации (рис. 1.144).

Примечание
В режиме Offset Mode запись автоматизации блокируется. Перед применением комбинаций "горячих" клавиш нужно сделать активным окно MultiTrack.

Рис. 1.144. Смещение в режиме Offset Mode на выделенной области

При выходе из режима Offset Mode (щелчок левой кнопки мыши на кнопке Ofst или нажатие клавиши <О>) все выполненные смещения будут приняты.
Отменить все смещения с сохранением предыдущего варианта автоматизации можно щелчком правой кнопки мыши или комбинацией клавиш <Ctrl>+<O>.
Вариант этого режима — относительное смещение (Relative Offset Mode), комбинация <Shift>+<O> или щелчок по кнопке Ofst с нажатой клавишей <Shift>. В нем все регуляторы панорамы устанавливаются в центральное положение, регуляторы уровня — в 0 дБ, а переключатели (кнопки) — в положение "выключено" (off).
В этом режиме любая регулировка смещения будет производиться относительно центрального (нулевого) положения. При выходе из режима Relative Offset Mode все значения относительного смещения также будут приняты.


Сведение в файл

Как известно, профессиональная запись — удовольствие недешевое. В студии тиканье часов отсчитывает монеты. А сведение является процессом творческим. И оно также невозможно в суете, как и медитация при работе на конвейере.
Если музыканты поставлены в положение цейтнота, нервничают, торопятся, раздражаются, то все это неизбежно сказывается на результате.

Примечание
Нам знакомы печальные эпизоды, когда прекрасная музыка была в прямом смысле слова загублена, т. к. музыканты были вынуждены самостоятельно свести сложнейший джазовый альбом в арендованной студии в день записи.

К сожалению, нередко долгий и многотрудный путь к заветному CD заканчивается печально — затраты огромны (творческие и материальные), а качества нет.
Как показывает практика, домашняя студия на базе PC — это новое решение для музыкантов. В разных областях известны шедевры ручной работы, сделанные с любовью, которые много раз ценнее "заводской штамповки". Если сводить собственную музыку в спокойной обстановке, не ограничивая себя во времени, без надзора "равнодушных ушей", то результат может превысить самые смелые ожидания.
Задача этой книги — рассказать о возможностях виртуальных технологий, реализованных в трех программных продуктах.
О звукорежиссуре здесь говорится пунктиром — только в связи с демонстрацией возможностей виртуальных технологий. Тонкостям режиссирования звука, так же, как и исполнительскому мастерству, нельзя научить только с помощью слова. Передача практических знаний в этих областях должна происходить от мастера к ученику непосредственно — на практических примерах. Поэтому мы не считаем нужным перегружать читателей "сводом правил звукорежиссера", тем более что звукорежиссура — это такое же призвание, как кино, театр, спорт и т. д. Знания здесь приносят пользу только в сплаве с талантом и трудолюбием.
Читателей, чувствующих в себе призвание и интересующихся вопросами звукорежиссуры глубже, адресуем к специальной литературе.
В этом разделе будет уделено внимание только практической информации.
Название раздела — "Сведение в файл" — отражает основной способ, применяемый в виртуальной студии.

Примечание
Описание способа сведения через внешний микшерный пульт (аналоговый или цифровой) на мастер-магнитофон выходит за рамки книги.

Сведение в файл выполняется в SAWStudio программно. Это означает, что компьютер с математической точностью пересчитывает весь виртуальный проект в звуковой файл или группу файлов (для многоканального звука). При этом действует принцип "что слышится, то и сводится", т. е. звучание проекта до сведения ничем не отличается от звучания вычисленного финального звукового файла.


Практические приемы сведения в SAWStudio

Обозначим некоторые важные моменты сведения в SAWStudio, на которые начинающим компьютерным музыкантам стоит обратить внимание.
Для начала следует позаботиться о качественном акустическом контроле. Это крайне важный момент. Нельзя художнику, создающему картину, смотреть на нее все время через грязное стекло.

Примечание
Инженерные представления об измерении звучания музыки только лишь с помощью анализаторов спектра, осциллографов и прочих приборов недопустимы, т. к. сведение — это еще и область психоакустики и искусства. Единственным и лучшим измерительным прибором является человеческое ухо.

Колонки музыкального центра могут быть только дополнительными средствами контроля. На них нельзя услышать большинство нюансов и дефектов. Нужно понимать, что экономия на студийных мониторах может полностью перечеркнуть смысл работы со звуком.

Примечание
Для начинающих можно посоветовать наушники-мониторы, например AKG К141 Monitor. Этот совет не относится к использованию их напрямую с дешевыми микшерными пультами. Поэтому лучше подключать выход звуковой карты непосредственно к линейному входу музыкального центра или усилителя, а AKG К141 Monitor в выход для наушников. При этом на музыкальном центре должны быть отключены (или установлены в линию) всевозможные эквалайзеры, T-Bass, X-Bass и т. д. А на усилителе должны быть отключены (или установлены в линию) регуляторы тембра и отключена тон-компенсация (которая при понижении громкости повышает уровень низкочастотных составляющих).

Перед началом сведения можно "потренировать ухо" — недолгое время послушать фирменный AUDIO CD хорошего качества с музыкой этого или близкого направления на том уровне громкости, который позволит различать все нюансы сведения.
Нужно учитывать некоторые моменты. Во-первых, AUDIO CD звучит, как правило, громче из-за звуковой обработки, примененной к нему в стадии премастеринга. Во-вторых, звуковое давление громкостью более чем 80 дБ SPL (sound pressure level) в течение 30—40 мин может вызвать утомление слуха, что сделает дальнейшее качественное сведение без восстановительного перерыва невозможным.
Если для мониторинга используется 16-битная звуковая карта, то может потребоваться дизеринг (сглаживание полутонов). Это связано с тем, что SAWStudio работает на более высоком внутреннем разрешении. Решение о его включении принимается на слух. При ощущении, что звук "острый", "железный" или "цифровой", дизеринг следует включить.
Дизеринг мультитрека включается выбором команды MultiTrack | Dither | On-Type1. Некоторые звуковые карты используют внутренний дизеринг, который выполняется аппаратно или программно на уровне драйвера.
Не рекомендуется приступать к сведению непосредственно после записи, т. к. утомленный слух способен значительно снизить конечный результат. Поэтому следует сделать перерыв, размер которого определяется индивидуальными психофизиологическими особенностями.
Нужно помнить, что при сведении идет работа с конкретным материалом, а не с какой-то абстрактной музыкой, подчиняющейся общемировым правилам. Поэтому в реальной жизни сведение — это еще и искусство компромисса. Профессионалы рекомендуют избавиться от предвзятых представлений о том, как должен звучать микс, и начать работать с тем, что есть в действительности. Ненужно стараться достать из вашего проекта то, что в него не заложено. Необходимо выявить его особенности и на них выстроить концепцию звучания, подчиненную главной музыкальной идее.
Сведение — это работа с готовым материалом. Но иногда именно при сведении обнаруживаются ошибки, допущенные на предыдущих этапах (фальшивые ноты, несоответствие отдельной партии общей идее произведения и т. п.). Поэтому нужно быть готовым к тому, что может потребоваться "хирургическое вмешательство" или перезапись плохих треков. Если для достижения результата жертвы оправданны, то на них нужно идти.
Сведение — своеобразное погружение в глубины звука. Это процесс длительный и не терпящий прерываний. Поэтому предварительно следует позаботиться о своей "безопасности" — исключить все факторы, способные рывком поднять вас на поверхность (например, заблокировать телефон и т. п.)
Как правило, оценка микса в начале сведения более объективна (так как слух еще не притупился). Если вы работаете на протяжении 2—3 часов, то слуховая усталость может трансформироваться в неосознанное раздражение, которое проявляется в навязчивом желании изменить все. В этом случае лучше сохранить прежний вариант как отдельный EDL-файл. Скорее всего, через день-два именно он покажется вам наиболее удачным.
Теперь о критериях качества записанной фонограммы. Специалисты уделяют особое внимание некоторым ее критериям.
"Пространственность формирует ощущение расстояния до инструмента или группы инструментов. Хорошо, если расстояние до исполнителей в записи кажется естественным и легко определимым. На пространственность в записи оказывают влияние ранние отражения сигнала и реверберация, ее время и уровень.
<...> Следующий параметр, по которому оценивается звукозапись, — это прозрачность. Под прозрачностью подразумевается ясность передачи музыкальной фактуры, различимость линий партитуры.
<...> Прозрачность — один из наиболее различимых слушателем параметров звучания. Однако ясность и прозрачность записи может требоваться не всегда в силу определенных жанровых особенностей. Например, при записи хора необходимо избежать различимости голосов отдельных хористов в партиях". (П. Кондрашин, ст. "Типичные ошибки звукорежиссеров при записи и сведении фонограмм", "Звукорежиссер", 1999, № 2, http://www.625-net.ru/arch.htm.)
Остановимся на очень важном вопросе: насколько ясным должно быть звучание. Здесь бытует ошибочная точка зрения: чем выше разборчивость партий, тем лучше фонограмма.
Проведем стилевую параллель между звуковым полотном и художественным. Графика и живопись обладают разными выразительными средствами: четкость линии в одном случае также неприменима, как и размытость контуров в другом.
Аналогичная ситуация и в музыке. Здесь также произведения разных направлений отличаются по набору выразительных средств.
Но нужно помнить, что отражение окружающего мира в музыке и живописи имеет свои законы, основанные на восприятии мира человеком. Один из них — разделение объекта и фона. Поэтому приемы, призванные подчеркнуть, выделить главное, не должны использоваться повсеместно. Это в равной мере относится к "четкости прослушивания" всех партий. Ненужно путать главное с второстепенным: идею и ее обрамление, соло и аккомпанемент, объект и фон и т. п.
Известный эксперт в области звуковой аппаратуры Анатолий Лихницкий пишет по этому поводу следующее: "И все-таки ясность звучания может оказаться чрезмерной. 'Гипертрофированная' ясность ощущается слушателями, например, как избыточность звуковых деталей. Эти детали отвлекают внимание от музыки, и в результате связь между элементами музыки в восприятии слушателей разрывается. Поразмыслив над этим, я предлагаю вместо информационного эталона ясности использовать эталон, соотносимый со шкалой эстетической оценки. Таким эталоном может быть баланс (соотношение) между разделенностью следующих друг за другом звуков и их связанностью". (А. Лихницкий. Качество звучания. Новый подход к тестированию аудиоаппаратуры. — СПб.: "ПиК", 1998.)
Основной инструмент размывания — "сглаживания" избыточных деталей — это ревербератор. Им следует пользоваться осторожно, т. к. легко получить неестественное звучание. Но если реверберация — художественный прием, воплощение музыкальной идеи, то запретов нет.
Еще один важный критерий качества, который должны учитывать даже начинающие компьютерные музыканты — это музыкальный баланс. Музыкальный баланс — это соотношение между партиями аранжировки.
"Музыкальный баланс должен исходить из партитуры, соответствовать замыслу композитора или дирижера и сохраняться при всех нюансах от рр до ff.
<...> Хороший баланс в записи создать не так трудно.
<...> Есть ряд объективных причин плохого баланса. Во-первых, недостаточная музыкальная культура и развитость вкуса звукорежиссера. Он часто не понимает степени важности той или иной партии. Ему кажется, что все сыгранное музыкантами должно звучать одинаково громко. Запись становится "плоской", грохочущей. Этот тип баланса мы называем 'инженерным сведением'". (П. Кондрашин, ст. "Типичные ошибки звукорежиссеров при записи и сведении фонограмм", "Звукорежиссер", № 2, 1999, http://www.625-net.ru/arch.htm.)
Именно описанным "инженерным сведением" страдают миксы начинающих компьютерных музыкантов.
Для преодоления ошибок начального этапа требуется развитие профессионализма, которое невозможно без тренировки звуковой наблюдательности, прослушивания и анализа эталонных AUDIO CD, посещения концертов симфонической музыки, — т. е. повышения общей музыкальной культуры. Для компьютерных музыкантов добавляется еще и грамотное использование виртуальных технологий.
Конечная цель сведения — это ни что иное, как распознавание художественного замысла произведения, затем бережное преобразование его и фиксирование результата на новом звуковом полотне.
Поэтому компьютерному музыканту обязательно нужно уметь оперировать со звуковыми образами, распознавать их и расставлять согласно "иерархии замысла".
Работая над сведением в программе SAWStudio, лучше начинать с удаления остатков чернового материала. А именно, подрезать объекты — отсечь на них пустые места, удалить те регионы, в которых содержатся помехи, шумы.
Затем следует распределить треки по группам, воспользовавшись для этого виртуальной маршрутизацией.
Далее нужно уделить внимание балансу звучания инструментов. Здесь есть разные подходы. Об одном из них пишет в своей статье С. Кругликова: "Другой вариант — отстроить баланс основных гармонических инструментов, вокала, сольные партии — и всех их выключить. Затем отдельно отстроить барабаны с басом, чтобы хорошо звучали сами по себе, и снова включить уже отстроенные инструменты, и лишь затем постепенно подмешивать к ним барабаны с басом. Этот подход не столь распространен, но о нем стоит говорить хотя бы потому, что им пользуются в разных странах наиболее известные звукорежиссеры и продюсеры: англичанин Алан Парсонс (Alan Parsons), известный как работами над собственным проектом, так и легендарным альбомом группы Pink Floyd 'Dark Side of the Moon'; американец Мэт Уоллес (Matt Wallace, альбом группы Faith 'No More The Real Thing'), француз Режи Раван (Regis Ravant, проект Mr. Magoo 'Mon petit chou')". (С. Кругликова, ст. "Сведение как творческий процесс. Часть 1. Частотная и динамическая обработка", "Звукорежиссер", № 7, http://www.625-net.ru/arch.htm.)
В рассматриваемой далее конфигурации с одним мастер-каналом и 23 группами ничто не мешает использовать подход Алана Парсонса в SAWStudio в полной мере. Кроме того, шесть Return-каналов также могут быть распределены по группам в различных вариациях. Следовательно, в подготовке к сведению можно выделить отдельный этап — конфигурирование виртуальной консоли.

Совет
Те конфигурации виртуальной консоли, которые вами часто используются, удобнее сохранять в файлы шаблонов mxt.

Основная идея — подготовить к сведению виртуальную студию таким образом, чтобы ее архитектура соответствовала целям и задачам проекта.

MS-эквализация

В нашей книге рассказывается о виртуальной студии, в которой вся обработка ведется программным способом — с помощью встраиваемых приложений (plug-ins).
Но в виртуальном мире вполне применимы многие советы профессионалов, работающих на реальном оборудовании.
Далее мы обозначим общие связки — между теорией и конкретной технологией.
Как уже отмечалось, одна из задач сведения — достижение компромисса между разделенностью и связанностью звуков.
Решить ее можно с использованием современной технологии трехмерного звука.

Примечание
Преимущества виртуальной студии в этом вопросе неоспоримы. Ведь возможности конструирования в виртуальном мире практически неограниченны — для них не существует тех пространственных рамок, которые свойственны реальному миру.

Итак, создадим определенную цепочку plug-ins. (Если предварительно треки были распределены по группам, то целесообразно применить последующую обработку к группе.)
Напомним, что в Output-канале сигнал стереофонический. Следовательно, для его обработки можно применить MS-эквализацию. Обычная LR-стереофония преобразуется в MS (Middle-Side) простым суммированием и вычитанием.
После преобразования суммарный канал — М — "отвечает" за центр, а разностный — S — за окружающее звуковое пространство. Их раздельная обработка является основой MS-эквализации.

Примечание
MS-эквализация — процесс, состоящий из последовательных действий: преобразования LR в MS, раздельной обработки каналов MS-эквалайзером, выполнения обратного преобразования в LR.

Она по своему действию существенно отличается от обычной эквализации, т. к. позволяет управлять звуковым пространством более эффективно (регулировать ширину стереобазы по частоте, выделяя звуковые планы, и т. п.).
Один их способов реализации MS-эквализации в SAWStudio — это цепочка plug-ins фирмы Waves (www.waves.com): Waves SI-MS Matrix (преобразование в MS), Waves-QlO Paragraphic EQ (в режиме раздельного регулирования каналов), Waves SI-MS Matrix (обратное преобразование в LR).
Их настройку удобно производить, приглушая по очереди суммарный М- и разностный S-сигналы с помощью регуляторов секции Input или Output эквалайзера Waves-QlO Paragraphic EQ.
Вместо эквалайзера Waves-QlO Paragraphic EQ можно использовать Waves Renaissance Equalizer REQ 6 bands, который также поддерживает раздельную регулировку по каналам (иногда этот вариант даже предпочтительнее).

Примечание
MS-эквализация является составной частью общей технологии MS-мастеринга, подробно описанной у Боба Катца (Bob Katz) ("The secret of the mastering engineer"). Его статьи размещены на сайте http://www.digido.com. Вполне возможно, подойдя к этой технологии творчески, применять ее для MS-эквализации групп.

Совет
Результаты получаются лучше, если частоты регулирования и добротности полос эквалайзера М- и S-каналов не совпадают.

Можно усложнить обработку, заменив в цепочке последний модуль Waves SI-MS Matrix на Waves SI Stereo Imager (рис. 1.145).

Рис. 1.145. Модуль Waves S1 Stereo Imager

Переключатель Input Mode нужно установить в режим М - input - S, а переключатель Output в режим L out R.
MS-эквализация вполне применима для обработки сигнала реверберации Return-канала. Цепочка plug-ins может быть следующей: Ultrafunk fx:reverb (http://www.ultrafunk.com), Waves SI-MS Matrix, Waves Renaissance Equalizer REQ 6 bands, Waves SI Stereo Imager (в режиме М - input - S).

Рис. 1.146. Plug-in Ultrafunk fxireverb

Ревербератор Ultrafunk fx:reverb особенно качественно работает именно в SAWStudio. Обработка его выходного сигнала вышеописанной цепочкой обеспечивает большие возможности в формировании объемного звукового пространства.

3D Stereo

Еще одним способом повышения прозрачности и ясности является применение технологии Qsound (www.qsound.com). Модуль QTools — QXpander (рис. 1.147) обеспечивает преобразование исходного стереосигнала в трехмерный звук 3D Stereo.
Модуль QTools — QXpander нужно установить последним в цепочке plug-ins Output-канала (группы) или Return-канала. В результате звучание группы выйдет за рамки обычного стерео.
Неплохие результаты можно получить при совместном использовании Waves SI Stereo Imager и QTools — QXpander. В этом случае все регулировки, производимые в Waves SI Stereo Imager, станут ярче и появится дополнительный контроль за размерами ЗD-пространства. Можно поэкспериментировать с регуляторами Shuffle и Freq. При обработке этой цепочкой plug-ins выходного сигнала эффекта Ultrafunk fx:reverb Return-канала можно получить красивый эффект ЗВ-реверберации.

Рис. 1.147. Модуль Qtools — QXpander

Примечание
Переключатель Width модуля Ultrafunk fx:reverb при использовании 30-ревер-берации в Return-канале лучше установить в положение Narrow (см. рис. 1.146). Прямой сигнал (кнопка Dry) должен быть отключен.

Исполнительные возможности управления ЗD-пространством обеспечивает говместное использование модулей Ultrafunk fx:surround (рис. 1.148) и QTools — QXpander.
Модуль Ultrafunk fx:surround — это surround sound panner, который формирует в исходном стереосигнале еще два закодированных — Center и Surround.

Примечание
О системах многоканального звука будет рассказано в разд. "Surround в SAWStudio".

После Surround-панорамирования модуль QTools — QXpander преобразует сигнал в 3D Stereo, обеспечивая тем самым своеобразное преобразование Surround-панорамирования в ЗD-панорамирование. Модуль Ultrafunk fx:surround поддерживает внутреннюю автоматизацию панорамирования по заданной траектории, а также имитирует эффект Доплера, создавая иллюзию движущегося источника звука. Для этого нужно щелкнуть на кнопке Focal point и разместить "наблюдателя" (желтый крест) в виртуальном пространстве.

Рис. 1.148. Модуль Ultrafunk fx:surround

Динамическая обработка

"Компрессия в наше время — вещь абсолютно необходимая по причине ограниченности динамических диапазонов как звуковых трактов радио и телевидения, так и самих носителей звуковой информации". (С. Кругликова, ст. "Сведение как творческой процесс. Часть 2.", "Звукорежиссер", № 8, 1999, http://www.625-net.ru/arch.htm.)
Пока не произошло полного перехода на DVD-Audio или SACD, пока используются 16-битные звуковые карты и "Low End" музыкальные центры, без компрессора не обойтись. Но это, так сказать, техническая сторона.
Компрессор представляет собой еще и художественное средство. Он может полностью изменить звучание, например, ударных инструментов и баса. Нужно понимать, что с художественной точки зрения использование компрессора всецело определяется музыкальным стилем, идеей и эстетическим эталоном.
В мире plug-ins существует немало программных реализаций динамической обработки. Некоторые могут одновременно сочетать в себе: компрессор, экспандер, гейт и лимитер. Подобные устройства, благодаря своей многофункциональности, называются динамическими процессорами.
Из всего ассортимента компрессоров, представленных на рынке plug-ins, мы остановимся на Waves C1 и Waves RCL, причем рассмотрим в большей степени их творческое применение.
Возьмем пример, в котором треки объединены в группы. (Возможные варианты: группа баса и ударных, группа гитар и т. д.)
В принципе, сигнал каждой группы можно обработать компрессором.

Примечание
Совсем не обязательно применять компрессор во всех случаях жизни, но в современной, особенно танцевальной музыке, они являются традиционными — входящими в концепцию современного звучания.

Если в проекте используются "живые" инструменты, то нужно постараться не "раздавить" динамику. Ведь в результате неосторожного обращения с компрессором можно уничтожить все динамические оттенки и в результате получить "другую" музыку.

Рис. 1.149. Компрессор Waves C1

Компрессор Waves C1 представляет собой динамический процессор студийного качества, который можно вызывать по отдельным компонентам. Поэтому в списке plug-ins находится несколько Waves Cl (Waves Cl-Comp, Waves Cl Gate и т. д.).
Полный вариант компрессора, изображенный на рис. 1.149, состоит из трех модулей.

  • Модуль Компрессор/Экспандер (слева).
  • Модуль Гейт/Экспандер (справа).
  • Модуль Фильтр-эквалайзер (внизу).

Модуль Фильтр-эквалайзер содержит графический дисплей АЧХ-фильтра.
Амплитудная характеристика (АХ) модулей динамической обработки отображается на втором дисплее, причем желтым цветом обозначена АХ модуля Компрессор/Экспандер, а голубым — модуля Гейт/Экспандер.
Кнопка Low Ref (Low-level reference) переводит модуль Компрессор/ Экспандер в альтернативный режим Peak Ref (Peak-level reference). Повторное нажатие на кнопку возвращает прежний режим.
Режим Low Ref mode — это режим классического компрессора, у которого с понижением порога Threshold понижается выходной уровень сигнала.
В режиме Peak Ref mode с понижением порога происходит автоматическая компенсация уровня.
Коэффициент Ratio по умолчанию равен 1.00:1. При этом динамическая обработка не производится. Если коэффициент Ratio меньше единицы, например, 0.80:1, то модуль выполняет функцию Upward Expander (динамическое расширение сигналов с уровнем выше порога). Если Ratio больше единицы, например, 2.00:1, то модуль выполняет функцию Downward Compressor (динамическое сжатие сигналов с уровнем выше порога).

Примечание
Отрицательные значения Ratio переводят модуль в особый режим Cancellation Mode, который применяется в случаях ослабления сигналов с большим уровнем.

При понижении порога до уровня примерно -47 дБ АХ компрессора принимает другой вид (рис. 1.150).
Такая амплитудная характеристика (Mid-level compression) обеспечивает сжатие только для сигналов среднего уровня, не затрагивая пиковых уровней. В этом режиме можно увеличить плотность звучания.
Параметр PDR (Program Dependent Release) обеспечивает адаптивное время восстановления (Release). Если сигнал имеет быстрый спад, то установка времени PDR превышающим длительность переходного процесса обеспечит автоматическое сокращение времени восстановления компрессора. Таким образом, медленные переходные процессы будут обрабатываться компрессором с предустановленным временем восстановления (параметр Release). А для быстрых — время восстановления будет сокращено.

Рис. 1.150. Mid-level compression

Второй модуль Гейт/Экспандер мы рассмотрим только в режимах Upward Compressor (сжатие сигналов с уровнем ниже порога) и Downward Expander (динамическое расширение сигналов с уровнем ниже порога). Для осуществления низкоуровневой компрессии необходимо перевести модуль в режим Экспандер — нажать кнопку Gate/Expander. Затем установить порог GateOpen и настроить параметр Floor в диапазоне положительных значений (рис. 1.151).

Рис. 1.151. Low-level compression

Низкоуровневая компрессия добавляет "дыхание", при ней лучше прослушиваются "хвосты" реверберации и мелкие детали звуковой картины.
Отрицательные значения параметра Floor переводят модуль Гейт/Экспандер в режим Downward Expander (низкоуровневое расширение).
Наличие модуля Фильтр-эквалайзер обеспечивает компрессору Waves C1 три дополнительных режима динамической обработки EQ Mode.

  • Wideband — режим широкополосной обработки. В нем сигнал последовательно обрабатывается модулями Компрессор/Экспандер и Гейт/ Экспандер.
  • Sidechain — управление динамикой осуществляется отфильтрованным сигналом.
    Обрабатываемый сигнал не подвергается частотной обработке.

Примечание
Отфильтрованный (АЧХ фильтра красного цвета) сигнал управления Sidechain можно проконтролировать, если нажать кнопку Sidechain в секции Monitor.

  • Split — управляющий и основной сигналы обрабатываются фильтром.
    Красная полоса фильтра является активной и именно в ней сигнал динамически обрабатывается. В синей (пассивной) полосе обработка не производится. Обработанный и необработанный (сухой) сигналы суммируются.

Примечание
Сигнал пассивной полосы можно проконтролировать, если нажать кнопку Passive в секции Monitor.
Комбинирование режимов EQ Mode модулей Компрессор/Экспандер и Гейт/Экспандер приводит к более сложным схемам виртуальной обработки, которые приведены в документации к Waves C1.

Переключатель Туре позволяет выбрать тип фильтра. Все управление фильтром сводится к перетаскиванию маркера на частотном дисплее.
Рассмотрим два простых демонстрационных примера.
Для того чтобы сделать трек или группу громче (плотнее), нужно перевести компрессор в режим Peak Ref mode. Затем регулятором Makeup установить уровень примерно -6 дБ. Задать коэффициент сжатия регулятором Ratio 2.00:1. После этого регулятором Threshold начать постепенно снижать порог.

Совет
Удобно изменять параметры plug-ins Waves с помощью клавиатуры. Для этого достаточно выделить элемент управления, ввести значение и нажать клавишу <Enter>. Вернуться к предыдущему значению параметра можно с помощью клавиши <Esc>. Плавную подстройку параметра удобно производить клавишами < [image] >, < [image] >, < [image] > < [image] > для горизонтальных и вертикальных регуляторов соответственно.

Индикатор Gain reduction Meter желтым столбиком отобразит величину компенсации, которая применяется для сохранения пикового уровня (рис. 1.152).

Рис. 1.152. Индикатор Gain reduction Meter

Большое значение имеет правильный выбор параметров Attack и Release. Например, при компрессии ударных инструментов слишком быстрое срабатывание компрессора может уничтожить их атаку. В результате этого звучание ударной установки станет неестественным.
Совместное применение низкоуровневого сжатия (Upward Compressor) и высокоуровневого расширения (Upward Expander) может использоваться для избирательного подчеркивания деталей звуковой картины. Если при этом задействовать фильтр в режиме Split, то Waves C1 будет функционировать как динамический эквалайзер (рис. 1.153).
Модуль Waves Renaissance Compressor (RCL) представляет собой некий гибрид из Waves C1 и Waves LI Ultramaximizer. Компрессор Waves RCL можно использовать как для динамической обработки треков (групп), так и для мастеринга. Внутренняя разрядность обработки — 64 бита с плавающей точкой. Поэтому алгоритм этого модуля соответствует профессиональным требованиям.
Управление компрессором Waves RCL реализовано еще проще, чем Waves С1 (рис. 1.154).

Рис. 1.153. Динамический эквалайзер

Рис. 1.154. Модуль Waves RCL

Традиционные регуляторы Thresh (порог), Attack (атака), Release (восстановление), Ratio (коэффициент сжатия/расширения) и Gain (уровень) ничем функционально не отличаются от аналогичных регуляторов модуля Waves C1. Но, тем не менее, между ними есть различия.
Одно из них — наличие на выходе лимитера с "потолком" в 0 дБ (то есть ни одна выборка не может выйти за границу в 0 дБ). Лимитер работает во всех режимах компрессора и, что особенно важно, в режиме Upward Expander. Три верхние кнопки — ARC/Manual, Opto/Electro и Warm/Smooth — предназначены для переключения режимов компрессора.

  • ARC (Auto Release Control) — режим автоматического восстановления. При этом время восстановления компрессора вычисляется специальным алгоритмом в масштабе заданного пользователем параметра Release. Этот режим рекомендуется использовать в большинстве случаев для достижения минимальных искажений сигнала.
  • Manual — режим ручного регулирования параметра Release.
  • Electro — модель поведения компрессора, при которой время восстановления уменьшается для случаев уровня подавления (gain reduction) меньшего, чем 3 дБ. Если уровень подавления превышает 3 дБ, то время восстановления увеличивается. Поэтому модель Electro обеспечивает наибольший RMS-уровень в случае умеренного сжатия.
  • Opto — модель поведения, инверсная к Electro и эмулирующая компрессоры с оптронной обратной связью. В этой модели если уровень подавления (gain reduction) превышает 3 дБ, то время восстановления уменьшается.
  • Warm — режим добавления низкочастотных гармоник к исходному сигналу.
  • Smooth — режим сохранения оригинального звучания.

Положение регулятора Ratio определяет тип динамической обработки. В позициях ниже значения 1.00 Waves RCL работает как традиционный Downward Compressor. Столбик индикатора Gain Meter в этом случае имеет оранжевый цвет и отображает уровень подавления (gain reduction). Превышение регулятором Ratio позиции 1.00 изменяет тип динамической обработки на высокоуровневое расширение (Upward Expander). Столбик индикатора Gain Meter окрашивается в синий цвет.
Высокоуровневое расширение — это такой же творческий инструмент обработки звука, как и сжатие. Например, в фирменном пресете Decompression bends используется высокоуровневое расширение для придания звуку "ударного" (punch) характера, подчеркивания динамических оттенков.
В заключение раздела отметим еще один момент. Компрессоры необходимо подключать в слоты FX Pre Fader для того, чтобы изменение уровня регуляторами громкости не влияло на их работу.


Промежуточное сведение

Несмотря на бурный рост производительности современных PC, промежуточное сведение в файл остается актуальным способом достижения компромисса между желаниями и возможностями: поставленной задачей и способами ее решения.
Смысл этого вида сведения состоит в том, чтобы закрепить промежуточный результат и тем самым высвободить ресурсы компьютера.
Промежуточное сведение выполняется в файл, расположенный в виде объекта на свободной дорожке.
Для максимального освобождения вычислительных ресурсов промежуточное сведение лучше использовать для "нагруженных" треков или группы.
В SAWStudio, благодаря автоматизации обхода эффектов (FX Bypass), можно подключить к проекту немалое число ресурсоемких plug-ins. По сравнению с конкурирующими продуктами для PC, эквивалентная производительность виртуальной студии на базе SAWStudio (по числу одновременно используемых ресурсоемких plug-ins с автоматизацией обхода) максимальна.
Но иногда этих возможностей тоже может оказаться недостаточно.
Сведение в файл в SAWStudio выполняется с помощью команд меню Ргос-ess/MixDown: Build Mix To New Soundflle(s) и Build Mix To Current Hot Track. При этом учитываются: автоматизация, обработка plug-ins, режимы Solo и Mute, а также выделение треков.
Рассмотрим действие команды Build Mix To Current Hot Track.
Перед ее вызовом необходимо щелкнуть на пустой дорожке для того, чтобы сделать ее "горячим" треком, т. к. сведение выполняется именно на него.
При вызове команды появится окно BuildMix To File Setup (рис. 1.155), аналогичное по структуре и элементам управления окну МТ Record Setup (см. разд. "Окно Record Remote Transport Window" выше в этой главе).
При наличии многоканального аудиооборудования будет создано несколько звуковых файлов по количеству активных мастер-каналов. (В нашем примере проект сводится в один звуковой стереофайл.)
Особенно следует обратить внимание на частоту сэмплирования Rate и разрядность Res. Частота сэмплирования Rate должна быть равной частоте сэмплирования проекта (мультитрека). В противном случае SAWStudio выполнит ресэмплирование (преобразование с изменением частоты дискретизации) звукового файла.

Совет
Для достижения максимального качества нужно избегать ресэмплирования. Самый лучший вариант— это изначальный выбор частоты дискретизации 44 100 Гц. В этом случае в дальнейшем— при мастеринге AUDIO CD— не придется ухудшать качество ресэмплированием.
Нам неизвестен ни один алгоритм звуковых программ для PC, который бы не обеспечивал ресэмплирования без ухудшения качества. Если все же без изменения частоты дискретизации не обойтись, то делать это нужно только при финальном сведении и только в окне BuildMix To File Setup. Изменение перед сведением в файл частоты дискретизации мультитрека вызовет многократное ресэмплирование файлов каждого трека, т. е. неизбежную цифровую деградацию.
Изменение частоты дискретизации Rate в окне BuildMix To File Setup вызовет другой алгоритм: смешивание и обработка треков с оригинальной частотой дискретизации и затем единственное конвертирование финального смешанного файла. В этом случае цифровая деградация минимальна.

Рис. 1.155. Окно BuildMix To File Setup

Наряду с сэмплированием в цифровых системах звукозаписи существует еще одна проблема — это искажения квантования. Они тесно связаны с разрядностью кодирования — Res. Внутреннее разрешение мультитрека SAWStudio — 24 бита. Следовательно, если при промежуточном или окончательном сведении уменьшить этот параметр, мы получим транкейт (от truncate — усечь).
Транкейт — основная причина деградации качества цифрового звука. Единственное внутреннее средство борьбы с транкейтом в SAWStudio — это сведение в файл самой высокой разрядности.
Отрадно заметить, что разрядность преобразователей звуковой карты не имеет здесь решающего значения, т. к. весь процесс сведения в файл полностью виртуален. Более того, на относительно дешевых звуковых картах заявленные 24-битные АЦП — часто умело поданная реклама, а не отражение реальных возможностей.

Примечание
Очень сложно обеспечить уровень собственных шумов входных цепей 24-битного АЦП не превышающим -150 дБ. Для звуковых карт без внешнего АЦП это вообще невыполнимо. Поэтому такой, условно называемый "24-битный" АЦП, не обеспечивает заявленной точности преобразования.

Но задачу можно решить в обход. Наиболее эффективный путь — сжатие динамического диапазона перед аналого-цифровым преобразованием с помощью аналогового компрессора. В такой системе обычный 16-битный АЦП обеспечит более высокую эквивалентную точность по сравнению с оцифровкой сигнала с несжатым динамическим диапазоном.

Примечание
"Радиолюбительскую" реализацию такой системы мы рассмотрели выше (см. разд. "Повышение качества записи 16-битной звуковой карты").

Итак, непосредственно сам процесс сведения начнется после нажатия кнопки ОК в окне BuildMix To File Setup. Индикация процесса осуществляется в окне Building Mix (рис. 1.156).

Рис. 1.156. Окно Building Mix

После окончания сведения в файл на "горячей" дорожке будет создан новый объект.
Длина его определяется областью, выделенной заранее, либо общей длиной проекта — от начала до правой границы последнего объекта.
В случае многоканального сведения в группу файлов объекты расположатся друг под другом, начиная с "горячего" трека. При этом будет соблюдаться последовательность аудиоустройств в окне BuildMix To File Setup.
Если процедура сведения выполняется повторно в тот же файл, то программа выдаст предупреждающее диалоговое окно, в котором будет предложена альтернатива: заменить исходный файл или его дополнить.

Временное промежуточное сведение

Проблема деградации цифрового звука, к сожалению, не решается простым промежуточным сведением в файл высокой разрядности. Цифровая обработка звука неразрывно связана с проблемой точности и корректности вычислений, накоплением погрешности. Каждое лишнее преобразование как правило ухудшает качество.
Объекты, полученные в результате обычного промежуточного сведения, повторно обрабатываются алгоритмами SAWStudio и plug-ins. Самым лучшим является случай однократной обработки, когда весь проект сводится в файл за один проход.
Многие профессиональные plug-ins обеспечивают внутреннюю 64-битную точность обработки в формате с плавающей точкой. Но затем обработанные данные приводятся к внутреннему 24-битному разрешению мультитрека. Поэтому лучше всего обходиться без промежуточного сведения — не подвергать звуковые данные лишним преобразованиям.
Однако вычислительные ресурсы компьютера могут оказаться недостаточными для однократного сведения. Для решения этой проблемы можно воспользоваться замечательным свойством SAWStudio — выделением треков.
В этом случае появляется уникальная возможность — выполнить промежуточное сведение временно. Это означает, что какая-то сильно нагруженная plug-ins группа треков временно сводится на свободную дорожку, назначенную на мастер-канал, благодаря чему ресурсы высвобождаются.
После чего выделяются все дорожки, не вошедшие в группу временного промежуточного сведения, и продолжается микширование с использованием дополнительных ресурсов.

Примечание
По понятным причинам без дорожки временного промежуточного сведения (Submix) дальнейшее микширование было бы невозможно вследствие "неучтенного" эффекта маскировки. Треки нельзя сводить вслепую, т. к. их великолепное звучание по отдельности вероятнее всего исчезнет при совместном воспроизведении.

В финальной стадии — перед операцией сведения в файл — дорожка временного промежуточного сведения исключается из процесса, а временно отключенные треки возвращаются из выключенного состояния. Затем весь проект пересчитывается программой в файл (как правило, медленно, но качественно). При этом ни одна дорожка не обрабатывается повторно.


Финальное сведение

Окончательное сведение в файл выполняется командой Build Mix To New Soundflle(s) меню Process/MixDown. В действии данной команды не существует никаких принципиальных отличий от сведения на "горячий" трек (кроме отсутствия объекта на "горячей" дорожке). Сведенный файл отображается в окне SoundFile. Финальный микс должен иметь максимальную разрядность 24 бита и частоту дискретизации 44 100 Гц, если он предназначен для дальнейшего премастеринга AUDIO CD.


Surround в SAWStudio

Системы пространственного звука принято обозначать термином Surround. Основное их отличие в количестве каналов: здесь оно превышает два. Поэтому Surround-системы — это системы многоканальные.
Звучание Surround-систем создает эффект присутствия, тем самым открывая новые горизонты компьютерной музыки.
Прежнее достижение — стандартный стереофонический двухканальный звук — тоже отличался от монофонического ощущением звукового пространства. Он легко реализовывался технически, поэтому двухканальная стереофония стала повсеместной. Но, например, в мире профессионального кино уже давно считается, что для создания звукового реализма требуется большее — как минимум четыре канала.
В области бытовой звуковоспроизводящей аппаратуры уже были сделаны попытки расширить стереоограничение — увеличить количество каналов до четырех. Так появилась квадрофония. Но ее введение, по ряду причин, не имело коммерческого успеха. Хотя прогрессивное начало в ней, несомненно, присутствовало — в ней было применено матричное кодирование, позволяющее упаковать четыре канала в два.
Развитие звукового оформления профессионального кино прогрессировало. Фирмой Dolby Laboratories (http://www.dolby.com) был проведен ряд разработок, который позволил сложившуюся к тому времени в кинематографе схему объемного звука LRCS закодировать в два канала.

Примечание
Аббревиатура LRCS расшифровывается как L (Left) — левый канал, R (Right) — правый канал, С (Center) — центральный канал, S (Surround) — пространственный.

Такая система матричного кодирования получила название Dolby Surround. В ней четыре канала LRCS аналоговым способом кодируются в два — Lt и Rt (Left, Right — total).
Первоначальный простой декодер Dolby Surround позволил выделить Surround-канал. Впоследствии сложный декодер Dolby Pro Logic обеспечивал полное декодирование LRCS.
Кодирование в упрощенном виде выглядит так:

  • L — без обработки в Lt;
  • R — без обработки в Rt;
  • С — ослабление на 3 дБ и сложение каждой его половины с Lt и Rt;
  • S — ослабление на 3 дБ, обработка полосовым фильтром, шумоподавителем и сложение каждой половины со сдвигом по фазе на —90 и +90 градусов с сигналами Lt и Rt.

Модуль Ultrafunk fx:surround программным способом обеспечивает панорамирование источника в виртуальном LRCS-пространстве и кодирование по технологии Dolby Surround (о модуле Ultrafunk fх:surround см. разд. "3D Stereo" выше в этой главе). Поэтому совсем не сложно создать с его применением в SAWStudio фонограмму в Dolby Surround.
В конце 1980-х годов в Dolby Laboratories была создана цифровая технология пространственного звука— Dolby Digital 5.1. В ней используется шесть каналов, которые обрабатываются особым алгоритмом информационного сжатия Dolby АС-3.
Шесть каналов получили следующие обозначения — L (Left), R (Right), С (Center), Ls (Surround left), Rs (Surround right), LFE (Low Frequency Effects, Subwoofer) — низкочастотный канал эффектов.
В SAWStudio отсутствует встроенный кодек АС-3, но, тем не менее, можно свести микс в шесть каналов в формате Dolby Digital 5.1 без информационного сжатия. Для этого в программе предусмотрена специальная Surround-маршрутизация с использованием регулятора XY Surround Pan. Рассмотрим ее.


Регулятор XY Surround Pan

XY Surround Pan реализован в виде виртуального джойстика, который имеется в отдельной секции XY Pan на всех Input-каналах и Return-каналах (рис. 1.157).

Рис. 1.157. Регулятор XY Surround Pan

Для того чтобы воспользоваться регулятором Surround-панорамы, нужно выполнить Surround-маршрутизацию на Output-каналах в секции XY Pan Assign (рис. 1.158).

Рис. 1.158. Surround-маршрутизация

Отметим, что для полноценного использования Surround-маршрутизации необходимо многоканальное оборудование, обеспечивающее нужное количество мастер-каналов.
Мастер-каналы нужно распределить в соответствии с форматом системы пространственного звука.

Примечание
Например, для Dolby Digital 5.1 может быть выделено три мастер-канала: L и R (1 канал), Ls и Rs (2 канал), С и LFE (3 канал).

Кнопки LR Front, LR Cntr, LR Rear, FB Cntr, Sub и Center в секции XY Pan Asgn каждого Output-канала предназначены для назначения маршрутов от регуляторов XY Surround Pan (см. рис. 1.158). В SAWStudio пользователь должен сам сконфигурировать виртуальную консоль под конкретную систему пространственного звучания.

Предупреждение
Если регулятор XY Surround Pan активен, то для исключения двойных аудиопотоков необходимо отжать соответствующие кнопки в секции Out Asgn виртуального канала.

Регулятор XY Surround Pan имеет восемь узлов, распределенных по периметру квадрата, окружающего виртуальный джойстик. Каждый узел может отключить один виртуальный канал Surround-маршрутизации. Красный цвет узла обозначает отключенное состояние. Повторный щелчок включает канал.
Кроме восьми узлов, секция XY Pan Asgn содержит два дополнительных регулятора: С (Center) и S (Sub) для раздельной маршрутизации центрального и сабвуферного канала.
Регулятор XY Surround Pan полностью автоматизирован.
Сведение многоканального проекта выполняется так же, как и двухканального,
но с одним отличием: результатом будет группа звуковых файлов, соответствующая количеству мастер-каналов. В дальнейшем эта группа может быть преобразована в формат АСЗ программным кодеком, например, SonicFoundry SoftEncode 5.1 (www.sonicfoundry.com).


Аудиомонтаж в SAWStudio

Для подавляющего большинства компьютерных музыкантов звуки — это важнейшее художественное средство выражения музыкальной идеи.
Возможности компьютерных виртуальных технологий для создания собственных звуковых красок настолько велики, что, пожалуй, единственным ограничением является недостаток звуковой фантазии или ограничения, навязанные извне (устоявшиеся стереотипы, эстетические эталоны, пропагандируемые СМИ).
У некоторых музыкантов — приверженцев акустической музыки или сторонников классической школы — существует консервативное предубеждение против компьютерных звуковых технологий.
Более того, многие знают о компьютерной музыке только по примерам звукового примитива, низкопробным штамповкам, подделкам под названием "а ля шоу-бизнес".
Мы с полной уверенностью заявляем, что программы такого класса, как SAWStudio, позволяют создавать настоящие звуковые вселенные.
Этот процесс можно производить, в частности, с помощью Loop-конструирования. Определимся с терминами, которые будут применяться при его описании.

  • Сэмпл (sample) — отсчет, выборка или фрагмент оцифрованного материала в формате звукового файла.
  • Грув (groove) — дорожка, фрагмент, содержащий музыкальную фразу.
  • Петля (loop) — оцифрованный фрагмент музыкальной партии длиной в целое число музыкальных тактов, предназначенный для циклического повторения.

Основными музыкальными параметрами грува и петли являются темп, тональность и тактовый размер (в подавляющем большинстве примеров современной танцевальной музыки используется размер 4/4).
Перечисленные повторяющиеся элементы могут служить "строительным материалом" для конструирования музыки.
Нужно отметить, что технологию конструирования можно использовать гораздо шире, чем только для создания танцевальной музыки. Сложившаяся сейчас ситуация противоестественна: образно говоря, всех пытаются убедить, что раз яблоки — это фрукты, то не существует никаких фруктов, кроме яблок.
Музыкальное искусство значительно шире. Оно должно радовать людей разного вкуса, возраста и предпочтений, а не только обслуживать двигательные рефлексы активной части молодежи, среди которой далеко не все являются ярыми приверженцами современных направлений.
Труд программистов, затраченный на создание музыкальных компьютерных программ, должен приносить человечеству гораздо больше дивидендов — в том числе в виде настоящих произведений искусства.
Многие прогрессивные компьютерные музыканты активно используют технологию создания собственных grooves, loops и samples для последующего конструирования из них сложных композиций.
Для того чтобы музыка, собранная из loops, не воспринималась как запиленная пластинка, следует разнообразить композицию. Для одной повторяющейся музыкальной фразы можно иметь, например, десяток loops с небольшими отличиями в исполнении, который затем выкладывается на мультитрек с различным чередованием.
"Существует мнение, что сочинение 'настоящей' музыки — это некое откровение, информация 'свыше', которую 'расслышал' и озвучил композитор. Не опровергая это утверждение, напомним, что в давние времена словом 'композитор' называли всех, занимающихся композицией в любой области искусства.
Латинское слово composite означает — сочинение, составление. И его можно отнести даже к составлению композиции букетов. Если рассмотреть творческий процесс 'под микроскопом', можно заметить, что композитор тоже 'составляет' музыку: из своих идей, звуковых впечатлений от окружающего мира и т. п.
Последние достижения в области музыкальных компьютерных программ позволяют музыканту в ходе экспериментов с музыкальным материалом почерпнуть интересные идеи для своего произведения. И на наш взгляд, сочинение музыки с использованием возможностей компьютера — прогрессивный путь".

Примечание
Приведенная цитата из книги: В. Урусова, Е. Медведев "Музыкальная азбука на PC", СПб.: "БХВ-Петербург", 2002. В этой книге можно найти подробную информацию о метрических размерах, тональностях, темпе, динамических оттенках, аккордах, практических приемах ритмической и ладовой квантизации, а также о других основных музыкальных понятиях. Весь материал этой книги посвящен соединению богатства музыкального языка и возможностей музыкальной компьютерной программы.


Библиотеки сэмплов

В SAWStudio для звукового монтажа предусмотрена отдельная сервисная возможность — библиотеки сэмплов Library. Максимальное количество библиотек в сессии — шесть, и они сохраняются в сессионном файле. Доступ к библиотекам осуществляется через меню View | Library.
Шесть окон Library лучше всего закрепить за отдельным рабочим экраном.
Рассмотрим интерфейс окна Library более детально (рис. 1.159). Кнопка File вызывает меню, состоящее из четырех пунктов.

  • Open Library EDL — импорт в окно Library списка регионов из другой сессии.
  • Open Directory Of.wav Files — импорт в окно Library всех звуковых файлов wav из конкретного каталога.
  • Add Selected To Multitrack (клавиша <Insert>) — создание объекта на "горячей" дорожке со стартовой границей в текущей позиции курсора из выделенного в списке Library файла.

Рис. 1.159. Окно Library

Примечание
Если в списке Library выделено несколько регионов, то объекты создаются последовательно друг под другом, начиная с "горячего" трека.

  • Clear Library Window — очистка списка регионов в окне Library.

Кнопка Link копирует выделенные регионы в списке Library в окно Regions.
Кнопка Import копирует выделенные в списке Library регионы в отдельный звуковой файл с одновременным занесением в список Regions. Эта функция особенно удобна при работе с CD ROM. Все импортированные регионы располагаются последовательно в одном звуковом файле (рис. 1.160), если в диалоговом окне Import Destination File не указывать разные имена звуковых файлов.

Примечание
На рис. 1.160 видно, что между импортированными регионами находятся зоны тишины. Эти зоны имеют длительность 0,5 с и предназначены для технологии гладких границ — SoftEdge.

Рис. 1.160. Расположение импортированных регионов

Кнопка Group обеспечивает доступ к группам регионов, если они были созданы в импортированном EDL-файле.
Прослушивание регионов в окне Library осуществляется щелчком правой кнопки мыши. Наиболее быстрый и удобный способ — это использование "горячих" клавиш:

  • <Enter> — прослушивание выделенного региона;
  • < [image] >, < [image] > — перемещение по списку Library;
  • <Пробел> — остановка воспроизведения;
  • <Page Up>, <Page Down> — быстрое пролистывание списка Library.

Для создания нового региона в окне SoundFile необходимо дважды щелкнуть на импортированном регионе в списке Library. Тогда импортированный регион откроется в окне SoundFile без режима воспроизведения.
При монтаже композиции следует перевести формат дорожки TimeLine в такты:доли:тики. Для этого нужно установить режим Tempo Mode и выбрать оптимальное разрешение Tick Resolution (см. разд. "Привязка к тактовой сетке" ранее в этой главе).


MS-мастеринг в SAWStudio

Мастеринг — это переплетение техники и искусства. На первый взгляд кажется, что выполнять его в домашней студии нет никакого смысла: ведь для него требуется специализация, квалификация и оборудование.
Но, тем не менее, если взглянуть на проблему демо-записи с другой стороны, то можно прийти к выводу, что демо-мастеринг все-таки необходим.
Основная функция демо-записи — донести музыкальные идеи автора до слушателя, вовлечь его в прослушивание. (Нужно еще учесть и тот факт, что бывают случаи, когда демо-записи издаются небольшими тиражами на AUDIO CD.)
Поэтому максимально качественное (насколько это возможно в условиях домашней студии) звучание демо-записи оказывается задачей № 1.

Примечание
Еще раз отметим, что статьи профессионалов, касающиеся проблем цифрового звука, можно найти на сайте http://www.digido.com.

MS-мастеринг — это мощный инструмент, с помощью которого можно "вытянуть" совершенно, казалось бы, "безнадежный" микс.
Для конструирования виртуальной студии MS-мастеринга нужна виртуальная консоль SAWStudio и профессиональные DirectX-plug-ins фирмы Waves.
Вариант маршрутизации виртуальной консоли для MS-мастеринга изображен на рис. 1.161.
В Input-канале стереофонический сигнал LR кодируется в MS с помощью Waves SI-MS Matrix и затем обрабатывается эквалайзером Waves Q10 — Paragraphic EQ в режиме раздельного регулирования каналов. (При этом кнопка Link в секции Control должна быть отжата, базовый пресет: 10-band master EQ.)
Отдельная эквализация суммарного (М) и разностного (S) каналов позволяет управлять стереопространством на любой частоте.

Совет
Если частоты фильтров эквалайзера приблизить к частотам нот музыкального темперированного строя, то шанс сделать фонограмму более музыкальной значительно повышается.

Далее сигнал распараллеливается на две группы, в каждой из которых регуляторы панорамы разведены в противоположные стороны. В этих группах производится раздельная многополосная динамическая обработка с помощью параметрического процессора Waves C4.

Примечание
Подробную информацию о параметрическом процессоре Waves C4 можно найти в нашей книге "'Живая' музыка на PC".

Раздельная многополосная динамическая обработка каналов М и S также превосходит по своим возможностям обычную LR-обработку. Например,
низкоуровневое сжатие S-канала может восстановить объемность, простран-ственность.

Рис. 1.161. Схема маршрутизации для MS-мастеринга в SAWStudio

После динамической обработки сигнал объединяется в мастер-канале, где происходит обратное преобразование в LR с 'помощью модуля Waves S1 Stereolmager (режим входа М - input - S).
Модуль Waves SI Stereolmager выполняет двойную функцию MS-LR-декодера и корректора стереоимиджа. Финальную обработку выполняет традиционный Ll-Ultramaximizer+, сочетающий в себе реквантайзер в 16 бит, пик-лимитер и дизеринг-процессор.
Для контроля в конце цепочки должны быть подключены измерительные модули plug-ins (см. рис. 1.161).
Преобразование в финальный файл осуществляется командой Build Mix To New Soundfile(s) меню Process/MixDown. Собственный дизеринг-процессор программы SAWStudio при этом должен быть отключен (в окне BuildMix To File Setup в поле Dither должно быть значение off).
Завершая главу, хочется отметить, что процесс виртуализации студийного оборудования набирает силу. Виртуальная консоль постепенно перемещается в плоскость повседневной реальности.

Примечание
На сайте http://www.corteksoft.com/ можно познакомиться с Virtual Audio Console System, еще одной реализацией виртуальной технологии.

И вполне возможно, что скоро привычные и осязаемые фейдеры микшерного пульта окончательно "пропишутся" на экранах мониторов. А это уже совсем другая реальность, готовиться к которой нужно уже сегодня, изучая виртуальные возможности замечательной, реальной программы SAWStudio.


Глава 2. Nuendo — виртуальная лаборатория звука

  • Nuendo — виртуальная лаборатория звука
    Настройка программы
    • Команда Devices \ Device Setup
      • Настройка AUDIO
        Настройка MIDI
        Окно VST Master Setup
        Окно Plug-in Information
    • Форматы файлов программы Nuendo
  • Мультитрек Nuendo
    • Интерфейс Nuendo
      • Создание проекта
        Структура рабочей папки проекта
        Настройка проекта, окно Project Setup
        Элементы управления в окне Nuendo Project
        Типы виртуальных треков
        Контекстное меню треков
        Программирование "горячих" клавиш
        Дополнительные настройки (Preferences)
        Окна проекта Marker, Browse Project, Pool
    • Панель Transport
    • Запись AUDIO
      • Выбор формата звукового файла
        Конфигурирование VST-входов
        Мониторинг
        Последовательная запись (Track after track)
        Параллельная многоканальная запись
  • Недеструктивное редактирование
    • Редактирование виртуального объекта
      • Манипуляторы
        Деструктивный и виртуальный фейды
    • Режимы недеструктивного редактирования
      • Операции с объектами
        Привязка к тактовой сетке (Snap)
        Операции с диапазонами
    • "Контейнер" Audio Part
      • Редактор Audio Part Editor
    • Редактор Sample Editor
      • Интерфейс редактора Sample Editor
        Недеструктивное редактирование в Sample Editor
    • Недеструктивное редактирование в окне Pool
  • Виртуальный микшер
    • Маршрутизация в Nuendo (Bus System)
      Панель VST Channel Settings
      • Common Panel
        Channel strip
        Channel Inserts
        Channel Sends
        Маршрутизация с использованием группового канала
    • Equalizer section (эквалайзер)
      • Интерфейс эквалайзера
        Эквализация с помощью анализатора спектра Spectrum Analizer
    • Работа с plug-ins
      • Качество цифровой обработки
        Задержка сигнала в plug-ins
        Сохранение настроек подключаемого модуля
        Сохранение настроек VST-микшера
    Surround в Nuendo
    • Конфигурирование Output Bus
      Surround-панорамирование
      • Особенности маршрутизации многоканального звука
    • Панель VST Master Effects
      • Подключение двухканальных модулей
        Использование матричного кодирования
    Автоматизация в Nuendo
    • "Живая" запись автоматизации
      Графическое редактирование автоматизации
      Графический ввод
      Редактирование автоматизации
      Автоматизация plug-ins
  • "Многослойное" деструктивное редактирование
    • Audio Processing
      • Конвертирование в формат 32 Bit Float
        История редактирования
        "Склеивание" слоев (Freeze Edits)
        Деструктивное редактирование общих копий (Shared Copies)
        Окно Process Plug-in
    • Редактирование в окне Pool
  • Сведение и мастеринг в Nuendo
    • Промежуточное сведение
      • Промежуточное сведение в Surround-проекте
        Модуль NuendoDither
        Временное промежуточное сведение
    • Финальное сведение
      • Моделирование естественной реверберации
    • Мастеринг с iZotope Ozone
      • Деструктивная обработка объектов с plug-in iZotope Ozone
    VST-инструменты
    • Входы и выходы VST-инструмента
  • Nuendo и Reason: совместное использование
    • Порядок запуска приложений и маршрутизация
  • Nuendo и Cubase VST: совместное использование.


Nuendo — виртуальная лаборатория звука

Начиная главу об этой замечательной программе, хочется сказать: добро пожаловать в мир Nuendo! Это приглашение — не рекламный лозунг, а отражение потока восторженных отзывов об этой программе в Интернете. Действительно, рейтинг популярности платформы Nuendo растет небывалыми темпами.
Фирма Steinberg, создавшая знаменитую программу Cubase VST, подарила миру вместе с Nuendo (www.nuendo.com) и новые понятия. Сегодня широко известно новое слово NuenDAW, обозначающее цифровую рабочую станцию аудио на базе Nuendo.
Нужно отметить, что создатели Nuendo выполнили ее интерфейс в стиле, похожем на стиль Cubase VST. К сожалению, этот шаг, сделанный для удобства пользователей, знакомых с системой Cubase, подчас служит основой ошибочного мнения, что Nuendo — это усеченный Cubase VST. Такое внешнее сравнение в корне неверно — программы Nuendo и Cubase VST предназначены для разных задач:

  • Cubase VST — это система для создания музыки (music creating & production system);
  • Nuendo — система для создания цифрового аудио (digital audio production system).

Эти программы не заменяют, а дополняют друг друга. Совместное использование обеих систем способно дать пользователю максимальный результат (см. интервью с Маркусом Клиффом (Marcus Cliffe) на сайте www.nuendo.com).

Примечание
Говоря о совместном использовании программ Nuendo и Cubase VST, нужно отметить, что, в "продвинутой студии" под Cubase VST с виртуальными VST-инструментами выделяется отдельный однопроцессорный PC, a Nuendo устанавливается на двухпроцессорный. Совместное (но не одновременное) аудиопроизводство в обеих программах возможно и на одном PC. Подробнее об этом см. в разд. 2.11 "Nuendo и Cubase VST: совместное использование".

  • Все новое воспринимается человечеством в три этапа: сначала вопрос "для чего мне это нужно?", затем догадка "можно попробовать", после чего откровение "как я раньше без этого жил!"
    Зададимся типичными вопросами: для чего создана программа Nuendo, какие преимущества она дает пользователям, чем она отличается от Cubase VST?

  • Работа с Audio, автоматизация. Nuendo имеет неоспоримые преимущества в обработке и сведении аудио, в частности в ней намного удобнее решено редактирование автоматизированных треков. В целом эргономичность интерфейса Nuendo при работе с Audio значительно выше, чем у Cubase VST.
  • Уровни отмены. В Cubase VST "традиционно" имеется только один уровень отмены последней операции, а в Nuendo — их бесконечность. Это связано с тем, что Cubase VST построен на базе MIDI-движка (MIDI-centric engine), который унаследовал одноуровневую отмену от предыдущих версий Cubase.
  • Создание звукового пространства. Nuendo разработана специально для технологий пространственного многоканального звука.
  • Высококачественный звуковой редактор. К Cubase VST для полноценного деструктивного редактирования необходимо подключать внешний звуковой редактор (например, WaveLab). Nuendo сама является многослойным Hi-End-звуковым редактором, поэтому в ней нет необходимости экспортировать звуковые данные в постороннюю программу.
  • Качество звука. Если сравнить качество софтверного смешивания Cubase VST и Nuendo, то и здесь заметна существенная разница в пользу Nuendo (особенно на двухпроцессорных машинах).
  • Виртуальный микшер. В Cubase VST количество групповых каналов фиксировано и равно восьми. В Nuendo можно самостоятельно строить сложные конфигурации виртуального микшера, используя до 64 групповых каналов.
  • Дискретность регулирования. В Cubase VST, как у приложения, основанного на МIDI-движке, дискретность регулирования громкости имеет 128 шагов (один шаг примерно в 0,2—0,5 дБ). В Nuendo дискретность регулирования громкости пренебрежимо мала — 0,01 дБ, что приближает виртуальное цифровое микширование к лучшим аппаратным образцам. Это позволяет получить гладкие переходы при изменениях уровня с записью и воспроизведением автоматизации.

Примечание
Последний пункт относится не только к Cubase VST, но и к другим программам, основанным на MIDI-движке. Поэтому качественное применение виртуального микширования на этих программах вряд ли возможно.

Перечень достоинств Nuendo можно продолжить. В этой главе мы расскажем о них подробно. Но, как известно, за все хорошее приходится чем-то платить: так и высокие показатели Nuendo при работе с цифровым аудио уравновешиваются упрощением возможностей редактирования MIDI. Этот факт, видимо, и послужил основанием для суждений о том, что Nuendo — это "усеченный Cubase". Но еще раз отметим, что это не так. Программа Nuendo обладает массой достоинств, которых нет в программе Cubase VST.
Конечно, мечты не имеют границ: человеку всегда хотелось иметь машину, которая делает все — летает в космос, ухаживает за газоном, варит кофе и т. п.
Но, к сожалению, как и в реальности, в виртуальном мире нет программ, которые делают абсолютно все и с одинаковым качеством. Единственно верный путь — это специализация: "развитие одних возможностей в ущерб другим для повышения общего качества специализированного продукта". По нему пошли и разработчики программы Nuendo. В результате пользователь получил дополнительные возможности при совместном использовании обеих программ.
Так, например, сонг Cubase VST можно импортировать в Nuendo и в ней закончить работу над проектом, либо, как уже отмечалось, выделить под виртуальную студию Cubase VST отдельный компьютер, синхронизированный с Nuendo. В этом случае проект остается доступным для редактирования на всех уровнях: от MIDI до AUDIO. Отметим, что этот вариант предпочтительней с точки зрения "прозрачности" проекта для редактирования.
Если для проекта не требуется сложное редактирование MIDI, то музыканту будет достаточно возможностей, предоставляемых Nuendo (версии 1.5 и выше), т. к. в этой программе имеется полноценный редактор MIDI Editor (аналог редактора Key Edit программы Cubase VST), возможность подключения VST-инструментов и все необходимые функции MIDI-редакти-рования.
Программа Nuendo позволяет музыкантам, даже работающим в домашней малобюджетной студии, находить интересное звучание, создавать свой — авторский звук. И, наверное, самое главное — это получать на компьютере качественное софтверное смешивание, недостижимое в программах, основанных на MIDI-движке.
Nuendo — так же, как и Cubase VST — поддерживает VST- инструменты и виртуальную шину ReWire.

Примечание
В этой главе мы рассмотрим совместное использование Nuendo и виртуальной студии Reason фирмы Propellerhead Software (http://www.propellerheads.se). Такое сочетание позволит на одном компьютере создавать полноценные электронные проекты в Surround-формате.

Для работы в Nuendo самые минимальные системные требования к PC таковы: РП-266 (или эквивалентный процессор AMD) с объемом RAM 128 Мбайт.
Емкость жесткого диска должна определяться из тех соображений, что одна минута цифрового аудио 16 бит 44 000 Гц занимает 10 Мбайт. Кроме того, Nuendo поддерживает целочисленный формат 24 бит и формат 32 бит с плавающей точкой. Поэтому емкость жесткого диска должна быть большой. Лучше вообще зарезервировать для аудиофайлов отдельный скоростной UDMA/100 жесткий диск (в крайнем случае, раздел) и отформатировать его в FAT32 с размером кластера 32 Кбайт.

Format [drive-letter]: /z:64 (DOS 7.0 (Windows 95 OSR2 и выше)).

Кроме этого, можно воспользоваться оснасткой Управление дисками Windows 2000.

Оптимизация
В Windows 2000 нужно выключить счетчики производительности дисков, набрав в командной строке (Пуск | Программы | Стандартные | Командная строка)

diskperf -N

Относительно выбора файловой системы отметим следующее. Если на компьютере используются две операционные системы, например, Windows 2000 и Windows 98, то применение NTFS сделает недоступными соответствующие разделы (или диски) из Windows 98. Однако NTFS надежнее, чем FAT 32, а вопрос сохранности аудиоданных стоит на первом месте. Поэтому, при достаточном (более 256 Мбайт) объеме RAM можно отформатировать диски для аудиофайлов в файловой системе NTFS, причем выбрать большой размер кластера — 64 Кбайт. Для этого нужно набрать в командной строке

FORMAT том: /А: размер

или воспользоваться оснасткой Управление дисками.
Оптимизация PC DAW, основанная на Nuendo (или SAWStudio) — процесс тонкий и парадоксальный. Поэтому дать универсальные советы, учитывающие весь спектр комбинаций аппаратных средств, обновлений, драйверов и.т.д. невозможно. Например, Nuendo в двухпроцессорной конфигурации (два PIII-933) может работать на 20% быстрее, если оптимизировать быстродействие для служб, работающих в фоновом режиме (разд. "Советы по оптимизации Windows 2000 для работы с SAWStudio" в главе 1). Эта рекомендация также не универсальна. Поэтому цель советов, предлагаемых в данной книге, — дать направление для самостоятельных поисков. Самой общей рекомендацией, наверное, может стать следующая: использовать разные жесткие диски для операционной системы с программами и аудиофайлов.
Для сэмплов, которые будут использоваться VST-сэмплерами, также следует зарезервировать отдельный раздел на жестком диске, причем этот раздел не должен располагаться на диске с аудиофайлами.

Рабочая конфигурация PC для Nuendo предполагает два процессора. Например: ASUS CUV4X-D, 2xPIII-933, RAM 1 Гбайт, 20 Гбайт системный жесткий диск 7200 rpm UDMA/100 и 60 Гбайт жесткий диск аудио 7200 rpm UDMA/100, Windows 2000 SP2, Matrox G400.


Настройка программы

Начнем знакомство с Nuendo с базовых настроек программы.
Взаимодействие с аудиооборудованием программа осуществляет через программный интерфейс ASIO (Audio Stream Input/Output). По умолчанию Nuendo использует ASIO Multimedia Driver для совместимости с любым звуковым оборудованием, поддержанным драйвером Windows Multimedia. ASIO Multimedia Driver устанавливается вместе с Nuendo и является стандартным компонентом.
При первом запуске Nuendo ASIO Multimedia Driver тестирует оборудование в диалоговом окне ASIO Multimedia — Audio-System-Test (рис. 2.1).

Рис. 2.1. Окно ASIO Multimedia — Audio-System-Test

Установки, определенные в результате автоматического тестирования, как правило, не требуют редактирования.
В связи с тем, что ASIO Multimedia Driver обеспечивает максимальную задержку (latency), нельзя использовать этот драйвер с виртуальными VST-инструментами при "живом" исполнении на MIDI-клавиатуре в реальном времени.
Для звуковых карт, совместимых с DirectX, можно использовать два дополнительных компонента: ASIO DirectX Driver и ASIO DirectX Full Duplex Driver.

  • ASIO DirectX Driver не поддерживает входы, поэтому он может использоваться только для сведения.
  • ASIO DirectX Full Duplex Driver поддерживает и входы и выходы, а также обеспечивает минимальную задержку. Но его полноценное использование с VST-инструментами также невозможно.

Для максимального использования возможностей Nuendo нужно применять оборудование, поддержанное специализированными ASIO-драйверами. В этом случае обеспечивается минимальная задержка в единицы миллисекунд, позволяющая использовать VST-инструменты в реальном времени.

Примечание
Самая недорогая звуковая карта, официально поддержанная специализированным ASIO-драйвером, — карта SB Audigy фирмы Creative Labs. С ней программа Nuendo уже позволяет создавать проекты в формате Dolby Surround 5.1 и в полной мере использовать VST-инструменты.

Качество звучания VST-инструментов зависит не только от карты, но и от типа ASIO-драйвера. Для максимально высокого качества нужно применять специализированные ASIO-драйвера. Далее программа Nuendo будет рассматриваться только со специализированными ASIO-драйверами.


Команда Devices I Device Setup

При запуске Nuendo загружается главное окно программы. В нем находится только транспортная панель (других окон нет, т. к. проект еще не создан).
Настройка программы осуществляется в меню Devices (Устройства) до создания проекта. Для системной настройки воспользуемся пунктом Device Setup в этом меню.


Настройка AUDIO

В появившемся окне Device Setup отметим устройство VST Multitrack в поле со списком Devices (Устройства) (рис. 2.2).

Рис. 2.2. Окно Device Setup

Правая половина окна Device Setup состоит из двух вкладок Setup и Add/Remove.
На вкладке Setup устройства VST Multitrack выполняются основные системные настройки движка Nuendo (VST engine).
Рассмотрим их.

  • Number of Disk Buffers — количество буферов жесткого диска на один аудиоканал.

Примечание
Это значение нужно подбирать для каждой конфигурации PC отдельно. Общие подходы таковы. Если Number of Disk Buffers уменьшить, то нагрузка на центральный процессор возрастет (за счет дополнительных операций ввода/вывода). Если его увеличить, это замедляет реакцию (увеличивает latency). При этом нужно учитывать, что большое количество аудиоканалов пропорционально повышает требования к объему оперативной памяти.

  • Disk Buffer Size — размер дискового буфера.

Примечание
Настройка этого параметра производится по аналогии с Number of Disk Buffers. Но, при недостаточном размере или количестве буферов, начинать настройку нужно с изменения значений в верхнем поле — увеличить количество буферов.

  • ASIO Driver — выбор типа ASIO-драйвера в раскрывающемся списке.

Примечание
В примере на рис. 2.2 используется специализированный ASIO-драйвер Creative EMUtOKx ASIO звуковой карты SB Audigy.

На рис. 2.3 изображен пример конфигурации компьютера с аудиоинтерфейсом М Audio Delta R-BUS (www.midiman.net). Интерфейс R-BUS разработан фирмой Roland специально для своих устройств, таких как, например, цифровые (виртуальные) микшеры Roland VM-3100Pro и Roland VM-7200. Применение одной платы аудиоинтерфейса М Audio Delta R-BUS обеспечивает двунаправленную передачу 24-битных аудиоданных по четырем стереоканалам.

Рис. 2.3. Выбор ASIO-драйвера M Audio Delta R-BUS

  • Clock Source — источник синхронизации.
    Если используется обычная мультимедиа-звуковая карта, то в поле Clock Source будет значение Internal (Внутренняя синхронизация). В случае более продвинутого оборудования установки синхронизации могут определяться в собственной панели управления (рис. 2.4).
  • Control Panel — вызов панели управления ASIO-драйвера. По сравнению со сложной панелью управления аудиоинтерфейса М Audio Delta R-BUS панель управления звуковой карты SB Audigy содержит только один элемент управления — ASIO Buffer Latency (рис. 2.5).
  • Release ASIO Driver in Background — флажок, обеспечивающий доступ к аудиооборудованию другим программам при работе Nuendo.

Рис. 2.4. Панель управления аудиоинтерфейса М Audio Delta R-BUS

Рис. 2.5. Creative ASIO Control Panel

  • Direct Monitoring — флажок, который разрешает управлять мониторингом в аудиооборудовании непосредственно из Nuendo таким же способом, как происходит внутренний мониторинг.
    Для осуществления работы этой опции звуковое оборудование должно поддерживать протокол ASIO 2.O. В связи с тем, что сигнал мониторинга в режиме Direct Monitoring не проходит через Nuendo, он не может обрабатываться виртуально.
  • Expert — доступ к дополнительным настройкам движка Nuendo.

Рис. 2.6. Окно VST Engine Expert Settings

  • Дополнительные настройки выполняются в окне VST Engine Expert Settings (рис. 2.6).
    • Audio Priority — в раскрывающемся списке можно изменить приоритет аудиопроцессов Nuendo. Установка низкого приоритета Low отдает приоритет остальным процессам (не аудио), например, MIDI. Этот режим следует применять в том случае, когда в проекте используется небольшое количество аудиотреков и главная задача — получить хорошую MIDI-синхронизацию. Установка значения Very High, напротив, отдает наивысший приоритет аудиопроцессам. Следует учитывать, что при такой установке могут возникать проблемы с MIDI-синхронизацией. Поэтому этот режим следует использовать только в случае сильной загруженности проекта виртуальной аудиообработкой. Остальные два режима Normal (MIDI = AUDIO) и High (AUDIO > MIDI) являются промежуточными.
    • Preload Amount — параметр, который устанавливает то количество аудиоданных (в секундах), которое может быть загружено предварительно—в момент позиционирования курсора мультитрека в режиме STOP.
    • Non Buffered Read — отключение кэширования чтения. Включать кэширование следует в том случае, если на дорожках мультитрека располагаются циклические фрагменты loops. В случае использования длинных треков, где располагаются аудиоданные большого объема, кэширование лучше отключить.
    • Non Buffered Write — отключение кэширования записи. В случае непрерывной записи длительных фрагментов кэширование записи лучше отключить.
    • Lower Latency — при установке данного- флажка включается режим минимальной задержки. В этом режиме время отклика программы на действия пользователя (например, изменение уровня громкости виртуального канала) минимально. Однако при этом может возникнуть перегрузка, сопровождаемая различными помехами (щелчками). При возникновении подобных проблем флажок следует снять.

Совет
Рекомендуем отключать Lower Latency для слабых однопроцессорных конфигураций.

    • Multi Processing — при установке данного флажка включается режим, доступный и активный только в двухпроцессорной конфигурации. Этот режим нужно обязательно оставить включенным — т. к. он обеспечивает заметное повышение производительности. Программа Nuendo распределяет обработку между обоими процессорами самостоятельно.

Примечание
Для использования мультипроцессорного режима Nuendo должна быть инсталлирована на двухпроцессорный компьютер под управлением Windows 2000.


Настройка MIDI

Настройка программы Nuendo для работы с MIDI выполняется достаточно просто.
Сначала в поле со списком устройств Devices нужно в окне Device Setup выделить устройство Default MIDI Ports (рис. 2.7).

Рис. 2.7. Выбор MIDI-порта

Затем на вкладке Setup в раскрывающихся списках MIDI Input и MIDI Output выбрать входной MIDI-порт и выходной MIDI-порт по умолчанию. В дальнейшем каждый созданный MIDI-трек будет иметь назначенные по умолчанию настройки входа и выхода.

Подключение Remote control device

Процесс виртуализации практически окончательно переместил привычный микшерный пульт с ручками и кнопками в виртуальный мир. Для управления виртуальным микшером используются специальные устройства дистанционного управления (Remote control) или микшер-контроллеры. Необходимость дистанционного управления обусловлена тем, что профессионально управлять виртуальным микшером невозможно только с помощью одной "нерасторопной стрелки мыши".
Альтернативой внешнему аппаратному микшеру может быть такое сочетание: двухпроцессорная конфигурация PC, программа Nuendo, дистанционный микшер-контроллер, который управляет виртуальным VST-микшером по MIDI.
Выбирая этот путь, нужно учитывать, что программа Nuendo напрямую поддерживает определенные типы микшер-контроллеров. Для выбора устройства нужно:

  1. 1. Перейти на вкладку Add/Remove в окне Device Setup (рис. 2.8).

  3. Рис. 2.8. Выбор Remote control device
  1. 2. Выделить устройство в поле со списком Device Classes и нажать кнопку Add.
  2. 3. Затем выделить добавленное устройство в поле со списком Devices и на вкладке Setup выбрать MIDI-порты входа и выхода в раскрывающихся списках MIDI Input и MIDI Output (если устройство использует MIDI обратную связь) (рис. 2.9).

Рис. 2.9. Настройка MIDI для Remote control device

В примере на рис. 2.9 используется MIDI/USB-устройство Steinberg Houston, которое специально разработано для VST-приложений (таких, как Nuendo).
Оно хорошо тем, что позволяет не использовать клавиатуру и мышь для управления подавляющим большинством параметров Nuendo.


Окно VST Master Setup

Главная особенность программы Nuendo — возможность профессиональной работы с пространственным многоканальным звуком (Surround Sound).
Сегодня трудно не согласиться с тем, что будущее — за многоканальным пространственным звуком. И поэтому понятен повышенный интерес компьютерных музыкантов к surround-тexнoлoгиям, вeдь в них открываются новые горизонты для творческой работы со звуком, возможности создания трехмерных звуковых миров.
Музыка во все времена являлась отражением технологий, созданных человечеством. Поэтому мы без опасений можем прогнозировать появление совершенно новых музыкальных направлений, которые до массового применения Surround были невозможны.
Сегодня существует несколько форматов многоканального звука. В соответствии с ними программа Nuendo спроектирована таким образом, чтобы пользователь мог самостоятельно сконфигурировать ее под конкретный формат. Рассмотрим, как это выполняется.
Мастер-шина (Master Bus) Nuendo максимально может иметь восемь каналов. А ее конфигурация под конкретный формат выполняется в окне VST Master Setup (рис. 2.10).
Для вызова этого окна нужно отметить опцию VST Master Setup в меню Devices.

Рис. 2.10. Окно VST Master Setup

На рис. 2.10 изображена настройка для режима стерео. В случае, если возможности Surround в Nuendo не используются, нужно выбрать пресет Stereo.
Если предполагается использовать стандартный мультиканальный формат, например, Dolby Digital 5.1, то достаточно выбрать стандартный пресет из раскрывающегося списка Presets (рис. 2.11).
Для пользовательской настройки потребуется изменить число каналов в поле Number of Channels, ввести с клавиатуры значения в поля столбцов Azimuth, Radius, Name и Label.

Рис. 2.11. Выбор стандартного формата

Точки виртуальных акустических систем можно перетаскивать мышью.
Созданную конфигурацию нужно сохранить. Для этого достаточно щелкнуть по кнопке Store. При этом в области Presets появится слово Preset с порядковым номером. Если предложенное название нужно изменить, следует щелкнуть правой кнопкой мыши на названии в области Presets, затем выбрать в контекстном меню пункт Выделить все (Select All), после чего ввести с клавиатуры новое название пресета, а затем завершить процесс нажатием клавиши <Enter>.


Окно Plug-in Information

Программа Nuendo поддерживает plug-ins двух стандартов: самый распространенный стандарт — DirectX и собственный стандарт VST-прило-жений — VST.
Для доступа к списку инсталлированных plug-ins необходимо отметить опцию Plug-in Information в меню Devices.
Окно Plug-in Information состоит из двух вкладок: VST Plug-ins и DirectX Plug-ins.
В поле Shared VST Plug-ins Folder (Папка общедоступных VST-plug-ins) задается путь к папке общедоступных VST-plug-ins.

Рис. 2.12. Окно Plug-in Information, вкладка VST Plug-ins

VST Plug-ins по умолчанию инсталлируются в папку C:\Program Files\Steinberg\Vstplugins. Кнопка Choose позволяет выбрать папку общих VST Plug-ins в дереве каталогов. Кнопка Update предназначена для обновления списка plug-ins.
Рассмотрим структуру вкладки VST Plug-ins:

  • самый левый столбец (без наименования) — отключает доступ к конкретному модулю. Если флажок установлен, то модуль доступен из VST-микшера;
  • следующий столбец — отображает количество загруженных однотипных модулей (рис. 2.13);

Совет
Если щелкнуть в поле с цифрой, указывающей количество загруженных модулей, то появится информационное окно. В примере на рис. 2.13 VST-plug-in Nu-endo Dynamics2 используется четыре раза в качестве эффекта, включенного в разрыв разных каналов (Insert Effect Channel), т. е. модуль Nuendo Dynamics2 виртуально "размножен".

  • Name — название подключаемого модуля;
  • Nb I/O — количество входов и выходов модуля;

Рис. 2.13. Вывод сведений об использовании модуля

Примечание
В Nuendo, в частности, используются специальные 8-канальные VST-plug-ins, несовместимые с Cubase VST.

  • Category — категория эффекта. Категория отражает функциональное назначение модуля. Например, модуль для мастеринга имеет категорию Mastering;
  • Vendor — фирма-производитель;
  • VST Version — версия программного модуля;
  • Delay (sample) — задержка (в отсчетах), которую вносит модуль при звуковой обработке;
  • Nb Pararas — количество регулируемых параметров модуля;
  • Nb Programs — количество программ (пресетов) в одном банке;
  • Modified — дата последней модификации модуля;
  • Folder — путь к папке размещения модуля.

Структурирование списка VST Plug-ins

VST Plug-ins представляют собой файлы с расширением dll. При инсталляции они располагаются в папке plug-ins общего доступа или в папке vstplugins, которая расположена в каталоге размещения файлов Nuendo.
Например, C:\Nuendo\vstplugins.
При большом количестве VST Plug-ins список подключаемых модулей становится длинным и его приходится постоянно прокручивать (рис. 2.14).

Примечание
Имеется в виду список доступных VST Plug-ins при подключении в структуре VST-микшера.

Рис. 2.14. Длинный список подключаемых модулей VST Plug-ins

Для того чтобы этого избежать, нужно рассортировать файлы dll по папкам. Сортировку можно выполнить, например, по функциональному признаку или по названию фирмы-изготовителя (рис. 2.15).

Рис. 2.15. Пример сортировки VST Plug-ins

Рис. 2.16. Список VST Plug-ins после сортировки

Предупреждение
При сортировке не следует применять копирование файлов dll.

После выполнения этой процедуры список структурируется и становится более удобным в работе (рис. 2.16).

Вкладка DirectX Plug-ins

На вкладке DirectX Plug-ins расположен список DirectX Plug-ins, инсталлированных в системе (рис. 2.17).

Рис. 2.17. Вкладка DirectX Plug-ins

Крайний слева столбец также служит для отключения доступа к plug-in в VST-микшере Nuendo.
Соседний столбец отображает количество загруженных модулей (или степень "размножения" модуля).
В примере на рис. 2.17 модуль Waves MondoMod m/s используется дважды. Если щелкнуть мышью в поле с номером, то в информационном окне можно определить конфигурацию подключения, так же, как и для VST Plug-ins.


Форматы файлов программы Nuendo

Рассмотрим форматы файлов, с которыми работает Nuendo (для удобства они сведены в табл. 2.1).

Таблица 2.1. Форматы файлов Nuendo

Название | Расширение | Назначение
Nuendo Project File (файл проекта) | npr | Содержит всю информацию о виртуальном проекте, включая настройки виртуального микшера, автоматизацию и plug-ins, ссылки на звуковые файлы, расположение объектов на мультитреке
Основные форматы звуковых файлов: AIFF, WAV, Real Audio, MPEG LayerS, Windows Media Audio, Broadcast Wave | aif, wav, rm, mp3, wma, wav | Содержат цифровые аудиоданные
Видеофайлы: Quick Time Video, AVI Video, MPEG Video | mov, qt, avi,mpg, mpeg | Содержат видео- и аудиоданные
MIDI-файлы | mid | Содержат MIDI-данные
Импортируемые файлы, содержащие данные (дополнительно, кроме вышеперечисленных): AIFC, REX (ReCycle), SD2 (Sound Designer II) | aif, rex, асЗ,sd2 | Содержат аудиоданные
Pool File (Library) | npl | Библиотека звуковых и видеофайлов
Key Commands File | key | Содержит настройки "горячих" клавиш
VST Mixer Settings | vmx | Содержит настройки виртуального микшера
Импортируемые файлы проектов: Open Media Framework Inter- change (OMFI), OpenTL, Premiere Generic EDL, Cubase Song | omf, tl, edl, all | Импортируемые файлы проектов, созданные в других приложениях. (OMFI — независимый формат, предназначенный для обмена между приложениями.)
Экспортируемые файлы проектов: OMFI, OpenTL | omf, tl | Экспорт проекта Nuendo в форматы файлов других приложений

Для обычного пользователя, использующего в своем творчестве только PC, интересен процесс импорта сонга Cubase VST в проект Nuendo.


Мультитрек Nuendo

Прежде чем перейти к детальному рассмотрению интерфейса Nuendo, мы предварительно познакомимся с ее системой шин (Bus System).
Для этого нужно снова зайти в меню Devices и выбрать пункты VST Inputs (клавиша <F5>) и VST Outputs (клавиша <F4>).
На рис. 2.18 изображен пример конфигурации VST-входов для специализированного ASIO-драйвера звуковой карты SB Audigy.

Рис. 2.18. Окно VST Inputs звуковой карты SB Audigy

Примечание
Еще раз отметим, что для максимального использования возможностей Nuendo необходимо применять оборудование, поддержанное специализированными ASIO-драйверами. Поэтому случай использования ASIO Multimedia Driver мы не рассматриваем.

ASIO-драйвер звуковой карты SB Audigy обеспечивает шесть стереовходов. Для того чтобы сделать вход активным, нужно нажать кнопку On. Желтый цвет этой кнопки означает, что вход активен.
На рис. 2.19 изображен пример конфигурации VST-входов аудиоинтерфейса М Audio Delta R-BUS.

Конфигурирование VST-выходов выполняется в окне VST Outputs (рис. 2.20).

Рис. 2.19. Окно VST Inputs аудиоинтерфейса M Audio Delta R-BUS

Рис. 2.20. Окно VST Outputs звуковой карты SB Audigy

Для активизации VST-выхода необходимо нажать кнопку Active. VST-выходы можно переназначать. Для этого достаточно щелкнуть в любом нижнем поле (рис. 2.21) и выбрать в раскрывающемся списке физический выход.
VST-выходы можно переименовывать. Пример переименования изображен на рис. 2.21.
По умолчанию фейдеры каждого VST-выхода связаны между собой. Если нажать на кнопку с изображением замка (на рис. 2.21 отмечена стрелкой), то фейдеры разблокируются и перейдут в режим раздельной регулировки.
На рис. 2.22 изображен пример переназначения VST-выходов для аудиоинтерфейса M Audio Delta R-BUS.

Рис. 2.21. Переназначение VST-выходов звуковой карты SB Audigy

Рис. 2.22. Переназначение VST-выходов M Audio Delta R-BUS

Шина BUS 1, не имеющая кнопки Active, всегда включена и называется мастер-шиной (Master Bus). По умолчанию все аудиоканалы назначены на мастер-шину. Конфигурация VST-входов и VST-выходов сохраняется вместе с проектом Nuendo. Однако при смене ASIO-драйвера эти настройки будут проигнорированы.


Создание проекта

При загрузке программы открывается главное окно (пустое). Для начала работы необходимо создать проект.
Проект — это базовое понятие программы Nuendo. Он содержит конфигурацию мультитрека и виртуального VST-микшера по аналогии с сонгом Cubase VST или сессией SAWStudio.
Создание проекта начинается с выполнения команды меню File | New Project (комбинация клавиш <Ctrl>+<N>). При этом открывается диалоговое окно New Project (рис. 2.23).

Рис. 2.23. Окно New Project

В Nuendo проекты создаются из шаблонов, расположенных в списке Templates.

Примечание
Например, если путь к программе C:\Nuendo, то путь к шаблонам C:\Nuendo\Templates.

В окне New Project шаблоны отображаются в виде списка. Названия шаблонов в списке — это названия проектов (файлов npr), расположенных в списке Templates.
Предложенные в списке шаблоны предназначены для различного функционального применения Nuendo.

Примечание
Ниже мы рассмотрим процесс создания собственного шаблона.

Итак, для того, чтобы создать проект, нужно выделить шаблон в списке и нажать на кнопку ОК.
Для использования Nuendo в качестве AUDIO/MIDI-секвенсора можно выбрать шаблон Audio-MIDI Music Production. В этом случае будет создан привычный проект, похожий на сонг программы Cubase VST (созданный по умолчанию — def.all).
Для дальнейшего изложения мы выберем системный шаблон Empty (Пустой), который не является проектом npr в списке Templates.

Рис. 2.24. Окно Set Project Folder

Далее Nuendo предлагает задать рабочую папку проекта в окне Set Project Folder.
Здесь процесс разветвляется на два способа:

  • Выделить предварительно созданную папку и нажать на кнопку Select (рис. 2.24).
  • В строке Directory name ввести с клавиатуры новое название рабочей папки и нажать на кнопку Create (рис. 2.25).

Примечание
Кнопка Select изменит свое название на Create в момент начала ввода с клавиатуры.

Рис. 2.25. Создание рабочей папки проекта


Структура рабочей папки проекта

Программа Nuendo, как хорошая хозяйка, автоматически наводит порядок в размещении всех рабочих файлов проекта. Это очень полезная особенность Nuendo. Так, если для дальнейшей работы возникнет необходимость переместить проект на другой компьютер (например, в студию), то достаточно будет скопировать лишь рабочую папку проекта.
Помимо этого, если на жестком диске расположено одновременно несколько проектов, то, благодаря этой функции, исключена случайная потеря нужных файлов при удалении одного из них.
Работа с файлами в программе Nuendo может иметь достаточно высокий уровень сложности: например, при многослойном деструктивном редактировании (см. разд. "'Многослойное' деструктивное редактирование" далее в этой главе). В этом случае программа создает большое количество дополнительных звуковых файлов, автоматически присваивая им имена по определенному алгоритму.
Пользователю нужно очень хорошо представлять структуру рабочей папки проекта, т. к. случайная потеря звуковых файлов может полностью парализовать всю дальнейшую работу.
Структура рабочего каталога Nuendo изображена на рис. 2.26.
Файлы npr, csh, bak являются информационными, т. е. содержат служебную информацию проекта.
В примере на рис. 2.26 файлы распределены таким образом: Project1.npr — это проект; Project1.bak — резервная копия проекта; Project1.csh — информация об имидже отредактированных объектов (этот файл появляется в том случае, если к объектам было применено деструктивное редактирование).

Рис. 2.26. Структура рабочей папки

Перейдем к рассмотрению вложенных папок.

  • Папка Audio содержит звуковые файлы, которые были записаны в Nuendo или импортированы в проект с копированием в рабочую папку.
  • Папка Fades предназначена для тех звуковых файлов, которые явились фрагментами объектов со свойствами Fade In и Fade Out.

Примечание
Забегая вперед, отметим, что в Nuendo операции с манипуляторами объектов Fade In/Out выполняются деструктивно. Происходит это так. В специально созданной папке Fades размещается деструктивно обработанная копия фрагмента, длина которого равна длине линии Fade. И ссылка при этом автоматически переназначается на копию Fade. Такое решение избавляет процессор от лишних вычислений Fade In/Out, что позволяет использовать высвобожденные ресурсы более эффективно.

  • Папка Images заполняется графическими имиджами (Peak-файлами) звуковых файлов. Имиджи имеют наглядное расширение peak.
  • Папка Edits появляется в случае использования деструктивного редактирования.
    В ней сохраняются результаты деструктивного редактирования (слои) или, иначе говоря, этапы редактирования в виде отдельных звуковых файлов.


Настройка проекта, окно Project Setup

После проведения подготовительных операций, описанных выше, проект будет создан и в главном окне программы откроется окно Nuendo Project — новое окно с мультитреком Nuendo (рис. 2.27).

Рис. 2.27. Окно проекта Nuendo Project

Нужно отметить, что интерфейс окна Nuendo Project имеет много общего с интерфейсом окна MultiTrack программы SAWStudio:

  • все основные элементы управления расположены в верхней секции (Toolbar);
  • под элементами управления расположена информационная панель Info Line;
  • в нижней части окна располагаются слева — секция треков (Track List) и справа — секция объектов (Event Display). Границу между этими секциями можно перемещать.

Но перед знакомством с элементами управления обратимся к настройкам проекта.

Терминология
В Nuendo используются термины Event (событие) и Part (часть) для обозначения объектов на мультитреке. Между Event и Part существуют различия, которые будут рассматриваться в дальнейшем. В тех местах главы, где различие между Event и Part несущественно, будет применяться обобщенный термин — объект.

Для доступа к настройкам в меню Project предусмотрен отдельный пункт — Project Setup (комбинация клавиш <Shift>+<S>). Параметры проекта частично отображаются в трех полях, расположенных между секцией треков и информационной панелью (рис. 2.28). Для доступа к окну Project Setup достаточно щелкнуть мышью на любом из них.

Рис. 2.28. Настройка проекта

Рассмотрим параметры проекта более детально.

  • Start — стартовая позиция проекта. В этом поле можно задать другую стартовую точку начала.
  • Length — длина проекта. (Длина проекта увеличивается автоматически, поэтому нет необходимости специально изменять этот параметр.)
  • Frame Rate — частота кадров. Параметр, имеющий отношение к синхронизации Nuendo с внешним оборудованием.
  • Display Format — глобальная установка формата измерения времени по шкале Ruler. В Nuendo предусмотрена возможность независимой установки временного формата для разных окон редакторов. Работа с loops и MIDI требует установки формата Bars+Beats (такты + доли).
  • Display Offset — смещение шкалы Ruler. Применяется при синхронизации с внешним оборудованием в том случае, если смещена стартовая позиция проекта (поле Start). Установка смещения Display Offset равной смещению стартовой позиции проекта приведет начало Ruler в нулевую точку.
  • Sample Rate — частота дискретизации проекта. Величина Sample Rate определяется возможностями оборудования и задачей. Запись и воспроизведение звуковых файлов в проекте осуществляется с частотой дискретизации проекта.

Примечание
Например, при использовании специализированных ASIO-драйверов звуковой карты SB Audigy частота дискретизации ограничена одной величиной — 48 кГц. При импорте в проект звуковых файлов с отличающейся частотой дискретизации программа в специальном диалоговом окне предложит их конвертировать для соответствия частоте дискретизации проекта.

  • Record Format — разрядность звуковых файлов, записываемых в проект.

Примечание
Nuendo позволяет записывать и воспроизводить звуковые файлы с 16-, 24- и 32-разрядным разрешением. 32-разрядный формат с плавающей точкой — это внутренний формат данных Nuendo. Поэтому для достижения максимального качества следует использовать именно его. Параметр Record Format влияет не только на разрядность записываемых файлов, но также и на параметры конвертирования файлов, импортируемых в проект. Если в проекте не предполагается деструктивная обработка звуковых файлов, то разрядность проекта можно установить в 24 Bit. Преимущества формата 32 Bit Float проявляются при многослойном деструктивном редактировании, т. к. этот формат обладает огромным виртуальным динамическим диапазоном.


Элементы управления в окне Nuendo Project

В программе Nuendo хороший дизайн, отличающийся лаконичностью, а также интуитивно понятный интерфейс. Здесь.нет той избыточности, которая вместо того, чтобы помочь пользователю, в большинстве случаев лишь утомляет. Однако при своей кажущейся простоте Nuendo достаточно сложная программа и в ней, как и в SAWStudio, много различных неочевидных возможностей.

Панель инструментов Toolbar

Начнем знакомство с интерфейсом с панели инструментов — Toolbar.

Совет
Рекомендуем для комфортного использования Nuendo применять разрешение монитора не менее 1024x768.

Панель инструментов традиционно занимает верхнюю часть окна Nuendo Project и представляет собой ряд красиво оформленных кнопок и раскрывающихся списков (рис. 2.28).
В Nuendo можно одновременно работать с несколькими проектами. Сделать активным один из проектов позволяет кнопка-индикатор [image] (Activate Project), которая расположена в левом верхнем углу.
Разделим кнопки панели Toolbar на 4 группы — в соответствии с их функционачьным назначением.

  • Первая группа. Кнопки, предназначенные для вызова информационной панели и других окон проекта.
    (Show Info) — отображение информационной панели Info Line.
    (Open Pool) — вызов окна Pool, в котором содержится иерархический список ссылок (аудиоклипов и регионов) на звуковые файлы проекта.
    (Open Browser) — вызов окна Browse Project, предназначенного для точного редактирования параметров проекта, таких как числовые значения точек автоматизации, позиции объектов на мультитреке и т. д.
    (Open Marker) — вызов окна Marker, представляющего собой список вкладок проекта.
  • Вторая группа. Кнопки, находящиеся на панели инструментов редактирования проекта (рис. 2.29) (слева направо):

Рис. 2.29. Панель инструментов редактирования проекта

    • Object Selection — редактирование в режиме объектов;
    • Range Selection — редактирование в режиме диапазонов (Range);
    • Split — разрезание объектов;
    • Glue — склеивание объектов;
    • Erase — стирание объектов;
    • Zoom — изменение масштаба;
    • Mute — приглушение объектов;
    • Draw/Line — инструмент рисования линий автоматизации, MIDI-сообщений и объектов, а также редактирования на уровне отсчетов;
    • Scrub/Play — инструмент контрольного прослушивания в режиме подчистки или воспроизведения.

    Примечание
    Для переключения между сдвоенными инструментами (например, Scrub/Play) нужно повторно щелкнуть по подсвеченной кнопке инструмента и выбрать неотмеченный пункт раскрывающегося списка.

    • Отдельно (справа) от панели, инструментов редактирования расположена
      кнопка       Autoscroll [image], отвечающая за автоматическую прокрутку окна проекта при воспроизведении.
    • Третья группа. Кнопки сдвига и привязки объектов, находящиеся на панели инструментов Nudge и Snap (рис. 2.30) (слева направо).

    Рис. 2.30. Панель инструментов Nudge и Snap

      • Trim Start Left (Right) — две кнопки, выполняющие сдвиг влево (вправо) стартовой границы выделенных объектов на величину, установленную в раскрывающемся списке Snap;

    Примечание
    Формат отображения времени в списке Snap соответствует установленному формату линейки Ruler. Если установлен режим отображения времени Bars+Beats, то в раскрывающемся списке Snap отображаются такты, доли и длительности. В примере на рис. 2.30 величина Snap установлена равной музыкальному такту (Ваг).

      • Move Left (Right) — две кнопки, выполняющие сдвиг выделенных объектов влево (вправо) на величину Snap;
      • Trim End Left (Right) — две кнопки, выполняющие сдвиг влево (вправо) финальной границы выделенных объектов на величину, установленную в раскрывающемся списке Snap;
      • Snap (привязка) — раскрывающийся список параметров, значения которых задают точность позиционирования объектов (диапазонов), а также их границ для операций недеструктивного редактирования.
    • Четвертая группа. Кнопки, находящиеся на панели функций Snap и Quantize (рис. 2.31) (слева направо).

    Рис. 2.31. Панель функций Snap и Quantize

      • Snap to Zero Crossing — привязка к нулевым отсчетам. Редактирование Audio происходит с автоматическим поиском и привязкой к ближайшему отсчету с нулевой амплитудой. Этот режим предохраняет от щелчков в местах стыковки объектов;
      • Snap — включение функции привязки Snap. Если функция активна, то объекты могут занимать только "разрешенные" позиции. При этом привязка объектов осуществляется с помощью специальной точки синхронизации Sync Point (подробнее об этом см. в разд. "Привязка к тактовой сетке (Snap) " далее в этой главе);
      • раскрывающийся список режимов Snap. (В Nuendo используется семь режимов Snap, которые мы подробно рассмотрим в разд. "Режимы функции Snap " далее в этой главе);
      • раскрывающийся список Quantize, предназначенный для операций квантизации MIDI-сообщений.

Изменение масштаба (Zoom)

При редактировании виртуального проекта часто требуется изменять масштаб отображения объектов.
В программе Nuendo управление масштабом производится предельно просто и наглядно.
В правом нижнем углу окна проекта расположены два слайдера (slider), предназначенные для управления масштабом по горизонтали и по вертикали (см. рис. 2.27). Они дублируются комбинациями "горячих" клавиш, которые в Nuendo можно программировать самостоятельно (см. разд. "Программирование 'горячих' клавиш" далее в этой главе).

    Cовет
    Быстро изменить масштаб по горизонтали можно с помощью мыши. Для этого нужно щелкнуть левой кнопкой мыши на линейке Ruler и, удерживая кнопку нажатой, протащить курсор мыши вверх или вниз вдоль курсора мультитрека (рис. 2.32).
    Для этого должен быть установлен флажок Zoom while Locating in Time Scale на странице Transport в дополнительных настройках Preferences (см. разд. "Дополнительные настройки" далее в этой главе).

    Слайдер Waveform Zoom, расположенный в правом верхнем углу окна проекта, изменяет масштаб отображения формы волны объекта.

    Совет
    Слайдер Waveform Zoom лучше всего удерживать в нижнем положении, чтобы форма волны объектов отображала достоверную информацию об уровне сигнала. Детально исследовать форму волны лучше в редакторе Sample Editor (см. разд. "Редактор Sample Editor" далее в этой главе).

    Рис. 2.32. Быстрое изменение горизонтального масштаба

    В Nuendo предусмотрен дополнительный сервис, позволяющий сохранять текущий горизонтальный масштаб и отображаемую временную позицию на линейке Ruler.
    Для этого в нижней части окна Nuendo Project под секцией Event Display
    расположен раскрывающийся список пресетов и две кнопки "+" и "-" (рис. 2.33).

    Рис. 2.33. Список пресетов Zoom

Каждое нажатие на кнопку "+" сохраняет текущие настройки Zoom в виде пресета. Для удаления пресета его необходимо предварительно выбрать и затем нажать кнопку "-". Встроенный пресет Full отображает проект полностью.
Названия пресетов по умолчанию состоят из имени Zoom и номера пресета. Пресетам рекомендуется дать определенные названия (иначе теряется смысл в использовании данного сервиса). Для этого достаточно щелкнуть на имени пресета и ввести новое название с клавиатуры.


Типы виртуальных треков

Конечно, на первых этапах знакомства с Nuendo можно создавать проекты из готовых шаблонов. Но рано или поздно пользователю придется изменить структуру проекта, т. к. шаблоны не могут учитывать всего многообразия возникающих задач.
Для создания треков в Nuendo существует меню Project | Add Track. Кроме того, треки можно создавать (добавлять) с помощью контекстного меню, если щелкнуть правой кнопкой мыши в секции Track List (рис. 2.34).

Рис. 2.34. Добавление виртуального трека

Совет
Команды добавления треков можно запрограммировать как комбинации "горячих" клавиш (см. рис. 2.34).

Рассмотрим типы виртуальных треков Nuendo более детально.

Примечание
Здесь мы будем предварительно знакомиться с элементами управления виртуального микшера. Подробно виртуальный микшер будет рассматриваться в разд. "Виртуальный микшер".

Audio Track

Аудиотрек (Audio Track) создается (добавляется) командой Audio в меню Project | Add Track или командой Add Audio Track контекстного меню секции Track List. Максимальное количество аудиотреков в Nuendo ограничено числом 500. Но не стоит воспринимать эту возможность как руководство к действию: на практике количество треков определяется здравым смыслом, решаемой задачей и зависит от конфигурации компьютера.

Совет
Не стоит без необходимости создавать треки, например, заранее — "про запас". Ведь каждая аудиодорожка — это расходование ресурсов, и прежде всего оперативной памяти. Разумное решение состоит в гибком расходовании ресурсов, т. е. добавлении аудиодорожек по мере необходимости.

Проведем сравнение, подчеркивающее преимущества программы Nuendo. В программе Cubase VST количество виртуальных каналов (то есть использование RAM) задается при настройке (в окне Audio System Setup) и в дальнейшем не зависит от количества Аудиотреков, которые при недостаточном количестве каналов конкурируют друг с другом. Это обязывает пользователя предварительно рассчитывать первоначальное количество каналов и затем его периодически корректировать.
В Nuendo расходование ресурсов организовано разумнее: они выделяются автоматически при создании каждого нового аудиотрека (что, несомненно, значительно удобнее).
Связь виртуальных каналов и дорожек в программе Nuendo тоже решена проще, чем в Cubase VST.
Каждый аудиотрек автоматически закрепляет за собой отдельный канал виртуального микшера. Поэтому нет "борьбы" между аудиодорожками за виртуальный канал микшера.
На аудиодорожках размещаются объекты, которые представляют собой аудиособытия (Audio Events) или аудиочасти (Audio Parts).
Разработчики программы Nuendo нашли способ просто и красиво разместить данные автоматизации.
Эти данные записываются на субтреки (Subtrаck), которые имеются у каждого аудиотрека. Количество таких субтреков зависит от числа типов автоматизированных данных.
Сравнивая Nuendo с другими программами, можно выделить ее положительные черты. Здесь пользователь, с одной стороны, избавлен от избыточной информации, а с другой — может быстро получить доступ одновременно ко всем типам автоматизированных данных выбрав команду Show Automation for All Tracks в контекстном меню треков (см. разд. "Контекстное меню треков" далее в этой главе).

Примечание
Напомним, что в SAWStudio необходимо было применять фильтрацию для раздельного редактирования нескольких типов данных автоматизации одной дорожки (клавиша <V>). А в Cubase VST 5.0 пользователь вынужден разыскивать нужный тип данных, обозревая в окне Controller всю структуру VST-микшера.

Рассмотрим элементы управления аудиотрека (рис. 2.35).

Рис. 2.35. Элементы управления аудиотрека

  • Кнопка + (Show/Hide Automation) (на рис. 2.35 обозначена цифрой 1) предназначена для доступа к субтрекам автоматизации. Щелчок по ней меняет пиктограмму на -. Это означает, что субтрек (субтреки) открыт. Повторный щелчок делает обратную операцию — скрывает субтрек (субтреки), возвращая символ +.
  • Три кнопки — FX, EQ и Ins — вызывают окно VST Channel Settings, которое обеспечивает доступ ко всем настройкам канала. Эти кнопки также служат индикаторами/выключателями (подробнее об этом см. в разд. "Виртуальный микшер" далее в этой главе).

Примечание
FX (Show/Enable Aux Sends), EQ (Show/Enable Equalizer) и Ins (Show/Enable Inserts).

  • Поле Name Field (см. рис. 2.35, цифра 2) — содержит название трека. По умолчанию треку присваивается название Audio N, где N — номер трека. Для изменения имени трека достаточно на нем щелкнуть и ввести новое название с клавиатуры.
  • Кнопка Toggle Timebase (см. рис. 2.35, цифра 3), переключает режимы трека: Time Base и Tempo Base.

Примечание
Разработчики не рекомендуют переключать режимы многократно, т. к. это может привести к потере точности позиционирования объектов на треке. Для MIDI-треков установлен режим Tempo Base. Поэтому их темп при воспроизведении зависит как от общего темпа проекта, так и от графика Tempo Track. Все аудиотреки по умолчанию установлены в режим Time Base, но пользователь может переключать режим на Tempo Base. Тогда временнью позиции объектов станут зависимыми от установок темпа. Режим Tempo Base нужно также использовать для тех треков, куда будут импортироваться ReCycle-файлы с расширением rex. В этом случае темп воспроизведения ReCycle-файла будет зависеть от установок темпа проекта Nuendo.

  • Кнопка R (Record Enable) включает режим записи аудиотрека. Активность режима записи индицируется миганием кнопки.
  • Кнопка М (Mute) (см. рис. 2.35, верхний ряд) — приглушает трек.
  • Кнопка S (Solo) — включает режим Solo.
  • Кнопка М (Monitor) (см. рис. 2.35, цифра 4) — включает режим мониторинга (подробнее см. в разд. "Мониторинг" далее в этой главе).
  • Кнопка Stereo/Mono (см. рис. 2.35, цифра 5) — предназначена для переключения режимов стерео и моно. В зависимости от выбранного режима будет производиться стереофоническая или монофоническая запись на аудиотрек. При импорте в проект звукового файла режим Stereo/Mono устанавливается автоматически — в зависимости от типа файла.
  • Кнопка Lock (см. рис. 2.35, цифра 6) — предназначена для блокировки трека. В режиме блокировки все операции деструктивного и недеструктивного редактирования на треке запрещены. Ни один объект нельзя скопировать или перетащить с заблокированного трека или на заблокированный трек.
  • Индикатор (см. рис. 2.35, цифра 7) — показывает уровень записи/ воспроизведения.

MIDI Track

Количество MIDI-треков (MIDI Track) в Nuendo не ограничено. Они создаются командой Project | Add Track | MIDI или командой Add MIDI Track контекстного меню секции Track List.
Программа Nuendo является виртуальной AUDIO/MIDI-студией (как и Cubase VST). Поэтому в ней можно полноценно использовать виртуальные VST-инструменты и, как уже говорилось, связываться с виртуальной студией Reason по протоколу ReWire.
В начале главы мы отмечали, что в Nuendo работа с MIDI реализована проще, чем в Cubase VST. Благодаря этому факту многие компьютерные музыканты, которым требовался несложный MIDI-секвенсор, лишь дополняющий мощные возможности AUDIO, получили все это в одном VST-приложении. Поэтому, когда появилась на свет программа Nuendo, ее графический интерфейс управления MIDI-треком оказался реализован просто и лаконично, отчасти напоминая панель Inspector в Cubase VST.
Рассмотрим этот интерфейс детально (рис. 2.36).

Рис. 2.36. Элементы управления MIDI-трека

  • Поле Name Field — служит для наименования MIDI-треков (выполняет ту же функцию, что и для аудиотрека). По умолчанию в поле Name Field пишется MIDI N, где N- номер MIDI-трека.
  • Раскрывающийся список Output (на рис. 2.36 обозначен как MIDI Out) — позволяет назначить MIDI-трек на MIDI-порт.
  • Если используются VST-инструменты или программа Reason, то в списке появляются виртуальные MIDI-порты. Для управления внешним синтезатором следует выбрать внешний MIDI-порт. На рис. 2.37 изображен пример выбора внешнего MIDI-порта для звуковой карты M-Audio Audiophile 2496.
  • Раскрывающийся список Input (на рис. 2.36 обозначен как MIDI In) — предназначен для выбора MIDI-входа. Содержание этого списка зависит от типа используемого MIDI-оборудования. (В случае использования, например, мультимедийной звуковой карты SB Audigy — следует выбрать SB Audigy MIDI Port [C400]).

Совет
Для того чтобы назначить один и тот же MIDI-порт сразу для всех MIDI-треков, следует осуществить выбор в списке с нажатой клавишей <Ctrl>.

Рис. 2.37. Выбор внешнего MIDI-порта

  • Списки Bank и Program — позволяют выбирать тембры (звуки, программы).
    Выбор номера программы в списке Program формирует MIDI-сообщение Program Change, а выбор номера банка — MIDI-сообщение Bank Select.
  • Раскрывающийся список Channel, обозначенный на рис. 2.36 как MIDI Channel, предназначен для выбора MIDI-канала.
  • Кнопка Toggle Timebase выполняет ту же функцию, что и для аудиотрека. Но для MIDI-трека режим по умолчанию — Tempobase. В этом режиме воспроизведение MIDI-объектов зависит от установок темпа проекта и графика Tempo Track (см. разд. "Nuendo и Reason: совместное использование" далее в этой главе).
  • Кнопка R (Record Enable) — разрешает режим записи на MIDI-трек.

Предупреждение
При нажатии на кнопку R входящие MIDI-сообщения начинают поступать на MIDI-порт, выбранный в списке Output. Поэтому до активизации режима Record Enable отклик, например, на нажатие клавиши MIDI-клавиатуры, — неслышен.

  • Кнопки М (Mute) и S (Solo) — выполняют такие же функции, как и для аудиотрека.
  • Кнопка Lock — блокирует операции копирования и перемещения на MIDI-треке.
  • Индикатор активности MIDI обозначен на рис. 2.36 буквой А.

Group Channel Track

Групповой канал (Group Channel Track) — это универсальный строительный материал для конструирования виртуального VST-микшера.
В программе Nuendo виртуальный микшер не является величиной с постоянными параметрами. Поэтому пользователь имеет большую свободу выбора при конструировании виртуальных маршрутов.

Примечание
Если сравнивать Nuendo с Cubase VST, то можно отметить, что здесь Nuendo тоже в выигрыше: у нее максимальное число групп — 64, в то время как у Cubase VST — только восемь групповых каналов.

Групповые каналы в Nuendo можно использовать в разных целях:

  • для объединения аудиотреков;
  • для объединения других групп;
  • в качестве шины Send Effects (эффектов посыла) — когда на группу посылаются сигналы с аудиотреков и других групп.

На дорожке Group Channel Track размещаются данные автоматизации — поэтому выглядят эти дорожки в окне проекта так же, как и субтреки аудиотреков.

Примечание
Все остальное управление групповым каналом осуществляется в окнах VST Mixer и VST Channel Settings.

Каждая новая дорожка Group Channel Track резервирует один канал VST-микшера.
На рис. 2.38 изображены элементы управления Group Channel Track.

Рис. 2.38. Элементы управления Group Channel Track

  • Кнопка "+" (Append Automation Track) добавляет субтреки группового канала. Кнопка "-", наоборот, убирает добавленные субтреки.

Примечание
Вся информация этого раздела относится к любым субтрекам автоматизации. Ведь фактически групповой канал в окне проекта тоже можно представить как первый субтрек автоматизации группового канала.

  • Раскрывающийся список, обозначенный на рис. 2.38 цифрой 1, предназначен для выбора автоматизируемого параметра. По умолчанию в списке присутствует один параметр Volume (Громкость). Для добавления параметров нужно выбрать пункт раскрывающегося списка Add. Тогда в появившемся окне Add Parameter станет доступным весь список автоматизируемых параметров канала (рис. 2.39).

Рис. 2.39. Выбор автоматизируемого параметра канала

Совет
Параметры в списке можно выделять (и добавлять) группами с клавишами <Shift> или <Ctrl>. В этом случае после добавления группы параметров достаточно открыть субтреки с помощью кнопок "+" или команды Show Automation контекстного меню аудиотрека (рис. 2.40).

Рис. 2.40. Субтреки с добавленными параметрами

Примечание
Параметры добавляются автоматически при "живой" записи автоматизации (подробнее об этом в разд."Автоматизация в Nuendo" далее в этой главе).

  • Числовое поле, обозначенное на рис. 2.38 цифрой 2, выполняет одновременно две функции: в нем параметр отображается и здесь же его можно регулировать.
    Параметры автоматизации делятся на непрерывные (contiguous) и переключатели (switch):
    • отображение switch-параметра осуществляется словами Off и On. Его переключение осуществляется по каждому щелчку мыши в числовом поле "2" (см. рис. 2.38);
    • отображение непрерывного параметра передается числовым значением. Регулируется оно с помощью виртуального слайдера, появляющегося при удержании кнопки мыши (рис. 2.41).

Рис. 2.41. Регулирование непрерывного параметра

  • Кнопка W (Write Automation) включает режим записи автоматизации группового канала.
  • Кнопка R (Read Automation) включает режим чтения данных автоматизации (Automation Events).
  • Кнопка М (Mute Automation) блокирует чтение данных автоматизации на субтреке.
    Режим Mute Automation позволяет выборочно отключать автоматизацию только одного параметра без отмены режима.чтения остальных данных.
  • Кнопка Lock запрещает какое-либо редактирование или запись данных автоматизации.

Master Automation Track

Этот трек в секции Track List называется так: VST Mixer. В проекте может быть только один Master Automation Track. Выглядит он как обычный трек автоматизации и отличается только своей специализацией.
Окно Add Parameter этого трека содержит следующие параметры:

  • Master Gain — автоматизация регулятора уровня Master;
  • Bus N (L и R) Volume, где N — номер выходной шины Output Bus;

Примечание
Количество шин (Output Bus) зависит от возможностей оборудования и типа ASIO-драйвера.

  • Effect 1 Input Level — Effect 8 Input Level — автоматизация регуляторов входного уровня восьми Send-эффектов (панель VST Send Effects вызывается клавишей <F6>) — рис. 2.42.

Рис. 2.42. Автоматизация входного уровня эффектов панели VST Send Effects

Plug-in Automation Track

Это еще один специализированный трек автоматизации. В секции Track List он называется VST Effects. В проекте допустим только один Plug-in Automation Track.
Параметрами автоматизации здесь выступают настройки подключенных VST-plug-ins в панелях VST Send Effects, VST Master Effects (клавиша <F7>), а также параметры VST-инструментов, подключенных в панели VST Instruments (клавиша <F11>). В окне Add Parameter каждый такой параметр начинается с обозначения Sn, Mn или In:

  • Sn (Send n) , где n — номер слота панели VST Send Effects;
  • Mn (Master n), где n — номер слота панели VST Master Effects (рис. 2.43);
  • In (Instruments n), где n— номер слота панели VST Instruments.

Рис. 2.43. Панель VST Master Effects

Через субтреки может быть получен быстрый доступ к данным автоматизации каждого параметра.

Marker Track

Для работы с закладками (или маркерами) в Nuendo предусмотрен специальный трек — маркер-трек (Marker Track). Он создается командой Project | Add Track | Marker, либо через контекстное меню Track List — командой Add Marker Track. В проекте может быть только один Marker Track.

Совет
Marker Track лучше всего сделать первой, самой верхней дорожкой проекта.

Рис. 2.44. Пример размещения маркеров на Marker Track

На рис. 2.44 изображен пример размещения маркеров на Marker Track. Специальные маркеры L (Left) и R (Right) ограничивают рабочую область (выполняют функцию, аналогичную локаторам программы Cubase VST). В Nuendo они имеют то же название — локаторы, — что и в Cubase VST.
По умолчанию локаторы L и R "сложены" в нулевой (Zero) точке проекта. Ухватившись мышью за R-локатор, можно переместить его вправо — ограничивая, тем самым, рабочую область.

Рабочая область
По аналогии с Cubase VST в программе Nuendo рабочая область — пространство, ограниченное специальными маркерами L и R (которые в дальнейшем будут называться локаторы).
Именно между этими локаторами "течет жизнь": здесь создаются Audio Part или MIDI Part (часть), осуществляется циклическая запись или циклическое воспроизведение и т. п. Иными словами, рабочая область — это область редактирования проекта.

Перетаскивание локаторов L и R вручную — это не самый удобный способ. Есть способы, позволяющие быстро выделить рабочую область.

  • <Ctrl>+<1> (<Сtrl>+<Доп.1>) — установка левого локатора в текущей позиции курсора мультитрека.

Примечание
<Доп.1> — клавиша <1> на дополнительной клавиатуре.

  • <Ctrl>+<2> (<Ctrl>+<Доп.2>) — установка правого локатора в текущей позиции курсора.
  • Выделение объекта (объектов) в секции Event Display и нажатие клавиши <Р>.
    В этом случае локаторы расположатся точно на границах объекта (объектов).
  • Выделение диапазона Range и нажатие клавиши <Р> (при этом длина диапазона должна быть не менее половины секунды).
    Локаторы расположатся точно на границах диапазона.
  • <Ctrl> + щелчок мышью на линейке Ruler позиционирует левый локатор.
  • <Alt> + щелчок мышью на линейке Ruler позиционирует правый локатор.

Удерживая клавишу <Ctrl> или <Alt>, можно перетаскивать соответственно левый или правый локатор (рис. 2.45).
Позиционирование курсора на одном из локаторов выполняется так:

  • <Доп.1> (<Shift>+<1>) — в позицию левого локатора;
  • <Доп.2> (<Shift>+<2>) — в позицию правого локатора.

Рис. 2.45. Перемещение локатора

Помимо локаторов на Marker Track можно размещать обычные маркеры.
Делается это с помощью клавиши <Insert> или инструментов Draw или Object Selection:

  • "нарисовать" маркер инструментом Draw (Карандаш) — щелкнуть им в выбранной позиции;
  • "нарисовать" маркер инструментом Object Selection (Стрелка), щелкнуть им в выбранной позиции, удерживая клавишу <Alt>;
  • нажать клавишу <Insert> — при этом маркер будет создан в текущей позиции курсора мультитрека.
    При создании маркера любым из перечисленных способов ему автоматически присваивается порядковый номер.

Совет
Маркеры с номерами от 3 до 9 можно быстро создать в текущей позиции курсора комбинациями <Ctrl>+<3> — <Ctrl>+<9>. Быстрое позиционирование курсора осуществляется комбинациями <Shift>+<3> — <Shift>+<9> или клавишами <3> — <9> на дополнительной клавиатуре.

Маркеры можно перетаскивать, выделять, удалять и переименовывать. Но к ним нельзя применять операцию копирования. На рис. 2.44 изображен пример присвоения имени маркеру "Vocal". Для этого достаточно выделить маркер, затем щелкнуть на панели Info Line в поле Name и ввести название с клавиатуры.
В секции Track List дорожка Marker Track имеет только один элемент управления — кнопку Toggle Timebase (см. рис. 2.44). В режиме Tempo Base позиции маркеров станут зависимыми от установок темпа и графика Tempo Track.

Video Track

Видеотрек (Video Track) предназначен для импорта в проект Nuendo видеофайлов. В проекте может быть только один Video Track. Пример импортированного MPEG-файла изображен на рис. 2.46.

Рис. 2.46. Video Track

При импорте видеофайла в диалоговом окне Import Video был установлен флажок Extract Audio. Поэтому помимо видеотрека появилась дополнительная дорожка Audio, содержащая звуковое сопровождение.
Работа в Nuendo с видео в данной книге не рассматривается.

Добавление/удаление нескольких треков

В контекстном меню Track List есть еще два пункта: Add Multiple Tracks и Remove Selected Tracks. Команда Add Multiple Tracks (она дублируется пунктом Multiple в меню Project | Add Track) позволяет добавить в проект сразу несколько треков одного типа.
В диалоговом окне Add Multiple Tracks в раскрывающемся списке Track можно выбрать тип трека, а в поле Count задать их количество.
Команда Remove Selected Tracks удаляет выделенные треки. Дорожка выделена, если ее элементы управления окружены красной прямоугольной рамкой. Для того чтобы выделить трек, нужно просто щелкнуть на нем в секции Track List.

Примечание
Любая манипуляция с элементами управления трека автоматически его выделяет.

Треки можно выделять группами. Для выборочного выделения достаточно щелкнуть левой кнопкой мыши на каждом из них с нажатой клавишей <Ctrl>. Если последовательно выделить с одновременным нажатием клавиши <Shift> любые два (не соседних) трека, то все остальные, расположенные между ними, тоже окажутся выделенными. Снять выделение с трека можно щелчком мыши, удерживая нажатой клавишу <Shift>, или выделением другого трека.
В Nuendo можно изменять порядок расположения треков путем их перетаскивания в секции Track List.


Контекстное меню треков

Интерфейс Nuendo построен таким образом, что многие операции выполняются с помощью контекстного меню, которое вызывается традиционно — правой кнопкой мыши. У разных типов виртуальных треков разные контекстные меню. Поэтому мы рассмотрим команды контекстных меню треков по отдельности и сконцентрируем основное внимание на треках: Audio, MIDI, Group Channel и Automation Subtrack.
Наибольшее число команд содержит контекстное меню аудиотрека. Для его вызова необходимо щелкнуть правой кнопкой мыши в свободной области между элементами управления (рис. 2.47).

Рис. 2.47. Вызов контекстного меню

Первый пункт меню Show/Hide Automation (Показать/скрыть автоматизацию) делает видимыми все задействованные по числу параметров субтреки автоматизации данного аудиотрека.
После выполнения этой команды при повторном вызове контекстного меню слово Show (Показать) заменится в первых двух командах на слово Hide (Скрыть). Поэтому если в контекстном меню будет повторно выбран один из двух первых пунктов, то произойдет обратное действие — все субтреки автоматизации будут скрыты.
Команда Show/Hide Automation for All Tracks глобальна — она открывает (скрывает) все субтреки автоматизации для всех аудиотреков проекта.
Используя перечисленные способы, в Nuendo можно получить максимально быстрый доступ к любому автоматизированному параметру.
Команда Disable/Enable Track позволяет серьезно экономить ресурсы дисковой подсистемы. Если трек выключен, то меняется оттенок серого цвета в секции Track List. При этом с жесткого диска не считывается информация, связанная с объектами выключенного трека.

Примечание
Обращаем внимание на то, что, в отличие от команды Disable/Enable Track, кнопка Mute не прекращает считывание данных с жесткого диска и, следовательно, не экономит ресурсы.
В Nuendo для эффективного использования ресурсов дисковой подсистемы необходимо пользоваться командой Disable Track.
Этой функцией целесообразно пользоваться при большом количестве дублей, расположенных на разных дорожках, или для временного промежуточного сведения (см. разд. "Временное промежуточное сведение" далее в этой главе).

Команда Auto Fades Settings позволяет для каждого трека или всего проекта сделать настройки автоматического Fade и Crossfade (виртуального фейда и кроссфейда).
Забегая вперед, отметим, что в Nuendo существует два вида Fades: деструктивный и виртуальный (подробнее см. разд. "Деструктивный и виртуальный фейды" далее в этой главе). Деструктивный фейд выполняется с помощью манипуляторов объекта (Audio Event). С его помощью создается физическая копия звукового файла и дополнительные ресурсы в реальном времени не расходуются. Виртуальные фейд и кроссфейд могут потреблять значительные ресурсы, особенно при большом количестве дорожек, т. к. вычисления ведутся во время воспроизведения.

Примечание
Команда Auto Fades Settings меню Project позволяет установить глобальные настройки Auto Fades для всего проекта.

Команда Remove Track удаляет тот трек, для которого вызвано контекстное меню.
Команда Remove Selected Tracks удаляет выделенные треки и просто дублируется для удобства в контекстном меню треков.
Пункт Select All Events выделяет все объекты, расположенные на данном треке.
Команда Duplicate Track создает копию трека со всем содержимым, расположенную под оригиналом.


Программирование "горячих" клавиш

Работать с мультирековыми программами с помощью одной только мыши — занятие трудоемкое. Значительно ускорить процесс работы можно с помощью так называемых "горячих" клавиш. В Nuendo их можно программировать самостоятельно — в соответствии с потребностями. По умолчанию многие комбинации "горячих" клавиш уже созданы, но их всегда можно изменить и подогнать под себя.
Для программирования акселераторов в меню File существует пункт Key Commands, который вызывает одноименное окно (рис. 2.48).
Рис. 2.48. Программирование комбинации клавиш
Окно Key Commands состоит из трех списков: Categories, Commands и Keys.
Каждая категория содержит несколько команд, которым приведены в соответствие комбинации клавиш. Для программирования новой комбинации нужно:

  1. 1. Выделить искомую команду в списке Commands.
  2. 2. Затем щелкнуть в строке Type new Key Command.
  3. 3. После этого набрать нужную комбинацию на клавиатуре.
  4. 4. Завершить процесс щелчком по кнопке Assign.

Одной команде может соответствовать несколько комбинаций, но все-таки лучше удалить предыдущую комбинацию кнопкой Remove. Изменить "горячие" клавиши можно на любом этапе: кнопка Reset сбрасывает настройки команды в первоначальное состояние, а кнопка Reset All сбрасывает все настройки "горячих" клавиш.
Просмотреть список запрограммированных "горячих" клавиш можно с помощью кнопки Show List в окне List of key commands.
Если настройка получилась удачной, ее можно сохранить на будущее — кнопкой Export. При этом создается файл с расширением key. Кнопка Import выполняет обратную операцию — восстанавливает сохраненную конфигурацию из файла key.


Дополнительные настройки (Preferences)

Помимо базовых настроек, которые мы рассмотрели выше, в Nuendo существуют дополнительные.
Дополнительные настройки "по умолчанию", конечно же, не создают проблем в работе с Nuendo. Но в связи с тем, что здесь есть некоторые тонкости, остановимся сначала лишь на некоторых из них. А позже затронем и остальные.
Итак, доступ к дополнительным настройкам осуществляется через меню File | Preferences, которое вызывает одноименное окно (рис. 2.49).

Рис. 2.49. Окно Preferences

В левой части окна Preferences расположена древовидная структура, содержащая страницы (Pages). В правой части окна находятся параметры выделенной страницы.
На рис. 2.49 в левой части окна Preferences выделена страница User Interface, а в правой доступны параметры этой страницы.
Флажок Auto Save обеспечивает функцию автосохранения, которую рекомендуется не отключать. Если функция Auto Save активна (флажок установлен), то программа автоматически создает резервную копию проекта с расширением bak. Если в Nuendo одновременно открыто несколько проектов, то у каждого проекта будет своя резервная копия.
Интервал обновления резервной копии устанавливается в поле Auto Save Interval.
Флажок Show Tips обеспечивает всплывающие подсказки на элементах интерфейса Nuendo.
Поле Maximum Undo содержит символ бесконечности, что означает неограниченный (unlimited) уровень отмены.

Примечание
По всей видимости, после традиционной одноуровневой отмены Cubase VST разработчики фирмы Steinberg в Nuendo навсегда решили эту проблему.

В это поле можно ввести любое число от 1 до 99 999. Правда, сразу за 99 999 следует бесконечность.
Раскрывающийся список On Startup определяет задачу, которую должна выполнить программа при старте. По умолчанию в этом поле с некоторой долей юмора написано Do Nothing (Ничего). Именно этот случай мы и рассматривали выше при создании проекта Nuendo. Однако процесс можно автоматизировать. Для этого мы подробнее изучим пункты раскрывающегося списка On Startup.

  • Open Last Project — эта опция избавит от необходимости разыскивать последний сохраненный проект, т. к. он будет открываться автоматически при старте Nuendo.
  • Open Default Project — автозагрузка проекта default.npr, который должен быть расположен в папке с программой Nuendo. Проект default.npr фактически является загружаемым при старте шаблоном, таким как Normal.dot в Microsoft Word. Для того чтобы создать загружаемый шаблон, достаточно сохранить соответствующий проект под именем default.npr командой Save As в меню File.

Совет
Быстро создать загружаемый шаблон можно из любого файла папки Templates, расположенной в папке Nuendo. Для этого достаточно скопировать его в папку Nuendo и переименовать в default.npr. Тогда при загрузке будет предложено только определить местоположение папки проекта.

  • Show Open Dialog — вызов при загрузке программы диалогового окна Open Project, в котором следует выбрать файл проекта.
  • Show Template Dialog — вызов при загрузке программы диалогового окна New Project со списком шаблонов.
  • Show Open Options Dialog — вызов при загрузке программы диалогового окна Nuendo Open Document Options (рис. 2.50) со списком последних открывавшихся в Nuendo проектов.

Рис. 2.50. Окно Nuendo Open Document Options

Примечание
Такой же список можно найти через меню File | Recent Projects.

Диалоговое окно Nuendo Open Document Options предлагает выбор:

  • Open Selection — для загрузки проекта, выделенного в списке;
  • Open Other — для поиска и загрузки проекта, который отсутствует в списке;
  • New Project создание нового проекта (вызов окна New Project со списком шаблонов и т. д.).

Опция Show Open Options Dialog более удобна и универсальна, поэтому ее можно рекомендовать для большинства задач.
Позже мы вернемся к дополнительным настройкам Preferences, а сейчас продолжим рассмотрение интерфейса и познакомимся с остальными окнами проекта.


Окна проекта Marker, Browse Project, Pool

Marker

Окно Marker вызывается кнопкой Open Marker панели инструментов Toolbar (см. разд. "Панель инструментов Toolbar" ранее в этой главе) (рис. 2.51) или командой Project | Markers.

Примечание
Кроме этого, окно Marker можно вызвать комбинацией "горячих" клавиш или кнопкой Show на транспортной панели.

Рис. 2.51. Окно Marker

Ответим на вопрос, для чего нужно окно Marker.
При редактировании сложного проекта часто требуется точно позиционировать курсор. Можно, конечно, менять масштаб для того, чтобы его удобно было перемещать. Но это значительно замедляет работу. Поэтому лучше пользоваться закладками. Они позволяют точно позиционировать курсор без изменения масштаба.
Для быстрого и точного перемещения курсора достаточно выбрать закладку в списке маркеров окна Marker. Этот список разделен на четыре столбца.

  1. 1. Первый столбец без названия. Он предназначен для перемещения курсе ра в позицию маркера. Символ [image] (стрелка) указывает текущую позиции курсора. Перемещается этот символ в столбце щелчком мыши.
  2. 2. Столбец ID (идентификатор) содержит порядковые номера маркеров. Это номера можно изменять: щелкнуть на номере маркера, ввести новый номер с клавиатуры и завершить процесс ввода нажатием клавиши <Enter>.
  3. 3. Столбец Position отображает позицию маркера (в формате, установленном на линейке Ruler). Эту позицию маркера также можно редактировал в окне Marker.
  4. 4. Столбец Description предназначен для присвоения закладкам имен и создания комментариев.

Примечание
В столбцах ID и Description не редактируются специальные маркеры-локаторы.

Рассмотрим функции кнопок Add, Remove и Move в работе с закладками.

  • Add (клавиша <Insert>) — добавляет маркер в список и на маркер-трек в т) позицию, где находится курсор (при включенном режиме STOP или Play);
  • Remove — удаляет выделенные маркеры из списка;
  • Move — перемещает выделенный маркер в текущую позицию курсора.

Командой Move следует пользоваться для того, чтобы изменить позицию маркера. Делается это просто: сначала нужно установить в новую позицию курсор мультитрека, а затем в окне Marker выделить маркер и нажать кнопку Move.

Browse Project

Окно Browse Project вызывается кнопкой Open Browser панели инструментов или командой Project \ Browser.
Его внешнее сходство с проводником Windows Explorer не случайно и объясняется задачами навигации. Окно Browse Project позволяет "путешествовать в пространстве проекта Nuendo" (рис. 2.52).

Рис. 2.52. Окно Browse Project

Окно Browse Project обеспечивает доступ ко всем параметрам проекта и позволяет редактировать их в виде чисел. В результате пользователь получает уникальную возможность не только видеть проект "изнутри", но и с математической точностью изменять любые параметры.

Примечание
Это необходимо, например, для точной коррекции (подгонки) данных автоматизации проекта.

Образно говоря, Browse Project — это всемогущий низкоуровневый редактор проекта Nuendo. Он с легкостью может выполнить функции редактора List Edit или окна Controller программы Cubase VST.
По строению окно Browse Project — аналогично проводнику Windows — делится на два окна: Structure List (слева) и Event Display (справа).
В левом окне размещена структура проекта (дерево). В правом — редактируемые данные.

Примечание
Термин Event (Событие) применяется в Nuendo к разным типам данных, относящихся ко всем типам треков.

Названия "папок" в "Nuendo Explorer" четко соответствуют названиям треков секции Track List (см. рис. 2.52).
Порядок папок в структуре идентичен расположению треков в секции Track List. Все манипуляции со структурой аналогичны действиям, выполняемым в проводнике Windows. А для того, чтобы раскрывать или скрывать дерево, предназначены кнопки [image] (+A1I) и [image] (-All) соответственно.
Внешний вид правой части окна Browse Project может быть различен — т. к. он зависит от типов редактируемых данных.
На рис. 2.52 изображен пример редактирования данных автоматизации. Поэтому в окне Event Display отображаются три столбца, которые имеют названия Type, Position и Value. Щелчок на названии столбца изменяет признак и порядок сортировки данных (как в файловом менеджере Windows Commander). Сортировка подчиняется простому правилу: если при щелчке мышью на названии столбца появляется символ стрелки, значит, по этому признаку данные сортируются. Столбцы можно менять местами.
Сходство с проводником Windows дополняет кнопка [image] (Up) — подъем на один уровень вверх.
Выше расположены три раскрывающихся списка с кнопкой [image] (Add). Рассмотрим их в последовательности слева направо:

  • Список Domain содержит форматы отображения времени (от Bars+Beats до Samples).
  • Следующий список (без названия) содержит тип события, которое добавляется в окне Event Display.
    Тип события зависит от того, какой уровень структуры проекта отображается в окне Event Display. На одних уровнях раскрывающийся список недоступен, а на других в списке может появиться один или более типов. Событие добавляется кнопкой Add. На рис. 2.53 изображен пример добавления MIDI-события.
  • Список Filter предназначен для того, чтобы данные в окне Event Display были отображены выборочно — только одного типа. Отключить такую фильтрацию можно, выбрав пункт [image] .

Рис. 2.53. Выбор типа события

  • Флажок Sync Selection обеспечивает синхронизацию операции выделения в окнах Browse Project и Project Window.

Pool

В Nuendo — также, как и в SAWStudio — реализован принцип недеструктивного редактирования. Это значит, что основные операции (копирования, разрезания, перемещения и т. д.) происходят не с физическими файлами, а только лишь со ссылками на них.

Примечание
Напомним, что в SAWStudio эти ссылки назывались регионами и для их учета было предусмотрено отдельное окно Regions (см. главу 1, разд. "Окно Regions").

В Nuendo деструктивное редактирование организовано сложнее, поэтому нужно пояснить основные термины, относящиеся к области ссылок: Audio Clip и Region.
Аудиоклип (Audio Clip). В программе Nuendo любой звуковой файл — записанный или импортированный — автоматически получает ссылку равной длины, которая называется аудиоклипом.
Но нужно отметить, что это понятие более широкое, т. к. при многослойном деструктивном редактировании Audio Clip может содержать ссылки на несколько звуковых файлов (см. разд. "'Многослойное' деструктивное редактирование" далее в этой главе). Поэтому, обобщая, можно сказать, что Audio Clip — это глобальная ссылка на звуковые файлы.
Регион (Region). Внутри аудиоклипа можно выделить области и обозначить их как новые ссылки. Такие ссылки называются регионами (Region).
Все ссылки (аудиоклипы и регионы) представлены в Nuendo в окне Pool. И они выстроены в строгую иерархию: аудиоклип выше, чем регион.
Как уже отмечалось, у программы Nuendo всегда царит порядок среди файлов проекта. А ведь в сложном проекте могут участвовать файлы различных форматов, записанные и импортированные, у разных проектов могут быть общие звуковые файлы и т. п.
Для того чтобы защитить пользователя от случайного удаления данных при работе со звуковыми файлами, в окне Pool предусмотрены следующие функции: корректный файловый менеджмент и "строгий" учет всех ссылок — аудиоклипов и регионов (аналогично окну Regions SAWStudio). Но это еще не все "должностные обязанности" окна Pool. Оно также предназначено для редактирования аудиоклипов.
Нужно отметить, что многофункциональность окна Pool с одной стороны полностью соответствует сложности задач, которые можно выполнять в Nuendo. Но с другой, интерфейс окна Pool прост и интуитивно понятен, несмотря на сложность выполняемых операций (рис. 2.54).
Вызывается окно Pool кнопкой Open Pool панели инструментов или командой Pool в меню Project.

Рис. 2.54. Окно Pool

Это окно представляет собой таблицу, в которой можно изменять количество столбцов и порядок их расположения.
Количество отображаемых столбцов задается в списке View. Один из них — столбец Media — удалить нельзя, т. к. он содержит иерархическую структуру аудиоклипов и регионов.
В примере на рис. 2.54 аудиоклип "Audio Clip" содержит два региона: "Region1" и "Region2". В столбце Image можно наглядно оценить размеры регионов и их позицию относительно стартовой границы аудиоклипа. Клипы и регионы можно прослушивать, если щелкнуть мышью на имидже.
Интерфейс окна Pool достаточно прост для самостоятельного освоения. Отметим лишь некоторые моменты.
Все операции редактирования сосредоточены в меню Pool и дублируются в контекстном меню, которое традиционно вызывается правой кнопкой мыши.
Кнопка Import вызывает диалоговое окно Import Medium, через которое можно импортировать в Pool все типы поддерживаемых Nuendo media-файлов.


Панель Transport

В каждой мультитрековой программе традиционно присутствует транспортная панель или дека. Она предназначена для управления процессами записи, воспроизведения и "перемотки".
На наш взгляд необходимость в этих элементах вызвана больше традицией дизайна, чем требованием удобства работы. Ведь управление всей домашней аудиотехникой производится клавишами и кнопками на пульте дистанционного управления. Для пользователей, которые предпочитают такой способ управления, функции транспортной панели дублируются на клавиатуре. В описываемой программе эти кнопки также поддерживаются внешними микшер-контроллерами (Remote control) (см. разд. "Подключение Remote control device" ранее в этой главе).
Вместе с тем, некоторыми функциями программы удобнее управлять именно с транспортной панели. Поэтому она заслуживает более детального рассмотрения.
Вызывается панель опцией Transport Panel меню Transport или запрограммированной "горячей" клавишей (рис. 2.55).
(Punch In) — активизация режима Punch. Если кнопка Punch In нажата, то запись начнется автоматически при пересечении курсором левого локатора в режиме воспроизведения.
(Punch Out) — автоматическое выключение записи при пересечении курсором правого локатора.
(Cycle On/Off) — включение/выключение режима циклического воспроизведения или записи.

Рис. 2.55. Транспортная панель

(Locators) — поля ввода и отображения координат локаторов.
(Preroll — Postroll Setting) — поля ввода значений Preroll и Postroll.
Значение в поле Preroll определяет расстояние, на которое откатывается курсор при старте воспроизведения или записи. Поле Postroll определяет задержку режима Stop после пересечения курсором правого локатора в режиме записи Punch (см. разд. "Запись в режиме Punch" далее в этой главе). Для применения этих функций нужно выбрать опцию Use Pre/Post-Roll в меню Transport.
(Position Display) — поле, в котором отображается и вводится позиция курсора мультитрека. Рядом расположен раскрывающийся список форматов отображения времени (Display Format).

Совет
Для плавного увеличения/уменьшения параметра нужно установить курсор мыши над или под модифицируемым разрядом Position Display. Если курсор расположен над разрядом, он примет вид [image], если под разрядом, то [image]. Далее для плавного увеличения/уменьшения разряда Position Display нужно нажать и удерживать левую кнопку мыши. Одиночный щелчок изменяет разряд на единицу. Для ввода значения с клавиатуры нужно щелкнуть по выбранному разряду, отделенному точками. А после двойного щелчка выделяются все разряды, поэтому можно вводить с клавиатуры значение координаты полностью.

(Position Slider + Nudge buttons) — ползунок перемещения курсора мультитрека и кнопки точной подстройки позиции: Nudge Position left и Nudge Position right.
Щелчок по одной из этих кнопок смещает курсор на минимальную единицу измерения времени в том формате, который установлен в списке Display Format. (Если, например, установлен формат Samples, то щелчок сдвигает курсор на один сэмпл.)
(Go to Project Start) и [image] (Go to Project End) — позиционирование курсора на границах проекта.
Остальные кнопки, расположенные под ползунком перемещения курсора, полностью соответствуют кнопкам управления обычного магнитофона. Все они дублируются клавишами на дополнительной клавиатуре:

  • Rewind — перемотка влево (клавиша <-> на дополнительной клавиатуре);
  • Fast Forward — перемотка вправо (клавиша <+> на дополнительной клавиатуре);
  • Stop — остановка (клавиша <0> на дополнительной клавиатуре);
  • Play — воспроизведение (клавиша <Enter> на дополнительной клавиатуре);
  • Record — запись (клавиша <*> на дополнительной клавиатуре).

(Tempo Track as Master On/Off) — включение/выключение режима управления темпом от Tempo-трека.
(Metronome Click On/Off) — включение/выключение метронома.
(Synchronization On/Off) — включение/выключение режима синхронизации.
(The Tempo and Time Signature Display) — дисплей, отображающий темп, музыкальный размер и режим синхронизации. Для ввода темпа и размера с клавиатуры нужно выполнить одиночный щелчок в соответствующих полях.
(Marker) — панель быстрого доступа к маркерам. Кнопка Show вызывает окно Marker (см. разд. "Marker" ранее в этой главе). Кнопки L, R, 3, ..., 8 перемещают курсор в позицию маркера. Они тоже дублируются клавишами на дополнительной клавиатуре:

  • левый локатор L — клавиша <1> (на дополнительной клавиатуре);
  • правый локатор R — клавиша <2> (на дополнительной клавиатуре);
  • маркеры 3—8 — соответственно, от клавиши <3> до клавиши <8> (на дополнительной клавиатуре).

Совет
Быстрое закрепление маркеров в текущей позиции курсора можно осуществить комбинацией <Alt> + щелчок мышью на кнопках L, R, 3 ..... 8.

Внешний вид транспортной панели можно изменить. Например, урезать ее функции до привычных кнопок управления магнитофоном. Для этого нужно щелкнуть правой кнопкой мыши на транспортной панели и в контекстном меню выбрать пункт Buttons Only.


Запись AUDIO

Процесс записи в Nuendo тесно связан с возможностями используемого оборудования и с поставленной задачей. Например, какой выбрать способ записи — последовательный (Track after track) или параллельный многоканальный, какой выбрать формат звукового файла и т. д.
Итак, подготовка к записи начинается с выбора формата звукового файла.


Выбор формата звукового файла

Вновь обратимся к дополнительным настройкам Preferences (рис. 2.56).

Рис. 2.56. Выбор формата записываемого звукового файла

На странице Audio в раскрывающемся списке Record Files Type можно выбрать три формата:

  • AIFF File (Audio Interchange File Format) — стандарт, предложенный Apple Computer Inc. AIFF-файлы имеют расширение aif и распространены на большинстве компьютерных платформ.

Примечание
Если в дальнейшем планируется перенос проекта в студию, рекомендуем использовать именно этот формат.

  • Wave File — самый распространенный формат для платформы PC, имеет расширение wav.

Примечание
Если предполагается работа с проектом только на платформе PC, то можно остановиться на этом формате.

  • Broadcast Wave File — волновой формат Wave File, содержащий текстовую информацию.

Примечание
В дополнительных настройках на странице Broadcast Wave можно ввести текстовую информацию (рис. 2.57).

Рис. 2.57. Поля для ввода текстовой информации


Конфигурирование VST-входов

Теперь кратко о возможностях аудиооборудования. На рис. 2.58 изображен пример конфигурации VST-входов аудиоинтерфейса М Audio Delta R-BUS (о нем говорилось в начале главы).
Эта конфигурация позволяет записывать параллельным способом двенадцать каналов одновременно (восемь из них по шине R-BUS).
Для активизации пары входов нужно нажать кнопку On в столбце Active. Например, для записи с портов R-Bus Inl Delta-RBUS (IN 1) и R-Bus In2 Delta-RBUS (IN 2) достаточно нажать верхнюю кнопку On (рис. 2.58). Тогда VST-входы IN1 и IN2 будут активизированы.

Рис. 2.58. Активизация VST-входа

Активизация
Для того чтобы вход был доступен в качестве источника сигнала, его необходимо активизировать в окне VST Inputs. Внутри VST-приложения ASIO-порт (столбец Port) будет представлен под названием, введенным в столбце Label.

Названия VST-входов в столбце Label можно изменять. На рис. 2.59 показана конфигурация VST-входов с пользовательскими названиями для звуковой карты SB Audigy.

Рис. 2.59. Конфигурация VST-входов SB Audigy

Активизация входов АС 97 L (R) обеспечивает запись с линейного входа звуковой карты (Line-In).
Покажем, как происходит подготовка к записи на одну аудиодорожку (на рис. 2.60 — дорожка Audio 01).

  1. 1. Откроем окно VST Channel Settings выбранного аудиотрека. Для этого нужно щелкнуть на любой из кнопок: FX, EQ или Ins.
  2. 2. В этом же окне определим активный VST-вход — источник сигнала записи (рис. 2.60). Для этого нужно щелкнуть по кнопке [image] селектора входов, совмещенного с кнопкой Monitor [image].

Внимание
Доступными являются только те входы, которые активизированы в окне VST Inputs.

Рис. 2.60. Выбор активного VST-входа

В примере на рис. 2.60 используется монофонический аудиоканал. При использовании стереотрека картина изменится. Здесь активные VST-входы представлены в качестве стереопар (рис. 2.61).

Рис. 2.61. Выбор активного VST-входа для стереоканала

Селектор входов доступен как из окна VST Channel Settings, так и из окна VST Mixer (рис. 2.62). Оно вызывается по умолчанию клавишей <F3> или через меню Devices командой VST Mixer.

Примечание
Все "горячие" клавиши, указанные далее, предложены при инсталляции Nuendo по умолчанию.

Рис. 2.62. Выбор активного VST-входа в окне VST Mixer


Мониторинг

Мониторинг — это акустический контроль записываемого сигнала. При записи в Nuendo можно пользоваться тремя видами мониторинга.

Внешний мониторинг

При внешнем мониторинге используется внешний аппаратный микшер или микшер звуковой карты. Входной сигнал до попадания в программу Nuendo ответвляется и смешивается непосредственно в микшере с выходным сигналом мультитрека Nuendo.
Так как сигнал мониторинга не проходит через программу Nuendo, то отсутствует его задержка (latency) и таким сигналом нельзя управлять, а также обрабатывать его виртуальными эффектами (plug-ins).

ASIO Direct Monitoring

Этот режим должно поддерживать оборудование, совместимое с ASIO 2.O.
Основное отличие режима ASIO Direct Monitoring от внешнего мониторинга состоит в том, что сигналом можно управлять из Nuendo так же, как в случае внутреннего мониторинга. Однако в этом режиме сигнал не проходит через Nuendo, поэтому исключена его обработка с помощью plug-ins.
Детали этого процесса зависят от специфики оборудования. В Nuendo для включения этого режима нужно выставить флажок Direct Monitoring в окне Device Setup устройства VST Multitrack (см. разд. "Настройка AUDIO" ранее в этой главе).

Примечание
Для применения этого режима мониторинга в звуковой карте M-Audio Audiophile 2496 в окне М Audio Delta Control Panel на вкладке Hardware Settings нужно снять флажок Disable Control of the Monitor Mixer and Patchbay/Router by Audio Applications.

Внутренний мониторинг (через Nuendo)

В этом режиме сигнал мониторинга проходит через Nuendo. Следовательно, им можно управлять и обрабатывать его виртуальными эффектами (plug-ins). Это очень важная функция, т. к. музыкант может сразу играть звуком, обработанным в реальном времени. Иначе говоря, компьютер с Nuendo превращается в виртуальный процессор эффектов. При этом на аудиотрек пишется "сухой" (необработанный) сигнал, что дает возможность в дальнейшем при необходимости изменить обработку.
Нужно отметить, что, к сожалению, у внутреннего мониторинга есть недостаток — у него появляется задержка (latency).

Примечание
Для внутреннего мониторинга нужно использовать специализированные ASIO-драйверы, обеспечивающие минимальную задержку. Флажок Direct Monitoring (см. выше) должен быть снят. Сигнал должен проходить только через Nuendo. Например, в случае применения звуковой карты M-Audio Audiophile 2496 в окне М Audio Delta Control Panel на вкладке Patchbay/Router зависимый переключатель H/W Out 1/2 нужно установить в позицию WavOut 1/2.

Но эта задержка достаточно мала, поэтому не стоит отказываться от внутреннего мониторинга. Например, даже в полупрофессиональной звуковой карте SB Audigy можно установить задержку ASIO Buffer Latency 2 мс. Поэтому остановимся на нем подробнее. И для этого вновь обратимся к дополнительным настройкам Preferences (рис. 2.63).

Рис. 2.63. Режимы внутреннего мониторинга

На странице VST режимы внутреннего мониторинга отражены в списке Auto Monitoring.

  • Manual — режим ручного управления с помощью кнопки Monitor аудиотрека (см. разд. "Audio Track" ранее в этой главе).
  • While Record Enabled — режим автоматического включения мониторинга при нажатии на кнопку Record Enable. (Кнопки Record Enable и Monitor связываются друг с другом — они включаются одновременно.)
  • While Record Running — автоматическое включение мониторинга только во время записи (например, после нажатия на кнопку Record транспортной панели).
  • Tapemachine Style — имитация стиля студийного магнитофона. Мониторинг автоматически отключается во время воспроизведения. (В режиме остановки и записи мониторинг включен.)


Последовательная запись (Track after track)

Опишем действия, необходимые для записи одного трека, на примере использования звуковой карты SB Audigy.

Предупреждение
Параметр ASIO Buffer Latency (Creative ASIO Control Panel) должен иметь минимальное значение, не превышающее 5 мс.

Предположим, что уже выполнены все операции по подготовке к записи, рассмотренные выше. Создадим аудиотрек, выберем активный VST-вход и рассмотрим случай ручного управления мониторингом — в режиме Manual.

Контроль уровня записи

Перед тем как приступить к записи, необходимо проконтролировать уровень. Это можно сделать двумя способами.

Рис. 2.64. Контроль уровня записи

  • Приблизительно оценить уровень с помощью трекового индикатора, нажав кнопку Record Enable или Monitor (рис. 2.64).
  • Более точный способ — нажать кнопку Record Enable, Monitor или In в окне VST Mixer (рис. 2.65).

Рис. 2.65. Точный контроль уровня записи

Уровень записи при необходимости корректируется с помощью внешнего микшера, либо микшера звуковой карты.
Основное требование к уровню записи несколько противоречиво: он не должен превышать 0 дБ, но при этом быть" максимальным, насколько это возможно.
В связи с тем, что эти характеристики являются чрезвычайно важными для понимания процесса записи, поясним их для нетехнических специалистов.
В подавляющем большинстве случаев реальные звуковые сигналы далеки по форме от идеальной синусоиды. Они характеризуются так называемым пик-фактором.

Примечание
Пик-фактор — это отношение пиковой мгновенной амплитуды к его эффективному значению — RMS (Root Mean Square — среднеквадратичное).

Например, для речи пик-фактор составляет величину порядка 20 дБ, а для "отмастеренного" CD AUDIO современной поп-музыки — может быть 6— 10 дБ.
В главе 1 отмечалось, что снижение уровня записи приводит к оцифровке с более низким разрешением, т. е. к снижению качества.
Но с другой стороны пиковый индикатор моментально отметит превышение порога в 0 дБ при увеличении уровня выше допустимого. В результате чего, например, при записи вокальной партии уровень может оказаться слишком заниженным, что заметно уменьшит качество ее звучания при 16-битной оцифровке, которое затем будет не восстановить программными средствами. Поэтому перед подачей на АЦП усиленный сигнал с микрофона следует обработать компрессором, т. е. сжать динамический диапазон — другими словами, уменьшить пик-фактор.
Выходной сигнал синтезатора, записываемого через линейный вход звуковой карты, имеет, как правило, меньший пик-фактор, чем сигнал вокальной партии с микрофона. Поэтому в этом случае можно обойтись без компрессора. И даже при использовании 16-битного АЦП можно получить вполне приличный результат, только немного уменьшив уровень до -4 -6 дБ, т. к. различить на слух 15-битное и 16-битное звучание значительно труднее, чем 16-битное и 24-битное.
Не следует забывать, что качество звука прежде всего определяется схемотехникой звуковой карты и качеством ее АЦП, а не только "магическим" количеством разрядов. Разрешающая способность АЦП и его реальная точность нередко различаются.

Запись с текущей позиции курсора

После настройки уровня можно приступать к началу записи.
Для этого нужно вернуться в окно Nuendo Project, нажать кнопку Record Enable (над кнопкой Monitor) и запустить записи кнопкой Record на транспортной панели.

Внимание
Для того чтобы производилась запись на трек, кнопка Record Enable должна быть нажата (во включенном состоянии она мигает). Эта кнопка дублируется в канальной секции VST-микшера (на рис. 2.65 отмечена стрелкой).

Рис. 2.66. Запись на аудиотрек

При такой последовательности действий запись начнется с текущей позиции курсора. При записи программа "рисует" имидж звукового файла. Это происходит, если отмечен флажок Create Images During Record на странице Event Display в дополнительных настройках Preferences (рис. 2.67).
Запись будет продолжаться до остановки кнопкой Stop транспортной панели.
Результатом записи будет новый объект — Audio Event в секции Event Display окна Nuendo Project (рис. 2.68).
Название объекта Audio Event состоит из имени аудиотрека, на котором производится запись, и номера дубля. В примере на рис. 2.68 объект имеет название "Record_00". Это значит, что на треке с названием "Record" была произведена первая запись. Последующие записи будут, соответственно иметь названия объектов "Record_01", "Record_02" и т. д.
В окне Pool дубли учитываются как аудиоклипы, имеющие статус Record (буква "R") (рис. 2.69).
Если воспользоваться функцией отмены Undo (меню Edit | Undo <Ctrl>+ +<Z>) или просто удалить объекты с мультитрека, то записанные аудиоклипы будут перемещены в корзину — Trash.

Рис. 2.67. Флажок Create Images During Record

Рис. 2.68. Объект Audio Event

Рис. 2.69. Аудиоклипы в окне Pool

Забегая вперед, отметим, что с помощью команды контекстного меню Empty Trash окна Pool можно по-разному удалить файлы: физически или только из окна Pool (рис. 2.70).

Рис. 2.70. Удаление неудачных дублей

Новую запись можно производить поверх предыдущей. В этом случае объекты накладываются друг на друга (рис. 2.71).

Примечание
Функцию наложения объектов можно запретить, если в дополнительных настройках Preferences на странице User Interface-Editing отметить флажок Delete Overlaps. Но мы не рекомендуем отказываться от многослойности муль-титрека Nuendo. Это свойство позволяет просто записывать дубли друг на друга, что в последствии облегчает их редактирование.

Рис. 2.71. Наложение объектов при записи

Воспроизведение объектов в Nuendo подчиняется простому правилу: в один момент времени воспроизводится самый верхний видимый видеообъект.
Порядок наложения объектов можно изменять. Для этого нужно вызвать контекстное меню щелчком правой кнопки мыши на любом из перекрывающих друг друга объектов. В открывшемся контекстном меню выбрать в субменю То Front объект, предназначенный для "поднятия в верхний слой" (рис. 2.72)

Рис. 2.72. Изменение порядка наложенных объектов

Запись с позиции левого локатора

Этот способ записи отличается от предыдущего тем, что предварительно нажимается кнопка Punch In [image] на транспортной панели. Тогда запись начнется автоматически с позиции левого локатора.

Рис. 2.73. Включение режима деактивации Punch In

Примечание
Этот режим записи отличается от режима Automatic Punch тем, что сразу нажимается кнопка Record на транспортной панели.

Кнопка Punch In может автоматически отключаться после остановки записи. Это делается так: в дополнительных настройках окна Preferences на странице Transport нужно установить флажок Deactivate Punch In on Stop (рис. 2.73, указано стрелкой).

Запись в режиме Punch

Режим Punch on the fly (на лету). Это, пожалуй, самый простой способ записи в режиме Punch. Для его осуществления нужно во время воспроизведения периодически нажимать кнопку Record на транспортной панели (или клавишу <*> на дополнительной клавиатуре). Последовательность действий такая:

  1. 1. Включить режим воспроизведения кнопкой Play.
  2. 2. Когда курсор подойдет к месту начала записи, нажать кнопку Record.
  3. 3. После того как запись окончена, выключить режим — для этого вновь нажать на кнопку Record. При этом воспроизведение будет продолжаться до команды Stop.

Внимание
При этом способе записи должны быть выключены обе кнопки транспортной панели — Punch In и Punch In Out.

Каждый повтор этой последовательности операций (цикл включения/ выключения записи без остановки воспроизведения) будет создавать новый аудиообъект).
Режим Automatic Punch. Этот способ записи — автоматический. Для его использования предназначены кнопки Punch In и Punch Out на транспортной панели.
Если нажата кнопка Punch In, то запись автоматически включается при воспроизведении с позиции левого локатора. Для этого нужно просто позиционировать курсор левее локатора L и включить воспроизведение.
Включенная кнопка Punch Out [image] обеспечивает автоматическое выключение записи при пересечении курсором позиции правого локатора.
В связи с тем, что кнопки Punch In и Punch Out работают независимо друг от друга, можно, например, включить только режим Punch Out (зафиксировать финальную границу записываемого объекта), оставив стартовую позицию свободной.

Внимание
Очень важно, чтобы локаторы L и R были расположены в соответствии с названиями, т. е. левый — слева, а правый — справа. Такое расположение локаторов отображается яркой зеленой линией между ними на линейке Ruler. Если они расположены неверно (наоборот), то эта линия меняет цвет на темно-зеленый.

В дополнительных настройках Preferences можно задать для режима Punch автоматическую остановку на правом локаторе. Для этого нужно установить флажок Stop after Automatic Punchout (рис. 2.74, указано стрелкой).

Рис. 2.74. Включение режима автоматического останова

Функции Preroll и Postroll, о которых мы упоминали при рассмотрении транспортной панели (см. разд. "Панель Transport" ранее в этой главе) обеспечат автоматическое смещение курсора на заданную величину в режиме записи Punch.

Примечание
Напомним, что для применения этих функций нужно отметить опцию Use Pre/Post-Roll в меню Transport.

Функции Preroll и Postroll очень удобны при записи "живого" исполнения. Во-первых, они автоматизируют процесс записи. Во-вторых, позволяют исполнителю подготовиться заранее (Preroll). В-третьих, продолжают воспроизведение на заданное время (Postroll) после правого локатора — не разрушают внезапной паузой творческое состояние (при активном флажке Stop after Automatic Punchout в настройках Preferences).
Совместное использование кнопок Punch In/Out с функциями Preroll и Postroll позволяет управлять процессом записи дублей с помощью одной только кнопки Record, полностью сосредоточившись на тонкостях исполнения (при сброшенном флажке Deactivate Punch In on Stop в настройках Preferences).
Функция Preroll также удобна при записи с текущей позиции курсора. Если она включена, то перед записью звучит небольшое вступление, за время которого исполнителю легко сориентироваться в темпе и ритме. Поэтому можно даже не включать метроном, если в проекте уже записаны треки с ритмическим каркасом композиции.

Способы позиционирования курсора

При записи и редактировании часто требуется перемещать курсор. Самый простой способ — щелкнуть мышью на линейке Ruler. Однако это не всегда удобно. Для того чтобы позиционировать курсор прямо в окне Event Display (щелчком в любой свободной области), нужно в дополнительных настройках Preferences на странице Transport установить флажок Locate When Clicked in Empty Space (рис. 2.75).

Рис. 2.75. Разрешение свободного позиционирования курсора

Для позиционирования курсора точно по границам объектов нужно использовать удобные команды Transport | Locate Next Event (клавиша <N>) и Transport | Locate Previous Event (клавиша <В>). Курсор перемещается по границам объектов выделенных треков. Если ни один трек не выделен, то перемещение происходит по границам всех объектов мультитрека.

Запись с использованием метронома

В Nuendo, так же, как и в Cubase VST, можно производить запись под звук встроенного метронома.
Активизация метронома выполняется кнопкой Click [image] на транспортной панели.
Его настройки производятся командой меню Transport | Metronome Setup. На рис. 2.76 изображено окно Metronome Setup, содержащее необходимые элементы управления.

Рис. 2.76. Окно Metronome Setup

Метроном в Nuendo может генерировать MIDI-сообщения и/или использовать аудиоканал. Для этого в окне Metronome Setup находятся две секции — MIDI и Audio, — а также секция общих настроек.
Если отмечен флажок MIDI Click, то метроном генерирует MIDI-сообщения в соответствии с музыкальным размером и темпом, установленным на транспортной панели. Раскрывающийся список MIDI Output позволяет назначить для метронома любой доступный MIDI-порт.

  • Поле Channel служит для выбора MIDI-канала.
  • Поле High Note позволяет задать звук сильной доли метронома (Beat).
  • Поле High Velocity задает параметр Velocity (скорость нажатия на клавишу, акцентирование, звукоизвлечение) для сильной доли.
  • Поле Low Note служит для выбора звука слабой доли (Offbeat).
  • Поле Low Velocity задает параметр Velocity для слабой доли.

Настройка этих параметров позволяет сделать "голос метронома" максимально благозвучным. Изменение параметров High Note, High Velocity, Low Note и Low Velocity сопровождается контрольным звуковым сигналом.
Аудиосекция содержит ползунковый регулятор Volume, определяющий громкость метронома аудиоканала. Для активизации аудиометронома нужно отметить флажок Audio Click.
В секции общих настроек в поле Precount Bars задается количество тактов, которое должен отсчитать метроном перед стартом процесса записи.

Внимание
Для того чтобы метроном отмерил заданное количество тактов перед записью, необходимо на транспортной панели нажать кнопку Punch In.

Флажки In Play, In Record, соответственно, активизируют метроном в режимах воспроизведения и записи.

Циклическая запись

Результатом циклической записи является создание регионов и/или объектов. Это зависит от дополнительных настроек Preferences. Для того чтобы подойти к циклической записи во всеоружии, остановимся еще раз на принципах организации ссылок внутри Nuendo.
Audio Clip — это глобальная ссыпка на звуковой файл или, в случае деструктивной обработки, на звуковые файлы. Она может содержать внутренние области — регионы, которые функционально аналогичны регионам SAWStudio. Иерархия всех ссылок отображается в окне Pool (см. рис. 2.54).
Audio Event — объект мультитрека, содержащий собственную ссылку на Audio Clip. Она не отображается в окне Pool. Фактически Audio Event представляет собой сегмент аудиоклипа с дополнительными виртуальными свойствами.
В Nuendo принцип недеструктивного редактирования получил свое дальнейшее развитие. Поясним, что он дает.
Объект Audio Event, содержащий внутреннюю ссылку, может быть расположен в любой временной позиции на дорожках мультитрека, а также иметь множество копий. Очень важно, что при этом не создаются физические копии звуковых файлов, т. е. все операции редактирования пользователь осуществляет виртуально. Программа полностью автоматизировала процесс и "самостоятельно следит" за порядком в соответствии ссылок и звуковых файлов. А значит, не нужно задумываться о том, с какой областью звукового файла идет работа.
Но при необходимости в Nuendo области звукового файла можно зафиксировать как отдельные ссылки. Это может потребоваться, например, для Loop-конструирования или при работе с дублями.
Для этого случая в Nuendo предусмотрена возможность создания Regions (регионов), с которыми можно производить отдельные манипуляции.
Обобщая, можно сказать, что в Nuendo существуют три разновидности ссылок:

  • Audio Clip — глобальная ссылка, которая ссылается на один или несколько физических файлов на диске;
  • Audio Event — собственная ссылка объекта на Audio Clip;
  • Region — зафиксированная ссылка на Audio Clip.

Типы ссылок имеют прямое отношение к режиму циклической записи, т. к. в результате этой операции появятся регионы, объекты Audio Event или регионы + объекты в зависимости от дополнительных настроек Preferences.
В нашей книге "'Живая' музыка на PC" мы говорили о преимуществах циклической записи для "живого" исполнения.
В Nuendo циклическая запись тоже применяется для записи дублей (Takes). Из них, используя методы недеструктивного редактирования, можно легко смонтировать "идеальный" дубль (Perfect Take).
Рассмотрим дополнительные настройки Preferences на странице Audio (рис. 2.77).

Рис. 2.77. Выбор режима циклической записи

Раскрывающийся список Cycle Record Mode предлагает выбор из трех опций: Create Regions, Create Events и Create Events +Regions. Остановимся на них подробно.
Для начала активизируем режим циклической записи. Для этого нужно нажать кнопку Cycle [image] на транспортной панели и ограничить зону циклической записи с помощью локаторов.
В режиме Create Regions каждый новый цикл будет завершаться созданием нового региона.
После остановки циклической записи кнопкой Stop транспортной панели на дорожке будет располагаться объект Audio Event последнего цикла.
В режиме Create Regions работа с дублями может производиться непосредственно в окне Nuendo Project. Для этого нужно вызвать щелчком правой кнопки мыши контекстное меню объекта и зайти в субменю Set To Region (рис. 2.78).

Рис. 2.78. Выбор региона

В примере на рис. 2.78 субменю содержит три региона: Takel, Take2 и Take3. Каждый из них соответствует одному циклу записи или дублю. Если отметить один из пунктов списка, то собственная ссылка объекта Audio Event будет переназначена на регион, выбранный в субменю.
Эту операцию лучше всего производить в режиме циклического воспроизведения — когда кнопка Cycle нажата. Тогда можно выбирать лучший дубль, прослушивая их в режиме реального времени с остальными треками проекта.
Работа с дублями возможна и в окне Pool (рис. 2.79).

Рис. 2.79. Дубли в окне Pool

Примечание
Забегая вперед, отметим, что регионы можно перетаскивать из окна Pool на дорожки мультитрека и таким образом конструировать музыку из регионов. Например, используя циклическую запись в режиме Create Regions, можно сформировать регионы — фрагменты будущего произведения.
В этом случае обоснованным решением может быть не поиск лучшего дубля, а создание коллекции дублей, сохранение различных вариантов исполнения музыкальной фразы в виде регионов.

Следующий режим — Create Events. Он отличается тем, что вместо регионов создаются объекты Audio Events, которые накладываются друг на друга.

Рис. 2.80. Выбор объекта

Если произошло наложение объектов, то становится доступным субменю То Front (рис. 2.80), которое позволят изменить порядок наложения Audio Events.

Примечание
Напомним, что на дорожке всегда воспроизводится только верхний объект.

Выбор удачного дубля можно осуществить в реальном времени в режиме циклического воспроизведения.
Нужно отметить, что в режиме циклической записи Create Events создаются лишь собственные сшжм объектов, поэтому в окне Pool будет отображаться только глобальная ссылка Audio Clip, которая состоит из дублей, последовательно записанных в длину.

Совет
Собственная ссылка объекта Audio Event может быть сохранена как регион с помощью команды Event as Region меню Audio.

Однако этот режим позволяет легко смонтировать "идеальный" дубль (Perfect Take). Для этого нужно воспользоваться инструментом Split [image] панели Toolbar и разрезать объект. Затем с помощью субменю То Front оставить наверху лучшие варианты (рис. 2.81).

Примечание
Инструмент Split разрезает в выбранной точке сразу все объекты, наложенные друг на друга.

Режим Create Events + Regions является комбинацией двух предыдущих. В нем создаются регионы и объекты (рис. 2.82).

Рис. 2.81. Монтаж "идеального" дубля

Рис. 2.82. Комбинированный режим

Комбинированный режим дает большую свободу выбора в редактировании записанного материала.

Создание "идеального" дубля (Perfect Take) в редакторе Audio Part Editor

Редактор Audio Part Editor программы Nuendo аналогичен редактору Audio Editor программы Cubase VST. Мы не будем его рассматривать здесь подробно, а остановимся на алгоритме монтажа "идеального" дубля Perfect Take.
В режиме циклической записи Create Regions нужно сделать следующее:

  1. 1. После остановки циклической записи открыть контекстное меню записанного объекта.
  2. 2. В контекстном меню выбрать команду Audio | Events to Part.
  3. 3. На запрос программы Create part using regions? ответить Regions.
  4. 4. Дважды щелкнуть на созданном объекте Audio Part.

Примечание
В открывшемся окне Audio Part Editor можно так же, как и в Cubase VST смонтировать дубль, пользуясь инструментами Split, Erase и Mute (рис. 2.83).
Более подробную информацию о редакторе Audio Part Editor можно найти в разд. "Редактор Audio Part Editor".

В режиме циклической записи Create Events последовательность действий будет отличаться от приведенной выше:

  1. 1. Выделить рамкой записанный объект Audio Event. (На информационной панели Info Line должна быть надпись Multiple Objects Selected.)
    2. В контекстном меню выбрать команду Audio | Events to Part.
    3. Дважды щелкнуть на созданном объекте Audio Part.

Рис. 2.83. Монтаж дубля в редакторе Audio Part Editor

При монтаже нужно учитывать, что в редакторе Audio Part Editor дубли "конкурируют" друг с другом за аудиоканал. Приоритеты при воспроизведении распределяются снизу вверх. Самый нижний дубль обладает наивысшим приоритетом, т. е. при воспроизведении прослушивается только он.


Параллельная многоканальная запись

Для параллельной многоканальной записи необходимо оборудование, которое может обеспечить необходимое количество каналов.
При наличии такого оборудования предварительная настройка сводится к активизации VST-входов и назначению активных VST-входов для записываемых аудиоканалов в окне VST Mixer (см. разд. "Конфигурирование VST-входов" ранее в этой главе).
После нее нужно нажать кнопку Record Enable на каждой записываемой дорожке и включить запись. Контроль уровня записи производится для каждого канала в окне VST Mixer или Nuendo Project.


Недеструктивное редактирование

В предыдущих разделах мы уже познакомилиоь с концепцией недеструктивного редактирования, реализованного в Nuendo. Центральным понятием, характеризующим эту концепцию, является Audio Event (аудиособытие).
Термин Audio Event перешел в Nuendo "по наследству" — из программы Cubase VST, где на Audio распространялась терминология MIDI (на MIDI-треках располагались MIDI Events, а на аудиотреках — Audio Events).
В программе Cubase VST проект (сонг) имеет трехуровневую структуру:

  • Tracks — уровень треков (верхний);
  • Parts — уровень частей (средний);
  • Events — уровень событий (нижний).

В Nuendo уровень Parts сохраняется только для MIDI. А для Audio реализовано другое решение: размещение Audio Events происходит непосредственно на аудиотреках.
Это значит, что Audio Events могут располагаться непосредственно на аудиотреках, минуя уровень частей (Parts).

Примечание
Из Audio Events можно собрать "контейнеры" (Audio Parts), образуя средний уровень для аудио. Но эта функция не является обязательной.

Такое решение принято не случайно, ведь Nuendo — это, прежде всего, система для создания Audio, где все должно быть подчинено идее недеструктивного редактирования.
Объект Audio Event в программе Nuendo обладает пятью манипуляторами и "по старинке" назван аудиособытием. Но функционально — это аудиообъект, имеющий виртуальные свойства.

Примечание
В программе Samplitude 2496, например, такой элемент с пятью манипуляторами называется объектом.

Одним из свойств объекта Audio Events является его собственная ссылка на Audio Clip. Остальные свойства объекта изменяются с помощью манипуляторов, которые мы рассмотрим в следующем разделе.


Манипуляторы

Итак, объект Audio Event имеет пять манипуляторов (рис. 2.84).
Для того чтобы манипуляторы стали видимыми, объект необходимо выделить щелчком мыши. Рассмотрим их функции.
Манипуляторы с номерами 1, 2 (см. рис. 2.84) служат для изменения границ объекта: Event Start и Event End. Курсор мыши видоизменяется при его наведении на манипулятор.

Рис. 2.84. Манипуляторы аудиообъекта

Если при этом нажать и удерживать левую кнопку мыши, то рядом с манипулятором появится надпись, содержащая информацию о координате границы и длине объекта (рис. 2.85). При перетаскивании манипулятора надпись отражает его текущую позицию.

Примечание
Информация этого раздела относится к версии Nuendo 1.53.

Рис. 2.85. Изменение границ объекта

Манипуляторы с номерами 3, 4 (см. рис. 2.84) управляют линиями плавного изменения громкости Fade In и Fade Out.
Эта операция не является полностью виртуальной и выполняется деструктивно — с созданием новой копии части звукового файла и переназначением ссылки. Длина части звукового файла равна длине линии Fade. Данная операция не затрагивает глобальную ссылку Audio Clip, поэтому разные копии Audio Events могут иметь независимые линии Fade.
Физические деструктивно обработанные копии оригинального звукового файла располагаются в папке Fades папки проекта.

Примечание
Такое решение позволяет существенно сэкономить вычислительные ресурсы.

При перетаскивании манипулятора 3 или 4 отображается надпись, содержащая текущую координату манипулятора и длину линии Fade (рис. 2.86).

Рис. 2.86. Изменение Fade In

При редактировании Fade соответственно изменяется имидж звукового файла. Это позволяет оценить изменения по внешнему виду.
Манипулятор с номером 5 (см. рис. 2.84) нужен для виртуального изменения громкости объекта.

Рис. 2.87. Изменение громкости объекта

Если перетаскивать этот манипулятор, то на экране отображается текущий уровень громкости и глубина изменения (diff.) в дБ (рис. 2.87) относительно предыдущего уровня. Имидж звуковой волны также обновляется, давая возможность визуальной оценки.


Деструктивный и виртуальный фейды

Деструктивный фейд

Пользователь программы Nuendo может выбирать, как распределить вычислительные ресурсы машины: какому из двух видов редактирования отдать предпочтение — виртуальному или деструктивному.

Терминология
Нужно заметить, что деструктивный способ редактирования, при котором создается резервная копия, не является чем-то принципиально новым. Подобный метод применяется и в редакторе Cool Edit Pro, и в Samplitude 2496. По нашему мнению, все способы защиты оригинальной информации от случайного разрушения являются достоинствами программы.
Любое редактирование в Nuendo названо в документации к программе неразрушающим. Это происходит оттого, что в Nuendo деструктивно редактируется физическая копия оригинальных звуковых данных.
Для того чтобы отличать процессы, происходящие при редактировании в реальном времени от непосредственной обработки звукового файла, используются термины Online и Offline.
В дальнейшем любое редактирование, в результате которого создается сохраняемый на диск звуковой файл, будет называться деструктивным.

Рассмотрим деструктивный фейд, который организован с помощью манипуляторов объекта.
В предыдущем разделе мы рассматривали манипуляторы объекта (см. рис. 2.84). Третий и четвертый из них обеспечивают деструктивный фейд с "бесшовным" переназначением ссылки — в местах стыковки отсутствуют щелчки. Пользователь может и не подразумевать о таком сервисе — т. к. программа выполняет эту операцию автоматически.
Как уже отмечалось, деструктивное редактирование избавляет процессор от лишних вычислений. Ведь объектов в проекте может быть много, и если для каждого в реальном времени вычислять фейд, то нагрузка на процессор будет большой. Намного разумнее потратить вычислительные ресурсы с большей выгодой — например, на обработку звука с помощью plug-ins.
Какие возможности предоставляет Nuendo для деструктивного фейда?
Для того чтобы это узнать, обратимся к меню Audio | Open Fade Editor(s). Пункты этого меню становятся доступными, если на мультитреке выделен хотя бы один объект.

Выделение объектов
Объекты можно выделять щелчком мыши, рамкой или последовательно: щелчками мыши с нажатой клавишей <Shift>. Также для операций выделения существует отдельное меню Edit | Select.
Если выделено несколько объектов, то их манипуляторы связываются. Это значит, что изменение позиции манипулятора у одного объекта вызывает синхронное изменение для других выделенных объектов.

Выбор пункта Open Fade Editor(s) может вызвать сообщение Please select audio events with fade times > 0! (Пожалуйста, выделите объекты Audio Events с временем фейда больше 0). Это означает, что выделен объект (объекты) с нулевыми позициями манипуляторов 3, 4 (см. рис. 2.84). Поэтому выбирать пункт Audio | Open Fade Editor(s) следует только для объектов с деструктивным фейдом.
Итак, отметим пункт Audio | Open Fade Editor(s) для выделенного объекта с деструктивным фейдом. Появится два окна настройки Fade In: и Fade Out: (рис. 2.88).

Рис. 2.88. Окна настройки деструктивного фейда

Примечание
Для наглядности на рис. 2.88 окна Fade In: и Fade Out: расположены рядом. Если смещен только один из манипуляторов фейда объекта, то появится только одно окно Fade In: или Fade Out: соответственно.

В центре расположен фейд-дисплей (Fade Display) с кривой Fade In (Fade Out). Кривую можно построить по точкам. Для этого достаточно щелкнуть в любом месте графического дисплея. Каждый щелчок создает новую точку. Точки свободно перетаскиваются мышью.
Кнопка [image] (Spline Interpolation) секции Curve Kind (Вид кривой) включает режим сглаживания (сплайн-интерполяции) кривой фейда. По умолчанию активен режим Linear Interpolation (линейной интерполяции), который включается соседней кнопкой.
Кнопка [image] (Restore) восстанавливает вид кривой на момент открытия окон Fade In: и Fade Out:, т. е. сбрасывает все настройки.
Под фейд-дисплеем расположен ряд кнопок вида кривой фейда (Curve shape buttons).
Фактически эти кнопки выполняют функцию быстрого вызова фирменных пресетов кривых фейда.
Собственные пресеты можно сохранить в секции Presets.
Кнопка Store сохраняет пресет под названием Preset N (где N — номер пресета). Для переименования нужно выбрать пресет в раскрывающемся списке, затем щелкнуть на его названии и ввести имя с клавиатуры, завершив процесс нажатием клавиши <Enter>.
Кнопка As Default сохраняет кривую фейда как пресет по умолчанию для тех объектов, где манипуляторы фейда пока не смещались, а также для всех вновь созданных объектов.
Если применить команду Audio | Remove Fades, удаляющую кривые фейда с выделенных объектов Audio Events, то последующее смещение манипуляторов фейда этих же объектов создаст кривую по умолчанию.
Кнопки Apply (Применить) и ОК (Применить и закрыть) сохраняют результаты редактирования в окнах Fade In/Out:.
Функция Crossfade работает аналогичным образом: в папке Fades создается (вычисляется) новый звуковой файл, равный длине зоны кроссфейда, и переназначается ссылка. Рассмотрим функцию Crossfade более детально.
В самом простом случае выделенные объекты Audio Events должны иметь область перекрытия. Кроссфейд создается в области перекрытия командой Audio | Crossfade (клавиша <Х>) (рис. 2.89).

Рис. 2.89. Кроссфейд в области перекрытия объектов

В более сложном случае кроссфейд может быть выполнен на объектах, имеющих размер внутренней ссылки меньший, чем Audio Clip. Манипуляторы с номерами 1 или 2 (см. рис. 2.84) должны быть смещены (то есть объект "подрезан"). Тогда для двух соседних объектов может быть выполнен кросс-фейд с автоматическим изменением границ на длину зоны кроссфейда, установленную по умолчанию в диалоговом окне Crossfade: (об этом ниже) (рис. 2.90).

Рис. 2.90. Кроссфейд при перекрытии аудиоклипов

На рис. 2.90 показан размер глобальной ссылки Audio Clip и укороченный размер внутренней ссылки Audio Event. Два соседних объекта с укороченным размером внутренней ссылки образуют кроссфейд после выполнения команды Audio | Crossfade. Важно отметить, что размер внутренней ссылки должен быть укорочен по отношению к глобальной ссылке со стороны прилегающих границ объектов.
Параметры кроссфейда можно редактировать в диалоговом окне Crossfade: (рис. 2.91). Для этого нужно выделить один или два объекта с кроссфейдом и повторно выполнить команду Audio | Crossfade (клавиша <Х>). Другой способ — дважды щелкнуть в зоне кроссфейда.
Диалоговое окно Crossfade: представляет собой комбинацию окон Fade In: и Fade Out:.
Кнопки Play Fade обеспечивают контрольное прослушивание результата функции Crossfade для каждого объекта по отдельности (Fade In и Fade Out).
Кнопка Play Dry дает возможность прослушать "сухой" звук без обработки.
Кнопка Play воспроизводит кроссфейд полностью, так же, как он будет звучать на мультитреке.
Флажок Equal Power формирует кривые таким образом, чтобы в зоне кроссфейда была постоянная суммарная мощность сигнала.
Флажок Equal Gain выполняет аналогичную функцию для поддержания постоянной суммарной амплитуды.

Рис. 2.91. Диалоговое окно Crossfade:

Кнопка Restore возвращает диалоговое окно к первоначальному состоянию на момент его открытия, т. е. сбрасывает все настройки.
В поле Length задается длина зоны кроссфейда в формате времени, определяемом в раскрывающемся списке форматов.
Кнопка As Default сохраняет текущие настройки диалогового окна Crossfade: как настройки по умолчанию. Эти настройки будут использоваться при каждом следующем применении функции кроссфейда. Значение поля Length также сохраняется как настройка по умолчанию, однако она не будет применяться в случаях кроссфейда с перекрытием объектов, где длина области перекрытия определяет зону кроссфейда.
Кнопка Recall Default копирует настройки по умолчанию в диалоговое окно Crossfade:. Такая функция может, например, применяться для возврата к настройкам по умолчанию после редактирования в диалоговом окне.

Совет
Размер зоны кроссфейда можно изменять простым перетаскиванием объектов. Но при этом объекты обязательно должны сохранять область перекрытия.

Зоны кроссфейда отображаются на мультитреке всегда. Однако кривые фейда, образованные на объектах фейд-манипуляторами 3, 4 (см. рис. 2.84) можно скрыть, если снять флажок Show Event Volume Curves Always на странице Event Display в окне Preferences (рис. 2.92).
Если флажок снят, то линии громкости отображаются только при выделении объекта Audio Event.

Рис. 2.92. Настройка режима отображения линий громкости

Виртуальный фейд

Виртуальный фейд (Auto Fades) представляет собой недеструктивное редактирование в чистом виде: кривые фейда рассчитываются процессором в реальном времени.
Основная функция виртуального фейда — более гладкие переходы между соседними объектами, поэтому процессором в реальном времени рассчитываются кривые Fade In/Out длиной 1—500 мс.
Еще раз отметим, что в Nuendo пользователю предоставляется возможность самостоятельно распределять вычислительные ресурсы машины. При большом количестве объектов виртуальный фейд может значительно снизить общую производительность, поэтому для него предусмотрены два вида настроек:

  • глобальные — распространяющиеся на все объекты проекта;
  • трековые — действующие только на объекты конкретной дорожки.

Совет
Для максимальной производительности рекомендуется не включать виртуальный фейд в глобальных настройках, а использовать только трековые настройки по мере необходимости.

Глобальные настройки осуществляются командой меню Project | Auto Fades Settings в диалоговом окне Auto Fades - Project: (рис. 2.93).

Интерфейс диалогового окна Auto Fades - Project: аналогичен рассмотренным выше окнам Fade In:, Fade Out: и Crossfade:.

Рис. 2.93. Диалоговое окно Auto Fades - Project:

Флажки Auto Fade In, Auto Fade Out и Auto Crossfades активизируют соответствующие режимы виртуального фейда и кроссфейда.
В поле со списком Length задается длина виртуального фейда в миллисекундах.
Кнопка As Default сохраняет глобальные настройки для всех последующих проектов. Это означает, что все вновь созданные проекты будут иметь одинаковые глобальные настройки.

Примечание
Функция сохранения глобальных настроек работает только для проектов, созданных из фирменных шаблонов. Если проект создается из собственного шаблона, ранее сохраненного командой File | Save as Template, то глобальные настройки будут соответствовать шаблону.

Трековые настройки виртуального фейда выполняются в окне Auto Fades -Track: (рис. 2.94), которое вызывается через контекстное меню треков командой Auto Fades Settings.
Отличие интерфейса этого диалогового окна от окна Auto Fades - Project в специальном флажке Use Project Settings. Если флажок активен, то на дорожке действуют глобальные установки. Если флажок сброшен, то на треке можно установить отдельные настройки.
Если изменить трековые настройки с активным флажком Use Project Settings, то программа воспримет их как новые глобальные настройки и выдаст запрос на их сохранение.

Рис. 2.94. Окно Auto Fades - Track


Режимы недеструктивного редактирования

Панель инструментов Nuendo функционально имеет много общего с панелью инструментов программы Cubase VST. Но существуют различия, основанные на том, что Nuendo больше специализируется для работы с Audio.
В Nuendo можно производить недеструктивные операции как с объектами (Events), так и с диапазонами (Range). Поэтому мы разделим недеструктивное редактирование на два вида:

  • Операции с объектами.
  • Операции с диапазонами.


Операции с объектами

Этот вид редактирования исключает использование инструмента Range Selection [image].
Рассмотрим операции с объектами.

Перемещение

Самый простой способ реализуется перетаскиванием объекта или группы выделенных объектов с помощью инструмента Object Selection (рис. 2.95).
Стрелками на рис. 2.95 показано направление перемещения объектов, которое сопровождается информацией о текущей координате точки синхронизации (Sync Point) смещаемого объекта (на рис. 2.95 в формате Bars+Beats).

Рис. 2.95. Перемещение выделенной группы объектов

Примечание
Точку синхронизации (привязки) Sync Point (Snap Point) мы подробно рассмотрим в разд. "Привязка к тактовой сетке (Snap)".

Если режим Snap (кнопка Snap On/Off [image] ) активен, то переместить объект возможно только на фиксированные позиции.
Если производить перемещение с нажатой клавишей <Ctrl>, то траектория объекта будет зафиксирована по вертикали или по горизонтали. Любые перемещения по диагонали будут запрещены. Такой метод сдвига объектов особенно полезен, если требуется перемещение по вертикали с сохранением стартовой позиции.
В Nuendo разработана защита от случайного смещения объекта при выделении щелчком мыши. Защита реализована как временная задержка (Drag Delay) между щелчком мыши и началом смещения объекта. Иначе говоря, чтобы сместить объект, нужно некоторое время удерживать кнопку мыши нажатой.
Величина задержки в миллисекундах регулируется в дополнительных настройках (рис. 2.96) на странице User Interface-Editing в поле Drag Delay.
Сдвиг выделенных объектов также выполняется с помощью кнопок Move Left и Move Right панели инструментов Nudge и Snap (см. разд. "Панель инструментов Toolbar").
На этом методы перемещения объектов не исчерпываются. Через меню Edit и четыре команды Move to реализуется еще четыре способа.

  • Move to Cursor — сдвиг выделенного объекта (или группы) к текущей позиции курсора мультитрека.

Внимание
Объект сдвигается таким образом, чтобы точка синхронизации совместилась с текущей позицией курсора. Если выделена группа, то с текущей позицией курсора совмещается точка синхронизации объекта, ближайшего к началу мультитрека.

Рис. 2.96. Настройка параметра Drag Delay

  • Move to Origin — сдвиг к оригинальной позиции, т. е. к той, в которой объект был записан на дорожку мультитрека.
  • Move to Front, Move to Back — сдвиг фронт/тыл для наложенных объектов, операция, аналогичная командам субменю То Front (см. разд. "Запись с текущей позиции курсора" ранее в этой главе).
  • Еще один способ реализуется через информационную панель Info Line (рис. 2.97).

Нужно выделить один объект и скорректировать координаты его стартовой границы.

Рис. 2.97. Сдвиг объекта с помощью панели Info Line

Копирование

Самый простой способ копирования — это перетаскивание объекта (или выделенной группы) с нажатой клавишей <Alt> инструментом Object Selection.
Остальные методы копирования связаны с командами меню Edit.

  • Duplicate (комбинация клавиш <Ctrl>+<D>) — дублирование выделенного объекта или группы.
    При этом копия объекта располагается сразу после оригинала, стыкуясь с его границей. При дублировании группы копия сохраняет взаимное расположение объектов. На рис. 2.98 изображен пример дублирования группы. Цифрами обозначены первый и последний (четвертый) объекты группы. Копия группы расположилась таким образом, что копия первого объекта (1 сору) граничит с последним объектом оригинала (4).

Рис. 2.98. Дублирование группы объектов

  • Repeat (комбинация клавиш <Ctrl>+<K>) — функция многократного дублирования. Основное ее отличие от функции дублирования Duplicate заключается в возможности задать конкретное число копий. Количество копий устанавливается в диалоговом окне Repeat Events (рис. 2.99) в поле Count.

Рис. 2.99. Окно Repeat Events

Shared Copies
Флажок Shared Copies устанавливает режим дублирования с созданием общих копий. Это имеет значение для Audio Part и MIDI Part. Для объектов Audio Event
состояние флажка Shared Copies не имеет значения, т. к. все копии объектов всегда являются общими копиями из-за одинаковой внутренней ссылки на Audio Clip. Результаты редактирования содержимого одной общей копии автоматически применяются ко всем остальным копиям. Общая копия помечается буквой S (Shared). Для отдельного деструктивного редактирования копии объекта Audio Event необходимо предварительно воспользоваться командой меню Edit | Convert to Real Copy (преобразовать в физическую копию). Тогда в окне Pool будет создана копия аудиоклипа.

  • Fill Loop — команда дублирования объектов с созданием циклической последовательности между локаторами L и R (рис. 2.100), причем последняя копия автоматически обрезается по позиции правого локатора — R.

Рис. 2.100. Создание цикла между локаторами

Кроме специфических методов копирования, рассмотренных выше, можно пользоваться традиционными: Cut, Copy и Paste, представленными одноименными командами меню Edit. Команда Paste выполняет операцию вставки объекта Audio Event таким образом, чтобы точка синхронизации Sync Point совпадала с текущей позицией курсора мультитрека. Специальная команда Paste at Origin осуществляет вставку объекта в оригинальную позицию, т. е. ту, в которой он был до операций Cut или Сору.

Переименование

По умолчанию имя аудиособытия указывает на Audio Clip в соответствии с внутренней ссылкой. Но при необходимости пользователь может переименовать выделенный объект. Делается это в поле Description на панели Info Line.
Переименованный объект Audio Event будет содержать в скобках название глобальной ссылки.

Разрезание

Нетрудно догадаться, что для этого предназначается инструмент Split [image] панели Toolbar.
Если режим Snap (кнопка Snap On/Off [image]) активен, то переместить инструмент Split можно только на фиксированные позиции. Рядом с инструментом Split отображается его текущая позиция, а на объекте — линия разреза (рис. 2.101).

Рис. 2.101. Операция разрезания объекта

Для разрезания достаточно щелкнуть левой кнопкой мыши, установив инструмент Split в нужную позицию.

Рис. 2.102. Операция Split Loop

Объекты можно разрезать непосредственно по линии курсора мультитрека с помощью команды Split at Cursor (комбинация клавиш <Alt>+<X>). Операция применяется к выделенным объектам. Если ни один объект не выделен, то по линии курсора разрезаются все объекты на всех дорожках мультитрека.
Разрезание объектов по границам обоих локаторов L и R выполняется с помощью команды Edit | Split Loop. Команда Split Loop применяется к выделенным объектам или ко всем объектам, если ни один из них не выделен (рис. 2.102).

Склеивание

Склеивание производится с помощью инструмента Glue (клей) [image] в направлении от начала мультитрека. Операция склеивания имеет двоякий результат в зависимости от предыстории редактирования (рис. 2.103).

Рис. 2.103. Различные результаты склеивания

Если склеить два объекта Audio Event сразу после разрезания, то снова образуется Audio Event. При этом объекты после разрезания не должны перемещаться или редактироваться. В более общем виде это правило можно сформулировать так: если аудиособытия располагаются последовательно друг за другом, а их внутренние ссылки расположены также последовательно на аудиоклипе, то склеивание образует Audio Event. В остальных случаях склеивание приводит к образованию "контейнера" Audio Part.

Группирование

Выделенные объекты можно сгруппировать командой Edit | Group. С точки зрения редактирования группа ведет себя как отдельный объект, т. е. операции редактирования применяются одновременно ко всем объектам группы. Объекты, входящие в группу, помечаются символом g.
Сгруппированные объекты разъединяются командой Edit | Ungroup.

Изменение границ объекта (Sizing)

Изменение границ объекта (или группы выделенных объектов) выполняется с помощью инструмента Object Selection [image] и манипуляторов 1, 2 (см. разд. "Манипуляторы").
Инструмент Object Selection имеет два режима:

  • Normal Sizing — при котором смещается только граница объекта;
  • Sizing Moves Contents — при котором содержимое объекта следует за смещаемой границей.

Примечание
В этом режиме происходит встречное смещение противоположной границы внутренней ссылки Audio Event.

Переключение между режимами осуществляется с помощью кнопки Object Selection.
Для этого нужно щелкнуть по подсвеченной кнопке (рис. 2.104) и выбрать режим во всплывающем меню.

Рис. 2.104. Режимы операции Sizing

"Галочкой" в меню отмечен активный режим. Для быстрого перехода к неактивному режиму нужно выполнить смещение границы с нажатой клавишей <Alt>.
В Nuendo существует полезная и удобная функция изменения границ аудио-событий с помощью инструмента Scrub/Play [image] в режиме подчистки (Scrub).
Смещение границы аудиособытия инструментом Scrub производится с акустическим контролем, что позволяет максимально точно определить позицию границы на реальном аудиоматериале.

Совет
Для редактирования аудиоматериала удобно4 использовать сочетание инструмента Scrub/Play (в режиме Scrub) с разрезанием по линии курсора мультитре-ка (команда Edit | Split at Cursor, комбинация клавиш <Alt>+<X>). С помощью инструмента Scrub ищется точная линия разреза (позиция курсора), а затем выполняется разрезание по линии курсора.

Еще одним интуитивно понятным способом изменения границ является использование кнопок Trim Button панели инструментов Nudge и Snap (см. разд. "Панель инструментов Toolbar" ранее в этой главе, рис. 2.30).

Примечание
Смещение границ (Normal Sizing или Sizing Moves Contents) кнопками Trim Button также зависит от установленного режима инструмента Object Selection.

Прокручивание содержимого объекта (Sliding)

Внутреннее содержимое объектов можно прокручивать без сдвига самих объектов.
На рис. 2.105 показан пример прокрутки аудиоклипа внутри аудиособытия.

Примечание
Если аудиособытие захватывает аудиоклип целиком, то прокрутка невозможна.

Рис. 2.105. Смещение собственной ссылки Audio Event

Фактически происходит смещение (Offset) границ Event Start и Event End собственной ссылки Audio Event относительно стартовой границы аудио-клипа без изменения позиции аудиособытия на мультитреке. Границы прокрутки определяются размерами аудиоклипа.
Содержимое объекта прокручивается с нажатыми клавишами <Ctrl> и <Shift>.

Блокирование объектов

Для защиты от случайного редактирования объекты можно заблокировать. Блокировка выделенных объектов осуществляется с помощью команды Edit | Lock. Для разблокирования предусмотрена команда обратного действия Unlock.
В зависимости от дополнительных настроек Preferences (рис. 2.106) объекты могут блокироваться по нескольким признакам:

  • Position — защита от перемещения;
  • Size — защита от смещения границ;
  • Other — защита от всех остальных видов редактирования, включая деструктивный фейд, деструктивное редактирование с обработкой plug-ins и т. д.

Рис. 2.106. Настройки параметров блокирования объектов

В дополнительных настройках на странице User Interface-Editing в раскрывающемся списке Lock Event Attributes можно установить любой вариант блокирования или их комбинацию.
Параметры блокирования выделенных объектов можно изменить, если повторить команду Lock для заблокированных объектов. Тогда в диалоговом окне Lock Event Attributes следует отметить или снять соответствующие флажки.

Рис. 2.107. Диалоговое окно Lock Event Attributes

Для одного выделенного объекта параметры блокирования можно изменить в поле Lock панели Info Line.


Привязка к тактовой сетке (Snap)

Без функции Snap недеструктивное редактирование было бы усложнено дополнительными усилиями по поиску синхронизации между объектами вручную.
Если композиция монтируется из фрагментов, привязанных к метру и ритму, то без функции Snap не обойтись. Благодаря ей пользователь может быстро и точно позиционировать объекты.
Для того чтобы функция Snap могла привязывать аудиособытия к тактовой сетке, каждое аудиособытие содержит точку синхронизации — Sync Point (Snap Point).
На рис. 2.108 точка синхронизации изображена в окне редактора Sample Editor. Здесь ее можно перетаскивать мышью.
В окне Nuendo Project точка синхронизации отображается вертикальной синей линией внутри аудиособытия.

Рис. 2.108. Точка синхронизации Sync Point (Snap Point)

Точка Sync Point представляет собой специальный маркер, относительно которого формируется позиция аудиособытия на дорожке. По умолчанию точка синхронизации расположена в начале аудиособытия, но может возникнуть необходимость переместить ее в соответствии с музыкальной задачей, например, на сильную долю. В окне Nuendo Project точка синхронизации смещается в текущую позицию курсора командой Audio | Snap Point to Cursor.

Совет
Поиск позиции курсора удобно выполнить с помощью инструмента Scrub, а затем уже сместить точку Sync Point командой Audio | Snap Point to Cursor.

Режимы функции Snap
Активизация функции Snap осуществляется с помощью кнопки Snap On/Off [image].
Режимы функции Snap выбираются в раскрывающемся списке панели функций Snap и Quantize (рис. 2.109).

Рис. 2.109. Раскрывающийся список режимов Snap

В списке предлагается на выбор четыре основных и три комбинированных режима. Рассмотрим режимы функции Snap по порядку.
Grid — классический режим привязки к тактовой сетке, известный пользователям Cubase VST. В этом режиме задается шаг тактовой сетки в формате времени (Display Format) линейки Ruler. Шаг тактовой сетки выбирается в раскрывающемся списке панели инструментов Nudge и Snap (рис. 2.110).

Рис. 2.110. Выбор шага тактовой сетки

Events — режим привязки к событиям. В этом режиме "центрами притяжения" становятся:

  • границы объектов;
  • точки синхронизации аудиособытий;
  • маркеры.

При этом сами маркеры также "притягиваются" к границам объектов и точкам Sync Point. Данный режим удобно использовать для быстрого монтажа без привязки к музыкальному размеру и темпу, когда ориентиром являются соседние объекты и маркеры (рис. 2.111).

Рис. 2.111. Привязка в режиме Events

Shuffle — режим тасования объектов. Применим для случаев, когда требуется изменить порядок следования соседних объектов. Выполняется простым перетаскиванием объектов.
В примере на рис. 2.112 объекты Audio Event 1 и Audio Event 2 поменяются местами.
Magnetic Cursor — режим привязки к курсору мультитрека, в котором объекты "прилипают" к курсору мультитрека своими стартовыми границами. Объекты Audio Event "прилипают" к курсору точками Sync Point.
Остальные режимы функции Snap представляют собой комбинации из вышеописанных.

Рис. 2.112. Тасование объектов в режиме Shuffle

Примечание
Нужно отметить, что функция Snap действует не только на объекты и маркеры, но и на точки автоматизации. Параметры функции Snap могут быть уставлены разными в окне Nuendo Project и окнах Audio Part Editor.


Операции с диапазонами

В Nuendo кроме различных манипуляций с объектами существует отдельный класс операций недеструктивного редактирования, которые проводятся с помощью диапазонов (Range).
Все эти операции выполняются с помощью инструмента Range Selection [image].

Совет
Если выбран инструмент Range Selection, то для выделения диапазонов можно воспользоваться меню Edit | Select.

С помощью диапазонов редактировать в большинстве случаев удобнее и быстрее, чем с помощью традиционных операций (разрезания, копирования и т. д.), т. к. диапазон не ограничен дорожкой или размерами объекта, а редактируется вся выделенная область. Она может охватывать несколько объектов даже на разных дорожках.
Рассмотрим приемы редактирования инструментом Range Selection.
Диапазон можно выделить не только пунктами меню Edit | Select, но и традиционно — с помощью мыши. Для этого достаточно протащить курсор мыши.
После того как диапазон выделен, его можно, например, переместить (рис. 2.113).

Рис. 2.113. Перемещение диапазона

Перемещение диапазона — это фактически ни что иное, как создание нового объекта.

Примечание
При операциях с диапазонами удобно использовать функцию привязки Snap.

Еще несколько способов выделения диапазона:

  • точное выделение объекта производится двойным щелчком на нем инструментом Range Selection;
  • если после точного выделения одного объекта нажать и удерживать клавишу <Shift>, а затем дважды щелкнуть на остальных объектах, то можно точно выделить группу;
  • если требуется расширить границы диапазона по горизонтали или по вертикали, следует подвести курсор мыши к границе диапазона (при этом он примет вид [image]) и протащить его в нужном направлении;
  • чтобы исключить ненужные треки из диапазона, следует щелкнуть на треке внутри диапазона при нажатой клавише <Ctrl>. (Повторный щелчок вернет трек в состав диапазона.)

Изменять, а также смещать границы диапазона можно и с помощью кнопок панели инструментов Nudge и Snap, или корректируя значения полей Start, End и Length панели Info Line. При этих способах содержимое, охваченное диапазоном, не перемещается.
Теперь перейдем непосредственно к редактированию.
Самый простой способ перемещения диапазона вместе с его содержимым был описан выше (см. рис. 2.113).
При копировании, в отличие от перемещения, нужно удерживать клавишу <Alt>, когда диапазон перетаскивается мышью.
Операции Duplicate, Repeat и Fill Loop для выделенного диапазона (режим Range Selection) ничем не отличаются от манипуляций с объектами.
Так, например, быстро создать циклическую последовательность (loops) из выделенного диапазона можно следующим образом:

  1. 1. "Грубо" выделить диапазон.
  2. 2. Включить циклическое воспроизведение диапазона командой Transport | Loop Selection.
  3. 3. Откорректировать границы фрагмента в режиме циклического воспроизведения (повторяя команду Loop Selection при каждом смещении границ).
  4. 4. Ограничить локаторами L и R область копирования Loops.
  5. 5. Применить команду Edit | Fill Loop (рис. 2.114).

Рис. 2.114. Создание цикла

В режиме редактирования диапазонов действуют и традиционные команды меню Edit: Cut, Copy и Paste. Но в их применении есть некоторые отличия по сравнению с режимом Object Selection.

  • Cut — вырезает выделенную область и переносит ее в буфер обмена.
  • Сору — копирует выделенную область в буфер обмена.
  • Paste — делает вставку из буфера в выделенный диапазон.
  • Paste at Origin — делает вставку в оригинальную позицию (в ту, которая была до копирования или вырезания).
  • Delete — удаляет содержимое выделенной области.

Остальные методы редактирования связаны с пунктами субменю Range в меню Edit.

  • Cut Time — буквально "вырезает время". При выборе этой команды все объекты, расположенные правее выделенной области, сдвигаются влево (на длину выделенной области). В остальном эта команда аналогична по действию команде Cut.
  • Delete Time — повторяет команду Cut Time, но без копирования в буфер обмена.
  • Paste Time — аналогична по действию команде Paste, но при вставке сдвигает вправо все объекты, расположенные правее выделенного диапазона. Величина сдвига зависит от длины объекта, находящегося в буфере обмена.
  • Paste Time at Origin — то же самое, что и Paste Time, но вставка производится в оригинальную позицию.
  • Split — разрезает объект по границам диапазона.
  • Crop — обрезает объект по границам диапазона.
  • Insert Silence — раздвигает объект на длину диапазона. При этом весь последующий материал (правая часть объекта и все объекты, расположенные после нее) сдвигается вправо. Если выполнить команду на пустом месте, то сдвинутся только объекты, расположенные правее диапазона (рис. 2.115).

Рис. 2.115. Операция Insert Silence

Примечание
Команды Paste Time и Paste Time at Origin доступны и в режиме Object Selection. Но в нем вместо вставки диапазона осуществляется вставка объекта со сдвигом всех объектов, расположенных правее.

В режиме Range Selection удобно производить и редактирование деструктивного фейда объектов Audio Event. Делается это так: выделяется диапазон,
затем выбирается пункт Adjust Fades to Range (клавиша <А>) в меню Audio. Результаты этой операции будут различаться: они зависят от того, как расположен диапазон относительно объекта (рис. 2.116).
Верхний пример. Если диапазон не пересекает ни одной границы объекта, то линии Fade In и Fade Out формируются по длине области объекта, не охваченной диапазоном.
Средний пример. Если диапазон пересекает границу объекта, то линия Fade формируется на расстоянии от границы объекта до границы диапазона.
Нижний пример. Если диапазон пересекает границу объекта и противоположную кривую Fade, то изменению подлежат обе линии Fade.

Рис. 2.116. Деструктивный фейд в режиме Range selection


"Контейнер" Audio Part

В программе Nuendo аудиособытия выкладываются непосредственно на дорожки мультитрека. Но, несмотря на это, может оказаться удобным собрать некоторые из них в "контейнеры" Audio Part. Эту операцию можно рассматривать как функцию объединения аудиособытий, так сказать, своеобразную сервисную надстройку.
Создать Audio Part можно следующими способами:

  • склеить аудиособытия одной дорожки инструментом Glue;
  • выделить одно или несколько аудиособытий и применить команду Events to Part в меню Audio;
  • создать пустой "контейнер" Audio Part двойным щелчком на аудиодорожке между локаторами L и R;
  • нарисовать пустой "контейнер" инструментом Draw/Line [image].

При необходимости "контейнер" можно демонтировать командой обратного действия: Audio | Dissolve Part. Она применяется к выделенным объектам Audio Part.


Редактор Audio Part Editor

Двойной щелчок на объекте Audio Part вызывает редактор Audio Part Editor (рис. 1.\\1). (О нем шла речь в разд. "Создание "идеального" дубля (Perfect Take.) в редакторе Audio Part Editor".)

Рис. 2.117. Окно редактора Audio Part Editor

Большая часть интерфейса и элементов управления в окне Audio Part Editor совпадает с окном Nuendo Project. Но есть отличия — три новые кнопки:
  • (Solo) — включает режим Solo для окна редактора, позволяющий прослушивать содержимое "контейнера" без остальных дорожек мультитрека;
  • (Play) — режим воспроизведения непосредственно на шину BUS1 в обход виртуальной обработки;

Примечание
Если не пользоваться этой кнопкой, то воспрйизведение в редакторе Audio Part Editor будет синхронизировано с воспроизведением проекта.

  • (Loop) — режим циклического воспроизведения. Циклическое воспроизведение выполняется автоматически на длину выделенного аудио-события или группы, а также диапазона Range.

Все способы редактирования, рассмотренные выше для окна Nuendo Project, действительны и для редактора Audio Part Editor. Поэтому этим редактором можно пользоваться как монтажным столом для группы объектов Audio Events, ведь для виртуального редактирования основным преимуществом редактора Audio Part Editor является наличие дополнительных виртуальных дорожек — Lanes (рис. 2.118).

Рис. 2.118. Виртуальные дорожки Lanes

С помощью дорожек Lanes легко решается проблема свободного места при сложном монтаже. И процесс, очень трудоемкий в других условиях, превращается в "успокаивающий нервы пасьянс".
При каждом копировании или перемещении аудиособытия вниз создается новая виртуальная дорожка. Таким образом, объекты не нагромождаются друг на друга, а аккуратно раскладываются ровными рядами на "рабочем столе".
Нужно отметить, что дорожки Lanes — это виртуальная надстройка над основным треком проекта Nuendo Project. Поэтому их воспроизведение осуществляется через один и тот же виртуальный канал (за исключением воспроизведения с помощью кнопки Play [image]).
Все дорожки Lanes имеют приоритеты. У нижней он самый высокий. Поэтому аудиособытия в соответствии с приоритетом "перехватывают" друг у друга виртуальный канал при воспроизведении. На рис. 2.118 белым цветом закрашены области, захваченные более приоритетной (нижней) дорожкой.


Редактор Sample Editor

Редактор Sample Editor программы Nuendo можно сравнить с окном SoundFile программы SAWStudio. Их функциональное назначение во многом совпадает. В обеих программах они служат для создания регионов и деструктивного редактирования.
Вообще, возможности редактора Sample Editor шире, чем возможности редактирования в окне SoundFile программы SAWStudio. Это обусловлено уникальным алгоритмом многослойного деструктивного редактирования Nuendo. Помимо этого здесь более сложная иерархия ссылок.
В редакторе Sample Editor можно выполнять операции, относящиеся к обоим видам редактирования: к деструктивному и недеструктивному. В этом разделе будет рассказано о создании регионов и аудиособытий в редакторе Sample Editor.

Совет
Вызов редактора можно закрепить за "горячей" клавишей. Это делается так. Сначала в окне Key Commands нужно выбрать категорию Edit, а в ней команду Open/Close Editor. Затем запрограммировать клавишу или комбинацию клавиш (см. разд. "Программирование "горячих" клавиш" ранее в этой главе). Таким образом можно управлять вызовом и закрытием окна всех редакторов Nuendo.


Интерфейс редактора Sample Editor

Если дважды щелкнуть на объекте Audio Event (или выделить группу и нажать запрограммированную "горячую" клавишу), то откроется окно (или несколько окон) редактора Sample Editor (рис. 2.119).
Интерфейс этого окна во многом напоминает интерфейс другого продукта той же фирмы Steinberg — редактора WaveLab. Ему свойственна та же лаконичность и интуитивно понятный интерфейс.
Внешний вид окна можно изменять. Для этого нужно щелкнуть правой кнопкой в окне Sample Editor и в контекстном меню выбрать субменю Elements.
В соответствии с отмеченными пунктами субменю Elements будут добавлены/скрыты элементы окна Sample Editor.
Самые часто используемые пункты этого меню вынесены на панель инструментов в виде кнопок: (Audio Event) и [image] (Show Regions).

Рис. 2.119. Окно редактора Sample Editor

Остальные пункты добавляют/скрывают следующие элементы:

  • Info Line — нижняя информационная панель (дублируется кнопкой [image] (Show Info)). Эта панель имеет секцию выбора формата отображения времен;
  • Level Scale — боковая панель отображения уровня в дБ или %. Имеет кнопку переключения единиц измерения;
  • Zero Axis — ось нулевого уровня;
  • Half Level Axis — ось уровня 50% (-6 дБ).

Окно редактора Sample Editor делится на две части: Thumbnail display и Waveform Display. Верхняя часть — Thumbnail display — отображает аудио-клип полностью и предназначена для быстрой навигации. Масштаб и содержимое нижнего окна — Waveform Display — соответствует области, захваченной синим прямоугольником в верхнем окне (рис. 2.120).
Границы синего прямоугольника перетаскиваются мышью. Для того чтобы сместить сам прямоугольник, нужно ухватить его мышью в нижней половине. При этом произойдет прокручивание нижнего окна Waveform Display.
В примере на рис. 2.119 кнопка Show Audio Event нажата, поэтому в окне Waveform Display отображаются границы внутренней ссылки аудиособытия Event Start и Event End, точка Sync Point и само аудиособытие выделены белым цветом.

Рис. 2.120. Быстрая навигация по аудиоклипу

Рассмотрим панель инструментов редактора.
Первые пять кнопок панели инструментов (слева направо) функционально совпадают с аналогичными кнопками проекта Nuendo Project. Кнопки [image] (Play) и [image] (Loop) имеют то же назначение, что и в окне Audio Part Editor. Причем если кнопка Show Audio Event нажата, то воспроизводится только аудиособытие. Иначе воспроизводится весь аудиоклип. Выделение диапазона инструментом Range Selection автоматически переносит цикл в выделенную область.
В этом разделе мы обратим внимание на операции недеструктивного редактирования в редакторе Sample Editor, т. е. на создание и редактирование аудиособытий, аудиоклипов и регионов.
Самая простая и очевидная операция — это изменение границ собственной ссылки аудиособытия. Для этого достаточно перетащить маркер Event Start или Event End.
Эта операция аналогична по действию перемещению манипуляторов 1, 2 (см. рис. 2.84) границ объекта.
Остальные действия связаны с выделением диапазона Range. Правее панели инструментов расположены три поля, отображающие:

  • позицию курсора мыши (cursor);
  • границы выделенного диапазона (два поля Selection). Поля Selection являются активными, в них можно изменять границы диапазона.

Во всех трех полях время измеряется в сэмплах (отсчетах). В информационной панели Info Line границы выделенного диапазона могут отображаться во всех форматах.
Выделение диапазона можно производить с помощью инструмента Range или воспользоваться субменю Select в меню Edit.

Адаптивное контекстное меню

Как известно, пользователю для работы в мультитрековых программах нужно использовать длинные списки меню и субменю или запоминать назначение кнопок, последовательности "горячих" клавиш.
Конечно, программисты стараются максимально облегчить работу пользователей (и спасибо им за это). Но с усложнением программ все сложнее даются интерфейсные решения. "Горячие" клавиши — вещь, конечно, удобная, но в больших количествах — это не панацея, а больше тренажер для памяти. Да и кнопки с пиктограммами иногда так абстрактно выражают в рисунке назначение, что догадаться о том, что там изображено, может только сам художник. Огромные количества "удобных кнопок", подобно ракушкам на днище корабля, тоже подчас мешают движению вперед.
В Nuendo применено другое решение. В этой программе реализована идея адаптивного контекстного меню. Причем контекст здесь — не только текущая позиция курсора мыши, но и последовательность действий пользователя. Поэтому программа постоянно подстраивается — комбинирует списки контекстного меню.
Это решение избавляет пользователя от лишних кнопок, помогает быстро найти требуемый пункт меню, предоставляет действительно нужную контекстную помощь (в отличие от навязчивых подсказок и "советов дня").
Приведем пример. Если щелкнуть левой (инструментом Range), а затем правой кнопкой мыши в редакторе Sample Editor, то вызванное контекстное меню будет содержать небольшое количество пунктов и субменю.
Но если выделить диапазон, то картина изменится: контекстное меню будет значительно шире, т. к. оно соответствует новой функциональной задаче. Программа "знает", что с диапазоном пользователь может выполнить гораздо больше операций.


Недеструктивное редактирование в Sample Editor

Создание аудиособытия

Если редактировать предполагается внутри собственной ссылки аудиособытия, то логично сначала установить такой масщтаб, чтобы вся ссылка отражалась на экране. Делается это с помощью контекстного меню в субменю Zoom командой Zoom to Event.
В случае редактирования аудиоклипа лучше выйти из режима Show Audio Event или вызвать редактор двойным щелчком на аудиоклипе в окне Pool.

Примечание
В редакторе Sample Editor можно быстро изменить масштаб, протащив курсор мыши по вертикали на линейке Ruler (см. разд. "Изменение масштаба (Zoom)" ранее в этой главе). Для этого должен быть установлен флажок Zoom while Locating in Time Scale на странице Transport в дополнительных настройках Preferences (см. разд. "Дополнительные настройки" ранее в этой главе).

Приведем последовательность действий при создании луп-объекта (loop), образно говоря, этого строительного элемента современной танцевальной музыки.
Прослушивать материал лучше инструментом Play [image], т. к. в этом случае фактически выделяется область воспроизведения (рис. 2.121) и можно быстро определить рабочую область для будущего лупа.

Рис. 2.121. Отображение области воспроизведения

Далее инструментом Scrub нужно установить курсор в стартовую позицию лупа. Инструмент Scrub позволяет на слух определить нужную точку, поэтому не требуется увеличивать масштаб.
Затем в контекстном меню в субменю Selection нужно выбрать пункт From Cursor to End. В результате будет выделен диапазон от позиции курсора до конца аудиоклипа.
После этого нужно вновь взять Scrub и с его помощью найти финальную границу лупа. Затем выбрать пункт Right Selection Side to Cursor в субменю Selection. В этом случае правая граница выделенного диапазона подрежется по текущей позиции курсора.
Далее нужно взять инструмент Range Selection и включить режим циклического воспроизведения с помощью кнопок Loop [image] и Play [image]. В режиме циклического воспроизведения следует при необходимости подстроить границы лупа (курсор мыши на границах лупа примет вид [image]. Если кнопка [image] Snap to Zero Crossing нажата, то подстройка границ будет производиться с привязкой к отсчетам нулевой амплитуды. Это в дальнейшем обеспечит бесшовную стыковку объектов.

Примечание
Кнопка Snap to Zero Crossing имеет свойства глобальной настройки, т. е. действует одновременно во всех окнах проекта.

Рис. 2.122. Создание объекта Audio Event из диапазона

Завершающей стадией станет превращение диапазона в объект Audio Event. Для этого нужно просто перетащить диапазон Range на аудиодорожку мультитрека с нажатой клавишей <Ctrl> (рис. 2.122).

Примечание
Можно перетащить диапазон в ту область окна Nuendo Project, где еще не созданы дорожки, тогда аудиотрек будет создан автоматически.

Создание аудиоклипа

Итак, главная "строительная" задача в редакторе Sample Editor — это правильно выделить диапазон. Остальное — дело техники. Из выделенного диапазона можно создать аудиособытие, аудиклип или регион.
В этом разделе мы рассмотрим способ создания глобальной ссылки — аудиоклипа. Для этого после выделения диапазона Range достаточно отметить пункт Bounce Selection в меню Audio.

Примечание
Еще раз подчеркнем, что полное меню Audio содержит много лишних пунктов, поэтому удобнее пользоваться контекстным меню.

Программа Nuendo задаст вопрос Create new edit version or new audio file? с тремя вариантами ответа: Edit Version, File и Cancel. Два из них приведут к дальнейшим действиям.

  • Edit Version — появится новый аудиоклип без создания нового звукового файла. При этом новый аудиоклип будет ссылаться только на диапазон Range исходного звукового файла.
  • File — будет создан новый звуковой файл, содержащий данные диапазона Range и аудиоклип, который ссылается на этот звуковой файл.

В обоих случаях создается новый аудиоклип и добавляется в окно Pool.

Создание региона

Для работы с регионами внешний вид редактора Sample Editor нужно изменить, нажав кнопку Show Regions [image]. Тогда в окне Sample Editor появится новый элемент (или секция) Regions.
Создание региона начинается с типовой операции выделения диапазона Range.
Затем применяется один из равноценных способов:

  • выбрать пункт Create Region(s) в меню Audio;
  • нажать кнопку Add в секции Regions (рис. 2.123) в окне Sample Editor.

Рис. 2.123. Создание региона

Как только регион создан и занесен в список (регион появляется и в окне Pool), программа сразу же выделяет его название в столбце Description, предлагая дать региону имя. Это нужно обязательно сделать, ведь использование безымянных регионов бессмысленно, т. к. регион — это отдельно существующая ссылка, которую пользователь сохраняет для последующего формирования объектов Audio Events.
Например, при озвучивании видеоролика могут понадобиться размещенные на одном или нескольких звуковых файлах специальные эффекты, шумы и т. п. Удобнее хранить такую звуковую базу как набор ссылок, регионов. Тогда процесс нелинейного монтажа, для которого и была создана программа Nuendo, будет происходить максимально быстро и удобно.
Редактирование региона также, как и его создание можно выполнить двумя способами:

  • с помощью маркеров Region 1 Start и Region 1 End (см. рис. 2.123);
  • редактируя координаты границ в столбцах Start и End в секции Regions.

В секции Waveform Display отображается только регион, выделенный в списке (в секции Regions). Выделять регионы в списке лучше всего щелчком на уровне безымянного столбца, отмеченного на рис. 2.123 стрелкой, или с помощью клавиш < [image] > и < [image] >.
Выделенный в списке регион удаляется кнопкой Remove секции Regions.
Если нужно выделить диапазон Range, равный выделенному региону, тo достаточно нажать кнопку Select.

Примечание
Если дважды щелкнуть на пиктограмме региона в окне Pool, то откроется окно редактора Sample Editor с выделенным диапазоном по всей длине региона.

Кнопка Play (секции Regions) позволяет прослушать регион. Режим циклического воспроизведения включается той же кнопкой Loop [image].
Процесс создания объекта Audio Event из региона показан на рис. 2.124. Для него нужно перетащить регион из списка на аудиодорожку или пустую область окна проекта Nuendo Project. Перетаскивание выполняется из поля безымянного столбца.

Совет
Перетаскивать регионы удобнее, если поменять местами столбцы секции Regions — как на рис. 2.124, или расширить безымянный столбец.

Рис. 2.124. Создание аудиособытия из региона


Недеструктивное редактирование в окне Pool

В Nuendo есть несколько способов достигнуть одного и того же результата.
Мы раньше рассказывали о приемах недеструктивного редактирования в редакторе Sample Editor. Но это далеко не все возможности профаммы. Для создания аудиособытий может использоваться и окно Pool.

Рис. 2.125. Окно Pool с регионами

На рис. 2.125 изображено окно Pool с аудиоклипом и тремя регионами. Аудиоклип и регионы можно прослушать непосредственно в нем. Для этого достаточно щелкнуть на имидже или выделить клип (регион) в списке Media и нажать кнопку Play [image]. Рассмотрим более детально, как с помощью операций в окне Pool из них создаются объекты Audio Events.
Объект можно создать непосредственно из аудиоклипа. Делается это либо путем простого перетаскивания в окно Nuendo Project, либо с помощью команд меню Pool.
На рис. 2.126 показан пример создания аудиособытия из аудиоклипа. Если активен режим Snap, то позиция объекта будет фиксироваться с помощью точки синхронизации Sync Point аудиоклипа.

Примечание
Точка синхронизации у аудиоклипа также, как и у аудиособытия, сдвигается в редакторе Sample Editor. Для этого нужно дважды щелкнуть на аудиоклипе в окне Pool и перетащить Sync Point в новую позицию. У каждого аудиособытия есть своя точка синхронизации.

Процесс перетаскивания региона ничем не отличается от перетаскивания аудиоклипа. Допустимо создание таким способом группы расположенных друг под другом объектов из выделенной группы регионов или аудиоклипов.
Другой способ формирования объекта заключается в применении команд субменю Insert in to Project меню Pool (или контекстного меню) для выделенного аудиоклипа. Рассмотрим их.

  • At Timecode Position — выделенный аудиоклип, регион (или группа) устанавливается стартовой границей в позицию, заданную в диалоговом окне Insert Media at Position в поле Position (рис. 2.127), на выделенную дорожку. Причем временной формат в поле Position соответствует формату линейки Ruler в окне Nuendo Project.

Рис. 2.126. Перетаскивание аудиоклипа из окна Pool

Рис. 2.127. Диалоговое окно Insert Media at Position

  • At Cursor — то же самое, но в текущую позицию курсора мультитрека. Причем в этом случае позиции объектов на мультитреке определяются точками синхронизации Sync Point.
  • At Origin — создание объектов в оригинальной стартовой позиции. Эта операция относится к аудиоклипам со статусом R, созданным в результате записи, и к позиции регионов внутри аудиоклипа. Оригинальная стартовая позиция аудиоклипов и регионов отображается в окне Pool в отдельном столбце Origin Time.

В примере на рис. 2.128 аудиоклип со статусом R и три региона расположены в виде объектов в оригинальных стартовых позициях.

Рис. 2.128. Пример создания объектов в оригинальной позиции

Рис. 2.129. Пример монтажа из регионов режиме Range Selection

Позиции объектов-регионов относительно объекта-аудиоклипа сохранены, что наглядно отображено на рис. 2.128. Таким образом, записанный аудиоклип и регионы, созданные внутри него, могут быть всегда выложены на мультитрек в оригинальной позиции.
При монтаже композиции из регионов удобно использовать инструмент Range Selection, т. к. это сокращает общее количество операций. Например, после перетаскивания региона на мультитрек достаточно выделить в режиме Snap диапазон Range и применить команды Edit | Duplicate или Repeat (рис. 2.129).
Расстояние между копиями объектов определяется длиной выделенного диапазона.


Виртуальный микшер

Фирма Steinberg давно утвердилась на мировом рынке как новатор аудиосистем, использующих ресурсы центрального процессора (native audio system). В декабре 1999 года она остановила разработку Cubase Audio версии TDM, предназначенной для работы с "железом" американской фирмы Digidesign, создателя знаменитой системы Pro Tools. Тем самым фирма Steinberg сделала окончательный выбор в пользу ресурсозависимых (native) аудиосистем, сконцентрировавшись на совершенствовании собственных технологий.
Появление Nuendo — доказательство того, что решение оказалось правильным. Фирма Steinberg не ошиблась, взяв стратегический курс на native audio system еще в ту пору, когда об обработке звука в реальном времени на PC не могло быть и речи. Профессионалы и сегодня придерживаются мнения о том, что native-системы предназначены исключительно для демо-записей.

Примечание
Профессиональный снобизм есть во всех областях. И история знает множество примеров, когда именно специалисты тормозили развитие прогресса с искренним убеждением в том, что их мнение является единственно верным. Так, например, было с самолетом. На этапе зарождения воздухоплавания официальная профессиональная позиция была непоколебима: аппарат, вес которого больше воздуха, взлететь не может.

Русскоязычный эквивалент слова native — ресурсозависимый. Этот перевод не вносит никакой ясности в понимание процессов, происходящих в цифровых аудиосистемах. Любая цифровая обработка сигналов зависит от вычислительных ресурсов либо центрального процессора (native), либо группы специализированных DSP. И если ресурсов недостаточно, то в обоих случаях нужно увеличивать производительность.
В мире native-систем соотношение производительность/доллар при прочих равных условиях получается выше. Цены же на сугубо специализированное оборудование всегда традиционно выше.
Не за горами появление еще более производительных процессоров. Поэтому и фирма Digidesign ввела поддержку ресурсозависимых RTAS plug-ins в системе Pro Tools. Целесообразно уже и на сегодняшнем уровне, и подразумевая завтрашний уровень производительности CPU, использовать его для обработки звука, а не ограничиваться только лишь интерфейсными функциями.
Платформа Nuendo не привязана к конкретному оборудованию. Именно в этом заключается ее мощное преимущество. Фактически компьютер с Nuendo становится ведущей (host) рабочей станцией, которую можно легко адаптировать под современную технологию и задачи.
На самом деле выбор в пользу native-решений совсем не означает, что использование аппаратных устройств обработки звука отныне запрещено. Просто современная производительность PC и Мае освобождает пользователя от их обязательного применения.


Маршрутизация в Nuendo (Bus System)

Итак, программа Nuendo в принципе позволяет обойтись без внешнего цифрового микшера, хард-диск рекордера и MIDI-секвенсора, т. к. все их функции она берет на себя.
Как VST-приложение Nuendo базируется на системе шин Bus System, которая обеспечивает интеграцию VST с имеющимися аппаратными средствами.
Это означает, что основу системы составляет виртуальный микшер VST Mixer с VST-входами (VST Inputs) и VST-выходами (VST Outputs). VST-входы и VST-выходы назначены на соответствующие ASIO-порты звукового оборудования, установленного в компьютере.
Система шин Bus System обеспечивает эффективную маршрутизацию аудиопотоков. Она дает возможность их вывода из виртуальной среды во внешние аппаратные устройства обработки. Позволяет осуществлять последующий ввод для записи результатов на аудиодорожки. В качестве внешнего устройства может выступать, например, цифровой микшер со встроенной обработкой.
Количество шин (Output Bus) определяется только конфигурацией оборудования, установленного на компьютер. Например, фирма Steinberg выпускает плату Steinberg Nuendo 96/52 для ввода/вывода через ADAT и SPDIF, обеспечивающую 52 канала с частотой дискретизации 96 кГц. ASIO ввод/вывод реализован таким образом, что даже при полной нагрузке, когда используются все 52 канала, загрузка CPU — 0% (подробности на сайте www.nuendo.com).
В качестве примера рассмотрим, как можно использовать преимущества Bus System для аппаратной звуковой обработки на самой бюджетной ASIO-карте SB Audigy.

Рис. 2.130. Пример конфигурации VST-выходов

На рис. 2.130 показан пример конфигурации VST-выходов. ASIO-драйвер звуковой карты SB Audigy позволяет организовать прямой маршрут на ее внутренний ревербератор.
Для этого одну из семи шин нужно назначить на ASIO-порт Reverb и нажать кнопку Active. Для удобства название назначенной шины нужно привести в соответствие (рис. 2.130). Мастер-шину (Master Bus) следует назначить на ASIO-порт Front L/R.
После такой несложной процедуры сигнал любого канала (а также эффекта панели VST Send Effects) виртуального микшера можно послать на аппаратный ревербератор. А сигнал мастер-шины при этом обрабатываться ревербератором не будет.
Несколько забегая вперед, отметим, что для организации маршрута нужно выбрать шину, имеющую в нашем примере название Reverb в раскрывающемся списке Sends (рис. 2.131).
Далее выходной сигнал ревербератора SB Audigy следует записать на свободную аудиодорожку в режиме воспроизведения проекта. Для этого нужно активизировать VST-вход Mix (Pre-EQ) L(R) (см. разд. "Конфигурирование VST-входов" ранее в этой главе).
Перед записью следует приглушить (Mute) каналы и использовать режим посыла Pre Fader. Тогда прямые сигналы будут отключены и останется только обработанный сигнал, который и будет записываться на дорожку.

Рис. 2.131. Выбор шины в списке Sends

Есть и другой способ: увести уровень шины BUS1 (Front L/R) в окне VST Outputs и оставить звучать только шину BUS2 (Reverb). В этом случае режим посыла Pre Fader не нужен.
Параметр ASIO Buffer Latency на панели управления ASIO-драйвера (Creative ASIO Control Panel) не должен превышать 10 мс.


Панель VST Channel Settings

Виртуальный микшер является неотъемлемой частью Nuendo, поэтому его можно увидеть либо почти полностью в окне VST Mixer, либо по частям в других окнах.
Микшер имеет сложную структуру. Поэтому даже в окне с VST Mixer не видны все его составляющие. Список всех панелей виртуального микшера расположен в меню Devices и дублируется "горячими" клавишами. Непосредственно к микшеру имеют отношения следующие панели:

  • VST Mixer — виртуальная консоль;
  • VST Send Effects — панель Send-эффектов (эффектов посыла);
  • VST Master Effects — панель мастер-эффектов (обработка суммарного сигнала).

Программа Nuendo — аналогично Cubase VST — разрешает быстрый доступ к настройкам канала через панель VST Channel Settings.
В Nuendo, к счастью, отсутствует панель Inspector программы Cubase VST, съедающая много полезного пространства мультитрека. И поэтому панель VST Channel Settings вызывается быстро и просто через любую из кнопок: FX, EQ и Ins секции Track List в окне Nuendo Project, либо аналогичными способами через эти же кнопки с панели VST Mixer.

Примечание
Окно VST Channel Settings для группового канала (Group Channel) и аудиока-нала не имеет различий. Но для группового канала окно VST Channel Settings нужно вызывать через панель VST Mixer.

Рассмотрим окно VST Channel Settings более детально (рис. 2.132).

Рис. 2.132. Окно VST Channel Settings

Каждый аудиотрек, выход VST-инструмента и канал виртуальной шины ReWire занимает одну канальную ячейку (Channel strip) VST-микшера. Окно VST Channel Settings отображает эту ячейку в развернутом виде. Здесь можно провести аналогию с окном Wide Mixer виртуальной консоли SAWStudio. Управление каналом содержит большое число элементов, которые должны храниться в свернутом виде до момента их использования. Поэтому настройка канала производится в окне, представляющем собой развернутую проекцию виртуального микшера.
Канал, для которого вызвана панель VST Channel Settings, автоматически выделяется. Выделение каналов и дорожек может происходить независимо друг от друга. Это выделение совпадает, если вызвана панель VST Channel Settings в окне Nuendo Project. В окне VST Mixer канал выделяется кнопкой-индикатором [image] (Select Channel) канальной ячейки (Channel strip).


Common Panel

Слева в окне VST Channel Settings расположена общая панель (Common Panel) глобальных настроек. Панель называется общей, потому что ее элементы управления отображаются в окне VST Channel Settings любого канала, а настройки являются общими для всех каналов.
Секция общей панели (Common Panel) с названием Selected Channel содержит поле доступа к раскрывающемуся списку каналов. Список — это способ быстрого перехода между элементами управления каналов (рис. 2.133).

Рис. 2.133. Быстрый переход через список каналов

Канал, отмеченный в списке, является выделенным.
Кнопка Init [image] сбрасывает все настройки канала в первоначальное состояние, а кнопки Copy, Paste позволяют копировать настройки одного канала на другие через внутренний буфер обмена. Для этого нужно на образцовом канале нажать Сору, перейти через список на другой канал и нажать Paste. При необходимости процедуру можно повторить для остальных каналов, т. к. настройки сохраняются в памяти до следующей команды Сору или закрытия проекта. Если в памяти есть настройки, то кнопка Paste подсвечивается красным светом.
На рис. 2.134 изображен внешний вид панели VST Mixer для шести каналов.
Панель VST Channel Settings вызывается теми же кнопками FX, EQ или Ins.
А функция копирования настроек позволяет быстро построить виртуальную схему маршрутизации с одинаковыми параметрами. Например, каналы могут содержать одну и ту же цепочку plug-ins с одинаковыми параметрами, одинаковую маршрутизацию аудиопотоков Send (посыл), настройки параметрического эквалайзера.

Рис. 2.134. Панель VST Mixer

При формировании маршрутов для наглядности удобнее использовать панель VST Mixer, однако сами каналы-дорожки создаются в окне проекта.
В окне VST Mixer общая панель (Common Panel) расположена слева и дополнена кнопкой Show Master (в отличие от вида в окне VST Channel Settings).

Примечание
На рис. 2.134 отображается еще и фейдер мастер-шины (Master Bus), т. к. нажата кнопка Show Master.

Общая панель (Common Panel) также содержит кнопки глобального отключения режимов Solo (Solo Off) и Mute (Mute Off). Это очень полезная функция, оценить которую можно только на практике.
Кнопки Read и Write All секции Automation общей панели включают/выключают режим чтения/записи автоматизации сразу на всех каналах.
Вернемся к дальнейшему рассмотрению панели VST Channel Settings.


Channel strip

Кроме общей панели (Common Panel) в ней содержатся канальные ячейки Channel strip, из которых в основном и состоит панель VST Mixer (рис. 2.135).
У ячейки Channel strip простой и интуитивно понятный интерфейс. С некоторыми элементами управления мы ознакомились выше (см. разд. "Контроль уровня записи" ранее в этой главе). Обратим внимание на остальные. Основу секции составляют регуляторы громкости и панорамы.

Рис. 2.135. Канальные ячейки Channel strip

В Nuendo можно задать разные режимы регулирования для элементов управления микшера.

Режимы регулирования

За эти параметры отвечает страница User Interface — Controls в дополнительных настройках Preferences. Страница содержит два раскрывающихся списка Knob Mode и Slider Mode.
Конечно, лучше всего производить управление с внешнего микшер-контроллера, однако Nuendo является гибкой системой, предназначенной для широкого применения от "продвинутых" студий до самых простых, домашних на базе одного PC. Поэтому в ней реализованы дополнительные сервисные функции эмуляции аппаратных интерфейсов, облегчающие жизнь при управлении мышью.
Элементы управления микшера Nuendo состоят из слайдеров (slider) и ручек (knob).
Список Slider Mode содержит три режима управления слайдерами.

  • Jump — в этом режиме щелчок мышью выше или ниже слайдера заставляет его буквально сделать "прыжок" (Jump) в эту позицию. Режим удобен для быстрого смещения слайдера, но не защищает от случайных сдвигов.
  • Touch — режим, требующий обязательного перетаскивания слайдера. Полностью защищает от случайного сдвига.
  • Ramp — режим, фактически представляющий собой замедленный режим Jump. В нем каждый щелчок мыши выше или ниже слайдера смещает его на небольшой шаг. А удержание кнопки мыши нажатой вызывает плавное движение слайдера к курсору мыши.

Совет
Режим Ramp удобно сочетать с записью автоматизации плавных переходов.

Для управления ручками (Knob) также предусмотрено три режима.

  • Circular — в этом режиме ручку можно вращать мышью или позиционировать щелчком в конкретной точке в пределах диаметра ручки.
  • Relative Circular — режим, аналогичный предыдущему. Но в нем исключена возможность быстрого позиционирования щелчком.
  • Linear — режим, в котором вращение заменяется линейным движением мыши по вертикали или по горизонтали. Нужно щелкнуть в пределах диаметра ручки и начать линейное движение. По нашему мнению, данный режим лучше всего подходит для записи автоматизации вращения ручек, т. к. точные линейные движения мышью выполнять легче, чем круговые.

На самом деле выбор какого-то одного режима не лишает возможности оперативно переключаться в другие. Например, из режимов Circular и Relative Circular можно оперативно переключиться в режим Linear, если регулировать с нажатой клавишей <Alt>. В режиме Relative Circular клавиша <Shift> поможет позиционировать ручку щелчком мыши. Наоборот, в режиме Linear клавиша <Alt> временно переключает в режим Circular.
Аналогичная возможность есть у режима Ramp (Slider Mode). Клавиша <Alt> временно переключает в режим Jump.
И еще одно общее правило: щелчок кнопкой мыши с нажатой клавишей <Ctrl> устанавливает регуляторы в положение по умолчанию (за исключением регуляторов уровня посыла Sends).
Разработчики Nuendo учли все возможные недостатки регулирования с помощью мыши и поэтому ввели точные режимы.
Для точного регулирования громкости нужно перетаскивать слайдер с нажатой клавишей <Shift>. В режиме Ramp с нажатой клавишей <Shift> плавное движение слайдера замедляется.
Еще один способ — это ввод значения с клавиатуры в поле-индикатор под регулятором громкости.
Клавиша <Shift> действует аналогичным образом и для регулятора панорамы.
Кроме того, для регулятора панорамы в дополнительных настройках Preferences можно задать режим компенсации громкости панорамирования. На странице VST в раскрывающемся списке Stereo Pan Law предложены три режима:

  • 0 дБ — без компенсации;
  • -3 дБ — компенсация на 3 дБ;
  • -6 дБ — компенсация на 6 дБ.

Механизм компенсации реализуется через ослабление суммарного сигнала в центральном положении регулятора панорамы.

Контроль уровня

Контроль уровня канала осуществляется измерителем, состоящим из двух модулей: Level Meter и Clip Indicator (рис. 2.136). Режимы измерения модуля Level Meter выбираются с помощью кнопок Fast и Hold общей панели (Common panel) в окне VST Mixer. Если обе кнопки отжаты, то индикатор имитирует работу стандартного VU-метра. Кнопка Fast переводит его в режим динамической индикации, когда измеритель сильней реагирует на динамику сигнала.
Кнопка Hold включает режим удержания индикации наивысшего пикового уровня. Время удержания регулируется в дополнительных установках Preferences на странице VST в поле VU-Meter Peak's Hold Time.
Кроме этого, максимальный пиковый уровень отображается в числовом поле рядом с модулем Clip Indicator. Для обновления показаний числового поля достаточно щелкнуть на регуляторе громкости или на модуле Clip Indicator.

Рис. 2.136. Измеритель уровня

В связи с тем, что все вычисления в Nuendo происходят в формате 32 бит с плавающей точкой, особенно опасаться перегрузки выше 0 дБ не следует. Математика обеспечивает огромный динамический диапазон. Проблемы могут начаться при переходе в целочисленный формат, который происходит при передаче данных в аппаратную часть. Это означает, что уровень на выходных шинах Output Bus (панель VST Outputs) не должен превышать 0 дБ.
Несмотря на виртуальный динамический диапазон формата 32 Bit Float ситуации, когда все канальные уровни превышают 0 дБ, а уровень VST-Master
для компенсации снижен, быть не должно. Необходимо оставаться в рамках диапазона, эквивалентного целочисленному формату, т. е. не злоупотреблять превышением порога в 0 дБ.

Группирование каналов

Как известно, в обычном режиме манипулятор мышь — это "однорукий робот" — она может изменять только один параметр. Но в программе Nuendo есть возможность менять с помощью мыши несколько параметров одновременно для каналов, объединенных в группы. Образно говоря, здесь можно "размножить" курсор мыши.
В группы можно связывать только предварительно выделенные каналы.
Для выделения группы нужно сначала при нажатой клавише <Shift> щелкнуть по кнопке Select каждой канальной ячейки Channel strip.
Затем выбрать пункт Link Channels в контекстном меню панели VST Mixer (комбинация клавиш <Ctrl>+<G>).
После того, как каналы связаны, они запараллеливаются по элементам управления. При этом относительное положение фейдеров сохраняется.
Среди элементов управления есть "индивидуалисты", которые "не хотят" объединяться в группы. Это регуляторы панорамы, секция Channel Inserts, маршрутизация входов и выходов канала.
Для удаления группы предназначена операция Unlink Channels (комбинация клавиш <Ctrl>+<U>). Она удаляет группу, распараллеливает каналы. Для ее проведения достаточно выделить только один канал, входящий в группу.
Нужно отметить, что расформировывается группа только целиком — удалять из нее каналы по очереди нельзя.
Если же требуется сделать индивидуальные настройки параметров только для одного канала, входящего в группу, то следует их выполнять при нажатой клавише <Alt>.
Группирование каналов позволяет одновременно изменять столько параметров, сколько пожелает пользователь.
Быстрый переход к индивидуальному управлению каналом осуществляется при нажатой клавише <Alt>. С ее помощью можно изменить относительное положение избранного регулятора в группе.
В итоге значительно расширить стандартные возможности управления микшером в реальном времени с помощью мыши позволяют: операция выделения каналов, комбинации клавиш <Ctrl>+<G> и <Ctrl>+<U>, а также индивидуальное регулирование с клавишей <Alt>.

Совет
Дополнительные преимущества можно получить при использовании мыши с колесиком, например, Genius Net Scroll+. Для управления регулятором виртуального микшера достаточно навести на него (или соответствующее числовое поле) курсор мыши и покрутить колесико. Если при этом нажать и удерживать клавишу <Shift>, то точность регулирования увеличится.

Приемы управления фейдерами с клавиатуры

Кроме способов долговременного связывания каналов, приведенных выше, существуют некоторые неочевидные приемы управления фейдерами. Они производятся с клавиатуры в окне VST Mixer.

  • Синхронно сдвинуть фейдеры выделенных каналов можно клавишами < [image] > или < [image] >.
  • Если клавишу < [image] > или < [image] > нажать и удерживать, то фейдеры выделенных каналов начинают плавное движение, соответственно, вниз или вверх.
  • Клавиши < [image] > и < [image] > перемещают статус выделенного канала, соответственно, влево и вправо по всем канальным ячейкам VST-микшера.
  • Быстрое выделение группы соседних каналов осуществляется клавишами < [image] > и < [image] > с нажатой клавишей <Shift>.
  • Группа расформировывается повторным нажатием клавиши < [image] > или < [image] > с отжатой клавишей <Shift>.

Таким образом, управлять виртуальным микшером можно достаточно эффективно, используя всего пять клавиш.

Кнопки режимов автоматизации

Кнопки [image] (Write Automation) и [image] (Read Automation) включают/выключают режим записи и чтения автоматизации канала (подробнее об этом в разд."Автоматизация в Nuendo").


Channel Inserts

Маршрут аудиопотока в канале

Перед знакомством с секцией Channel Inserts рассмотрим маршрут аудиопотока в канале (рис. 2.137).
Сигнал последовательно (сверху вниз) проходит четыре слота Insert-эффектов (подключаемых в разрыв) секции Channel Inserts. Эффект самого верхнего слота обрабатывает звук первым в цепочке plug-ins.
Затем сигнал обрабатывается модулем EQ (эквалайзер) и поступает на регуляторы громкости и панорамы. В зависимости от состояния кнопки Рге (Рге Fader) в слот секции Channel Sends сигнал поступает: до регулятора громкости (панорамы) и кнопки Mute — если нажата кнопка Рге, либо после них — при выключенной кнопке Рге.
Секции Channel Inserts, Channel Sends и EQ имеют режим обхода Bypass.

Рис. 2.137. Маршрут аудиопотока в канале

Подключение plug-ins

Теперь вернемся к секции Channel Inserts. Как следует из названия, она предназначена для подключения plug-ins в разрыв (Insert). На рис. 2.138 показана эта секция и список эффектов, который вызывается щелчком в поле слота с надписью No Effect. Подключение эффекта выполняется простым выбором его названия в списке.

Рис. 2.138. Подключение Insert-эффекта

Отключение эффекта производится выбором пункта No Effect списка plug-ins. После подключения эффект находится в неактивном состоянии, в режиме обхода (Bypass).
Для активизации эффекта нужно нажать кнопку [image] (On). Доступ к окну настроек эффекта осуществляется с помощью кнопки [image] (Edit).
Если требуется подключить эффект одновременно для всех каналов, следует предварительно нажать и удерживать клавишу <Ctrl>. Отметим, что это очень удобная функция, позволяющая быстро "размножить" подключаемый модуль plug-in на все каналы.
Plug-in, подключенный в слот, можно одновременно на всех каналах активизировать или деактивировать, если нажать на кнопку [image] (On) с клавишей <Ctrl>.
Режим обхода всех Insert-модулей включается кнопкой [image] (Bypass).
Здесь важно отметить следующее. В режиме Bypass все Insert-модули переходят в неактивное состояние, и поэтому снижается нагрузка на CPU. Если активен хотя бы один Insert-модуль, то высвечиваются две кнопки: (On) и [image] (Ins). Кнопка Ins доступна в секции Track List в окне Nuendo Project и в секции Channel strip виртуального микшера.
В процессе работы над проектом часто требуется быстро получить информацию о том, какие треки обрабатываются Insert-эффектами, а также сравнивать "сухое" и обработанное звучание и оперативно контролировать загрузку CPU. В Nuendo эти операции выполняются просто — с помощью кнопки-индикатора Ins. Поэтому для управления режимом Bypass нет необходимости постоянно вызывать окно VST Channel Settings — достаточно щелкнуть по кнопке Ins правой кнопкой мыши (или левой кнопкой с нажатой клавишей <Ctrl>). Такой способ управления относится и к остальным кнопкам-индикаторам FX и EQ.


Channel Sends

Маршрутизация

Секция Channel Sends предназначена для формирования Send-маршрутов. Она состоит из восьми слотов Send с регуляторами уровня посыла (FX Send Level) и позволяет организовать восемь маршрутов из одного канала.
Это обстоятельство, в частности, позволяет утверждать, что программа Nuendo — действительно виртуальная звуковая лаборатория. Она предоставляет пользователю небывалую свободу в конструировании виртуального микшера и создании многообразных схем маршрутизации. Потенциал программы Nuendo разрушает стереотипный взгляд на то, что возможности PC для обработки звука ограничены.
Необходимость маршрутизации объясняется тем, что использовать только Insert-эффекты крайне невыгодно по следующим причинам:

  • во-первых, из-за неэффективного расходования вычислительных ресурсов. Ведь Insert-эффекты являются индивидуальными для каждого канала, поэтому их потребуется "размножать". Например, в случае использования общего ревербератора как Insert-эффекта;
  • во-вторых, микширование прямого и обработанного сигналов (dry/wet) осуществляется с помощью самого Insert-эффекта. А в системе микширования, организованной по принципу посыл/возврат (Send/Return), уровень обработанного сигнала каждого канала контролируется регулятором уровня посыла (Send).

Маршрут организовать очень просто. Нужно выбрать "пункт назначения" в списке Sends и нажать кнопку On. В зависимости от состояния кнопки Рге (Pre Fader) сигнал будет ответвляться по-разному: если эта кнопка нажата, то он ответвляется до регуляторов громкости и панорамы; в том случае, если Рге отключена — то сигнал ответвляется после них (см. рис. 2.137).
Содержание списка Sends зависит от конфигурации виртуального микшера и оборудования. А именно, от количества групповых каналов и шин Output Bus, а также от конфигурации мастер-шины, созданной в окне VST Master Setup (количества каналов).

Рис. 2.139. Пример списка маршрутов Channel Sends

В примере виртуальный микшер имеет шестиканальную конфигурацию мастер-шины (пресет 5.1 Surround) и десять групповых каналов (групп) (рис. 2.139, секции списка отмечены цифрами З и 4).
ASIO-драйвер звуковой карты поддерживает семь шин (Output Bus), которые находятся в активном состоянии (рис. 2.139, секция списка отмечена цифрой 2).
Поэтому в данном примере список Sends делится на четыре секции (они пронумерованы на рис. 2.139).
В секции 1 всегда одинаковое количество пунктов — восемь. Это число слотов панели VST Send Effects (о ней мы будем говорить ниже).
Секция 2 может отсутствовать, если шины (Output Bus) в проекте неактивны или их не обеспечивает архитектура звуковой карты.

Примечание
Маршрут (посыл) на активную шину Output Bus нужен в тех случаях, когда к одному из выходов подключаются, например, внешние устройства обработки или требуется сделать мониторный микс для исполнителя (см. главу 1, разд. "Использование AUX-каналов для мониторинга"). В этом случае кнопка Рге (Рге Fader) должна быть нажата.

Секция 3 тоже может отсутствовать, если в проекте не используются групповые каналы (Group Channel).
Секция 4 списка Sends позволяет сформировать маршрут непосредственно на мастер-шину (Master Bus), и ее содержание зависит от конфигурации VST Master (см. разд. "Окно VST Master Setup" ранее в этой главе").
Нужно обратить внимание на то, что в примере на рис. 2.139 в списке отсутствуют групповой канал Group 01, и шина BUS 1. Это объясняется тем, что мы намеренно использовали в качестве примера групповой канал Group 01, а канал не может быть назначен сам на себя.
На рис. 2.140 изображен список выходов (Channel Output) ячейки Channel strip того же группового канала Group 01. Шина BUS 1 занята, и поэтому она отсутствут в списке Sends (см. рис. 2.139). Нельзя из одного канала одновременно сформировать два маршрута (один прямой — Out, другой посыл — Send) на одну и ту же шину. Если переназначить выход Channel Out на другую шину, например BUS 2, то в списке Sends исчезнет шина BUS 2 и появится, соответственно, шина BUS 1.
Напомним, что в Nuendo выходы групповых каналов можно назначать друг на друга. Но для них действует такое же ограничивающее правило: нельзя из одного канала одновременно сформировать два маршрута (один прямой — Out, другой посыл — Send) на один и тот же групповой канал.
Возьмем на заметку (позже вернемся к этому): в Nuendo есть возможность использовать в качестве Send-эффектов виртуальную "стойку" Insert-эффектов группового канала.
В программе Nuendo возможны многочисленные варианты схем маршрутизации аудиопотоков, ведь максимальное количество групп — 64 (!).

Рис. 2.140. Пример списка маршрутов Channel Output

Совет
Для удобства групповые каналы лучше сразу переименовать в соответствии с их назначением в структуре виртуального микшера. Например, если используется Insert-эффект ревербератор группы в качестве Send-эффекта, то соответствующий групповой канал можно назвать Reverb. Для этого нужно щелкнуть в текстовом поле с названием канала (Group nn, где nn — номер группы) над списком Channel Output routing и ввести новое имя с клавиатуры.

Панель VST Send Effects

Для простых маршрутов предусмотрена специальная ("классическая") панель VST Send Effects, которая хорошо знакома пользователям программы Cubase VST. Состоит она из восьми слотов и вызывается через меню Devices, либо клавишей <F6>, либо двойным щелчком в поле слота секции Channel Sends.
Подключение plug-ins осуществляется типичным образом (как и в секции Channel Insert): красная кнопка активизации эффекта, расположенная на каждом слоте, предназначена для оперативного включения/отключения эффекта, а кнопка Edit — для доступа к настройкам plug-in. Каждый слот имеет регулятор входного уровня эффекта.

Рис. 2.141. Панель VST Send Effects

Нужно отметить, что работа с банками и пресетами plug-ins также является типичной для всех plug-ins (о ней будет рассказано позже). А сейчас перейдем к маршрутизации.
Особенным моментом в концепции Bus System — о которой шел разговор раньше — является тот факт, что выходы Send-эффектов можно назначать непосредственно на активные шины Output Bus (рис. 2.142).

Рис. 2.142. Маршрутизация выходов Send-эффектов

Это означает, что при наличии внешнего цифрового микшерного пульта можно, например, выход виртуального ревербератора направить за пределы Nuendo — т. е., непосредственно на пульт. Выигрыш в ясности и прозрачности звуковой картины при этом может быть достаточно ощутимым. Это зависит от конкретной модели цифрового микшера.
Модули plug-ins, имеющие внутреннее микширование dry/wet, должны быть установлены в режим wet, что означает: 100%-ный выход обработанного сигнала и 0%-ный — прямого.


Маршрутизация с использованием группового канала

Зачастую работа со звуком требует усложнения схемы маршрутизации. И тогда возможностей панели VST Send Effects становится мало. Например, в том случае, если один эффект панели VST Send Effect нужно заменить последовательной цепочкой plug-ins или требуется именно стерео Send-маршрутизация (панель VST Send Effects принимает моносигнал).
Тогда на помощь приходят "универсальные строительные элементы" — групповые каналы Group Channel. Они представлены в двух окнах: в окне Nuendo Project в качестве дорожек автоматизации, а в окне VST Mixer как ячейки Channel strip.
Можно сказать, что групповые каналы — это те же самые аудиоканалы, но без VST-входрв.
Групповые каналы можно назначать друг на друга, использовать для Send-маршрутизации с аудиоканалов или других групп. Но, несмотря на широту возможностей, между этими каналами "военная дисциплина" — строжайшая иерархия маршрутов.
Первое правило: от того, как расположены Audio- и Group-треки в окне Nuendo Project в секции Track List зависит порядок следования ячеек Channel strip в окне VST Mixer.

Примечание
Несколько опережая события, предлагаем обратить внимание на два рисунка: 2.143 и 2.144. На рис. 2.143 в обоих окнах порядок следования треков и каналов последовательный: 01, 02, 03, 04; а на рис. 2.144 первый номер находится в середине — 02, 03, 01, 04. То есть, при изменении расположения групповых дорожек в секции Track List изменится и порядок следования ячеек Channel strip. Важным для понимания моментом является то, что такие перестановки неизменно скажутся на звучании материала, т. к. будет изменена иерархия групповых каналов.

Итак, самая верхняя дорожка мультитрека представлена первой ячейкой Channel strip — ближайшей к общей панели (Common panel). От расположения дорожки Group Track зависит ее место в иерархии групповых каналов.
Рассмотрим простой пример. Создадим на пустом мультитреке четыре групповых трека и назначим их выходы друг на друга. Сразу выявится закономерность, что с увеличением номера группового канала в его списке Channel Output уменьшается количество возможных маршрутов к другим группам.
Отсюда вытекает второе правило: групповой канал можно назначать только на те групповые каналы, которые расположены после него — т. е. ближе к фейдеру мастер-шины.
Проверим правило — назначим группы друг на друга "по старшинству": Group 01, Group 02, Group 03, Group 04 (рис. 2.143).

Рис. 2.143. Маршрутизация групповых каналов

А теперь изменим этот порядок расположения групповых треков в секции Track List: переместим Group 01 ближе к концу списка — на место трека Group 03.

Рис. 2.144. Влияние расположения Group-треков

На рис. 2.144 показано, что в результате такого перемещения произошло автоматическое переназначение выходов.
Канал Group 01 стоял раньше первым в последовательности и был назначен на канал Group 02. Теперь Group 01 стоит третьим. Поэтому он не может сохранять маршрут на "младший" канал, стоящий в последовательности перед ним, — на Group 02. Следовательно, выход канала Group 01 автоматически переназначается на мастер-шину.
Канал Group 02 был назначен на канал Group 03. Но теперь третьим находится Group 01. Значит именно на него и назначается Group 02 (см. рис. 2.144).

Предупреждение
Необходимо учитывать, что перестановки или добавление новых групповых треков могут разрушить существующую схему маршрутизации. Поэтому при добавлении нового трека необходимо предварительно выделить самый нижний групповой трек в секции Track List или вообще снять выделение с треков щелчком мыши с клавишей <Shift>. Новый трек добавляется ниже выделенного. Если же не выделен ни один трек, то новый трек будет добавлен "в конец списка" — ниже самого последнего в секции Track List.

"Закон субординации" действителен и для Send-маршрутов с группового канала на другой групповой канал.
Подводя итог, отметим, что вариантов схем маршрутизации может быть много: от простой функциональной замены панели VST Send Effects до специальных схем обработки звука.
В качестве иллюстрации приведем пример сложной маршрутизации (рис. 2.145).
Здесь четыре группы сведены в пятую — Group 05 — через маршрутизацию Channel Output. Из аудиоканала Audio 01 сформированы Send-маршруты на все пять групп.
В группах тоже есть возможность формирования дополнительных Send-маршрутов. Правда, только с учетом "правила субординации": чем выше "звание" (порядковый номер в последовательности) — тем меньше вариантов получить "дальнейшее назначение".
В результате получилась схема маршрутизации, которая может быть творчески использована для сложной обработки звука с применением автоматизации микшера и VST-plug-ins.

Предупреждение
Модули plug-ins, используемые в качестве Send-эффектов и имеющие внутреннее микширование dry/wet, должны быть установлены в режим wet, т. е. обеспечивать 100%-ный уровень обработанного сигнала и нулевой уровень прямого.

В этой системе микширования фейдер каждого группового канала фактически выполняет функцию Return-регулятора.

Рис. 2.145. Пример маршрутизации с групповыми каналами

Групповые каналы могут использоваться и для более простых задач объединения каналов, так же, как группы в SAWStudio. Каналы, назначенные на групповой канал через Channel Output routing, получают общую обработку его Insert-эффектами (например, эквалайзером и компрессором). А управление уровнем суммарного сигнала (Submix) будет осуществляться только одним фейдером. Кроме того, выход каждого группового канала может быть направлен во внешний микшер через Output Bus. В результате получится схема микширования виртуальных каналов в группах с возможностью последующего смешивания групп во внешнем микшере.

Режимы Solo и Mute для сложной маршрутизации

Применение групповых каналов для сложных схем маршрутизации имеет ряд особенностей, связанных с режимом Solo. Включение режима Solo на любом канале приглушает (Mute) все каналы, включая и групповые. А ведь это достаточно типичная ситуация, когда требуется прослушать отдельный трек в режиме Solo с обработкой. Для того чтобы избежать нежелательного приглушения групп, избранных для Send-маршрутизации, нужно для них применить специальный режим Solo Defeat. Переход в режим Solo Defeat осуществляется щелчком по кнопке Solo с нажатой клавишей <Alt>. Повторение этой комбинации отменяет режим Solo Defeat.

Примечание
Данный режим может применяться и для обычных аудиоканалов.

Следующая особенность, связанная с режимом Solo, следует из иерархии маршрутов. Если в примере на рис. 2.145 включить режим Solo на канале Group 05, то в режиме Solo окажутся все остальные группы.
И наоборот, включение режима Solo на любом из групповых каналов с Group 01 по Group 04 автоматически переведет в режим Solo канал Group 05. Таким образом, каналы, связанные общим маршрутом по выходу (Channel Output routing), связаны также и режимом Solo.
В примере на рис. 2.145 если смотреть от канала Group 05, то маршрут разветвляется на остальные группы.
Следовательно, правило формулируется так: "старший" канал активизирует режим Solo на всех "подчиненных" каналах. И наоборот, "подчиненный" канал "передает эстафету" (режим Solo) по иерархии вверх.
Режим Mute отличается от Solo тем, что он распространяется только по нисходящей.
"Старший" канал приглушает все "подчиненные" каналы.

Примечание
Это правило распространяется и на аудиоканалы, назначенные на группы.

Особенности маршрутизации моноаудиоканала

Многие источники сигнала имеют один канал, например, микрофон. Поэтому далеко не во всех случаях целесообразно записывать стереотреки. Если для входного сигнала не применяется специальная стереообработка внешним процессором эффектов, то имеет смысл задействовать один канал. Однако результат обработки моноканала Insert-эффектами plug-ins также остается моно. Для преодоления этой проблемы нужно использовать групповые каналы. Моноаудиоканал нужно назначить на групповой канал, в котором и применить стереообработку.
Использование Send-маршрутизации также имеет свои особенности. В случае посыла на эффекты панели VST Send Effects, например, на ревербератор, выходной сигнал реверберации будет уже стереофоническим (при соответствующих настройках подключаемого модуля).
Send-маршрутизация с использованием групп выглядит несколько сложнее (рис. 2. 146).

Рис. 2.146. Send-маршрутизация моноканала

Аудиоканал через один слот секции Sends может быть связан с группой либо как левый канал, либо как правый, что обозначается названием группы с буквой R.


Интерфейс эквалайзера

Отдельным компонентом окна VST Channel Settings является параметрический графический эквалайзер (рис. 2.147).
Интерфейс этого эквалайзера построен таким образом, что на построение АЧХ требуется максимум четыре щелчка мышью. Дисплей (curve display), отображающий форму АЧХ, является активным. Если эквалайзер находится в исходном состоянии, например, после нажатия на кнопку Reset, то на дисплее отображается прямая линия.
На оси X расположен весь звуковой частотный диапазон от 20 Гц до 20 кГц. По оси Y отложены децибелы. Глубина регулирования эквалайзера ±24 дБ.
Построение АЧХ выполняется щелчком мыши в точке с координатами X,Y. Так как эквалайзер имеет четыре полосы, то в зависимости от координаты X будет создаваться соответствующая точка с номером от 1 до 4. Как только все точки созданы, дальнейшее изменение АЧХ можно выполнять либо с помощью операции drag&drop, либо с помощью ручек эквалайзера. Для повторения процесса создания точек нужно нажать кнопку Reset.

Рис. 2.147. Equalizer section

Примечание
Точки можно создавать и в "аномальном" расположении, например, друг под другом. Только номер первой созданной точки соответствует секции эквалайзера по координате X.

Все полосы эквалайзера — Lo, Low Mid, Hi Mid и Hi — представлены вертикальными секциями, каждая из которых состоит из кнопки On, активизирующей обработку в частотной полосе, и ручек Gain/Frequency (уровень/частота) и Q (добротность, острота кривой АЧХ-фильтра).
Наличие сдвоенной ручки Gain/Frequency объясняется скорее требованиями дизайна программы, чем удобством регулирования. Поэтому для изменения параметров эквалайзера удобней пользоваться следующим приемом.

  1. 1. Нажать и удерживать клавишу <Alt>.
  2. 2. Щелкнуть в одном из полей: Gain, Frequency или Q, при этом должен появиться виртуальный слайдер (рис. 2.148).
  3. 3. Выполнить регулирование движением мыши вверх или вниз.

Рис. 2.148. Регулирование с помощью виртуального слайдера

Этим приемом регулирования удобно пользоваться при "живой" записи автоматизации. Например, при формировании специального эффекта с помощью перестраиваемого по частоте полосового фильтра.

Совет
Повысить точность регулирования можно, если смещать слайдер с нажатой клавишей <Shift>.

Регулирование посредством перетаскивания точек АЧХ на дисплее тоже имеет свои особенности. Обычное перетаскивание точек затрагивает сразу два параметра: уровень Gain и частоту Frequency. Однако достаточно часто возникает задача модификации только одного параметра. Достигается это так:

  • перетаскивание с нажатой клавишей <Ctrl> блокирует все параметры, кроме уровня Gain;
  • клавиша <Alt> оставляет для регулирования только частоту;
  • клавиша <Shift> блокирует все параметры, кроме добротности.

Таким образом, нажав любую из этих клавиш, можно работать с АЧХ как бы "в разрезе", только по одному параметру. При необходимости можно с клавиатуры ввести точные значения в поля Gain, Frequency и Q.
Секции Low Mid и Hi Mid представляют собой полосовые фильтры, перестраиваемые по частоте и добротности. И в зависимости от уровня Gain, фильтр либо выделяет, либо подавляет полосу. Секции Lo и Hi устроены иначе. В зависимости от положения регулятора Q они могут работать как три разных типа фильтра.

  • Числовая индикация добротности означает, что секция Lo или Hi работает в режиме полосового фильтра.
  • Low S. — Low Shelving-фильтр для секции Lo и High S. — High Shelving-фильтр для секции Hi.
  • High P. — High-Pass-фильтр (ФВЧ) для секции Lo и Low P. — Low-Pass-фильтр (ФНЧ) для секции Hi.

Настройки эквалайзера могут быть сохранены кнопкой Store в секции Presets. Пресет сохраняется под типовым именем Preset N, где N — номер пресета. Для переименования нужно щелкнуть левой кнопкой мыши на названии пресета, ввести новое с клавиатуры и завершить процесс нажатием клавиши <Enter>.


Эквализация с помощью анализатора спектра Spectrum Analizer

Нередко музыканты сталкиваются со своеобразным частотным конфликтом треков. Это может происходить из-за того, что тембрально богатый инструмент затеняет своими обертонами "соседа", попадает в чужой частотный диапазон. Или в звучании присутствуют паразитные резонансы, мешающие ясной и чистой звуковой картине. Для преодоления этой проблемы при сведении применяются параметрические эквалайзеры, инструменты "пластической хирургии звука".
Общие подходы к прояснению звуковой картины такие: сначала аккуратно вырезать резонансы, а затем попробовать ослабить мешающие частоты на соседних каналах. При этом установки эквалайзера, ослабляющие мешающие частоты, необязательно должны быть постоянными. С помощью автоматизации их можно использовать динамически, только на время конфликта треков.
Теперь осталось определить мешающие частоты.
Конечно, можно воспользоваться знаниями о частотных диапазонах музыкальных инструментов, "таблицами эквализации". Можно искать частоты на слух. Но лучше всего использовать мощные встроенные возможности Nuendo для точного спектрального анализа.

Примечание
Кстати, до появления Nuendo спектральный анализ был прерогативой только звуковых редакторов. Пользователь должен был экспортировать трек в звуковой редактор и там производить спектральный анализ. И только после этого браться за эквалайзер. В Nuendo пользователь, наконец-то, избавлен от этих сложностей.

Для вызова анализатора спектра (Spectrum Analizer) нужно выделить объект (или объекты) и выбрать пункт меню Audio | Spectrum Analizer. В контекстном меню Audio пункт Spectrum Analizer стоит первым, но удобнее всего за программировать комбинацию "горячих" клавиш.
Перед началом анализа появится диалоговое окно Spectrum Analizer (рис. 2.149).

Рис. 2.149. Диалоговое окно анализатора спектра

Так как спектральный анализ не является в данном случае самоцелью, то можно не изменять параметры анализа, предложенные программой по умолчанию. Их вполне достаточно. Флажок Normalized Values лучше оставить отмеченным, тогда график будет автоматически нормализован. Нижний раскрывающийся список From Stereo существует только при анализе стереообъектов. В нем можно задать дополнительные параметры анализа стереообъектов:

  • Mono Mix — анализ суммы левого и правого каналов;
  • Mono Left, Mono Right — анализ только одного канала — левого или правого;
  • Stereo — создание двух совмещенных графиков для левого и правого каналов.

После щелчка по кнопке Process начнется процесс спектрального анализа, который завершится появлением либо одного окна с графиком (рис. 2.150), либо нескольких для каждого выделенного объекта.

Примечание
Если выделить диапазон инструментом Range Selection, то спектральный анализ будет производиться для выделенного диапазона. В окне Pool можно проанализировать выделенный аудиоклип.

Рис. 2.150. Результат спектрального анализа

Для большинства случаев удобнее использовать логарифмический масштаб отображения частоты по оси X; для этого нужно отметить флажок Freq.log.
Флажок dB переводит ось Y в децибелы. Раскрывающийся список Frequency/ Note изменяет единицу измерения частоты с Гц на обозначения нот.
В полях Min и Мах задаются границы отображения частотной кривой по оси X.
Флажок Active сохраняет окно и его настройки для следующего спектрального анализа. Иначе каждый следующий анализ будет создавать новое окно. При этом не нужно закрывать окно с флажком Active.
В интерфейсе анализатора спектра предусмотрена удобная функция, позволяющая с помощью мыши измерять результаты анализа. Благодаря ей трудности исследования превращаются в обычное перемещение курсора мыши по горизонтали в пределах дисплея с графиком. При этом специальный курсор станет послушно следовать вдоль кривой, а его позиция будет отображаться на маленьком дисплее, расположенном вверху справа (см. рис. 2.150).
Координата курсора состоит из четырех параметров.

  • Первый параметр: буква — L или R (отсутствует у монофайлов) обозначает канал. Для измерения графика правого канала нужно нажать и удерживать клавишу <Shift>.
  • Второй параметр обозначает частоту в герцах.
  • Третий параметр обозначает уровень. В зависимости от состояния флажка dB уровень измеряется в децибелах или относительных единицах.
  • Четвертый параметр (delta value) показывает разность между текущей позицией курсора и позицией, где был произведен щелчок правой кнопкой мыши.

Если щелкнуть правой кнопкой мыши, то в этой позиции будет закреплен базовый нулевой уровень. Перемещая курсор, можно легко измерить уровень любой точки относительно созданного базового уровня.
Анализатор спектра позволяет существенно облегчить задачу эквализации, и выполнить ее с максимальной точностью. Для этого нужно исследовать график, найти частоты, где максимально сосредоточена звуковая энергия трека. Затем перейти на соседние "мешающие" треки и ввести полученные значения в поля Frequency параметрического эквалайзера с клавиатуры. После этого начать процесс постепенного подавления этих частот.
Если количества секций канального эквалайзера недостаточно, в помощь можно добавить в качестве Insert-эффекта VST-plug-in Nuendo EQ 2.


Качество цифровой обработки

Очень кратко о взаимоотношениях Nuendo и plug-ins можно сказать следующее.
Программа Nuendo поддерживает два самых распространенных стандарта plug-ins: VST и DirectX. Некоторые производители выпускают plug-ins сразу в двух стандартах, например, Ultrafunk (www.ultrafunk.com). VST-plug-ins поддерживают автоматизацию параметров в VST-приложениях. Кроме того, как правило, VST-plug-ins менее ресурсоемки.
Модули plug-ins, поставляемые в комплекте с Nuendo, имеют простой и ясный интерфейс. Многие из них синхронизируются с темпом проекта, например, Double Delay, что дает возможность их применения в качестве дополнительного музыкального инструмента.
Теперь перейдем к теме цифровой обработки звука.
Как известно, цифровая обработка звука имеет неприятную тенденцию к накоплению погрешности, которая вызывается конечной точностью обработки. Никакие красивые графики и коммерческий дизайн подключаемого модуля не должны вводить в заблуждение. Единственным, реальным критерием качества алгоритма plug-in может быть только слуховое восприятие.
Ресурсозависимые (native) системы иногда критикуют за эффект замутнения звуковой картины, который объясняется недостаточным быстродействием CPU для звуковой обработки в реальном времени и задержками plug-ins.
Однако, как ни странно, нет принципиальной разницы между обработкой звука специализированными DSP и обработкой центральным процессором.
Действительно, в реальном времени аппаратные устройства работают быстрее. Это, несомненно, важно, когда время — деньги, например, в профессиональной студии. В домашней студии на качество можно потратить значительно больше времени. Поясним. Звук на компьютере можно обрабатывать и не в реальном времени, но зато с ювелирным качеством. Кроме того, применение двухпроцессорной конфигурации PC увеличивает производительность системы при обработке в реальном времени.
На рис. 2.151 показана загрузка CPU в однопроцессорном режиме. А на рис. 2.152 — в двухпроцессорном. Переключение режима Nuendo осуществлялось в окне VST Engine Expert Settings с помощью флажка Multi Processing (см. разд. "Настройка AUDIO" ранее в этой главе).

Рис. 2.151. Однопроцессорный режим

На рис. 2.152 видно, что программа Nuendo распределила обработку между обоими процессорами. Таким способом устраняется одна из причин эффекта замутнения звуковой картины — недостаточность производительности.

Рис. 2.152. Двухпроцессорный режим


Задержка сигнала в plug-ins

И еще об одном важном аспекте — задержке, которая может с одинаковым успехом возникать как в аппаратных, так и в виртуальных процессорах эффектов.
Для того чтобы успешно работать с конкретным подключаемым модулем, нужно точно знать, вносит ли он задержку. Игнорирование этого факта может привести к искажениям звука. Для иллюстрации этого эффекта мы предлагаем читателю провести простой эксперимент — один и тот же drumloop разместить на соседних дорожках в одинаковой стартовой позиции. А затем в разрыв одного канала подключить компрессор Waves RCL (с пресетом Full RCL reset) и сравнить с режимом Bypass.
Из-за этого явления в сложной схеме маршрутизации, где аудиопоток разветвляется, часть потока может быть обработана с "несанкционированной" задержкой, а затем смешана с остальной частью.

Примечание
Существует специальная опция Insert Plug-in Delay Compensation в дополнительных настройках Preferences на странице VST. Но она помогает далеко не со всеми подключаемыми модулями.

Для борьбы с этим явлением есть несколько способов.

  • Не использовать в качестве Insert-эффектов модули, дающие задержку.
  • Не использовать режим лимитера на динамических процессорах.
    Как правило, режим лимитера использует алгоритм look ahead, дающий задержку.
    Например, отключение лимитера в DirectX-модуле dB-D dynamics processor (кнопка brick wall) www.db-audioware.com, а также в VST-модуле Ul-trafunk fx:compressor (кнопка Limiter) устраняет задержку.
  • Скомпенсировать задержку вручную.

Поясним последний пункт.
Программа Nuendo, как истинно профессиональное аудиоприложение, позволяет смещать объекты с точностью до отсчета (сэмпла). Для этого нужно перевести параметр Display Format в окне Project Setup формат Samples (см. разд. "Настройка проекта, окно Project Setup" ранее в этой главе). В панели инструментов Nudge и Snap (рис. 2.30) выбрать величину Snap, равную одному сэмплу (1 sample). Далее кнопкой Move Left можно сдвигать выделенный объект к началу мультитрека с шагом в один сэмпл. Отметим, что подобный метод достаточно трудоемок. Поэтому лучше иметь точную информацию о величине задержки, вносимой модулем.
Зная точную величину задержки в сэмплах, легче вычесть ее прямо из координаты стартовой границы объекта, отображаемой в поле Start панели Info Line. Полученный результат ввести с клавиатуры в это же поле. Тогда задержка будет полностью скомпенсирована.
Информацию о величине задержки модуля можно получить в окне Plug-in Information (см. разд. "Окно Plug-in Information" ранее в этой главе), но только для VST-plug-ins. Кроме того, задержка большинства VST-plug-ins компенсируется Nuendo автоматически (если в дополнительных настройках отмечена опция Insert Plug-in Delay Compensation). Проблема остается в основном для DirectX-plug-ins. Поэтому имеет смысл протестировать plug-ins на предмет задержки и измерить ее точную величину.
Из списка тестируемых plug-ins, по понятным причинам, нужно исключить эффекты, "специализирующиеся" на задержках. Поэтому в основном тестировать нужно динамические процессоры (компрессоры, экспандеры) и психоакустические процессоры (эксайтеры, сатураторы и т. д.).
Самый простой и эффективный способ поиска величины задержки — это сложение в противофазе двух каналов белого шума. При отсутствии задержки на выходе получится тишина, при сдвиге только на 1 отсчет (сэмпл) будет прослушиваться шум.
Белый шум можно сгенерировать в Cool Edit Pro в виде 32-битного монозвукового файла. А для тестирования создать специальный 32-битный проект в формате времени Samples с двумя аудиодорожками. Курсор установить в позицию, например, 10000 samples, используя Position Display транспортной панели (см. разд. "Панель Transport" ранее в этой главе). Затем импортировать (меню File | Import | Audiofile) в позицию курсора звуковой файл с белым шумом и скопировать объект на соседнюю дорожку с сохранением позиции (с клавишами <Alt> и <Ctrl>). Для скопированного объекта применить операцию деструктивного инвертирования фазы (контекстное меню Process | Phase Reverse). На запрос программы ответить: New Version. Далее нужно снять опцию Insert Plug-in Delay Compensation в дополнительных настройках Preferences. Измерительная установка готова.
Если все сделано правильно, и фейдеры каналов находятся в положении 0 дБ, то при воспроизведении на выходе должна быть тишина. Для дополнительной проверки можно временно сдвинуть один из объектов на один сэмпл. Далее в разрыв одного из каналов подключается тестируемый модуль и включается режим циклического воспроизведения. Если на выходе сохраняется тишина, то модуль не вносит задержку и не изменяет уровень сигнала. Если появился шум, то нужно сначала проверить уровень на выходе модуля, а затем начинать измерение, т. е. сдвигать объект другого канала, к которому не подключен ни один Insert-модуль, от начала мультитрека.
Переключение шага Snap на 10 samples ускорит процесс. С уменьшением задержки между каналами шумовой тон будет повышаться, с увеличением — понижаться. Если тон начал понижаться, значит нужно вернуться назад, уменьшить шаг до одного сэмпла и продолжить движение. В момент компенсации на выходе будет тишина.
Величина задержки определяется как разность между координатами стартовых границ двух объектов. Например, разность координат 00010064 и 00010000 дает величину задержки в 64 отсчета. Полученная в результате тестирования информация позволит принимать правильные решения о месте того или иного модуля в схеме маршрутизации виртуального микшера, а также раз и навсегда избавит от проблемы задержек plug-ins, вызывающих замутнение звуковой картины.


Сохранение настроек подключаемого модуля

Конфигурация настроек подключаемого модуля может сохраняться либо в файлы банков fxb, либо — программ fxp. На рис. 2.153 изображен пример сохранения настроек модуля Nuendo EQ2.
Для сохранения/загрузки банков и программ предназначен раскрывающийся список File. Команда Save Effect сохраняет текущие настройки как программу в файл fxp. Для возврата к сохраненным настройкам нужно загрузить файл fxp командой Load Effect.
Для наиболее часто используемых пресетов (программ) предназначены банки. Для каждого вида VST-plug-ins банк может иметь разное количество программ.
Для DirectX-plug-ins банк содержит 16 программ. Программы выбираются в раскрывающемся списке рядом с красной кнопкой активизации модуля.

Рис. 2.153. Сохранение настроек plug-ins

Примечание
Переключение программ может быть записано на субтрек автоматизации.

По умолчанию в списке содержатся только пункты Init с номерами программ. Банк можно сформировать двумя способами.

  • Из текущих настроек. Текущие настройки автоматически запоминаются в выбранной в списке программе. Программе рекомендуется присвоить имя (ввести с клавиатуры так же, как во все текстовые поля Nuendo) и перейти на следующую. Выполнить настройку эффекта, затем повторить процесс. После заполнения банка сохранить его в файл fxb.
  • Из fxp-файлов ранее сохраненных программ. В списке выбирается любая программа, например, с названием Init. Затем загружается файл fxp. Программе при необходимости присваивается новое имя. Затем процесс повторяется для следующей свободной программы в банке.

Примечание
Каждая программа сохраняется в файл fxp вместе с сохранением собственного имени (не путать с названием файла fxp). При последующей загрузке в банк имя программы восстанавливается.


Сохранение настроек VST-микшера

Так же, как и в SAWStudio, в Nuendo есть возможность полного сохранения настроек микшера. Делается это через контекстное меню панели VST Mixer (рис. 2.154) или окна VST Channel Settings в файлы с расширением vmx.

Рис. 2.154. Контекстное меню VST Mixer

О функциях Link Channels и Unlink Channels рассказывалось раньше, теперь рассмотрим остальные пункты.

  • Save Selected Channels — сохраняет все настройки выделенных каналов, включая маршрутизацию выхода (Channel Output routing).
  • Load Selected Channels — загрузка ранее сохраненных настроек для выделенных каналов. В файле vmx сохраняется порядок расположения каналов. При загрузке этот порядок восстанавливается. Например, если были сохранены настройки для пяти каналов I, 2, 3, 4, 5, то при восстановлении выделенные каналы 1, 4, 7, 9, 11 получат настройки соответственно: 1-1, 4-2, 7-3, 9-4 и 11-5 каналов. Если количество выделенных каналов меньше, чем количество ранее сохраненных, то и для меньшего числа порядок расположения каналов будет сохранен.
  • Save Master and Sends — сохраняет настройки VST Master Setup, уровни выходных шин VST Output Bus, их активное/пассивное состояние и конфигурацию выходов, уровень Master-фейдера, а также все параметры и маршрутизацию эффектов панелей VST Send Effects и VST Master Effects.
    Эти настройки являются глобальными, поэтому их применение не требует предварительного выделения каналов.
  • Load Master and Sends — загрузка ранее сохраненных глобальных настроек.
  • Save Master Fx — сохраняет конфигурацию и установки эффектов панели VST Master Effects.
  • Load Master Fx — загрузка конфигурации и установок эффектов панели VST Master Effects.
  • Save All Mixer Settings — сохранение полной конфигурации VST-микшера (то есть всех настроек, перечисленных выше).
  • Load All Mixer Settings — загрузка полной конфигурации VST-микшера.

Внимание
Функция Load All Mixer Settings не добавляет каналы. Если в файле vmx сохранена 18-канальная конфигурация, а применяется она для микшера из 10 каналов, то остальные восемь каналов не будут добавлены.

Совет
Так как для всех видов настроек предназначен один тип файла vmx, то рекомендуется в названии этого файла отражать его содержание. Например, 16All.vmx (полная конфигурация для 16-ти каналов) или 1_7_11_12Sel.vmx (настройки 1,7, 11, 12 каналов).
Для цепочек Insert-эффектов одного канала EQDyn.vmx (эквалайзер+комлрес-сор), EQCompGate.vmx (эквалайзер+компрессор+гейт) или EQDyn(Drums).vmx (эквалайзер+компрессор с настройками для обработки drumloops).


Surround в Nuendo

Surround Sound — это огромная тема, которой посвящено немало серьезных книг, поэтому читателей, глубоко интересующихся данным вопросом, мы адресуем к специальной литературе. Технология Surround Sound находится в непрерывном развитии. Постоянно появляются новые форматы многоканального звука. Преимущество Nuendo состоит именно в том, что ее можно быстро адаптировать под любой формат, т. е. создать свой пресет в окне VST Master Setup.
Благодаря этому Nuendo можно с успехом использовать даже в концертной деятельности — для концертов электронной музыки с применением многоканальной фонограммы. В этом случае нужно будет адаптировать Nuendo к конкретному оборудованию, количеству каналов и расположению акустических систем.


Конфигурирование Output Bus

Для того чтобы воспользоваться возможностями Nuendo для пространственного многоканального звука (Surround Sound), нужно как минимум установить в компьютер многоканальную звуковую карту. В задачу данной книги не входит тема сравнительного анализа существующих звуковых карт. В качестве образца далее будет рассмотрена продукция фирмы Creative Labs. Причин этому несколько.
Во-первых, Creative Labs — безусловный лидер в области производства самых массовых звуковых карт низкой ценовой категории — серьезным образом относится к многоканальному звуку. Во-вторых, выбранная авторами звуковая карта SB Audigy предназначена не только для компьютерных игр, но и для формата Dolby Digital. Причем фирма Creative Labs не ограничилась только лишь традиционными мультимедиа-функциями, а выпустила к карте специализированный ASIO-драйвер, обеспечивающий мультиканальность для VST-приложений.
Следовательно, массовый компьютерный музыкант может, имея самую бюджетную конфигурацию компьютерной студии, осваивать просторы самого современного многоканального звука.
И вновь обратимся к настройкам Nuendo. В окне VST Master Setup выберем пресет 5.1 Surround и нажмем кнопку ОК. Затем в окне VST Outputs переназначим и активизируем выходы так, как показано на рис. 2.155.

Рис. 2.155. Назначение выходов Output Bus для Surround Sound

Примечание
Остальные выходы на рис. 2.155 не показаны, т. к. они неактивны и в данном случае значения не имеют.

Вопросы подключения SB Audigy к внешнему оборудованию мы опускаем, т. к. к звуковой карте прилагается подробная документация.
Вернемся к Nuendo. После вышеописанных манипуляций виртуальная студия готова к работе с многоканальным звуком в формате 5.1 Surround.
На рис. 2.156 показан вид фейдера мастер-шины в порядке убывания количества каналов для разных пресетов VST Master Setup.

Рис. 2.156. Внешний вид фейдера мастер-шины для разных форматов

Забегая вперед, отметим, что в составе Nuendo есть специальные многоканальные VST-plug-ins. Например, plug-in Matrix Encoder, который выполняет матричное кодирование формата LRCS в обычное стерео для последующего декодирования системой Dolby Pro Logic (см. главу 1, разд."Surround в SAWStudio").
Поэтому, имея звуковую карту SB Audigy, в Nuendo можно создать микс для систем Dolby Pro Logic и Dolby Digital 5.1 (подробнее об этом ниже).
Маршрутизация для Surround Sound становится более сложной. Существует два способа маршрутизации выхода канала микшера на многоканальную мастер-шину.

  1. 1. Прямая маршрутизация. При ней любой канал VST-микшера можно назначать непосредственно на один из выходов мастер-шины (рис. 2.157).
  6. Рис. 2.157. Назначение выхода канала на мастер-шину

  8. 2. Маршрутизация через специальный plug-in SurroundPan (Surround Fanner). В этом случае выход канала микшера назначается на Surround Fanner (регулятор панорамы многоканального звука). На рис. 2.157 — это самый нижний пункт списка.

Рассмотрим второй способ более детально.


Surround-панорамирование

Если назначить выход канала микшера на модуль SurroundPan, то регулятор панорамы заменится на Surround Fanner. На рис. 2.158 слева изображена ячейка Channel strip с регулятором Surround-панорамы.
Зеленая точка отображает позицию панорамируемого источника звука в виртуальном Surround-поле. Щелчок в любой точке Surround-поля позиционирует источник звука в эту точку. Точку можно просто перетаскивать мышью. Комбинация <Ctrl> + щелчок мышью перемещает источник звука в позицию фронт-центр.

Рис. 2.158. Surround Panner

Модуль Surround Panner может быть представлен в разных видах. В ячейке Channel strip он отображается в уменьшенном виде. Для того чтобы открыть полное окно настроек, нужно дважды щелкнуть по уменьшенному изображению в ячейке Channel strip. По умолчанию открывается окно Panner в стандартном режиме Standard Mode (см. рис. 2.158). В полном окне модуля Surround Panner для панорамирования звукового источника в виртуальном пространстве появляются дополнительные возможности.
Количество и расположение виртуальных акустических систем в Surround-поле регулятора определяется настройками VST Master Setup.
Мы не будем подробно останавливаться на деталях интерфейса модуля Surround Panner, а рассмотрим только некоторые, наиболее важные на наш взгляд, моменты.

Совет
Если дважды щелкнуть на названии модуля [image] (Panner), то модуль преобразуется в список комбинаций "горячих" клавиш, которым мы и рекомендуем воспользоваться.

  • Слайдер LFE-уровня задает уровень сигнала, подаваемого на низкочастотный канал LFE (Low Frequency Emitter) (только для конфигураций VST Master Setup с LFE-каналом).
  • Слайдер Center Level (Standard Mode) — перераспределяет сигналы центра между каналами L, R и Center. Положение 100% означает, что центральный сигнал полностью передается каналом Center, 0% — центральный сигнал передается каналами L и R.
  • Ручки (Divergence Controls): Front, Back (ось X) и Y (ось Y) — определяют кривые ослабления, используемые для позиционирования звука. Если звуковой источник поместить точно в позицию виртуальной акустической системы (например, R), то уровень сигнала остальных систем будет равен нулю (минус бесконечность). Смещение позиции ручек Front, Back и Y выше 0,0% прибавит уровень на остальных виртуальных динамиках.
  • Режим Mono Mix является основным для монофонических источников звука. Для стереоканалов существует три симметричных (зеркальных) режима Y-Mirror, X-Mirror и XY-Mirror. Для стереоканалов режим по умолчанию — Y-Mirror (симметричный режим относительно оси Y) (рис. 2.159). В режиме Mono Mix сигналы левого и правого каналов суммируются на входе модуля Surround Fanner.

И наоборот, моносигнал расщепляется на левый и правый каналы, если симметричный режим применяется для моноканала.

Рис. 2.159. Режим Y-Mirror

  • Слайдер Attenuator (Position Mode, Angle Mode) регулирует уровень источника сигнала. В режиме Position Mode — это регулировка диаметра звукового поля, который можно визуально оценивать по концентрическим окружностям.
  • Слайдер Normalize (Position Mode, Angle Mode) изменяет степень нормализации сигнала. В положении 1.0 обеспечивается полная нормализация, и суммарный уровень сигнала со всех виртуальных акустических систем будет равен 0 дБ.

Параметры модуля Surround Fanner автоматизируется (об автоматизации см. разд."Автоматизация в Nuendo" далее в этой главе).


Особенности маршрутизации многоканального звука

Работа с многоканальным звуком расширяет возможности звуковой обработки с помощью plug-ins. Выходы Send-эффектов (панель VST Send Effects) можно назначить непосредственно на шины Output Bus, сконфигурированные для определенного многоканального формата, например, на каналы Ls и Rs для получения спецэффектов.
Более широкие возможности предоставляет Send-маршрутизация с использованием группового канала. В этом случае выход группы назначается на модуль Surround Panner, и результат обработки Insert-эффектами может свободно позиционироваться в Surround-поле. С помощью такого решения легко реализуется Surround-реверберация, которая должна имитировать эффект концертного зала.

Примечание
Реалистичная Surround-реверберация получается с помощью многоканальных plug-ins, подключаемых в панель VST Master Effects. Например, OctoVerb — Surround-ревербератор из пакета Nuendo Surround Edition (Steinberg) или ТС SurroundVerb (TC Works).

Для создания спецэффектов широкие возможности предоставляет автоматизация параметров модуля Surround Panner и модулей VST-plug-ins, включенных как Insert-эффекты группового канала.


Панель VST Master Effects

Мы намеренно не рассматривали панель VST Master Effects раньше, т. к. в стереоконфигурации она является аналогом сходной панели программы Cubase VST, которая в этой программе предназначена для подключения plug-ins общей обработки. Такими plug-ins обычно бывают эквалайзеры, компрессоры, максимайзеры и дизеринг-процессоры.
В этом разделе речь идет о Surround Sound, поэтому панель VST Master Effects будет рассмотрена под этим углом зрения — для многоканального режима.
В зависимости от настроек VST Master Setup мастер-шина в программе Nuendo может состоять максимум из восьми каналов.
Панель VST Master Effects вызывается одноименной командой меню Devices, клавишей <F7> или кнопкой Ins (Ipserts) фейдера мастер-шины (см. рис. 2.156). Панель состоит из восьми слотов, причем седьмой и восьмой слоты включены после фейдера мастер-шины Master Gain (рис. 2.160).

Примечание
На рис. 2.160 изображена шестиканальная конфигурация панели VST Master Effects для пресета 5.1 Surround.

Рис. 2.160. Панель VST Master Effects

Сделано это не случайно. Седьмой и восьмой слоты предназначены для восьмиканального дизеринг-процессора Nuendo Dither (или двухканального UV 22), а также для модуля Matrix Encoder. После обработки этими модулями уровень сигнала больше изменяться не должен.
Остальные шесть слотов могут использоваться для тех же компрессоров, эквалайзеров и максимайзеров. Каждый слот активизируется красной кнопкой. Каждый щелчок правой кнопкой мыши по кнопке Ins (Inserts) фейдера мастер-шины (см. рис. 2.156) включает/выключает режим обхода всех слотов панели VST Master Effects.
В многоканальной конфигурации Surround-проекта обработка должна вестись специализированными многоканальными plug-ins. Такие модули после инсталляции нужно искать в субменю Surround списка plug-ins.
Фирма Steinberg разработала для Nuendo специальный пакет восьмиканальных модулей под названием Nuendo Surround Edition. Пакет состоит из следующих plug-ins:

  • OctoQ — эквалайзер с графическим дисплеем, восьмиканальный вариант популярного эквалайзера Q-Metric (производство Steinberg);
  • OctoComp — восьмиканальный компрессор;
  • OctoVerb — Surround-ревербератор;
  • OctoMaxx — восьмиканальный вариант популярного модуля Loudness Maximizer (производство Steinberg);
  • LFE Splitter — устройство выделения низкочастотного сигнала для LFE-канала;
  • LFE Combiner — устройство объединения низкочастотного канала с остальными каналами.

С помощью этого пакета в Nuendo можно производить Surround Mastering многоканального звука во всех существующих форматах.
Для работы с многоканальным звуком необходимо иметь возможность группировать каналы (то есть связывать каналы по обработке).
Для примера можно рассмотреть случай обработки стереосигнала компрессором с отсутствием связи между каналами. Тогда громкий звук в одном канале вызовет срабатывание компрессора только по этому каналу. Результат — смещение звука по стереобазе к центру. Связь между каналами вызвала бы срабатывание компрессора по обоим каналам, и смещения звука не произошло бы. Чтобы понять преимущества восьмиканального компрессора со сгруппированными каналами, распространим эту ситуацию на многоканальный звук.


Подключение двухканальных модулей

В Nuendo есть возможность подключения в многоканальную панель VST Master Effects двухканальных модулей. По умолчанию двухканальный модуль займет первые каналы, обычно L и R.
При желании модуль можно переназначить на другие каналы. Для этого достаточно щелкнуть на имидже окна Patch Editor (рис. 2.161) и сформировать новый маршрут в полном окне.

Рис. 2.161. Окно Patch Editor

Двухканальный модуль условно изображен как серый прямоугольник: сверху расположены входы, а снизу выходы. Переназначение входов и выходов модуля осуществляется перетаскиванием мышью. Допустима и перекрестная маршрутизация, как в примере на рис. 2.161. При перекрестной маршрутизации щелчок на сером прямоугольнике (модуле) по линии канала включает/выключает режим обхода (Bypass).
На рис. 2.161 каналы L и R назначены на модуль Ultrafunk fxReverb, и затем, обходя его, поступают на следующий plug-in или выход. Маршруты каналов Ls и Rs разорваны. Дальнейшее движение по каналам Ls и Rs производит сигнал каналов L и R, обработанный ревербератором Ultrafunk fxReverb.


Использование матричного кодирования

Сведение проекта в стандарте Dolby Pro Logic должно осуществляться с помощью модуля Matrix Encoder. Он преобразует формат LRCS в Lt и Rt (подробности о матричном кодировании см. в главе 1 "Surround в SAWStudio"). Поэтому в установках VST Master Setup должен быть выбран пресет LRCS, а модуль Matrix Encoder подключен в седьмой слот панели VST Master Effects.

Примечание
В принципе, допустимо использование матричного кодирования для преобразования проекта Dolby Digital 5.1 в Lt и Rt. Для этого нужно в окне VST Master Setup перейти на пресет Standard 3/2 и выполнить сведение через Matrix Encoder. Каналы Ls и Rs соединятся в один S-канал. Модули Matrix Encoder и Matrix Decoder специально выполнены пятиканальными — для облегчения процесса перехода между форматами.

Модуль Matrix Decoder предназначен для мониторинга, поэтому он включается сразу за энкодером.

Рис. 2.162. Модули Matrix Encoder и Matrix Decoder

Регулятором Gain модуля Matrix Encoder (рис. 2.162) при необходимости корректируется уровень. После этих приготовлений можно прослушивать микс. Он будет звучать так, как в системе Pro Logic. При сведении нужно периодически отключать Matrix Decoder и проверять микс на стереосовместимость. Также для сравнения с исходным сигналом можно периодически обходить оба модуля. Перед окончательной процедурой сведения в файл (mixdown) следует не забыть оставить только Matrix Encoder и деактивировать Matrix Decoder.


Автоматизация в Nuendo

Программа Nuendo является полностью автоматизированной виртуальной студией.
Работа в ней с Automation Events (автоматизированными данными) организована очень просто и удобно: пользователю даже необязательно знать, что такое субтрек автоматизации.
Для записи автоматизации можно выделить два способа, которые не отрицают, а дополняют друг друга. Это "живая" запись в реальном времени и графический ввод.
"Живая" запись автоматизации, как правило, используется на стадии финального сведения проекта. Если в процессе редактирования проекта совмещается запись автоматизации с монтажом композиции, то одинаково применимы оба метода. Причем данные автоматизации в этом случае должны "следовать за объектами": переноситься и копироваться вместе с ними.
Работая с автоматизацией, нужно учитывать, что время реакции виртуального микшера на регулирующее воздействие определяется задержкой latency, т. е. зависит от типа и настроек ASIO-драйвера.


"Живая" запись автоматизации

Включается режим записи автоматизации кнопками Write Automation (на рис. 2.163 они пронумерованы).
Каждая кнопка включает режим записи автоматизации данного канала.

Примечание
В окне VST Channel Settings включение режима записи автоматизации выполняется так же, как и в окне VST Mixer. Кнопка Write All секции Automation общей панели включает глобальный режим записи на всех каналах.

В режиме Write Automation все движения автоматизируемых фейдеров, ручек и позиции кнопок будут записываться во время воспроизведения.

Рис. 2.163. Включение режима записи автоматизации

Нужно отметить, что по сути "живая" запись автоматизации не отличается от записи "живого" исполнения на аудиотрек, только в качестве музыкального инструмента выступает VST-микшер.
Чтение записанных данных автоматизации происходит только в режиме Read Automation. Режимы чтения и записи удобно совмещать для того, чтобы при записи прослушивать остальные автоматизированные треки. (Все автоматизированные регуляторы в программе Nuendo для наглядности анимированы.)
Режим чтения включается соседней зеленой кнопкой — Read Automation. Когда он активен, положение автоматизированных регуляторов определяется только событиями Automation Events.
Остановимся на этом подробнее. Если данные автоматизации записаны на субтрек, а режим чтения Read Automation выключен, то трек находится в статическом режиме.
Статический режим — это режим трека по умолчанию. Он не зависит от того, есть ли на субтреках записанные данные автоматизации. График изменения параметра представляет собой прямую линию Static Value Line (рис. 2.164), потому что параметр не изменяется во времени. Линия автоматизации в статическом режиме выглядит как светло-серая кривая, а регулятор автоматизируемого параметра можно свободно перемещать.

Рис. 2.164. Динамический и статический режимы

При переходе в динамический режим чтения автоматизации линия Static Value Line исчезает. Остается только кривая автоматизации, которая и определяет положение регулятора.
Запись, а точнее перезапись данных автоматизации удобно производить в окне Nuendo Project. Рассмотрим простой пример. Допустим, мы записали в несколько проходов автоматизацию громкости, панорамы и уровня посыла (FX Send 1 Level). Но затем потребовалось подкорректировать некоторые моменты. Конечно, это можно сделать и графическим способом (об этом ниже). Но иногда удобнее перезаписать конкретный субтрек "вживую".
Для доступа к субтрекам нужно применить команду Show Automation (или Show Automation for All Tracks) контекстного меню треков. В результате раскроются субтреки всех параметров, которые были автоматизированы. Далее надо включить воспроизведение, затем в нужный момент щелкнуть в числовом поле выбранного субтрека и удерживать левую кнопку мыши нажатой. Тогда рядом с курсором мыши появится виртуальный слайдер, который предназначен для наглядного отображения и регулирования изменяемого параметра (рис. 2.165). Запись новых данных автоматизации начинается с момента появления виртуального слайдера, поэтому нужно сразу начинать регулирование.

Примечание
На субтреке автоматизации должны быть включены режимы Write и Read Automation.

Рис. 2.165. Перезапись автоматизации

Такое регулирование эффективней изменения параметров "в слепую" в окне VST Mixer. Наблюдая за движением курсора по субтреку автоматизации, легче вычислить "проблемные зоны" и моменты начала регулирования.

Совет
Повысить точность регулирования можно, если смещать виртуальный слайдер с нажатой клавишей <Shift>.

Для сложных случаев есть "резерв" — кнопка Mute Automation. Она может помочь, например, при автоматизации VST-plug-ins. Расположена эта кнопка рядом с кнопками Write и Read Automation — на всех субтреках автоматизации и групповых треках. Польза кнопки Mute Automation заключается в том, что она позволяет выборочно приглушать субтреки, т. е. отключает чтение автоматизации ненужных параметров.

Предупреждение
В Nuendo все создаваемые кривые автоматизации автоматически упрощаются. Делается это для того, чтобы сократить общее количество событий автоматизации (Automation Events). Степень упрощения задается в дополнительных настройках Preferences на странице User Interface-Editing слайдером Automation Reduction Level. Минимальный уровень упрощения устанавливать не рекомендуется, т. к. кривая автоматизации будет содержать множество бесполезных точек (Automation Events).


Графический ввод

Графический ввод осуществляется инструментом Draw (Карандаш). Им можно нарисовать кривую автоматизации полностью (протащив карандаш) или построить по точкам (щелкнуть в каждой позиции) (рис. 2.166).
Даже если трек находился в статическом режиме, введение карандашом только одной точки сразу же переведет трек в динамический режим, включится режим чтения.

Рис. 2.166. Графический ввод автоматизации

Удалить варианты рисования кривой можно командой Edit l Undo или стереть инструментом Erase (Ластик).

Добавление и удаление параметра автоматизации
Каждый параметр автоматизации расположен на отдельном субтреке. (Здесь необходимо вернуться к разд. "Group Channel Track".) Для того чтобы добавить параметр, нужно щелкнуть в поле субтрека (на рис. 2.38 обозначено цифрой 1). Затем в раскрывающемся списке параметров выбрать пункт Add. При этом откроется окно Add Parameter, содержащее список автоматизируемых параметров (см. рис. 2.39). Добавление параметра выполняется двойным щелчком на элементе списка. Удаление параметра осуществляется командой Remove Parameter контекстного меню субтрека.

Точки можно вводить не только инструментом Draw, но и инструментом Object Selection (Стрелка). В этом случае необходимо на треке предварительно включить режим чтения и точки ставить только непосредственно на линии, и лишь затем их перетаскивать.
Инструмент Draw имеет "двойника" — инструмент Line. Для того чтобы на него перейти, нужно повторно щелкнуть по подсвеченной кнопке Draw панели инструментов Toolbar и выбрать нижний пункт раскрывающегося списка. Инструмент Line работает так же, как и Draw, но есть исключение: он формирует прямые отррзки линий автоматизации и не переводит субтрек из статического режима в режим чтения.


Редактирование автоматизации

Точки автоматизации — это ни что иное, как события (Automation Events). Поэтому к ним применимы те же операции и приемы редактирования, что и к объектам Audio Events. А именно: точки можно выделять, перемещать, копировать через буфер обмена, группировать, удалять и сдвигать кнопками Move Left/Right панели Nudge и Snap, а также размножать командами Duplicate, Repeat и Fill Loop (для этого нужно выделить две или более точки). На них распространяется действие функции Snap (кроме режима Shuffle).
Правда, точки "слишком малы" для команд меню Edit: Split at Cursor, Split Loop, Move to Front и Move to Back, которые не работают с Automation Events.

Совет
Быстро выделить все точки субтрека можно командой его контекстного меню Select All Events.

Огромное достоинство программы — возможность перемещения или копирования объектов вместе с событиями автоматизации. Такой сервис позволяет совместить монтаж с записью автоматизации. Выполняется он как обычная операция недеструктивного редактирования, только с чуть большей предварительной подготовкой — требуется выделить не только объект, но и точки автоматизации (рис. 2.167).
Режим Range Selection предоставляет еще большую свободу в перемещении и копировании. В примере на рис. 2.168 выделенный диапазон, охватывающий кривую автоматизации громкости одного канала, был скопирован на другой канал и даже на другой параметр.
Так же легко выполняется и другая часто встречающаяся задача — точное редактирование автоматизированного параметра (на уровне одного события). Для ее проведения нужно выделить событие и на панели Info Line изменить параметр Value (рис. 2.169) с нажатой клавишей <Shift>.
Точное редактирование можно проводить также в окне Browse Project, т. к. в нем — синхронно с окном Nuendo Project — выделяется событие автоматизации. Флажок Sync Selection в этом случае должен быть отмечен (см. разд. "Browse Project"ранее в этой главе).

Рис. 2.167. Комплексное копирование в режиме Object Selection

Рис. 2.168. Копирование в режиме Range Selection

Рис. 2.169. Модификация параметра с помощью панели Info Line


Автоматизация plug-ins

Наряду со всеми, параметры plug-ins тоже могут быть автоматизированы.
Для Insert-эффектов данные автоматизации записываются на субтреки аудио- и группового канала. Поэтому они редактируются описанными выше методами.
Параметры VST-plug-ins находятся на особом положении — они могут автоматизироваться полностью. Благодаря этому можно записать и воспроизвести непрерывное изменение параметра в реальном времени, а также автоматизировать положение переключателей — switches (если они есть в конструкции эффекта).
Для DirectX-plug-ins можно использовать автоматизированное переключение программ в банке DirectX-модуля. Всего в нем находится 16 программ, это свидетельствует о том, что с помощью автоматизации можно в реальном времени манипулировать шестнадцатью пресетами. Такая сервисная возможность позволяет полноценно использовать DirectX-plug-ins даже без полной автоматизации параметров.
Например, для Insert-эффекта одного трека можно создать специальный банк, состоящий из шестнадцати программ (максимум). И во время воспроизведения трека просто переключать эти программы с записью автоматизации.

Совет
Чтобы достичь синхронного переключения эффектов "живую" запись автоматизации следует отквантовать. Для каждой точки автоматизации эта процедура может быть выполнена следующим образом: курсор мультитрека устанавливается в точную позицию, например, в начало каждого такта, а выделенная точка автоматизации сдвигается в позицию курсора командой Edit | Move to Cursor. Рекомендуется использовать комбинированный режим Snap, например, Grid+Cursor.

Для автоматизации тех plug-ins, которые подключаются в панелях VST Send Effects и VST Master Effects, нужно создать специальный трек — Plug-in Automation Track (см. разд. "Plug-in Automation Track" ранее в этой главе). На этом же треке размещаются данные автоматизации VST-инструментов.


"Многослойное" деструктивное редактирование

Ресурсов компьютера, как и денег, никогда не бывает много. Особенно, когда хочется все и сразу. Но если расходовать ресурсы эффективно, то даже на относительно медленном домашнем компьютере можно многого достичь.
Именно деструктивное редактирование (Offline Process) позволяет получить высокий (теоретически неограниченный) уровень качества обработки на компьютере.
Offline-редактирование необходимо также и для тех алгоритмов, которые нельзя выполнить в реальном времени.
В программе Nuendo подход к Offline-редактированию получил новое, мощное развитие. Разработчики назвали созданный тип Offline-редактирования в документации к программе неразрушающим. Это действительно так в том смысле, что обработка не затрагивает оригинальные звуковые файлы. Мы решили назвать ее "многослойным" деструктивным редактированием, т. к. нам кажется, что такое название точнее всего отражает суть технологии, разработанной фирмой Steinberg.

Примечание
Напомним, что любой тип обработки с сохранением звуковых данных на жесткий диск мы определили как деструктивный. А способность программы защитить оригинальный материал от случайного повреждения — это ее несомненное достоинство.

Слои — понятие, знакомое пользователям Adobe Photoshop. Но в звуковой мультитрековой программе — это без преувеличения революционный прорыв. Ведь если не хватает ресурсов на все и сразу, то можно выполнить просчет эффектов поочередно, создавая слои Offline-редактирования. И если время не поджимает, то продукт музыканта-любителя вполне может сравняться по качеству с профессиональным.


Audio Processing

Операции деструктивного редактирования, которые в терминологии Nuendo называются Audio Processing, осуществляются с помощью команд субменю Process и субменю Plug-ins в меню Audio или соответствующих контекстных меню. Команды субменю Process предоставляют в распоряжение пользователя функции уровня Hi-End звукового редактора. Команды субменю Plug-ins обеспечивают деструктивную обработку алгоритмами подключаемых модулей.


Конвертирование в формат 32 Bit Float

Прежде чем будет рассмотрен процесс конвертирования, обратим внимание на формат обрабатываемых звуковых файлов. Деструктивное редактирование предполагает многократную обработку. Следовательно, необходимо принять меры защиты от деградации качества.
Оставим 16-битный формат без внимания, т. к. он изначально непригоден для хранения промежуточных результатов обработки без потери качества.

Примечание
Подробную информацию по этому поводу можно найти в нашей книге "'Живая' музыка на PC".

Теперь сделаем выбор между целочисленным 24-битным и 32-битным форматами с плавающей точкой (32 Bit Float). Здесь нужно учесть следующее. Во-первых, 32-битный формат — это внутренний формат Nuendo, во-вторых, сохранение результата в целочисленном 24-битном формате может привести к случайной потере качества из-за превышения уровня в 0 дБ. Далеко не все модули снабжены измерителями уровня.
Напротив, 32-битный формат с плавающей точкой защищен от проблемы 0 дБ чисто математически. Поэтому случайное превышение уровня 0 дБ не приведет к необратимой потере качества. После операции Normalize к уровню 0 дБ слышимые искажения исчезнут, потому что ЦАП звуковой карты преобразует в аналог только целочисленный формат. А сигнал в формате 32 Bit Float с уровнем, превышающим 0 дБ, после преобразования в целочисленный формат всегда ограничен сверху.
Вывод: если в проекте предполагается использовать качественное деструктивное редактирование, то звуковые файлы нужно преобразовать в 32-битный формат с плавающей точкой.
Преобразование для выделенных аудиоклипов выполняется в окне Pool командой контекстного меню Convert Files (меню Рооl | Convert Files). Если нужно конвертировать все файлы, то следует выделить папку Audio в окне Pool и повторить действия, описанные выше. Команда Convert Files вызывает диалоговое окно Convert Options (рис. 2.170).

Рис. 2.170. Окно Convert Options

Все параметры конвертирования сосредоточены в четырех раскрывающихся списках.

  • Sample Rate — частота дискретизации. Значение Keep сохраняет параметр без изменений.
  • Sample Width — разрешение (разрядность) сэмпла. В нашем случае установлена на максимум.
  • Channels — количество каналов. В нашем случае выбор — Keep.
  • File Format — формат звукового файла. В нашем случае в смене формата нет необходимости, поэтому выбираем — Keep.

Список Options задает дополнительные параметры конвертирования:

  • New Files — создаются копии файлов, которые конвертируются и добавляются в Pool. Но все ссылки аудиоклипов остаются прежними, т. е. на оригинальные файлы;
  • Replace Files — конвертируются оригинальные звуковые файлы с сохранением ссылок (этот параметр конвертирования подходит для нашего случая);
  • New + Replace in Pool — создаются копии файлов, которые конвертируются и добавляются в Pool с заменой оригинальных файлов. Все ссылки переназначаются на новые конвертированные файлы. (Этот вариант позволяет сохранить оригинальные файлы, например, если они используются в другом проекте.)

Существует другой способ конвертирования. Вначале разрешение проекта повышается до 32 бит в окне Project Setup (см. разд. "Настройка проекта, окно Project Setup" ранее в этой главе). Затем в окне Pool к выделенным клипам применяется команда Pool | Conform Files. В появившемся диалоговом окне можно выбрать Keep, тогда конвертироваться будут копии с сохранением исходных файлов. Или выбрать Replace, тогда конвертироваться будут исходные файлы. Ссылки аудиоклипов в обоих случаях будут переназначены на конвертированные файлы.


История редактирования

Команды деструктивного редактирования субменю Process и Plug-ins применяются к выделенным объектам или диапазонам.

Примечание
К выделенным диапазонам — в окнах Sample Editor, Audio Part Editor и Nuendo Project. К выделенным объектам — в окнах Audio Part Editor и Nuendo Project.

Эти команды применяются также к выделенным аудиоклипам и регионам в окне Pool.
Преимущество Nuendo проявляется в том, что редактирование можно производить, не останавливая процесса воспроизведения (например, воспроизведения в цикле). Результат деструктивной обработки можно немедленно оценить в совместном звучании с остальными треками, и при необходимости отменить командой Edit | Undo, не останавливая воспроизведения. Простая отмена последнего действия, характерная для других звуковых программ, расширена в Nuendo до свободной модификации любого этапа (слоя) в истории редактирования (Offline Process History).
Эти возможности превращают Nuendo в инструмент нового типа, предназначенный для музыкально-звукового творчества.
Прокомментируем многослойный принцип работы Nuendo.
Итак, предположим, что у нас есть объект Audio Event и к нему применяется, например, команда Audio | Process | Reverse. У объекта Audio Event есть собственная ссылка на аудиоклип (Audio Clip) в виде сегмента (области внутри аудиоклипа). А аудиоклип, в свою очередь, ссылается на звуковой файл.
Теперь рассмотрим, как происходит процесс образования слоев. Слой создается как физическая копия сегмента, которая обрабатывается командой Reverse и помещается в папку Edits (папка Edits создается внутри папки проекта).
Формат оригинального звукового файла при этом сохраняется. В завершение собственная ссылка объекта Audio Event переназначается на копию (слой). Это происходит аналогично бесшовному алгоритму деструктивного фейда.
В результате аудиоклип (Audio Clip) будет ссылаться уже на два физических файла на диске, т. к. он теперь содержит обработанный сегмент. В программе такой сложный аудиоклип помечается в окне Pool в столбце Status специальным символом [image].

Примечание
В случае выделения диапазона Range обработанный сегмент равен выделенному диапазону.

Если повторить команду деструктивной обработки, то будет создана еще одна копия с переназначением внутренней ссылки объекта и т. д. (рис. 2.171).

Рис. 2.171. Audio Processing в Nuendo

Такая система позволяет сохранить не только оригинальный материал, но и все ступени обработки. Зададимся вопросом: в чем ее отличие от обычной истории отмен с созданием обработанных копий?
Для ответа на него применим зрительную аналогию и вновь воспользуемся понятием слоя. Иными словами, для наглядности станем рассматривать каждую операцию деструктивной обработки как слой, который мы наложили на звук.
Начнем с обычного звукового редактора. Допустим, что звуковой файл в нем обработан последовательностью из пяти команд деструктивного редактирования. Теперь представим, что потребовалось изменить параметры обработки, например, второго действия (уровня). Это значит, что сначала нужно вернуться на этот уровень с помощью команды Undo. Затем изменить здесь параметры обработки. После чего вновь восстановить все последующие этапы. Для этого потребуется сохранить каждый уровень обработки как отдельный пресет.
В Nuendo для решения подобной задачи достаточно просто вызвать нужный уровень (например, второй слой) и сделать в нем требующиеся изменения. После такого редактирования программа автоматически пересчитает всю обработку следующих уровней (слоев).
Таким образом, в программе Nuendo все уровни обработки одинаково доступны пользователю, и поэтому они могут быть представлены как отдельные, не склеенные между собой слои.
Доступ к слоям осуществляется через диалоговое окно Offline Process History (рис. 2.172), которое вызывается из меню Audio командой Offline Process History.

Примечание
Команда Offline Process History применяется к выделенному объекту или группе, а также к выделенному диапазону. Если выделенный диапазон захватывает несколько объектов, то откроется несколько окон Offline Process History.

Рис. 2.172. Окно Offline Process History

В примере на рис. 2.172 показана история редактирования объекта DrumLoop, к которому был применен алгоритм реверсивной реверберации. Последовательность операций отражается в столбце Action в порядке нумерации. Расшифруем описание алгоритма, изображенного на рис. 2.172:

  • 1. Операция Reverse — реверсирование всего объекта (в столбце Start записана единица).
  • 2. Применение алгоритма Ultrafunk fxReverb в выделенном диапазоне Range (в столбце Start отображается в сэмплах смещение границы выделенной области относительно стартовой границы аудиоклипа, в столбце Length отображается длина обработанного сегмента).
  • 3. Повторное применение алгоритма Ultrafunk fxReverb в другом выделенном диапазоне.
  • 4. Реверсирование всего объекта.
  • 5. Нормализация всего объекта.

Каждый шаг алгоритма можно рассматривать как слой и редактировать его параметры независимо. Для выполнения этого нужно выделить слой (элемент списка) и применить одну из трех операций: Remove, Modify и Replace by.

Примечание
Если в результате редактирования изменялась длина аудиоклипа, например, в результате процесса Time Stretch или операций Cut, Copy, Paste в редакторе Sample Editor, то такие слои помечаются в столбце Status символами [image]. Подобный слой может быть только удален. Но только в случае, если он был последней операцией редактирования. Если выделить такой слой в середине истории редактирования, то кнопки Remove, Modify и Replace by блокируются.

Кнопка Remove просто удаляет выделенный слой. Кнопка Modify позволяет изменить параметры обработки в выделенном слое. А кнопка Replace by дает возможность даже заменить алгоритм обработки в слое. Для этого нужно предварительно выбрать plug-in или функцию в раскрывающемся списке, расположенном под кнопкой Replace by (см. рис. 2.172).
Все слои (или последующие ступени обработки), расположенные в списке ниже выделенного слоя, к которому применяются операции Remove, Modify или Replace by, будут автоматически пересчитаны.


"Склеивание" слоев (Freeze Edits)

Если процесс деструктивного редактирования завершен, то слои можно "склеить" командой меню Audio | Freeze Edits. Операция "склеивания" слоев очищает папку Edits и историю редактирования.
Если существует только одна версия аудиоклипа (то есть остальные аудио-клипы не ссылаются на тот же звуковой файл), то применение команды Freeze Edits вызовет диалоговое окно с кнопками Replace, New File и Cancel.
Выбор Replace означает, что все этапы редактирования будут применены к оригинальному звуковому файлу. Или, иначе говоря, "склеенные" слои будут перенесены в оригинальный звуковой файл.
Выбор New File отличается тем, что будет создан новый отредактированный звуковой файл в папке Audio. Оригинальный звуковой файл останется без изменений.
В более сложном случае, когда несколько аудиоклипов ссылаются на один и тот же звуковой файл (то есть аудиоклип имеет несколько версий редактирования), в диалоговом окне находится только кнопка New File. Таким образом, программа автоматически защищает материал от случайного повреждения. То есть реализованная в Nuendo концепция деструктивного редактирования действительно является неразрушающей.


Деструктивное редактирование общих копий (Shared Copies)

Давайте посмотрим, что произойдет, если деструктивную обработку применить к одному объекту, имеющему копии (Shared Copies). Программа выдаст диалоговое окно, предлагающее либо продолжить — Continue, либо создать новую версию — New Version. Выбор Continue означает, что будет обработан общий для всех копий объектов сегмент, и, следовательно, звучание всех копий объектов изменится. Выбор New Version приведет к автоматическому созданию копии аудиоклипа, содержащего обработанный сегмент. При этом собственная ссылка объекта будет переназначена на новый аудиоклип. Таким образом, только отредактированный объект изменит свое звучание.
Теперь обратимся к ситуации, когда деструктивное редактирование применяется к группе выделенных объектов, представляющих собой общие копии (Shared Copies). В этом случае Nuendo предложит либо пропустить копии — Skip Doubles, либо создать новые версии — New Version. Выбор Skip Doubles означает, что обработка будет происходить так же, как и для одного объекта, т. е. только одного сегмента, общего для всех копий. Выбор New Version означает, что каждый объект будет обрабатываться по отдельности. Как было бы в случае объектов, не являющихся общими копиями (Shared Copies).


Окно Process Plug-in

Функции субменю Process относятся к неотъемлемым атрибутам любого профессионального звукового редактора и имеют аналоги в реализациях других фирм-производителей. Поэтому они здесь подробно не рассматриваются.

Примечание
На CD, прилагаемом к книге, рассматриваются примеры их использования.

Процесс Acoustic Stamp имеет, например, аналог в виде эффекта Room Simulator в программах Samplitude 2496 и Samplitude Producer, в DirectX-модуле Acoustic Mirror фирмы Sonic Foundry.

Примечание
Подробности об эффекте Room Simulator можно узнать в нашей книге "'Живая' музыка на PC".

Дополнительно можно отметить, что процессы Pitch Shift и Time Stretch позволяют использовать специальный МРЕХ-алгоритм, обеспечивающий максимальное качество звука. Все функции субменю Process имеют интуитивно понятный интерфейс и несложны в освоении. Поэтому мы более детально рассмотрим общие элементы управления в окне Process Plug-in.

Рис. 2.173. Два вида окна Process Plug-in

К выделенным объектам или диапазонам можно применить деструктивную обработку алгоритмами подключаемых модулей plug-ins. Для этого нужно в меню Audio зайти в субменю Plug-ins.
Путь к алгоритмам DirectX-plug-ins выглядит так: Audio | Plug-ins | DirectX. После выбора подключаемого модуля в списке открывается окно Process Plug-in (рис. 2.173). Окно может иметь полный или сокращенный вид в зависимости от состояния кнопки More/Less. Сокращенный вид содержит элементы управления самого модуля, а также кнопки Preview/Stop и Process.
Кнопка Preview/Stop включает/выключает режим предварительного прослушивания. В этом режиме выделенный объект или диапазон воспроизводятся в цикле, и каждое изменение в настройках модуля быстро отражается на звуке.

Примечание
Переход в режим Preview можно производить, не останавливая циклического воспроизведения проекта.

Кнопка Process запускает процесс деструктивной обработки с закрытием диалогового окна Process Plug-in. Если при этом был активен режим циклического воспроизведения проекта, то результат обработки сразу же прослушивается совместно с остальными треками.
Оперативно оценить результат деструктивной обработки можно, не останавливая циклического воспроизведения. Это выполняется с помощью команд Undo, Redo в меню Edit.
Отметим, что такую технологию целесообразно применять в трех случаях. Во-первых, для относительно слабых компьютеров — где обработка в реальном времени вызывает трудности. Во-вторых, для ресурсоемких plug-ins. И в-третьих, для сложных алгоритмов обработки, которые невозможно реализовать в реальном времени.

Предупреждение
Если применяется деструктивная обработка к моноаудиоматериалу, то работает только левый канал подключаемого модуля.
Если подключаемый модуль вносит задержку, то эта задержка, как правило, вносится и при деструктивной обработке.

Рассмотрим дополнительные возможности, предоставляемые слайдерами нижней секции окна Process Plug-in.

  • Dry mix /Wet mix определяют баланс между оригинальным Dry-сигналом и обработанным Wet-сигналом. Оба слайдера имеют между собой связь с инверсией. Однако их можно регулировать независимо при нажатой клавише <Alt>. При этом нужно стараться не превысить порог в 0 дБ.
  • Tail (хвост) — задает длительность послезвучия, которое может быть вызвано обработкой алгоритмами реверберации. Оригинальный материал при этом удлиняется. Длительность "хвоста" учитывается в режиме Preview. Для выполнения этой функции флажок, расположенный слева от слайдера, должен быть отмечен.
  • Pre-CrossFade и Post-CrossFade — позволяют плавно выводить и уводить эффект за фиксированное время. Pre-CrossFade задает время выведения эффекта от начала выделенной области или стартовой границы объекта. Post-CrossFade устанавливает время уведения эффекта от конца выделенного диапазона или финальной границы объекта. Сумма времен Pre-CrossFade и Post-CrossFade не может превышать длины редактируемой области.


Редактирование в окне Pool

В окне Pool деструктивную обработку можно применять к выделенным аудиоклипам и регионам (рис. 2.174).

Рис. 2.174. Окно Pool с деструктивно обработанными регионами

Обработка регионов — это, по сути дела, обработка областей аудиоклипов, поэтому у них одна и та же история редактирования. Для вызова окна Offline Process History нужно выделить аудиоклип и выбрать пункт Offline Process History в меню Audio.
Еще раз обращаем внимание на то, что деструктивно обработанные аудио-клипы помечаются символом [image] (см. рис. 2.174).
Рассмотрим более детально специальные функции окна Pool по работе с аудиоматериалом. Все эти функции сосредоточены в меню Pool (или контекстном меню Pool).
Еще раз подчеркнем, что окно Pool создано специально для корректных манипуляций с аудиоматериалом. Звуковые файлы нельзя перемещать или переименовывать средствами Windows. В противном случае при загрузке проекта будет открыто диалоговое окно Resolve Missing Files, в котором будет предложено:

  • Locate — указать путь к отсутствующим файлам вручную;
  • Folder — указать папку, где могут находиться файлы;
  • Search — включить режим автоматического поиска;
  • Close — проигнорировать запрос и закрыть окно (проект при этом все равно откроется).

Из окна Pool можно также осуществлять манипуляции с потерянными файлами (Missing Files). Для этого предназначены пункты Find Missing Files и Remove Missing Files в меню Pool. Команда Find Missing Files вызывает рассмотренное выше диалоговое окно Resolve Missing Files, а команда Remove Missing Files просто удаляет ссылки на потерянные файлы из окна Pool.
Благодаря уникальному алгоритму деструктивного редактирования в Nuendo есть возможность восстановления случайно потерянных файлов из папки Edits, т. е. восстановления аудиоклипов по истории редактирования.
Такие аудиоклипы имеют статус reconstr (рис. 2.175).

Рис. 2.175. Аудиоклипы с возможностью восстановления

Для восстановления достаточно выделить клипы в окне Pool и применить команду Reconstruct из меню Pool.
Рассмотрим пример окна Pool, изображенного на рис. 2.176.
Аудиоклипы Sound1 и Sound2 имеют статус потерянных файлов, аудиоклип Loop — статус звукового файла, расположенного за пределами рабочей папки проекта (импортированного в проект без копирования в рабочую папку), а аудиоклип Bass_00 имеет статус звукового файла, записанного на мультитреке.

Рис. 2.176. Окно Pool до создания архива

Для приведения проекта в порядок, например, перед его архивированием на CD-R, предусмотрена специальная команда Prepare Archive. Результат ее действия изображен на рис. 2.177.

Рис. 2.177. Окно Pool после создания архива

В данном примере команда Prepare Archive выполнялась дважды. В первый раз был выполнен поиск потерянных файлов, во второй раз все файлы, расположенные вне рабочей папки проекта, были скопированы в каталог проекта в папку Audio. Теперь для архивирования достаточно сохранить только рабочую папку проекта.

Примечание
Команда Prepare Archive "склеивает" слои всех деструктивно отредактированных аудиоклипов проекта. При этом пользователю предоставляется возможность выбора в соответствующем диалоговом окне. Кнопка Freeze "склеивает" слои при создании архива. Кнопка No производит формирование архива с историей редактирования.

Удаление выделенных клипов производится с помощью клавиш <Delete>, <Backspace> или командой Delete меню Edit. Удаление производится через одно или два диалоговых окна, в зависимости от наличия ссылок на аудиоклип в проекте. Если ссылки есть, то первое (предупреждающее) диалог окно предлагает все их удалить кнопкой Remove, а затем появляется основное диалоговое окно с кнопками Remove from Pool и Trash. Выбор Remove from Pool означает, что удаляются только ссылки, а сами звуковые фа остаются на жестком диске. Выбор Trash переносит аудиоклипы в Корзину.
Окончательное удаление производится командой Pool | Empty Trash, но тоже через очередное диалоговое окно с кнопками Erase и Remove from Pool.
Здесь пользователю предлагается в последний раз пересмотреть свое решение о физическом удалении аудиоматериала. Кнопка Erase удаляет файл жесткого диска.
Окно Pool можно "почистить". Команда Remove Unused Media удаляет все задействованные в проекте аудиоклипы либо в Корзину, либо из окна Pool.


Промежуточное сведение

Как известно, главной проблемой виртуальных ресурсозависимых систем. является конечная производительность CPU. Даже на самом быстром компьютере наступает момент, когда вычислительные ресурсы исчерпываются В Nuendo контроль за загрузкой CPU и дисковой подсистемой осуществляется с помощью панели VST Performance (рис. 2.178).

Рис. 2.178. Панель VST Performance

Панель состоит из двух индикаторов текущей загрузки и двух индикаторов перегрузки (справа). Визуально контролируя загрузку, необходимо оптимально расходовать вычислительные ресурсы, не доводя индикатор CPU до красной шкалы.
VST-движок (VST Engine) работает в реальном времени постоянно, независимо от активности режима воспроизведения. Поэтому перегруженная система начнет заметно "тормозить" и комфортная работа станет невозможной.
Снижение нагрузки на CPU можно выполнить только сознательно, т. е. уменьшить количество обработки в реальном времени, деактивировать наиболее "прожорливые" plug-ins.
Перегрузка дисковой подсистемы может быть устранена изменением размера и числа дисковых буферов (см. разд. "Настройка AUDIO" ранее в этой главе). Если это не помогает, то есть два выхода: заменить жесткий диск на более быстрый или отключить некоторые треки командой контекстного меню Disable Track (см. разд. "Контекстное меню треков" ранее в этой главе).
Один из способов экономии ресурсов CPU и дисковой подсистемы — это применение промежуточного сведения, т. е. сведения части проекта в файл подсмеси (Submix) или группу файлов с последующим освобождением ресурсов.
Определимся с разрешением звукового файла (файлов) подсмеси (Submix). Так как этот файл содержит в себе информацию нескольких треков и будет участвовать в дальнейшем сведении, то его разрешение должно быть максимальным — 32 Bit Float. А частота дискретизации — равной частоте дискретизации проекта.
В Nuendo сведение в файл выполняется с помощью команды File | Export | Audio Mixdown. Приглушенные и отключенные треки, а также приглушенные объекты с помощью инструмента Mute в сведении не участвуют. Иначе говоря, сведение в файл подчиняется правилу: "Как звучит проект при воспроизведении, так будет звучать и файл". Необходимым условием выполнения команды Audio Mixdown является ограничение рабочей области локаторами L и R. Сведение выполняется только в рабочей области.
Команда Audio Mixdown реализуется через диалоговое окно Export Audio Mixdown in (рис. 2.179). Рассмотрим его.
Пропустим очевидные элементы интерфейса и остановимся на главном.

  • Список Files of type (Тип файла) — выбор формата звукового файла. Для PC рабочим форматом является Wave File.
  • Список Coding позволяет выбрать метод сжатия Wave-файла (с потерей качества), если активны кодеки ACM (Audio Compression Manager). Для форматов высокого разрешения в списке доступно только РСМ/ uncompressed Waves.
  • Список Attributes (Атрибуты) относится к кодекам АСМ.
  • Список Channels (Каналы) позволяет осуществить выбор между обычным форматами Mono, Stereo Split и Stereo Interleaved. Выбор формата Stereo Split приведет к созданию двух монозвуковых файлов для левого и правого канала (на рис. 2.179 это Submix2L.wav и Submix2R.wav). Формат Stereo Split не рекомендуется использовать для промежуточного сведения, т. к. Nuendo автоматически не обрабатывает "расщепленные" стереофайлы как один объект.
  • Список Resolution определяет разрешение будущего файла от 8 Bit до 32 Bit Float.
  • Список Sample Rate определяет частоту дискретизации будущего фала от 8 кГц до 384 кГц.

Рис. 2.179. Окно Export Audio Mixdown in

Секция Include содержит два флажка: Automation и Effects. Снятие флажка Automation означает, что при сведении в файл данные автоматизации будут игнорироваться. Снятие флажка Effects приведет к тому, что при сведении в файл обработка Insert-, Send- и Master-эффектами производиться не будет.
Секция Import to также содержит два флажка: Pool и Audio Track. Эта секция как раз и используется для промежуточного сведения. Если отмечен только флажок Pool, то в окно Pool будет добавлен новый аудиоклип, ссылающийся на созданный файл.
Если отмечен еще и флажок Audio Track, то на новой аудиодорожке между локаторами будет создан объект Audio Event, имеющий внутреннюю ссылку на новый аудиоклип в окне Pool. Таким способом осуществляется реимпорт Submix-файла обратно в проект.
Процесс сведения в файл начнется после щелчка по кнопке Save.


Промежуточное сведение в Surround-проекте

Многоканальный Surround-проект еще более требователен к вычислительным ресурсам, чем обычный стерео. Особенно "прожорливы" многоканальные plug-ins, подключаемые как Master-эффекты. Поэтому мы рассмотрим многоканальное промежуточное сведение, актуальное для Surround-проектов.
В Nuendo Surround-проект можно экспортировать в звуковой файл специального многоканального формата Multi Channel Interlieved или в группу монозвуковых файлов Multi Channel Split, каждый из которых соответствует одному каналу Surround-формата.
Для реимпорта в Surround-проект нужно использовать формат Multi Channel Split.
Рассмотрим практический пример промежуточного сведения для проекта в формате 5.1 Surround. В окне Export Audio Mixdown in в списке Channels появится два новых пункта 6 Chan. Split и 6 Chan. Interleaved (рис. 2.180).

Рис. 2.180. Экспорт Surround-проекта

Выберем пункт 6 Chan. Split и нажмем кнопку Save. В результате будут созданы шесть монозвуковых файлов по числу каналов. Каждому звуковому файлу будет автоматически присвоен порядковый номер канала. Если отмечены флажки секции Import to, то в проекте будут созданы шесть моноаудиотреков с названиями звуковых файлов. Между локаторами разместятся шесть аудиообъектов.
Все шесть каналов будут назначены по умолчанию на шину BUS1. Переназначение каналов в соответствии с Surround-форматом нужно произвести вручную. Каждый канал следует назначить в соответствии с его номером непосредственно на мастер-шину (маршрутизация Channel Output) (рис. 2.181).

Рис. 2.181. Переназначение импортированных треков

Совет
Каналы импортированных треков лучше сразу сгруппировать (см. разд. "Группирование каналов" ранее в этой главе).


Модуль NuendoDither

В цифровом звуке между тихими и громкими сигналами существует неравноправие. Тихие сигналы недополучают нужное количество разрядов или кодируются с худшим разрешением, чем громкие. В результате сигналы с низким уровнем громкости подвергаются специфическим цифровым искажениям квантования. Борьба с этими искажениями ведется с помощью алгоритмов дизеринга и нойс-шейпинга.

Примечание
Подробные сведения по этой проблеме можно найти в специальной литературе или в нашей книге "'Живая' музыка на PC".

В комплект Nuendo входит два дизеринг-процессора plug-ins NuendoDither и UV22. Модуль UV22 выполняет специализированный алгоритм, предназначенный только для мастеринга AUDIO CD. В этом разделе мы остановимся на восьмиканальном модуле NuendoDither (рис. 2.182).

Рис. 2.182. Модуль NuendoDither

Модуль NuendoDither подключается всегда в седьмой или восьмой слот панели VST Master Effects, т. к. уровень громкости после этого алгоритма изменяться не должен. Интерфейс модуля традиционно для фирмы Steinberg лаконичен. Слайдер Dithering имеет три положения: Off, Type 1 и Туре 2. В положении Off низкоуровневый шум не добавляется. Шум в позиции слайдера Туре 2 лучше подчеркивает высокочастотные составляющие сигнала. Слайдер Noise-Shaping имеет четыре позиции от Off до Туре 3. Позиция Туре 3 соответствует самому "агрессивному" алгоритму нойс-шейпинга, когда спектр низкоуровневого шума максимально смещен в высокочастотную область.

Совет
Работу модуля в разных режимах можно оценить на слух, если установить переключатели Ditherbits в положение 8 (8 разрядов).

Секция Ditherbits содержит восемь переключателей, по одному на канал, для максимального числа каналов Surround-формата. Переключатели имеют значения 8, 16, 20 и 24. Установленное значение должно соответствовать разрядности экспортируемого звукового файла. Модуль NuendoDither должен использоваться при экспорте в файл более низкой разрядности, например, 32 Bit Float в 16 бит, а также в случае обработки эффектами панели VST Master Effects, особенно для Surround-проектов.


Временное промежуточное сведение

В мультирековых программах предыдущего поколения компьютерные музыканты были вынуждены создавать проекты-клоны для промежуточного сведения частей сложного проекта.
Возможности Nuendo позволяют обойтись без проектов-клонов. Функция Disable Track, описанная в разд. "Контекстное меню треков", отключает чтение данных с жесткого диска для данного трека, снижая тем самым лишнюю нагрузку на диск. Имея сложный проект с большим количеством треков достаточно лишь отключить резервные треки, не удаляя их содержимое.
В главе 1, в разд. "Временное промежуточное сведение" уделили достаточное внимание проблеме деградации цифрового сигнала после каждого этапа обработки. Практический вывод достаточно прост — нужно стремиться сводить проект в файл за один проход. Или, в идеале, в окончательном варианте проекта не должно быть файлов промежуточного сведения. В Nuendo эта задача решается с помощью функции Disable Track.
Группа треков сводится в файл (Submix). Submix-трек назначается непосредственно на мастер-шину. Все треки группы отключаются с помощью функции Disable Track. Все Insert-эффекты этих треков обходятся кнопкой Bypass. После этих манипуляций освобождаются ресурсы CPU и дисковой подсистемы. После микширования остальных треков проекта вместе с Submix-треком (или Submix-треками) нужно отключить Submix-треки с помощью функции Disable Track, а ранее отключенные дорожки включить (функция Enable Track) и снять режим Bypass. Процесс заканчивается финальным сведением в файл.
Конечно, метод временного промежуточного сведения способен одновременно обеспечивать комфортную работу и максимальное качество. Но его возможности также ограничены производительностью компьютера. Ведь на практике окончательное сведение в файл будет производиться с полной загрузкой CPU.

Примечание
Проект должен сводиться в файл без перегрузки CPU. Nuendo позволяет делать сведение в файл и при перегрузке процессора, но при этом могут возникнуть сбои.

Поэтому самыми эффективными средствами остаются деструктивное редактирование и upgrade на более производительное "железо".


Финальное сведение

С нашей точки зрения, пользователи Nuendo не ограничены разработчиками программы в творчестве. Работу над проектом можно производить на профессиональном уровне даже в домашних условиях. Пользователь Nuendo может уже не ограничиваться "MIDI-черновиком" композиции, предназначенной для переноса в студию. Проект (в особенности электронной музыки) может быть выполнен полностью в аудиоформате и только заключительная стадия финального сведения произведена в студии. Для этого проект экспортируется в формат OMF (меню Edit | Export | OMF) и переносится в студию с системой Digidesign Pro Tools.
Разделить творческий процесс работы со звуком в программе Nuendo на какие-то этапы можно только условно. В любой момент есть возможность "достроить" виртуальный микшер, изменить схему маршрутизации, перезаписать субтреки автоматизации или заменить очередной слой в истории редактирования. Поэтому остановимся на некоторых общих рекомендациях.
После условного этапа монтажа проекта следует продумать схему маршрутизации: количество групповых каналов, прямые и Send-маршруты, тип применяемой обработки. Решения принимаются исходя из звуковой концепции проекта и возможностей оборудования, в немалой степени выбор зависит и от производительности компьютера. Разумное сочетание деструктивной обработки с Insert- , Send- и Master-эффектами позволит эффективно использовать ресурсы машины.
Формат файла-мастера выбирается в соответствии с его дальнейшей судьбой. Если мастеринг предполагается осуществлять в Nuendo, то формат должен быть 32 Bit Float. Формат файлов для Surround-проектов определяется возможностями тех приложений, где их предполагается далее использовать.


Моделирование естественной реверберации

В программе Nuendo есть еще возможности, которые неочевидны на первый взгляд. Остановимся на них. Одна из проблем получения качественного софтверного сведения состоит в том, что алгоритмы программно реализованных ревербераторов либо намеренно упрощены, и тогда их ресурсоемкость мала, либо реализованы качественно, например, Waves RVerb, но тогда их ресурсоемкость велика. Упрощенные алгоритмы приводят к неестественной, синтетической реверберации, замутнению звуковой картины и плохой читаемости звуковых планов. Качественные алгоритмы "съедают" львиную долю ресурсов CPU.
Задачу можно решить традиционно применением дорогостоящих аппаратных устройств. Однако возможно и другое решение. К виртуальной студии, наверное, не следует относиться только как к модели аппаратной студии, где все процессы происходят в реальном времени. Если изменить правила и подойти к решению творчески, то откроются другие методы.
Рассмотрим простой практический пример моделирования естественной реверберации помещения в стереопроекте Nuendo. Создадим групповой канал и временно в качестве Insert-эффекта используем какой-нибудь программный ревербератор с отключенным прямым сигналом (Dry). Сформируем Send-маршруты на этот групповой канал с аудиотреков, сигнал которых предполагается послать на ревербератор. Настроим уровень посыла каждого трека. Затем выходы аудиотреков переназначим на другую активную шину Output Bus, а выход группового канала оставим на мастер-шине BUS 1. Приглушим те треки, сигнал которых не посылается на ревербератор. И деактивируем временный программный ревербератор группового канала. После этого выполним промежуточное сведение в файл 32 Bit Float. В результате на новой аудиодорожке появится объект, содержащий только суммарный необработанный сигнал группового канала, предназначенный для дальнейшей обработки алгоритмом реверберации.
Теперь к полученному объекту нужно применить (в режиме стерео) деструктивный процесс Acoustic Stamp (меню Audio | Process | Acoustic Stamp) с импульсом, выбранным исходя из размеров виртуального пространства. Слайдер Wet mix (см. рис. 2.173) должен быть в положении 100%. В дальнейшем полученный аудиотрек с сигналом реверберации просто подмешивается к остальным трекам. Этот сигнал можно подвергнуть дальнейшей обработке. Например, для управления шириной стереобазы в качестве Insert-эффекта аудиотрека реверберации можно использовать модуль Stereo Spread из комплекта Nuendo.
Подведем итоги. Во-первых, такая технология существенно экономит ресурсы CPU за счет исключения "тяжелых" алгоритмов программных ревербераторов, во-вторых, обеспечивает ясную и реалистичную звуковую картину, т. к. фейдер канала реверберации фактически изменяет уровень сигнала виртуального микрофона, расположенного в глубине смоделированного помещения.
Демонстрационные файлы импульсов хранятся в папке impulse в рабочем каталоге программы. Для получения максимального качества рекомендуется использовать профессиональные библиотеки импульсов.


Мастеринг с iZotope Ozone

Для мастеринга в Nuendo предусмотрен отдельный шаблон проекта 32Вit Float Stereo Mastering, содержащий схему маршрутизации с цепочкой plug-ins. Однако в мире plug-ins в последнее время появляются значительно лучшие решения. Наиболее удачной реализацией на наш взгляд является DirectX-plug-in Ozone фирмы iZotope. Inc. (http://www.izotope.com) (рис. 2.183). Этот модуль содержит в себе 64-битную виртуальную студию мастеринга. В Ozone используется точное моделирование аналоговых приборов. Кроме того, все виртуальные модули точно подогнаны друг к другу и соединены виртуальной 64-битной шиной, что исключает деградацию качества, характерную для цепочек отдельных plug-ins. Все это вместе создает теплый аналоговый звук с уровнем качества, ранее не достижимого для виртуальной обработки.
Цепочка plug-ins для мастеринга AUDIO CD в этом случае предельно проста: iZotope Ozone + UV22. Оба модуля подключаются в панель VST Master Effects после регулятора громкости Master Gain. Внутри модуля Ozone есть собственные регуляторы уровня, поэтому использовать фейдеры VST-микшера не нужно.

Рис. 2.183. Модуль iZotope Ozone

Оzone состоит из шести модулей, каждый из которых имеет собственное окно настроек. Последовательность подключения модулей при желании можно изменить (рис. 2.184).

Рис. 2.184. Внутреннее соединение модулей

Для этого нужно щелкнуть по кнопке Graph и изменить порядок подключения перетаскиванием модулей.
Переход между окнами осуществляется с помощью шести нижних кнопок с названиями модулей. Рядом с каждой кнопкой расположена еще одна кнопка-индикатор Active, с помощью которой можно быстро включить/выключить внутренний модуль. Детальное рассмотрение технологии мастеринга с помощью Ozone — отдельный разговор. Здесь будут кратко освещены функции внутренних модулей.
Модуль Paragraphic Equalizer совмещен с анализатором спектра. Благодаря этому появляется возможность точного визуального контроля за эквализацией. Комбинация <Alt> + щелчок на дисплее включает режим "аудио-лупы", в котором прослушивается только та частота, которая расположена под курсором мыши.
Функция Snapshots обеспечивает до четырех снимков спектра сигнала. Благодаря этому появляется возможность сравнить спектр собственной
фонограммы со спектром коммерческого AUDIO CD. Функция 6dB Guide высвечивает подсказку — наклон спектра, определяющий тональный баланс.
Модуль Mastering Reverb предназначен для создания дополнительного пространства и глубины. При этом сохраняется вся пространственная обработка, произведенная на стадии сведения. Для индивидуальной настройки модуля служит флажок Solo Reverb Signal. Модуль снабжен индикатором стереоимиджа Vectorscope.
Модуль Multiband Dynamics — это четырехполосный динамический процессор, совмещающий в себе компрессор, экспандер и лимитер в каждой частотной полосе (рис. 2.185).

Рис. 2.185. Окно модуля Multiband Dynamics

Верхняя часть окна является общей для всех многополосных модулей. Границы частотных полос можно изменять. Кнопка М приглушает частотную полосу, а кнопка В включает режим обхода частотной полосы для всех multiband-модулей.
Элементы управления динамического процессора каждой частотной полосы одинаковы. Выделение частотной полосы в верхней части окна автоматически открывает доступ к соответствующим элементам управления. На рис. 2.185 наглядно отображено, какая часть амплитудной характеристики процессора относится к лимитеру, компрессору и экспандеру. Кнопка Show обеспечивает доступ к настройкам времени срабатывания и восстановления лимитера, компрессора и экспандера отдельно в каждой частотной полосе.
Модуль Multiband Harmonic Exciter используется для спектрального обогащения сигнала. Проблема "засушенного" цифрового звука преодолевается добавлением гармоник в полосе Band 2. Регулирование в полосе Band 4 может существенно добавить яркости на высоких частотах.
Модуль Multiband Stereo Imaging осуществляет многополосную коррекцию стереоимиджа. Модуль имеет также дополнительную функцию многополосной задержки (Multiband Delay) левого или правого канала. С помощью независимого регулирования времени задержки в каждой частотной полосе (при снятом флажке Group all band delays) можно исправить стереоимидж совершенно на первый взгляд безнадежного микса.
Модуль Loudness Maximizer традиционно обеспечивает финальную обработку, делая микс громче за счет алгоритма пикового лимитирования. Модуль работает в двух режимах: Brickwall и Soft Limiting. В режиме Brickwall ограничение пиков начинается с уровня, заданного регулятором Threshold, при этом ни одна выборка не может превысить уровень, заданный регулятором Margin. В режиме Soft Limiting уровень, заданный регулятором Margin, не является абсолютным пределом. Это обеспечивает режим естественного "мягкого" ограничения (клиппирования). Степень клиппирования контролируется по индикатору выходного уровня. Нужно отметить, что оба алгоритма модуля Loudness Maximizer обеспечивают чистое и прозрачное звучание.
Выбор одного их них определяется стилем музыкального произведения и вкусом пользователя.
Индикатор выходного уровня работает в двух режимах: пиковом РРМ и среднеквадратичном RMS. Для переключения режимов нужно зайти в секцию Level Meters окна Options.
Экспорт файла-мастера должен происходить с параметрами 16 бит и 44 кГц, установленными в окне Export Audio Mixdown in.


Деструктивная обработка объектов с plug-in iZotope Ozone

Мы уже отмечали выше, что деструктивное редактирование обеспечивает теоретически неограниченное качество обработки звука на компьютере. Действительно, в этом случае производительность уже не играет столь большой роли. Определяющим становится качество алгоритма. Оптимизированные 64-битные алгоритмы модуля iZotope Ozone как раз и разработаны с целью достижения максимального качества, а не комфортной работы на медленных машинах. Поэтому имеет смысл побороться за качество не только на этапе мастеринга, но и на уровне обработки объектов во время сведения.
Внутренние модули iZotope Ozone можно использовать по отдельности и совместно в разных сочетаниях. Например, модуль Multiband Harmonic Exciter вдохнет настоящую жизнь в тускло звучащие треки с записью
акустических инструментов. Также можно поэкспериментировать с обработкой эксайтером файлов-импульсов для процесса Acoustic Stamp.
Сочетание Mastering Reverb + Multiband Dynamics + Multiband Harmonic Exciter произведет чудеса при обработке вокального трека. "Теплый", "ламповый" эквалайзер Paragraphic Equalizer, совмещенный с анализатором спектра, обеспечит точную и качественную эквализацию объектов.
Микс, сделанный в Nuendo по такой технологии, меньше всего напоминает о "цифре", тем более о плоском компьютерном звучании.
При Loop-конструировании иногда используется предварительная обработка сэмплов в программе T-RackS 24. Это делается для того, чтобы добиться яркого, сочного, "лампового" звучания итогового микса. Nuendo в сочетании с модулем iZotope Ozone избавляет от необходимости вообще использовать T-RackS 24, т. к. по нашему мнению возможности и качество алгоритмов iZotope Ozone значительно выше, и вся обработка ведется в одной мультитрековой программе. А это немаловажный фактор, потому что предварительная обработка сэмплов не должна вестись вслепую, нужно проверять их взаимную сочетаемость.


VST-инструменты

В начале главы мы уже говорили о том, что функции MIDI в Nuendo значительно упрощены по сравнению с Cubase VST, т. к. Nuendo предназначена для саунд-дизайна, сведения и мастеринга. Поэтому тем читателям, которые привыкли работать в Cubase VST, мы порекомендуем использовать Nuendo только для сведения проектов, саунд-дизайна и мастеринга. А для музыкального творчества использовать, конечно же, Cubase VST. Однако для простых MIDI-проектов возможностей Nuendo вполне достаточно.
Эта книга посвящена проблемам виртуальных звуковых технологий. Поэтому здесь нет ответов на вопросы, касающиеся редактирования и записи MIDI.

Совет
В связи с тем, что редактор MIDI Editor в Nuendo является ближайшим аналогом редактора Key Edit программ Cubase VST и Cubasis, рекомендуем музыкантам, которые интересуются этими вопросами, нашу книгу "Музыкальная азбука на PC". Она полностью посвящена именно музыкальным компьютерным технологиям.


Входы и выходы VST-инструмента

Параметрами VST-plug-ins версии VST 2.0 можно управлять по MIDI через виртуальный MIDI-порт. Один из вариантов таких VST-plug-ins — это модуль Steinberg Voice Machine.
Plug-in может включаться как Insert-эффект. А его управление осуществляется с MIDI-дорожки, которая назначена на виртуальный MIDI-порт.
В части подключения по MIDI VST-инструменты похожи на такие plug-ins. Но у них есть отличия, связанные с тем, что функционально они являются виртуальными синтезаторами. Поэтому их выходы непосредственно встраиваются в VST-микшер в виде канальных ячеек Channel strip.
Обобщая, можно сказать, что VST-инструмент — это виртуальное устройство, имеющее MIDI-вход и аудиовыход VST.
Идея создания VST-инструментов состоит в том, чтобы заменить аппаратные MIDI-устройства их виртуальными аналогами. Данная технология непрерывно развивается. О существенном прогрессе свидетельствует появление такого профессионального VST-инструмента, как 32-битный сэмплер HALion фирмы Steinberg.
Технология VST позволяет обойти многие проблемы, которые вызваны, как правило, особенностями звуковых карт, а также низким качеством встроенных синтезаторов и АЦП. Благодаря технологии VST MIDI-проект можно выполнить полностью виртуально и затем без потерь перевести его в AUDIO. Главным условием полноценного применения этой технологии является использование звуковой карты, поддержанной специализированными драйверами ASIO. Малое время задержки (latency) имеет определяющее значение для исполнения на VST-инструменте с MIDI-клавиатуры в реальном времени.
Выходной сигнал VST-инструмента может обрабатываться в реальном времени с помощью plug-ins. Для этого специально под задачу формируется схема маршрутизации VST-микшера. Для деструктивной обработки MIDI-треки переводятся в AUDIO с помощью функции экспорта (меню File | Export | Audio Mixdown).

Примечание
Если процесс экспорта производится в файл с высоким разрешением, то потери качества не происходит, т. к. перевод MIDI в AUDIO происходит виртуально.

В результате в VST-системе вместе сводятся MIDI-треки с VST-инструментами и аудиотреки. И, таким образом, для VST-инструментов становятся действительны все вышеприведенные сведения о маршрутизации, автоматизации и обработке звука.
VST-инструменты инсталлируются так же, как и VST-plug-ins, в общую папку Shared VST Plug-ins Folder или папку vstplugins в рабочем каталоге Nuendo.
Рассмотрим пример подключения VST-инструмента HALion.
В Nuendo (версии 1.5 и выше) для подключения VST-инструментов существует специальная панель VST Instruments (рис. 2.186). Доступ к ней можно посредством меню Devices или клавиши <F11>.

Рис. 2.186. Панель VST Instruments

VST-инструменты подключаются в слоты так же, как и VST-plug-ins. Кнопка Edit вызывает окно настроек виртуального синтезатора.
После загрузки VST-инструмента добавляется виртуальный MIDI-порт и появляются дополнительные ячейки Channel strip (их количество зависит от конструкции синтезатора).

Рис. 2.187. Входы и выходы сэмплера HALion

На рис. 2.187 показан пример конфигурации для сэмплера HALion: виртуальный MIDI-порт halion, а также четыре стереовыхода Hal 1 — Hal 7 и четыре моновыхода Hal 9 — Hal 12.
По своему устройству канальные ячейки VST-инструментов похожи на ячейки аудиоканалов. Только у них нет VST-входов, зато присутствует кнопка Edit, которая нужна для вызова окна настройки виртуального синтезатора.
В окне Nuendo Project каналы VST-микшера виртуальных синтезаторов представлены только как субтреки автоматизации. При включении режимов Write или Read Automation канальной ячейки в окне Nuendo Project автоматически добавляется субтрек. Активизация глобальных режимов Write или Read ALL добавляет на мультитрек все субтреки автоматизации каналов VST-инструментов.

Предупреждение
Автоматизацию каналов VST-инструментов не следует путать с автоматизацией самих виртуальных синтезаторов. Напомним, что эти данные записываются в специальный трек VST Effects, добавляемый командой контекстного меню Add Plug-in Automation Track.

Рис. 2.188. Маршрутизация программ сэмплера HALion

На рис. 2.188 показан пример внутренней маршрутизации программ сэмплера HALion. Здесь осуществляется управление по восьми MIDI-каналам звуками (программами, тембрами) сэмплера. Каждая программа использует свой отдельный выход. Такое решение позволяет эффективнее использовать возможности VST-микшера Nuendo.


Nuendo и Reason: совместное использование

Итак, программа Nuendo в состоянии заменить виртуальными аналогами практически все необходимые аппаратные приборы. Все они были рассмотрены выше: виртуальный микшер, виртуальные модули обработки и VST-инструменты. Но есть еще один способ многократно приумножить и без того немалые возможности программы Nuendo. Для этого нужно соединить ее с другой виртуальной студией.
Идея одновременного использования нескольких музыкально-звуковых приложений на одном компьютере довольно заманчива. Но далеко не всегда удается ее эффективно реализовать — достичь их устойчивой совместной работы. Для соединения между собой разных приложений приходится использовать всевозможные виртуальные MIDI- и AUDIO-кабели. Возникают проблемы синхронизации, сбои и т. д.
В Nuendo эта проблема решается следующим образом. Здесь встроена поддержка специального протокола ReWire, совместно разработанного фирмами Propellerhead Software и Steinberg. Протокол ReWire надежно связывает между собой два приложения, одно из которых становится ведущим (Master), а другое ведомым (Slave). Нетрудно догадаться, что "начальником" является Nuendo.
Рассмотрим ситуацию, когда Master-приложением становится Nuendo, а в качестве Slave-приложения выступает программа Reason 1.0 фирмы Propellerhead Software.
Протокол ReWire обеспечивает:

  • 64 аудиоканала между Master- и Slave-приложениями;

Примечание
Следующая версия протокола — ReWire2 обеспечивает 256 аудиоканалов и двунаправленную передачу MIDI-сообщений. Максимальное количество MIDI-каналов до 4080, что соответствует 255 устройствам с 16-ю MIDI-каналами.

  • точную аудиосинхронизацию между двумя программами; связывание транспортных панелей и локаторов;
  • сниженное потребление ресурсов (по сравнению с обычным использованием двух программ без протокола Re Wire).

В случае совместного использования Nuendo и Reason 1.0 Nuendo может использоваться как MIDI-секвенсор, управляющий по ReWire виртуальными инструментами Reason.


Порядок запуска приложений и маршрутизация

Запуск приложений в нужном порядке — одно из необходимых условий правильного функционирования виртуальной системы.
Запускаемым приложением номер 1 должна быть программа Nuendo. После старта нужно создать проект и зайти в меню Devices. Если программа Reason установлена на компьютер, то в меню Devices появится новый пункт Reason, который и нужно выбрать. В появившемся окне Reason мы увидим каналы шины ReWire (рис. 2.189).

Рис. 2.189. Окно Reason

Следующим шагом должна стать активизация хотя бы одного канала с помощью кнопки столбца Active. Для начала достаточно включить только стереопару Mix L и Mix R. После этого шага можно запускать Reason. Выключение производится в обратном порядке: сначала закрывается Reason, и только после этого Nuendo.
Совместный проект Nuendo+Reason теперь сохраняется в двух файлах: npr и ms.
В дальнейшем не нужно беспокоиться об активизации каналов ReWire и внутренней конфигурации Reason при открывании ранее сохраненных проектов. Все настройки сохранены в файлах npr и ms. Поэтому после загрузки в Nuendo проекта, содержащего связи с Reason, нужно запустить Reason, загрузить в него вторую часть совместного проекта, и все маршруты восстановятся.
На рис. 2.190 показан пример возможной маршрутизации Nuendo+Reason.
От программы Reason изображена задняя панель устройства маршрутизации Hardware Interface, куда подключено двенадцать виртуальных аудиокабелей. Гнезда задней панели Hardware Interface через шину ReWire соединяются непосредственно с входами канальных ячеек Channel strip VST-микшера.
Несмотря на то, что доступны все 64 канала, в данном примере в окне Reason активизировано только девять ReWire-каналов. Поэтому сигнал устройств, подключенных в Reason к каналам 10, 11, 12, не достигнет Nuendo (такое подключение сделано исключительно для иллюстрации). Количество канальных ячеек Channel strip VST-микшера в точности равно числу активных каналов ReWire. Включение/выключение каждого ReWire-канала в окне Reason (см. рис. 2.189) автоматически добавляет/удаляет канальную ячейку ReWire (рис. 2.190) VST-микшера.
Внутреннее устройство ReWire-ячеек Channel strip не отличается от ячеек аудио- и групповых каналов. Субтреки автоматизации для ReWire-ячеек создаются автоматически при активизации режимов Write/Read Automation так же, как и для VST-инструментов.
При создании устройства в программе Reason, например, Redrum Drum Computer, в список Output MIDI-трека Nuendo добавится виртуальный MlDI-порт, скажем, Reason Redrum 1.
ReWire-каналы конвертируются в аудиотреки так же, как и каналы VST-инструментов — либо с помощью экспорта в файл, либо непосредственно сводятся вместе с аудиотреками в финальный микс.
Nuendo как Master-приложение задает темп воспроизведения проекта для Slave-приложения. Например, можно нарисовать кривую изменения темпа на специальной дорожке, которая называется Tempo Track (рис. 2.191), или изменить музыкальный размер.

Рис. 2.190. Пример маршрутизации Nuendo+Reason

Примечание
Редактор Tempo Track Editor вызывается командой Tempo Track в меню Project (комбинация клавиш <Ctrl>+<T>). Для изменения музыкального размера нужно щелкнуть инструментом Draw в области Time Signature area (на рис. 2.191 отмечена стрелкой) в выбранной позиции, а затем изменить размер в поле Signature.

Рис. 2.191. Окно Tempo Track

Кнопка Master на транспортной панели или в редакторе Tempo Track Editor должна быть нажата. Но если при этом изменить темп в программе Reason, то кнопка Master в Nuendo будет автоматически деактивирована.


Nuendo и Cubase VST: совместное использование

В начале этой главы мы уже говорили, что каждая программа имеет свою специализацию. Создавать музыкальную композицию лучше всего в Cubase VST, а саунд-дизайн, сведение и мастеринг — это уже область применения Nuendo. Эффективное и специализированное использование обеих программ — основа для получения максимального результата. В этом разделе мы рассмотрим стратегию создания проекта в обеих программах, но на одном компьютере.
Сама технология импорта очень проста. Сонг Cubase VST (версии 3.x и выше) импортируется в проект Nuendo командой Cubase Song в меню File | Import. При этом нужно открыть файл сонга Cubase VST с расширением all. Далее следует обычный диалог создания проекта Nuendo.
При импорте, что совершенно естественно, возникают потери. Поэтому процесс создания проекта в двух программах можно условно разделить на три составляющие.

  1. 1. Создание MIDI-проекта в Cubase VST и его импорт в Nuendo.
  2. 2. Создание AUDIO-проекта в Cubase VST и его импорт в Nuendo.
  3. 3. Комбинированный вариант.

Импорт MIDI-проекта в Nuendo происходит с ограничениями. Игнорируются параметры панели Inspector, некорректно импортируется Drum Track и т. д. Поэтому этот вариант лучше всего применять для простых MIDI-проектов, а в программе Cubase VST предварительно зафиксировать параметры панели Inspector для выделенных частей MIDI Part командой Freeze Play Parameters в меню Functions.
Импорт AUDIO-проекта также происходит с ограничениями. Игнорируется автоматизация, некоторые Insert-эффекты.

Примечание
Все приведенные примеры относятся к импорту сонга Cubase VST 5.1 R1 в проект Nuendo 1.52.

При этом сохраняется Send-маршрутизация с настройками VST Send-эффектов, позиции фейдеров VST-микшера, состояние кнопок Solo и Mute, настройки канальных эквалайзеров.
Исходя из этих особенностей, можно предложить следующую последовательность действий.
В Cubase VST создается MIDI-проект и производится запись аудиотреков. Затем MIDI-дорожки потреково перезаписываются на аудиодорожки, если используются аппаратные MIDI-устройства. VST-инструменты конвертируются в аудиоформат с высоким разрешением через меню File | Export | Audio Tracks.

Совет
Экспорт VST-инструментов удобно совместить с обработкой подключенным в качестве Master-эффекта DirectX-plug-in iZotope Ozone, например, его многополосным эксайтером и модулем Loudness Maximizer.

Если используется автоматизированная обработка эффектами панели VST Send Effects, то выходы этих модулей лучше всего экспортировать в отдельный аудиотрек в формате 32 Bit Float (в Cubase VST/32). Для этого выходы эффектов должны быть назначены на шину Master, а выходы аудиотреков временно переназначены на любую активную шину, например, BUS2.

Совет
В проекте Cubase VST нужно стремиться к максимально "сухому" (необработанному) звучанию. В особенности спедует избегать применения программных эффектов реверберации. В идеале достаточно только конвертировать MIDI в AUDIO.

В итоге подготовленный для импорта в Nuendo сонг Cubase VST должен содержать только аудиотреки, и желательно, чтобы в структуре VST-микшера не было подключенных plug-ins. Вся остальная часть работы над проектом производится уже в Nuendo с помощью приемов и средств, описанных в этой главе.
Если большая часть работы над проектом находится в области AUDIO, то в Cubase VST создается только MIDI-проект, а процесс записи аудиотреков переносится в Nuendo.
Приведенная схема, конечно же, условна. Распределение задач между обеими программами определяется многими факторами: стилем музыкального произведения, индивидуальными технологическими приемами пользователя и возможностями оборудования.


Глава 3. Маршрутизация в Samplitude Producer

  • Маршрутизация в Samplitude Producer
    Уровень треков
    • Треки AUXBus и Submix Bus
      Маршрутизация в окне Track Info
      Маршрутизация DirectX plug-ins
      • Автоматизация AUX Send/Retur
    Уровень объектов
    • Редактор объектов
      • Маршрутизация эффектов виртуального объекта
        Маршрутизация объектов
    Samplitude Mixer
    • Маршрутизация эффектов мастер-секции
      Общие настройки Samplitude Mixer
  • Внутренняя разрешающая способность Samplitude Producer


Маршрутизация в Samplitude Producer 2496

Усложнение виртуального микшера — это тенденция, которая четко прослеживается в новом поколении программ многодорожечной записи на жесткий диск. Подобная закономерность не случайна. Ведь виртуализация студий — это ни что иное, как перенесение ручек и фейдеров на экран монитора — т. е. полноценная эмуляция аппаратного микшерного пульта.
В программе Samplitude Producer 2496 (шестая версия популярной программы Samplitude 2496, www.magix.com) тоже произошли изменения в соответствии с требованиями времени. Это проявилось в появлении нового уровня виртуализации — маршрутизации объектов и усовершенствовании виртуального микшера Samplitude Mixer.
В результате создана новая виртуальная среда для смешивания в реальном времени. Разработчики Samplitude Producer 2496 (для сокращения в дальнейшем будем называть ее Samplitude Producer) считают, что их пользователь не нуждается в многоканальной звуковой карте, т. к. дополнительные AUX- и Submix-шины реализованы в структуре виртуального микшера. Поэтому достаточно только контролировать стереопару на выходе мастер-секции.
Пятая версия программы Samplitutde 2496 была подробно рассмотрена в нашей книге '"Живая' музыка на PC". Здесь будет рассказано только об основных отличиях шестой версии этой программы:

  • о маршрутизации на двух уровнях (треков и объектов);
  • о виртуальном микшере (Samplitude Mixer);
  • о редакторе объектов.


Треки AUXBus и Submix Bus

AUX Bus и Submix Bus — это два новых типа треков, которые появились в шестой версии программы.
Проводя сравнение с другими программами, рассмотренными в данной книге, можно сказать, что трек AUX Bus — это аналог Return-трека SAWStudio, а трек Submix Bus — аналог Output-трека SAWStudio. По своим функциям AUX Bus и Submix Bus могут быть представлены и как аналоги Group-трека Nuendo.

Примечание
Напомним, что Group-трек Nuendo может использоваться и как Submix-шина, и как дополнительная AUX-шина.

Иначе говоря, треки AUX Bus и Submix Bus — это такие же универсальные строительные элементы виртуального микшера, как и Group-треки Nuendo.
В программе Samplitude Producer можно преобразовать обычный трек виртуального VIP-проекта в AUX Bus и/или Submix Bus. Делается это с помощью контекстного меню трека Track Menu. В субменю Track Properties нужно отметить пункт Submix Bus и/или AUX Bus (рис. 3.1).

Рис. З.1. Изменение типа трека

Создать треки AUX Bus или Submix Bus можно через пункты New Submix Bus и New AUX Bus меню Track | Insert new Tracks.
Новый трек создается на мультитреке всегда ниже выделенного трека. Выделяется трек щелчком мыши и обозначается параллельными горизонтальными желтыми линиями.

Предупреждение
Самый верхний трек проекта не может быть преобразован в Submix- и AUX-трек.

Единственное отличие дорожек AUX Bus и Submix Bus от обычных треков Samplitude — это дополнительные функции маршрутизации и маркировка голубым цветом. Например, на них так же, как и на обычных треках, могут быть расположены виртуальные объекты.
Маршрутизация в Samplitude Producer подчиняется "правилам субординации" аналогично маршрутизации в Nuendo:

  • Send-маршруты (посыл) могут быть сформированы на AUX-трек только с дорожек с меньшим номером;
  • для дорожек с большим номером, чем у существующих AUX-треков, нужно создавать новые AUX-треки, расположенные ниже на мультитреке;
  • прямые маршруты с дорожек могут быть созданы только на Submix-треки с большим номером;
  • Submix-треки могут назначаться друг на друга по старшинству: от меньшего номера к большему.


Маршрутизация в окне Track Info

Окно Track Info содержит все основные параметры настройки трека. Вызвать его для выделенного трека можно командой Track | Track Information или щелчком мыши на кнопке Track Properties [image] расположенной на треке. Назначение выхода трека на Submix-трек осуществляется в поле Output.
На рис. 3.2 показано, что VIP-проект содержит три Submix-трека. Поэтому в списке маршрутов три дополнительных пункта (помимо физического устройства SB Audigy Audio [C400]).
Переназначение выходов можно выполнять без остановки воспроизведения — т. е. в "горячем" режиме.
Список выходов и устройств записи будет расширен, если используется многоканальное оборудование, например, аудиоинтерфейс М Audio Delta R-BUS (рис. 3.3).

Рис. 3.2. Окно Track Info

Рис. 3.3. Список устройств многоканального оборудования

Кнопка Effects/Routing обеспечивает доступ к специальному окну маршрутизации эффектов — Effect Routing — Mixer Track, в котором доступны все настройки маршрутизации трека (рис. 3.4).

Рис. З.4. Окно маршрутизации эффектов Effect Routing — Mixer Track

Примечание
Быстрый вызов окна Effect Routing — Mixer Track осуществляется через пункт Track Routing Dialog контекстного меню трека.

В списке Effects перечисляются модули обработки, через которые последовательно (сверху вниз) проходит сигнал трека.
К этим модулям относятся не только традиционный эффекты (типа Dynamics), но и регулятор уровня Gain, регуляторы панорамы Pan и громкости Volume, а также виртуальные устройства send-маршрутизации AUX Send (Pre) (AUX Send (Post).

Тот модуль, который в настоящее время активен, отмечен флажком. Для изменения статуса модуля нужно выделить его в списке, а затем нажать кнопку On/Off или щелкнуть в поле флажка.
Если требуется вызвать окно настроек, нужно выделить модуль в списке, после чего щелкнуть по нему правой кнопкой мыши или нажать кнопку Edit.
Четыре устройства не могут быть дeактивированы, т. к. они являются обязательными элементами виртуального микшера. Это Gain, Pan, Volume и AUX Send (Pre/Post).
Изменить порядок расположения модулей можно кнопками [image] секции Effect Order. Для этого нужно выделить модуль в списке и сместить его одной из этих кнопок вверх или вниз. Каждый щелчок смещает модуль на один уровень.

Примечание
Изменять порядок расположения модулей можно в "горячем" режиме, не останавливая воспроизведение.

Удобным сервисом является то, что настройки окна Effect Routing — Mixer Track могут быть сохранены как пресеты. Они также могут быть скопированы через буфер обмена с помощью стандартных кнопок [image] (Сору) и [image] (Paste).
Копируются настройки раздельно — по секциям:

  • порядок модулей — в секции Effect Order;
  • настройки модулей — в секции Effect Settings.

Если требуется распространить установки на все треки, то следует воспользоваться набором из четырех кнопок All Tracks, каждая из которых отвечает за отдельную область параметров настройки.
В окне Effect Routing — Mixer Track можно сформировать схему прямой и send-маршрутизации трека.
Для прямых маршрутов предназначено поле Output. Оно дублирует такое же поле в окне Track Info.

Примечание
Прямой маршрут — назначение выхода трека на физическую или виртуальную шину.

Для организации маршрутов на AUX-треки (посыл) нужно выделить пункт AUX Send (Рге) или AUX Send (Post), а затем нажать кнопку Edit. При этом появится окно AUX Routing — Mixer Track (рис. 3.5). В нем в прямоугольных секциях отображены элементы управления send-маршрутизацией на дополнительные AUX-шины.

Рис. З.5. Окно AUX Routing — Mixer Track

  • Кнопка New AUX Bus предназначена для создания новых AUX-шин (AUX-треков). Количество AUX-шин в Samplitude Producer ограничено числом 999 (то есть практически безгранично).
  • Кнопка Reset AUX Sends сбрасывает настройки AUX-шин в состояние по умолчанию.
  • Кнопки [image] и [image] (scroll through the Auxes) предназначены для прокрутки окна AUX Routing — Mixer Track (в связи с тем, что его вместимость — только восемь AUX-шин).
  • Каждая секция содержит регулятор уровня посыла [image] (AUX send value). Для изменения уровня нужно щелкнуть мышью в пределах прямоугольной рамки регулятора и протащить курсор вправо или влево. Значение уровня посыла отображается в соседнем числовом поле, в которое можно вводить точное значение с клавиатуры. Если значение off, то AUX-шина неактивна.
  • Флажок Рге (Pre Fader) выполняет традиционную функцию переключателя pre/post fader. Если флажок установлен, значит сигнал посылается на AUX-шину с модуля AUX Send (Рге).
    Это устройство представлено в окне Effect Routing — Mixer Track одноименным пунктом в списке Effects. В зависимости от местоположения модуля AUX Send (Рге) в структуре эффектов канала (в списке Effects) посылаемый сигнал будет различным.
    Пассивное состояние флажка Рге переключает AUX-шину на модуль AUX Send (Post).

Примечание
К маршрутизации, формируемой с помощью флажка Рге, нельзя подходить формально, т. е. как к схемам Pre/Post Fader. Состояние флажка Рге должно связываться именно с модулями AUX Send (Рге) и AUX Send (Post), т. к. возможности Samplitude Producer позволяют поместить оба модуля, например, после фейдера (модуля Volume).

  • Активное состояние флажка visible означает, что в окне Samplitude Mixer будет отображено название данной AUX-шины (например, AUX 9).
    Максимальное количество "видимых" AUX-шин — четыре. Но использоваться их может гораздо больше. Флажки visible — это зависимые переключатели. Они выбирают те шины, которые будут отображены в окне виртуального микшера.
  • В секции Info отображается статистика проекта:
    • в строке Project — общее количество AUX-шин;
    • в строке Track — количество активных AUX-шин и количество посылов с активным флажком Рге.

Напомним, что организация маршрутов на AUX-шины строго подчиняется "правилу субординации": номер AUX-трека всегда должен превышать номер того трека, с которого организуется посыл.
Но недоступная AUX-шина отображается иначе, чем остальные в окне AUX Routing — у нее заблокировано числовое поле и флажки. Как же ее использовать?

Примечание
Конечно, есть обходной путь— создать еще одну AUX-шину кнопкой New AUX Bus, но при этом теряется сам смысл AUX-шины. Ведь дополнительная шина предназначена в основном для того, чтобы одну группу эффектов звуковой обработки сделать общей для разных треков.

Выход есть: если AUX-шина недоступна, нужно просто повысить ее номер — в окне VIP-проекта перетащить AUX-трек ниже того трека, с которого организуется посыл. Для перетаскивания трека нужно нажать клавишу <Shift> и нажать на кнопку Track Properties; как только курсор мыши изменится на [image], можно перемещать трек.

Примечание
Если перемещение треков вызывает разрушение сложившейся схемы маршрутизации, программа выдаст предупреждающее диалоговое окно с возможностью отмены.

Рис. 3.6. Перетаскивание треков


Маршрутизация DirectX plug-ins

Подключение DirectX-plug-ins в разрыв виртуального канала осуществляется одинаково для всех типов треков. В контекстном меню треков выбирается пункт DirectX Plug-Ins Track, вызывающий одноименное окно (рис. 3.7).

Рис. З.7. Окно DirectX Plug-Ins Track

Список проинсталлированных DirectX Plug-ins находится справа и называется Installed DirectX Plug-Ins.

Совет
Для быстрого поиска подключаемого модуля нужно щелкнуть по любому из них в списке и затем нажать на клавиатуре первую букву его названия. Например, периодическое нажатие на букву W позволит пролистать все plug-ins фирмы Waves.

Список активных plug-ins расположен слева и называется, соответственно, Active Plug-ins. Выделенный в правом списке plug-in переносится в активный список двойным щелчком на названии модуля или щелчком по кнопке с подсказывающей пиктограммой [image].

Совет
Флажок Force Mono Processing следует активизировать для одноканальных plug-ins, таких, например, как Antares Microphone Modeler. Нельзя одновременно использовать стерео и моно plug-ins, т. к. большинство стерео plug-ins несовместимы с режимом Force Mono Processing.

Интерфейс окна DirectX Plug-Ins Track в описываемой программе Samplitude 2496 существенно изменен с предыдущей (пятой) версии.

  • Во-первых, теперь появилась возможность изменять порядок подключения модулей кнопками [image] (Up, Down).
  • Во-вторых, модули могут быть подключены до и после фейдера (pre/post fader). На это указывают разделители списка Рге и Post.

Примечание
В примере на рис. 3.7 plug-in Ultrafunk fx: Reverb подключен до фейдера, т. к. он расположен в списке выше разделителя Post.

В виртуальном мире Samplitude Producer подключение до или после фейдера (модуля Volume в окне Effect Routing — Mixer Track — это всего лишь условность.
Проиллюстрируем это на знакомом уже окне маршрутизации эффектов Effect Routing — Mixer Track (см. рис. 3.4).
Размещение DirectX-модуля в списке Active Plug-Ins выше или ниже разделителя Post означает его подключение в разрыв канального модуля DirectX Plugin (Pre) (или, соответственно, модуля DirectX Plugin (Post) в окне маршрутизации эффектов). Или, иначе говоря, цепочки DirectX-plug-ins находятся внутри более крупных виртуальных устройств: модулей DirectX Plugin (Рге) и DirectX Plugin (Post).
Такое решение — основа новых огромных творческих возможностей обработки звука, которые были недостижимы в более ранних версиях Samplitude 2496.

Рис. З.8. Пример подключения DirectX-plug-ins

В примере на рис. 3.8 два DirectX-модуля подключены как Рге- и Post-эффекты. Их фактическое расположение в виртуальной структуре канала определяется позицией модулей DirectX Plugin (Рге) и DirectX Plugin (Post). Только лишь изменяя их положение относительно собственных эффектов программы Samplitude Producer, уже можно получить немало вариантов обработки.
А если к этому добавить AUX Send-маршрутизацию, то схема обработки звука может получиться еще более сложной и многовариантной, что часто и требуется для получения, например, специальных звуковых эффектов в реальном времени. Ведь AUX-треки по сути дела представляют собой обычные треки с той же внутренней виртуальной структурой.
Если учесть, что максимальное количество AUX-шин — 999, то получается, что теоретически виртуальная среда Samplitude Producer позволяет производить обработку звука с любой сложностью.


Автоматизация AUX Send/Return

Если сравнить реализацию виртуального микшера в трех программах — SAWStudio, Nuendo и Samplitude Producer, — то можно заметить, что в первых двух она выполнена более логично, в отличие от Samplitude Producer.
В последней есть ограничения автоматизации, вызванные отсутствием автоматизированных регуляторов уровня посыла AUX Send. В результате чего пользователь вынужден самостоятельно конструировать избыточную (с точки зрения авторов) схему маршрутизации.

Примечание
Под избыточностью здесь подразумевается то, что AUX-треки в Samplitude Producer используются для автоматизации уровня посыла AUX Send, а функцию AUX-трека выполняет дорожка Submix Bus.

Но т. к. без маршрутизации не обойтись, то, следуя совету из документации к программе, можно творчески применять автоматизируемые регуляторы громкости и панорамы AUX-трека.
Сделать это просто. Допустим, нам необходимо автоматизировать уровень посыла AUX Send на цепочку plug-ins с двух обычных аудиотреков. Для этого нужно для каждого из аудио-треков создать отдельный AUX-трек. Затем эти AUX-треки назначить на дорожку Submix Bus, где в разрыв должна быть подключена эта цепочка plug-ins. Тогда автоматизируемые регуляторы Volume AUX-треков начнут выполнять функцию регуляторов уровня посыла AUX Send, а регулятор Volume Submix-трека — функцию регулятора уровня возврата Return (рис. 3.9).
Несомненно, столь оригинальное решение позволяет выйти из положения. Но у него есть существенный недостаток. Значительно удобнее управлять всеми параметрами канала, включая посыл AUX Send, из одной канальной ячейки Channel strip, как происходит в программах Nuendo и SAWStudio.
Предложенное решение приведет к регулировке автоматизированного уровня посыла на каждый эффект отдельными фейдерами соседних канальных ячеек Channel strip. Иными словами, управление параметрами одного канала вынужденно делится на несколько канальных ячеек.
Но здесь полезно вспомнить о понятии виртуальный объект, который является основной отличительной чертой программы Samplitude Producer от конкурирующих программных продуктов.
Виртуальный объект — это набор команд или алгоритм виртуального редактирования в реальном времени. Поэтому он содержит ссылку (регион) на физический звуковой файл и другие свойства, относящиеся к звуковой обработке в реальном времени.
С другой стороны, данный объект — это универсальный строительный материал, "кирпичик" для построения музыкально-звуковой композиции.
Можно по-разному относиться к идее "объектно-ориентированного" подхода к созданию музыки. Но нельзя не согласиться, что он — некий модный эталон сплава современного музыкального мышления и компьютерных звуковых технологий.

Рис. З.9. Пример маршрутизации

Примечание
Виртуальный объект в Samplitude Producer намного сложнее, чем его аналоги в SAWStudio и Nuendo. Поэтому для изменения его свойств создан отдельный редактор объектов.
Термин "объект", предложенный разработчиками Samplitude Producer, кажется нам наиболее удачным. Поэтому мы распространили его на все программы, рассматриваемые в данной книге.

Программа Samplitude Producer — это наиболее полная реализация объектно-ориентированного" подхода к обработке звука. Этот подход позволяет в большинстве случаев обойтись вообще без автоматизации, т. к. каждый виртуальный объект может быть разделен на необходимое количество частей-объектов, каждая из которых, в свою очередь, может иметь свой индивидуальный набор свойств — параметров обработки.
В предыдущих версиях Samplitude Producer у объектов было схожее устройство. Но в Samplitude Producer разработчики пошли по пути дальнейшего их усложнения.
В результате этого появилась маршрутизация объектов (подробнее см. в разд. "Маршрутизация объектов"). Она позволяет непосредственно с объектов организовывать send-маршруты. Такое решение не имеет аналогов и поэтому требует от пользователя несколько иного мышления, чем при работе с традиционным микшером.
В Samplitude Producer формирование схемы маршрутизации тесно связывается с недеструктивным редактированием (то есть разрезанием объектов и переназначением маршрутов каждой части). Это во много раз повышает гибкость системы, т. к. пользователь не привязан к маршрутизации на уровне треков и способен сформировать маршруты AUX Send для любой точки аудиоматериала.


Редактор объектов

Сегодня для того, чтобы современный компьютерный музыкант мог реализовать все свои звуковые фантазии, конструкции традиционного микшерного пульта может оказаться недостаточно. Уже не спасают эффекты, подключаемые в разрыв канала и дополнительные AUX- и Submix-шины.
И это не прихоть избалованных пользователей, а веление времени. Ведь современная музыка (особенно в области саунд-дизайна) развивается так же стремительно, как и область информационных технологий. И компьютерные музыканты вправе рассчитывать на виртуальную креативную среду высокого качества, которая никоим образом не ограничивает их фантазию.
Идеал здесь можно сформулировать так: пользователь должен иметь возможность доступа ко всем виртуальным ресурсам звуковой обработки в любой точке аудиоматериала. При этом все процессы должны происходить в реальном времени.
Концепция виртуального объекта в программе Samplitude Producer отвечает этому современному требованию. Объект здесь имеет в качестве свойств подключаемые модули звуковой обработки. Он, в некотором роде, является самостоятельным виртуальным каналом микшера: к нему подключены в разрыв plug-ins, у объекта есть эквалайзер, регуляторы громкости и панорамы и т. д.
В программе Samplitude Producer виртуальные ресурсы звуковой обработки могут быть легко сконцентрированы в любой точке аудиоматериала. Это делается путем простого разрезания объектов, а затем изменения свойств каждой части.
Подобный подход к виртуальному объекту имеет преимущества и с точки зрения эффективности использования ресурсов CPU.
Ведь каждый объект представляет собой отложенную задачу, которая решается только тогда, когда на территории объекта находится курсор мультитрека. Следовательно, в другое время вычислительные ресурсы расходуются на другие объекты.
Усложнение виртуального объекта неизбежно повлекло за собой усложнение интерфейса его редактора.
Получить доступ ко всем виртуальным свойствам объекта пользователь может через редактор Object Editor. Он вызывается несколькими способами:

  • с помощью контекстного меню через пункт Object Editor;
  • в режиме редактирования Universal Mode двойным щелчком в нижней половине объекта относительно горизонтальной линии, разделяющей дорожку пополам;
  • кнопкой [image] (Object Editor) на панели Buttonbar (для выделенного объекта).

Интерфейс редактора объектов претерпел существенную модернизацию по сравнению с предыдущими версиями программы.
Во-первых, его окно может отображаться в трех режимах: от компактного до максимального.
Во-вторых, появилась возможность одновременной работы в окне VIP-проекта и Object Editor. Поэтому теперь не нужно закрывать окно редактора объектов для того, чтобы произвести действия в окне VIP-проекта.
Например, достаточно выделить в окне VIP-проекта другой объект, и редактор объектов автоматически перейдет на выделенный объект. Или выделить диапазон и прослушать фрагмент в режиме циклического воспроизведения вместе с редактируемым объектом.

Рис. 3.10. Окно Object Editor

Рассмотрим редактор объектов более детально (рис. 3.10).
Слева расположены кнопки переключения режимов редактора и флажки Mini, Max, управляющие отображением окна. Если оба флажка неактивны, то вид окна редактора объектов соответствует изображенному на рис. 3.10.
Флажок Mini минимизирует окно, а флажок Мах обеспечивает одновременный доступ ко всем секциям редактора объектов.
Над флажками расположены три кнопки режимов, видимые в окне редактора, если оба флажка неактивны:

  • Object Effects (Object Editor Effects Mode) — режим, в котором доступны для редактирования все ресурсы звуковой обработки виртуального объекта;
  • Position/Fades (Object Editor Position/Fade Mode) — режим редактирования кривых Fade In и Fade Out. В этом режиме редактор объектов функционально не отличается от аналога предыдущей версии программы;
  • Pitchshifting/Timestretching (Object Editor Pitchshifting/Timestretching Mode) — режим виртуальных функций Time Stretch и Pitch Shift (рис. 3.11).

Рис. 3.11. Режим Pitchshifting/Timestretching

В режиме Pitchshifting/Timestretching появляется возможность виртуального растяжения/сжатия объекта во времени (Time Stretch) или изменения высоты его тона (Pitch Shift).
Окно редактора объектов в этом режиме можно условно поделить на три области.
В первой области (слева) изменяется параметр Pitch Shift, во второй (справа) — Stretch Length, а между ними в третьей области расположен зависимый переключатель режимов Stretch Mode.
Позиция переключателя Time Stretching обеспечивает независимую регулировку обоих параметров.
Позиция Resample связывает оба регулятора, т. к. у объекта просто изменяется частота дискретизации.
В режиме Time Stretching параметры Pitch Factor и Stretch Factor могут изменяться только в диапазоне от 0.500 до 2.000. В режиме Resample диапазон значений, вводимых в поля Pitch Factor и Stretch Factor с клавиатуры, значительно расширяется.
Управлять высотой тона и растяжением объекта во времени можно и непосредственно в окне VIP-проекта. Для этого нужно перейти в режим редактирования Pitchshift/Timestretch mode (нажать кнопку [image] (Pitchshift/ Timestretch mode) на панели Mouse mode) и перетащить мышью один из двух манипуляторов (рис. 3.12).

Рис. 3.12. Pitch Shift и Time Stretch в окне VIP-проекта

На рис. 3.12 цифрой 1 обозначен манипулятор функции Time Stretch, a цифрой 2 — манипулятор функции Pitch Shift. Различие между верхним и нижним (на рисунке) объектами состоит в том, что верхний объект находится в режиме Resample, установленном в редакторе объектов. Надписи Pitch и Stretching в нижней части объекта указывают на то, что применены обе виртуальные функции.

Совет
Использование функции Time Stretch позволяет легко подогнать темп одного циклического фрагмента под другой. Для этого достаточно установить объекты на соседних дорожках в одинаковую стартовую-позицию и применить виртуальное растяжение/сжатие одного из объектов до точного совпадения границ с включенной функцией привязки Snap к границам объектов.


Маршрутизация эффектов виртуального объекта

Кнопка FX\Routing вызывает окно Effect Routing — Object Editor редактора объектов (рис. 3.13). Это окно имеет точно такой же интерфейс, как и окно Effect Routing — Mixer Track. Однако некоторые элементы интерфейса отсутствуют или недоступны.

Рис. 3.13. Окно Effect Routing — Object Editor

В списке Effects перечислены модули, через которые проходит сигнал объекта. В отличие от предыдущих версий в Samplitude Producer собственные модули обработки можно подключать в редакторе объектов так же, как и DirectX-plug-ins.
Модуль, отмеченный знаком "—" (например, Dehisser на рис. 3.13) неактивен и выгружен. В остальном логика интерфейса похожа на маршрутизацию эффектов на уровне треков. Из-за того, что порядок подключения модулей изменять запрещено, копировать через буфер обмена можно только настройки эффектов.
Нужно еще обратить внимание на то, что DirectX-plug-ins подключаются только до регулятора Volume, а маршруты на AUX-треки формируются наоборот — после регулятора Volume объекта.
Подключение модулей обработки производится в режиме Object Editor Effects Mode редактора объектов. Для этого предусмотрены две секции Effects Chainers: DirectX Plugins и FX Inserts (рис. 3.14).

Рис. 3.14. Секции подключения виртуальных модулей Effects Chainers

В секции DirectX Plugins выбор встраиваемого приложения осуществляется в любом из трех раскрывающихся списков-слотов. При этом нужно учитывать, что при подключении первого модуля выбор раскрывающегося списка-слота не имеет значения. Модуль все равно окажется в самом верхнем слоте. Кнопка [image] (DirX) вызывает окно DirectX Plug-Ins объекта (рис. 3.15), которое отличается от такого же окна на уровне треков отсутствием разделителей Рге и Post в списке Active Plug-Ins.
В этом окне можно подключать столько plug-ins, сколько требуется, хотя в секции DirectX Plug-Ins будут отображаться только первые три модуля. В такой организации интерфейса есть определенная логика. Для работы в реальном времени разумнее ограничиться максимум тремя модулями DirectX plug-ins. А для сложной обработки с большим количеством plug-ins логичнее применить деструктивное редактирование объекта, т. е. выделить объект и выбрать пункт меню Effects | DirectX Plugins.
Кнопка [image] (On), расположенная на уровне слота, в неактивном состоянии переводит эффект в режим обхода (Bypass). Самая верхняя кнопка On в неактивном состоянии деактивирует все подключенные DirectX-plug-ins.
Кнопка [image] (Edit) (или щелчок правой кнопкой мыши по кнопке On) вызывает/скрывает окно настроек виртуального модуля.

Рис. 3.15. Окно DirectX Plug-Ins (Object)

Секция FX Inserts устроена аналогичным образом, за исключением того, что окно настроек модуля закрывается традиционно — кнопками OK, Cancel или [image].
При настройке параметров звуковой обработки объекта нужно не забывать порядок расположения модулей и при необходимости заходить в окно Effect Routing — Object Editor (см. рис. 3.13). В этом окне удобно управлять всей виртуальной звуковой обработкой объекта. В секции FX Inserts доступны только три слота, однако, если нужно задействовать всю мощь Samplitude Producer, то удобнее действовать через список Effects в окне Effect Routing — Object Editor.


Маршрутизация объектов

Давайте представим себе такой аппаратный микшер, где с каждого канала можно сформировать маршруты на 999 AUX-шин, как в Samplitude Producer. Каких он будет размеров, сколько в нем будет проводов и разъемов, какое количество специалистов понадобится для его обслуживания? Но волшебство виртуального мира позволяет разместить все это в одном компьютере, и при этом даже не выйти за пределы экрана монитора.
Маршрутизация объектов — это новый уровень виртуализации, принципиально недостижимый для аппаратных устройств (если, конечно, аппаратное устройство не будет представлять собой специализированный компьютер со строенным программным обеспечением, аналогичным Samplitude Producer).
для организации маршрутов в редакторе объектов имеется отдельная секция маршрутизации AUX Sends (рис. 3.16).

Рис. 3.16. Секция маршрутизации объекта

Эта секция представляет собой часть окна AUX Routing, в которой доступно управление уровнем посыла только на две AUX-шины. Кнопка Edit вызывает окно AUX Routing — Object Editor (рис. 3.17).

Рис. 3.17. Окно AUX Routing — Object Editor

Это окно отличается от окна AUX Routing — Mixer Track тем, что здесь нет флажка Рге, т. к. в редакторе объектов возможны маршруты только AUX Send (Post).
В примере на рис. 3.17 шинаAUX 1 недоступна, т. к. ее номер меньше, чем номер трека, где расположен объект, т. е. "правило субординации" всесильно — оно действует и для объектов.
Второе отличие: в окне AUX Routing — Object Editor можно активизировать одновременно только два флажка visible, т. к. в редакторе объектов отображается только два регулятора AUX Send.

Примечание
Перемещение любого из регуляторов секции AUX Sends автоматически создает AUX-трек с большим номером, если он не был создан до этого.

Каждый объект имеет независимую конфигурацию окна AUX Routing — Object Editor. Это означает, что с каждого объекта формируются разные маршруты с разным уровнем AUX Send. Это свойство позволяет обойтись без традиционной автоматизации AUX Send, которая реализована в Nuendo и SAWStudio. Здесь задача маршрутизации решается иначе. Объект просто разрезается на несколько частей. Затем с каждой части, которая является самостоятельным объектом, формируются новые независимые маршруты с отрегулированным уровнем AUX Send.

Рис. 3.18. Пример маршрутизации объектов

На рис. 3.18 показан пример маршрутизации объектов с тремя AUX-треками. Для художественной обработки звука первоначальный объект поделен на фрагменты. Затем с каждого фрагмента сформированы маршруты на AUX-треки с подключенными цепочками DirectX-plug-ins.
Еще раз обратим внимание на тот факт, что каждый объект можно рассматривать как отдельный виртуальный канал, практически повторяющий внутреннюю структуру обычной канальной ячейки. Тогда дорожку, на которой расположены объекты, можно рассматривать как Submix Bus для этих объектных каналов. И если установить фейдером Volume уровень трека, например, -70 дБ, то останется только сигнал AUX Send-маршрутизации объектов.
Подходы к сведению значительно отличаются в той виртуальной среде, которая базируется на принципе маршрутизации объектов. Здесь процесс может быть выполнен на двух уровнях:

  • на уровне объектов. Изменение всех свойств объектов. Формирование AUX Send-маршрутов;
  • на уровне треков. Управление регуляторами громкости и панорамы треков, подключение plug-ins. Изменение внутреннего порядка расположения модулей. Формирование маршрутов на AUX- и Submix-треки.

Для дорожек, содержащих однородные объекты (имеющие одинаковые свойства), разумнее вынести всю основную обработку на уровень треков. А на уровне объектов производить предварительную "легкую" обработку, например, частотную коррекцию и шумоподавление.
В проектах, построенных по принципу Loop-конструирования, монтажа музыки из "кирпичиков", алгоритм звуковой обработки сильней привязывается к конкретному объекту, становится его неотъемлемой частью. При копировании и перемещении объектов их свойства сохраняются, что дает возможность совместить два творческих процесса: создание звуковой концепции и аранжировку.

Предупреждение
При копировании и перемещении объектов тоже работает "правило субординации". Не следует размещать объекты на дорожках с большим номером, чем номер AUX-трека, на который сформирован объектный маршрут, иначе соответствующая AUX-шина станет недоступной. Для избежания этой проблемы рекомендуется размещать AUX-треки ниже основных треков проекта, присваивая им максимальный номер.

Таким образом, в Loop-проектах более эффективно производить всю основную обработку на уровне объектов. А на уровне треков — выполнять общее микширование.


Samplitude Mixer

Программа Samplitude Producer содержит заново разработанный виртуальный микшер. Нужно отметить значительное улучшение его дизайна по сравнению с предыдущими версиями. Интерфейс стал еще более близок к аппаратным аналогам.
Всеми параметрами обработки звука и маршрутизации VIP-проекта можно управлять из окна Samplitude Mixer.

Рис. 3.19. Окно Samplitude Mixer

Микшер традиционно состоит из канальных ячеек Channel strip и мастер-секции.
Список модулей в окне маршрутизации эффектов Effect Routing — Mixer Track (см. рис. 3.4) полностью соответствует структуре ячейки Channel strip. Рассмотрим модули по порядку.

  • Регулятор уровня канала Gain предназначен для подстройки уровня на входе канала.
  • Секция маршрутизации AUX Bus Sends может отображать только четыре регулятора уровня посыла. Для доступа к диалоговому окну AUX Routing — Mixer Track следует нажать кнопку Edit. Щелчок правой кнопкой мыши на уровне одного регулятора открывает контекстное меню, в котором можно выбрать пункт Рге Fader, эквивалентный одноименному флажку в окне AUX Routing — Mixer Track.
  • Секция Delay — Reverb содержит модуль Echo/Delay/Reverb, присутствовавший и в предыдущих версиях Samplitude Producer. Щелчок правой кнопкой мыши на регуляторе открывает диачоговое окно настроек эффекта (это правило действительно для всех модулей обработки виртуального микшера). Секция содержит кнопку ON, пассивное состояние которой означает перевод модуля в режим обхода Bypass (такая кнопка имеется у каждого модуля обработки).
  • Секция Dyn. содержит канальный динамический процессор Compressor/Expander/Noise Gate/Limiter, также перешедший по наследству от предыдущих версий программы.
  • Секция Equalizer представляет собой четырехполосный параметрический эквалайзер с простым и ясным интерфейсом.
  • Секция Track Name в текстовом поле отображает название трека. Для AUX-треков текстовое поле имеет светло-красный фон, для Submix-треков — светло-синий. Щелчок левой кнопкой мыши в текстовом поле вызывает диалоговое окно Track Info (см. рис. 3.2), а щелчок правой кнопкой — контекстное меню трека.
  • Секция Panorama содержит регулятор панорамы. Щелчок правой кнопкой мыши вызывает диалоговое окно Surround Panning Module, представляющее собой Surround Panner с дополнительными настройками.
  • Кнопки SOLO и MUTE выполняют свои традиционные функции.
  • Кнопка DirX предназначена для активации и подключения DirectX-plug-ins. Щелчок правой кнопкой мыши открывает окно DirectX Plug-Ins — Track (см. рис. 3.7). Щелчок на кнопке DirX левой кнопкой мыши активизирует/деактивирует plug-ins.
  • Секция Volume Fader содержит регулятор громкости, индикатор уровня канала и кнопку Automation. Если кнопка Automation нажата, то все движения фейдера будут записываться как кривая автоматизации Volume, a движения регулятора панорамы как кривая автоматизации Panorama. Кроме того, при воспроизведении движения регуляторов будут анимированы.
  • Секция Track Output позволяет назначить выход трека на Submix-трек, мастер-секцию или другое аудиоустройство. Для этого достаточно выбрать в раскрывающемся списке нужный маршрут (подробнее об этом ниже).
  • Секция Track Information представляет собой кнопку с номером трека. Для обычных треков кнопка имеет желтый цвет, а для AUX- и Submix-треков — синий. Щелчок по этой кнопке вызывает окно Track Info (см. рис. 3.2).
  • Секция Track FX Routing также является кнопкой с названием FX. Щелчок по ней открывает доступ к маршрутизации эффектов в окне Effect Routing — Mixer Track (см. рис. 3.4).

Рис. 3.20. Пример конфигурации виртуального микшера

В окне Samplitude Mixer можно очень быстро и удобно переназначать выходы треков. В списке маршрутов выходы обозначаются буквами:

  • красная буква М обозначает мастер-секцию Stereo Master или 5.1 Surround Master;
  • синяя буква В обозначает внутреннюю Submix-шину (Submix Bus);
  • зеленая буква О обозначает выход на другое аудиоустройство в обход мастер-секции.

Совет
При наличии многоканального оборудования появляется возможность назначения AUX-треков на другой физический выход. В этом случае AUX-шину можно будет использовать для вывода сигнала мониторного микса музыканту-исполнителю при "живой" записи или для подключения внешних устройств звуковой обработки.

На рис. 3.20 показан пример конфигурации Multi IO виртуального микшера для аудиоинтерфейса М Audio Delta R-BUS. Любой канал Samplitude Mixer может быть назначен на доступное аудиоустройство. Здесь возможна такая схема маршрутизации: распределить все основные треки проекта по трекам Submix Bus, а уже их в свою очередь назначить на физические выходы многоканального аудиоинтерфейса для дальнейшего смешивания во внешнем микшере.
Выбор устройства осуществляется в раскрывающемся списке Output.
Владельцам звуковых карт с одним выходом подойдет конфигурация Stereo Master с мастер-секцией. В ней все каналы назначаются или на Submix-шины, или непосредственно на мастер-секцию. Поэтому в такой конфигурации смешивание осуществляется только виртуально.


Маршрутизация эффектов мастер-секции

Многое перешло к мастер-секции по наследству от предыдущих версий Samplitude 2496. Но в ней есть и немало усовершенствований. Рассмотрим маршрутизацию эффектов мастер-секции.
Кнопка FX, расположенная в самом низу, вызывает диалоговое окно Effect Routing — Mixer Master (рис. 3.21).
Нужно отметить, что все окна Effect Routing программы Samplitude Producer имеют схожий интерфейс, у которого есть лишь небольшие отличия, касающиеся специфики объектов, треков и мастер-секции. Например, в окне Effect Routing — Mixer Master нельзя копировать настройки через буфер обмена, потому этот элемент интерфейса здесь отсутствует за ненадобностью (ведь мастер-секция у проекта одна).

Рис. 3.21. Окно Effect Routing — Mixer Master

Важная особенность шестой версии Samplitude Producer — это возможность изменения последовательности расположения модулей обработки в канале и мастер-секции. Изменить порядок эффектов в мастер-секции может потребоваться, например, при мастеринге Audio CD. Для этого в окне Effect Routing — Mixer Master оставлены соответствующие кнопки [image].
Если в качестве лимитера мастер-секции будет использоваться модуль Advanced Dynamics, то флажок use Advanced Dynamics for Mixer "Dyn/Limiter" должен быть отмечен. В противном случае в режиме Limiter окажется установлен старый модуль Compressor/Expander/Noise Gate/Limiter из предыдущих версий Samplitude Producer. Мы рекомендуем всегда использовать новый модуль Advanced Dynamics.
Продолжим рассмотрение мастер-секции виртуального микшера.
На рис. 3.22 цифрами отмечены модули, составляющие мастер-секцию.

  1. 1. DirectX Plug-in Chainer — модуль подключения DirectX plug-ins. Для подключения эффекта достаточно щелкнуть на любом из шести слотов. В появившемся диалоговом окне DirectX Plug Ins Master осуществляется и стандартный выбор DirectX-модулей. Модуль DirectX Plug-in Chainer соответствует элементам DirectX Plugin (Pre) и DirectX Plugin (Post) списка Effects в окне Effect Routing — Mixer Master.

Рис. 3.22. Мастер-секция Samplitude Mixer

  1. 2. Native Effects Section — модуль внутренних ресурсозависимых модулей Samplitude Producer. Сюда относятся Dehisser, FFT Filter, Multiband Dynamics и Advanced Dynamics. Этого набора вполне достаточно для мастеринга Audio CD. К нему можно добавить профессиональные DirectX-plug-ins, например, Waves C4.
  2. 3. EQ Section — секция параметрического мастер-эквалайзера. В отличие от канальных параметрических эквалайзеров, здесь вынесены отдельные ручки регулирования частоты.
  3. 4. Stereo Enhancer — многополосный модуль изменения ширины стереобазы. По сравнению с предыдущими версиями в этом модуле значительно улучшен дизайн.
  4. 5. Master Faders — секция мастер-фейдеров. В ней также расположены индикаторы выходного уровня, кнопка DirX для подключения и активизации DirectX-plug-ins, кнопка Normal для нормализации сигнала в реальном времени и кнопка Link для связывания фейдеров. Кнопка Mono позволяет проверить сигнал на моносовместимость.
  5. 6. Output Options — секция, в которой производятся все манипуляции с выходным сигналом. Секция содержит раскрывающийся список выходов. Для звуковой карты с одним выходом в списке будут присутствовать два значения, например, SB Audigy Audio [C400] и Inactive. Выбор пункта Inactive приведет к переназначению всех канальных выходов (минуя мастер-секцию) непосредственно на выход звуковой карты. Кнопка Mixdown вызовет диалоговое окно Trackbouncing, содержащее все необходимые опции для пересчета VIP-проекта в звуковой файл. Кнопка FX обеспечивает доступ к диалоговому окну Effect Routing — Mixer Master (см. рис. 3.21). И наконец, в самом низу расположены еще две кнопки: ON и Mix, объединенные общей функцией Output to file. Если кнопка ON активна, то выходной сигнал микшера в реальном времени записывается в файл в формате 32 Bit Float или в целочисленном 16-битном формате. Это зависит от того, какая установлена внутренняя разрешающая способность Samplitude Producer (об этом ниже). Кнопка Mix открывает диалоговое окно Name for recording project, где можно задать имя звукового файла и его размещение на жестком диске.
  6. 7. Input Attenuation — секция, содержащая аттенюатор для пошагового ослабления сигнала на входе звуковой карты. Аттенюатор ослабляет сигнал на выходе всех каналов, поэтому основное его предназначение — это предотвращение клиппирования в многоканальной (Multi IO) конфигурации оборудования (когда сигналы треков с большой амплитудой, назначенные на физические выходы, получают ограничение). В конфигурации с одним выходом внутренний формат 32Bit Float автоматически защищает от перегрузки. На практике это означает, что в виртуальной среде перегрузка канала компенсируется без искажений снижением уровня фейдерами мастер-секции.
  7. 8. Reset Buttons — кнопки общего сброса виртуального микшера. Mono — полная реконфигурация микшера для работы с монотреками. Stereo — полная реконфигурация микшера для работы со стереотреками. Peaks — сброс всей индикации пикового уровня. FX — сброс всех настроек собственных эффектов виртуального микшера (исключая DirectX-plug-ins).
  8. 9. Snapshots — секция сохранения моментальных снимков полной конфигурации микшера. Этой функцией удобно пользоваться для быстрого перехода между различными вариантами сведения. Секция содержит 8 слотов с кнопками и текстовыми полями. Щелчок по кнопке фиксирует состояние микшера в пустом слоте, при этом в текстовом поле появляется надпись Snap n, где n — номер слота. После двойного щелчка в текстовом поле можно ввести новое название с клавиатуры. Комбинация <Shift> + щелчок левой кнопкой мыши перезаписывает снимок. Щелчок правой кнопкой мыши очищает слот. Если слот содержит снимок, то кнопка имеет желтый цвет. Для того чтобы вернуться к ранее сохраненной конфигурации, достаточно щелкнуть по желтой кнопке левой кнопкой мыши. Дополнительные кнопки Save/Load позволяют сохранять/загружать настройки микшера в файл с расширением mix.
  9. 10. Control Group — секция формирования групп. В виртуальном микшере предусмотрена возможность связывания элементов управления в группы. Для этого нужно щелкнуть левой кнопкой мыши на каждом элементе управления (например, регуляторе панорамы) с нажатой клавишей <Ctrl>, а затем нажать кнопку Build в секции Control Group. Таким способом можно создать необходимое количество групп. Для расформирования группы нужно щелкнуть на любом ее элементе (выделить группу) и нажать кнопку Break. Кнопка FX (Mute FX) блокирует всю виртуальную обработку треков, давая возможность быстро сравнить "сухой" (dry) и обработанный сигнал.
  10. 11. Mixer Views — секция, управляющая полнотой отображения виртуального микшера. Каждая из пяти кнопок ON отвечает за определенную секцию виртуального микшера. В активном состоянии кнопки ON секция отображается. Шестая кнопка вызывает многофункциональное окно Visualization, предназначенное для индикации уровня, спектра, формы и корреляции фазы суммарного сигнала. Все эти параметры нужно контролировать при сведении и мастеринге Audio CD.
  11. 12. Mixer Templates and Setup — секция общих настроек виртуального микшера. В раскрывающемся списке Preset можно выбрать встроенный шаблон или собственный заранее созданный пресет.

Здесь нужно отметить, что алгоритмы собственных FX-модулей и виртуального смешивания Samplitude Mixer, реализованные в Samplitude Producer, отличаются высокой точностью, обеспечивая чистое и прозрачное звучание. Чаще всего качество обработки собственных FX-модулей выше качества некоторых DirectX-plug-ins.
Поэтому в большинстве случаев предпочтительнее ограничиться внутренними ресурсами Samplitude Producer, тогда высокое качество обработки гарантировано.
Вышесказанное не относится к алгоритму реверберации Samplitude Producer (эффект Echo/Delay/Reverb в режиме Reverb). Казалось бы, именно здесь может потребоваться какой-нибудь DirectX-plug-in ревербератор. Однако мощные возможности Samplitude Producer позволят обойтись без него и сэкономить ресурсы CPU на "тяжелых" алгоритмах программных ревербераторов. Для этого нужно воспользоваться эффектом Room Simulator, который при помощи алгоритма свертки с отзвуком импульса сформирует качественный и естественный сигнал реверберации. Эффект Room Simulator не работает в реальном времени. Поэтому нужно выполнить несколько подготовительных действий.
Предположим, у нас сформированы Send-маршруты на AUX-трек, где временно подключен в разрыв программный ревербератор. Задача состоит в том, чтобы преобразовать этот сигнал в объект на AUX-треке. Для этого нужно переключить Send-маршруты в состояние Рге Fader (или сформировать маршруты с объектов) и увести фейдеры всех остальных треков. Если все сделано правильно, должен прослушиваться сигнал только AUX-трека. Далее следует "обойти" (Bypass) программный ревербератор и выполнить промежуточное сведение (Track Bouncing) "сухого" сигнала на выделенную дорожку AUX-трека. Заключительной стадией этого алгоритма станет деструктивная обработка полученного объекта эффектом Room Simulator с уровнем Original в секции Mix, равным 0% и расформирование Send-маршрутов на этот AUX-трек. В результате высококачественный сигнал реверберации будет просто подмешан в проект как отдельный трек.

Примечание
Качество реверберации зависит от файла отзвука импульса, поэтому рекомендуется применять профессиональные библиотеки импульсов. Для получения специальных эффектов к файлам импульсов можно применить дополнительную обработку. Например, задействовать эффект Reverse для получения реверсивной реверберации или эффект FFT Filter /Analizer в динамическом режиме.


Общие настройки Samplitude Mixer

Доступ к общим настройкам виртуального микшера осуществляется через кнопку Edit в секции Mixer Templates and Setup (см. рис. 3.22). Все основные параметры сосредоточены в диалоговом окне Project Mixer Setup (рис. 3.23).
В раскрывающемся списке Preset содержатся конфигурационные пресеты виртуального микшера. Пресеты сохраняются кнопкой Save как файлы с расширением mis.
Текстовые поля секций Tracks, Submix Busses и Aux Busses предназначены для быстрого ввода необходимого количества треков. Флажки keep current number позволяют сохранить текущее значение при загрузке другого конфигурационного пресета. Если флажок отмечен, то после нажатия на кнопку ОК значение соответствующего параметра не изменится.

Рис. 3.23. Окно Project Mixer Setup

Секция Master содержит зависимый переключатель, управляющий конфигурацией мастер-секции. Переключатель имеет три позиции: nо master (без мастер-секции), Stereo Master (обычная конфигурация) и 5.1 Surround Master (шестиканальная Surround-конфигурация мастер-секции). Флажок keep current settings сохраняет текущие настройки так же, как и флажки keep current number.
Секция Device Setup (track in/output assignament, routing) отвечает за маршрутизацию каналов. Зависимый переключатель имеет четыре позиции:

  • keep current setup (сохранение текущих настроек);
  • assign all tracks to the stereo master (конфигурация для звуковой карты с одним выходом, все треки назначаются на мастер-секцию);
  • assign tracks to several devices (Multi I/O) (конфигурация для мультиканального оборудования);
  • use saved preset of setup (использовать конфигурацию загруженного пресета).

В самом низу в секции Effect Routing расположены две кнопки: Tracks/ Busses и Stereo Master. Кнопка Tracks/Busses обеспечивает быстрый вызов окна Effect Routing — Mixer Track для выделенного трека VIP-проекта. А кнопка Stereo Master вызывает окно Effect Routing — Mixer Master. Таким образом, окно Project Mixer Setup обеспечивает быстрый доступ ко всем основным параметрам маршрутизации виртуального проекта.


Внутренняя разрешающая способность Samplitude Producer

Системные настройки программы заключены в одном большом глобальном окне, которое вызывается командой меню Options | System/Audio.

Рис. 3.24. Окно System/Global Audio Options

Переключение между внутренними окнами осуществляется вертикальным рядом кнопок-пиктограмм, расположенных слева. Кнопка-пиктограмма Playback Devices открывает доступ к окну, изображенному на рис. 3.24. cекции internal Resolution зависимый переключатель внутренней разрешающей способности Samplitude Producer имеет две позиции — 16 Bit и 32 Bit.
Для того чтобы понять, к чему приводит целочисленная арифметика, предлагаем произвести простой эксперимент.
Установить переключатель в позицию 16 Bit и нажать кнопку ОК. Затем искусственно вывести уровень любого трека за 0 дБ, т. е. перегрузить трек таким образом, чтобы искажения стали заметны на слух. После этого попытаться скомпенсировать перегрузку фейдерами мастер-секции. Искажения не исчезнут.
Затем повторно вызвать окно System/Global Audio Options и перевести переключатель в позицию 32 Bit. При компенсации перегрузки фейдерами мастер-секции искажения исчезают "чудесным образом". Это связано с огромной виртуальной перегрузочной способностью математических операций в форте с плавающей точкой.
Из этого примера следует, что внутренняя разрешающая способность Samplitude Producer должна быть установлена в 32 Bit. А переключение в 16 Bit может использоваться только на очень слабых компьютерах, где задача получения качественного звука не является актуальной.

Примечание
16-битный формат в принципе обеспечивает хорошее качество применительно к коммерческому тиражированию фонограмм. Однако его явно недостаточно для оцифровки (см. разд. "Повышение качества записи 16-битной звуковой карты" в главе 1) и последующей обработки сигнала. Для записи нужно использовать 20—24-битные АЦП, а обработку производить в 32-битном формате с плавающей точкой.
Формат 32 Bit Float имеет ряд преимуществ по сравнению с целочисленным представлением выборок. Во-первых, виртуальный динамический диапазон можно считать практически неограниченным (отсутствует "проблема 0 дБ"), во-вторых, шум квантования не имеет абсолютной зависимости от уровня сигнала, как в случае целочисленного представления. Поэтому отсутствует опасность деградации качества из-за изменения уровня сигнала при многократных обработках.

Следующая секция Device Resolution/Driver Communication востребована только в случае возникновения проблем при воспроизведении. Например, если проект содержит 24-битные звуковые файлы, а драйвер 16-битной звуковой карты не способен правильно их воспроизводить, то следует устаноить переключатель секции Device Resolution/Driver Communication в положение 16 Bit.

Как уже отмечалось, внутреннее разрешение Samplitude Producer должно быть установлено в 32 Bit. Однако если для мониторинга используется 16-битная звуковая карта или в Sampitude Producer выполняется мастеринг Audio CD, следует использовать ее внутренний дизеринг.

Предупреждение
Если при мастеринге используется plug-in, содержащий собственный дизеринг-процессор (например, Waves L1-Ultramaximizer+), то внутренний дизеринг Samplitude Producer следует отключить. При этом нужно следить за маршрутизацией эффектов мастер-секции. Модуль, содержащий дизеринг-процессор, должен быть самым последним в цепочке plug-ins.

Доступ к настройкам внутреннего дизеринга осуществляется в том же окне глобальных настроек с помощью кнопки-пиктограммы Program Options. Затем в появившемся окне Program Settings нужно нажать кнопку Dithering Options.
Дальнейшие настройки выполняются в диалоговом окне Dithering Options (рис. 3.25).

Рис. 3.25. Окно Dithering Options

Зависимый переключатель Dithering Mode (Realtime Conversion from Float to 16 Bit) позволяет выбрать два режима дизеринга или отключить дизеринг вообще, заменив его математическим округлением. В поле Dithering Depth in Bits (0.01 ... 16.0) задается уровень шума дизеринга в битах.
В заключение отметим, что программа Samplitude Producer предоставляет совершенно новые виртуальные технологии, способные удовлетворить самые серьезные запросы компьютерных музыкантов. Применение качественных 24-битных ADC-конвертеров (analog to digital converter) в сочетании с виртуальной обработкой в 32-битном формате с плавающей точкой обеспечит профессиональное качество звука.


Введение


Мифология в звукозаписи

Мифы — это одна из стабильных величин нашего постоянно изменяющегося мира. Причина этому явлению очевидна. На общем фоне рынка техники — пестрящего ежедневными новинками и псевдопрорывными технологиями — необходима некоторая основательность, стабильность.
В области персональных компьютеров элемент идеологической стабильности хранится в мифах, которые по традиции передаются от пользователя к пользователю.
Несмотря на то, что эти предания быстро устаревают и значительно отстают от технического прогресса, они по традиции пользуются непререкаемым дедовским авторитетом.
В области персональных компьютеров мифы обосновались прочно. Один из них впрямую касается темы книги. Он гласит, что на персональном компьютере якобы нельзя заниматься музыкой и, тем более, получить при этом сколько-нибудь приемлемый результат в виде хорошего звука.
Согласимся, что еще совсем недавно — два-три года назад — качественная программная обработка звука в реальном времени на PC была действительно невозможна. Сейчас же ситуация кардинально изменилась: производительность PC растет стремительно.
Всего год назад мы предлагали читателям способы решения проблем, связанных с недостаточным быстродействием компьютера: в книге "'Живая' музыка на PC" рекомендовали (в шутку) дождаться выпуска процессоров, работающих на частоте микроволновой печи. Сегодня это стало реальностью — достигнута и превышена частота 1000 МГц. С такими темпами технического прогресса фантазия не намного отстает от воплощения.
Поэтому сегодня, как никогда прежде, нужно быть в курсе последних достижений в интересующей области, а не прислушиваться к долгоиграющей пластинке заезженных мифов.


Век "всеобщей виртуализации"

В наши дни основной вектор развития музыкальных компьютерных технологий направлен в область ресурсозависимых (Native) технологий.
Ведущие разработчики музыкального программного обеспечения ориентируются в основном на программную (виртуальную) технологию обработки звука — без применения специализированных аппаратных устройств (Native Audio Processing).
Фирма Steinberg (http://www.steinberg.net, http:/www.nuendo.com) развенчивает ложное представление о незаменимости аппаратных средств и заявляет, что ее продукт — программа Nuendo — превращает PC в DAW (Digital Audio Workstation — цифровая рабочая аудиостанция), которая не нуждается в "специализированных аппаратных средствах DSP".
Об этом открыто продекларировано в документации к программе: "один из замечательных мифов цифровых аудиосистем состоит в том, что для построения полноценной цифровой рабочей станции требуются вагоны 'железа' и DSP-чипов Nuendo не нуждается ни в каких специализированных аппаратных средствах DSP и так, постоянно адаптируясь к текущему состоянию of-the-art-технологии, тем самым обеспечивая себе статус профессиональной промышленной платформы в течение последующих лет".

Примечание
Цитата приведена из документации к программе Nuendo: "One of the great myths of digital audio systems is that truckloads of audio hardware and DSP chips are necessary to build a capable audio workstation. ... Nuendo needs no dedicated DSP hardware and so constantly adapts itself to the current state-of-the-art technology".

DSP-чип
DSP (digital signal processor) — специализированный процессор цифровой обработки сигнала.

Теперь несколько слов о "сопутствующих товарах" — plug-ins, встраиваемых приложениях или виртуальных эффектах.
Здесь тоже наблюдается значительный прогресс. Раньше низкая производительность PC тормозила рост качества алгоритмов, заложенных в разнотипные встраиваемые приложения. Поэтому разработчикам приходилось идти на компромисс, например, использовать 16-битные алгоритмы, всевозможные упрощения, усечения и т. д.
Сегодня прежний сдерживающий фактор — недостаток быстродействия — стремительно исчезает, что, в свою очередь, дает небывалый простор для технических решений разработчиков plug-ins.
Так, уже сейчас во многих plug-ins используется 64-битная внутренняя точность обработки, что, в принципе, и является одним из важнейших показателей профессиональности приложений. Показатель, который находится в одном ряду с другими всевозможными хитростями и ноу-хау — в виде моделирования высококачественных аналоговых устройств, психоакустических алгоритмов и т. д.
Теперь посмотрим на тенденцию "всеобщей виртуализации" с точки зрения потребителей: профессионалов и любителей.
Последнее время все чаще в различных публикациях, в том числе и в Интернете, появляются схожие по тональности мнения звукорежиссеров и других специалистов по цифровому аудио о том, что значительно удобнее работать с компьютерной программой, чем сражаться с ветряными мельницами в виде ящичков и коробочек, связанных между собой паутиной проводов.
Подведем промежуточный итог: нет сомнений в том, что сегодня происходит необратимый процесс виртуализации студий — и мы являемся его свидетелями. Наконец-то настало время, когда все этапы работы с музыкальным материалом можно производить только в компьютере.
И теперь звук может обрабатываться, не покидая его пределов, вплоть до последнего этапа — переноса на коммерческий носитель (CD-Audio, DVD-Audio и т. д.).
Итак, если вы, уважаемые читатели:

  • не желаете превращать свое жизненное пространство в склад "мгновенно устаревающего железа";
  • намерены максимально использовать последние достижения в области компьютерных технологий (имея при этом возможность оперативно их менять);
  • планируете расходовать средства на занятия музыкой в разумных пределах,

то настоятельно рекомендуем вам обратить свой взгляд в направлении виртуальных звуковых технологий.
И еще один штрих — сравним простоту освоения разнородных продуктов рынка: программ для PC и аппаратных устройств.
В действительности оборудование, которое предлагают ведущие фирмы для домашних студий, постоянно усложняется. Например, документация к цифровому микшерному пульту в ценовом диапазоне от 6000 $ может в пять раз превышать по объему документацию к программному обеспечению для PC (например, документацию к программе Nuendo).
Это объясняется тем, что подобное сложное изделие представляет собой специализированный компьютер со своей внутренней операционной системой. Поэтому человеку, незнакомому с компьютерными технологиями, освоить подобное устройство будет уже нелегко.
Сформулируем вывод, сделанный жизнью: музыканту, живущему в век информационных технологий, так или иначе не избежать изучения компьютера. Возврата к "старым добрым ящикам", по всей видимости, уже не предвидится.
Но свобода выбора остается. Она заключается в том, что человек сам решает, в какой из областей наращивать свои знания: изучать постоянно меняющееся многообразие специализированных устройств или осваивать стандартизированное программное обеспечение для PC.


Домашняя студия — мастерская музыканта

Представим себе художника, который, аналогично музыканту, вынужден арендовать время в студии вместо спокойного творчества в своей мастерской. Сможет ли творец создать произведение искусства за отведенные часы? Вдохновение редко к кому приходит без опозданий. Но почему-то нас уже почти не удивляет тот факт, что современный музыкант "обязан уметь творить в условиях конвейера".
Такой парадокс, скорее всего, сложился потому, что раньше технологии профессиональной звукозаписи были очень дороги и поэтому не могли быть массовыми.
Но теперь высокое быстродействие современных PC и наличие программ, превращающих PC в Digital Audio Workstation (PC DAW), позволяют широким массам музыкантов создать свою персональную (домашнюю) студию. Именно такому программному обеспечению и посвящена данная книга.
Кратко сформулируем точку зрения авторов на этот счет:

  • Персональный компьютер в настоящее время является максимально надежной и эффективной базой, ядром для организации звукозаписывающей студии. Он обеспечивает большую гибкость и более высокое соотношение производительность/доллар, чем специализированные аппаратные устройства.
  • Сегодня домашняя студия на базе PC DAW позволяет достичь профессионального конкурентоспособного звучания. Поэтому стоит тщательно подойти к выбору дополнительных аппаратных устройств, определить, какая часть обработки будет производиться виртуально, а какая с помощью "железа".
  • Никакое оборудование не заменит МАСТЕРА (талантливого музыканта, творческого звукорежиссера).


Подходы к тестированию качества звучания

И в заключение рассмотрим качество звучания через призму эстетической и психоакустической составляющих.
Для того чтобы определить, что же такое качество звучания, воспользуемся результатами исследований известного специалиста в области аудиоаппаратуры Анатолия Марковича Лихницкого. Он предлагает для тестирования оборудования класса Hi-End использовать граммофонные записи начала XX века.
"Мы убедились, что метод тестирования, использующий старые фамзаписи с их офаничением полосы частот, плохим отношением "сигнал/шум" и искажениями, обладает большей разрешающей способностью, чем метод тестирования, при котором используются современные записи.
Оказалось, что старые фамзаписи позволяют лучше замечать качественные изменения как в аналоговой, так и цифровой части записывающего оборудования. Отмеченная способность главным образом объясняется исключительным богатством музыкального содержания старых записей.
Без этого содержания, как следует из предлагаемой мной концепции, аудио-экспертиза не просто дает менее надежные результаты, но и вообще утрачивает смысл". (А. М. Лихницкий, "Качество звучания. Новый подход к тестированию аудиоаппаратуры", СПб.: "ПиК", 1998.)
В основе концепции А. Лихницкого лежит предположение, что удовлетворение от прослушивания музыки складывается из трех компонентов:

  1. 1. Достоверность— иллюзия реальности звуковой картины, созданной звуковоспроизводящим аудиооборудованием. Чем сильнее иллюзия, .тем выше достоверность.
  2. 2. Комфортность — степень отсутствия раздражающих факторов, таких как шумы, трески, искажения и т. д. Причем подчеркивается, что комфортность определяется субъективной глубиной дискомфорта вследствие концентрации внимания слушателя на этих раздражающих факторах.
  3. 3. Музыкальность — концентрация внимания слушателя на самой музыке, вовлеченность в процесс прослушивания. При этом делается важный вывод, что слушатель готов пожертвовать достоверностью и комфортностью, если он по-настоящему вовлечен в прослушивание, т. е. получает эстетическое наслаждение от самой музыки. В этом случае слушатель обратит внимание на дефекты записи только при разрушении ими здания музыки, нарушения ее содержания.

Нельзя не согласиться с этими утверждениями. Тем более что они подтверждаются современными поговорками музыкантов, вроде "мы слушаем музыку, а не качество звучания", "музыку портят не байты и биты, а композиторы" и т. п.
Музыкальный продукт должен быть качественно выполнен на всех этапах: композиции, исполнения и записи.
Более того, запись должна музыкально звучать на любом носителе: по радио, по телевидению, на магнитофонах и музыкальных центрах разного класса и т. д.
Именно этим, как мы понимаем, и объясняется А. Лихницким выбор граммофонного материала, не удовлетворяющего современным требованиям с инженерной точки зрения, зато обладающего высокой эстетической ценностью с точки зрения музыкальности.
Благодаря работам А. М. Лихницкого становятся понятными парадоксы современности: когда старые записи (например, записи Beatles, сделанные в 1960-х годах) больше вовлекают в прослушивание, чем многие современные — выполненные на технике последнего поколения, главным (и, пожалуй, единственным) критерием качества которой стали следующие параметры: 24 бит/96 кГц/56-битная обработка аппаратными эффектами.
Итак, сами по себе технические параметры оборудования не гарантируют высокого качества фонограммы во всех трех составляющих: достоверности, комфортности и музыкальности.
Загадочная с точки зрения инженера составляющая — музыкальность — вообще остается за пределами области технических измерений.
Но она, как ни странно, и является наиболее значимой величиной с точки зрения успеха записи у слушателя (по крайней мере, это можно предположить). Забегая вперед, отметим, что важнейшая цель мастеринга — повышение этой составляющей.
Таким образом, основная задача, которую способен решить музыкант в своей персональной компьютерной студии, формулируется так: создание фонограммы, вовлекающей в прослушивание.

Примечание
Сразу оговоримся, что мы не рассматриваем случай плохой музыки. Наши рассуждения относятся к варианту, когда "живое" исполнение на акустических или электронных инструментах вызывает значительный интерес у публики. А запись, обладающая музыкальностью, способна поддерживать этот интерес у слушателей, побывавших на "живых" концертах, либо привлекать новую аудиторию.

В книге будут рассмотрены три программных продукта нового поколения:

  • SAWStudio от фирмы Innovative Quality Software;
  • Nuendo от фирмы Steinberg;
  • Samplitude Producer 2496 от фирмы Magix.

Все программы имеют свои особенности и могут применяться для решения разноплановых музыкальных задач. Основное внимание будет подчинено наименее затратной для создания современной демо-записи технологии — "весь звук внутри компьютера".